]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- pl translations
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 Summary:        This is the PgSQL authentication module for Apache
3 Summary(pl):    Modu³ autentykacji PgSQL dla Apache
4 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.9.10
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Group(de):      Netzwerkwesen/Server
11 Group(pl):      Sieciowe/Serwery
12 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
13 Patch0:         %{name}-version.patch
14 BuildRequires:  postgresql-devel
15 BuildRequires:  /usr/sbin/apxs
16 BuildRequires:  apache(EAPI)-devel
17 Prereq:         /usr/sbin/apxs
18 Requires:       apache(EAPI)
19 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
23
24 %description
25 This is an authentication module for Apache that allows you to
26 authenticate HTTP clients using postgresql RDBMS.
27
28 %description -l pl
29 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
30 klientów HTTP z u¿yciem bazy danych postgresql.
31
32 %description -l pt_BR
33 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
34 PostgreSQL.
35
36 %prep 
37 %setup -q -n "mod_%{mod_name}-%{version}"
38 %patch0 -p1
39
40 %build
41 /usr/sbin/apxs \
42         -I %{_includedir}/postgresql \
43         -l pq \
44         -c mod_%{mod_name}.c \
45         -o mod_%{mod_name}.so
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_pkglibdir}
50
51 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /usr/sbin/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
58 if [ -f /var/lock/subsys/httpd ]; then
59         /etc/rc.d/init.d/httpd restart 1>&2
60 fi
61
62 %preun
63 if [ "$1" = "0" ]; then
64         /usr/sbin/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
65         if [ -f /var/lock/subsys/httpd ]; then
66                 /etc/rc.d/init.d/httpd restart 1>&2
67         fi
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc *.html
73 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.27825 seconds and 4 git commands to generate.