]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
- unified, made it apache2 package
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ uwierzytelnienia MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        4.3.9
17 Release:        0.1
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        ftp://ftp.debian.org/debian/pool/main/liba/libapache-mod-auth-mysql/libapache-mod-auth-mysql_%{version}.orig.tar.gz
21 # Source0-md5:  9c1ecbe5fb64d4c93444311ff34bfe35
22 Patch0:         %{name}-ac.patch
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache-devel >= 2.0.0
25 BuildRequires:  apr-util >= 1:1.0
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  libtool
29 BuildRequires:  mysql-devel
30 Requires:       apache(modules-api) = %apache_modules_api
31 Requires:       apache-mod_auth
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
35 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
36
37 %description
38 This is an authentication module for Apache that allows you to
39 authenticate HTTP clients using MySQL RDBMS.
40
41 %description -l cs
42 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
43 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
44 MySQL.
45
46 %description -l de
47 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
48 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
49 einer MySQL-Datenbank prüft.
50
51 %description -l es
52 mod_auth_mysql puede usarse para limitar el acceso a documentos
53 servidos por un servidor web verificando datos en una base de datos
54 MySQL.
55
56 %description -l fr
57 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
58 servis par un serveur Web en vérifiant les données dans une base de
59 données MySQL.
60
61 %description -l it
62 mod_auth_mysql può essere usato per limitare l'accesso a documenti
63 serviti da un server Web controllando i dati in un database MySQL.
64
65 %description -l ja
66 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
67 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
68 ¤¬¤Ç¤­¤Þ¤¹¡£
69
70 %description -l pl
71 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
72 uwierzytelnianie klientów HTTP z u¿yciem bazy danych MySQL.
73
74 %description -l pt_BR
75 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
76 MySQL.
77
78 %description -l sv
79 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
80 servade av en webbserver genom att kontrollera data i en
81 MySQL-databas.
82
83 %prep
84 %setup -q -n mod-auth-mysql-%{version}
85 %patch0 -p1
86
87 %build
88 %{__aclocal}
89 %{__autoconf}
90 %configure \
91         --disable-apache13 \
92         --enable-apache2 \
93         --with-apxs2=%{apxs} \
94         --with-mysql=%{_prefix}
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
100
101 libtool install apache2_mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
102 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
103
104 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
105         $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 if [ -f /var/lock/subsys/httpd ]; then
112         /etc/rc.d/init.d/httpd restart 1>&2
113 fi
114
115 %postun
116 if [ "$1" = "0" ]; then
117         if [ -f /var/lock/subsys/httpd ]; then
118                 /etc/rc.d/init.d/httpd restart 1>&2
119         fi
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %doc DIRECTIVES USAGE
125 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
126 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.04996 seconds and 4 git commands to generate.