]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
- BR: autoconf,automake
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ autentykacji MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        2.20a
17 Release:        3
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://web.oyvax.com/src/mod_auth_mysql-%{version}.tar.gz
21 URL:            http://www.diegonet.com/support/mod_auth_mysql.shtml
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  mysql-devel
25 BuildRequires:  %{apxs}
26 BuildRequires:  apache(EAPI)-devel
27 Requires(post,preun):   %{_sbindir}/apxs
28 Requires:       apache(EAPI)
29 Requires:       apache-mod_auth
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31 Obsoletes:      mod_auth_mysql
32
33 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
34
35 %description
36 This is an authentication module for Apache that allows you to
37 authenticate HTTP clients using mysql RDBMS.
38
39 %description -l cs
40 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
41 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
42 MySQL.
43
44 %description -l de
45 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
46 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
47 einer MySQL-Datenbank prüft.
48
49 %description -l es
50 mod_auth_mysql puede usarse para limitar el acceso a documentos
51 servidos por un servidor web verificando datos en una base de datos
52 MySQL.
53
54 %description -l fr
55 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
56 servis par un serveur Web en vérifiant les données dans une base de
57 données MySQL.
58
59 %description -l it
60 mod_auth_mysql può essere usato per limitare l'accesso a documenti
61 serviti da un server Web controllando i dati in un database MySQL.
62
63 %description -l ja
64 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
65 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
66 ¤¬¤Ç¤­¤Þ¤¹¡£
67
68 %description -l pl
69 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
70 klientów HTTP z u¿yciem bazy danych mysql.
71
72 %description -l pt_BR
73 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
74 MySQL.
75
76 %description -l sv
77 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
78 servade av en webbserver genom att kontrollera data i en
79 MySQL-databas.
80
81 %prep
82 %setup -q -n mod_%{mod_name}-%{version}
83
84 %build
85 %{__aclocal}
86 %{__autoconf}
87 %configure \
88         --with-apxs=%{apxs} \
89         --with-mysql=%{_prefix}
90
91 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{_pkglibdir}
96
97 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
104 if [ -f /var/lock/subsys/httpd ]; then
105         /etc/rc.d/init.d/httpd restart 1>&2
106 fi
107
108 %preun
109 if [ "$1" = "0" ]; then
110         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
111         if [ -f /var/lock/subsys/httpd ]; then
112                 /etc/rc.d/init.d/httpd restart 1>&2
113         fi
114 fi
115
116 %files
117 %defattr(644,root,root,755)
118 %doc README* USAGE
119 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.058904 seconds and 4 git commands to generate.