]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
- added %{apxs} local macro to avoid adapter problems
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ autentykacji MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        0.11
17 Release:        3
18 License:        GPL
19 Group:          Networking/Daemons
20 Group(cs):      Sí»ové/Démoni
21 Group(da):      Netværks/Dæmoner
22 Group(de):      Netzwerkwesen/Server
23 Group(es):      Red/Servidores
24 Group(fr):      Réseau/Serveurs
25 Group(is):      Net/Púkar
26 Group(it):      Rete/Demoni
27 Group(no):      Nettverks/Daemoner
28 Group(pl):      Sieciowe/Serwery
29 Group(pt):      Rede/Servidores
30 Group(ru):      óÅÔØ/äÅÍÏÎÙ
31 Group(sl):      Omre¾ni/Stre¾niki
32 Group(sv):      Nätverk/Demoner
33 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
34 Source0:        ftp://ftp.kcilink.com/pub/mod_%{mod_name}.c.gz
35 Source1:        ftp://ftp.kciLink.com/pub/mysql-group-auth.txt
36 Patch0:         %{name}-name.patch
37 BuildRequires:  mysql-devel
38 BuildRequires:  %{apxs}
39 BuildRequires:  apache(EAPI)-devel
40 Prereq:         %{_sbindir}/apxs
41 Requires:       apache(EAPI)
42 Requires:       apache-mod_auth
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
46
47 %description
48 This is an authentication module for Apache that allows you to
49 authenticate HTTP clients using mysql RDBMS.
50
51 %description -l cs
52 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
53 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
54 MySQL.
55
56 %description -l de
57 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
58 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
59 einer MySQL-Datenbank prüft.
60
61 %description -l es
62 mod_auth_mysql puede usarse para limitar el acceso a documentos
63 servidos por un servidor web verificando datos en una base de datos
64 MySQL.
65
66 %description -l fr
67 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
68 servis par un serveur Web en vérifiant les données dans une base de
69 données MySQL.
70
71 %description -l it
72 mod_auth_mysql può essere usato per limitare l'accesso a documenti
73 serviti da un server Web controllando i dati in un database MySQL.
74
75 %description -l ja
76 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
77 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
78 ¤¬¤Ç¤­¤Þ¤¹¡£
79
80 %description -l pl
81 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
82 klientów HTTP z u¿yciem bazy danych mysql.
83
84 %description -l pt_BR
85 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
86 MySQL.
87
88 %description -l sv
89 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
90 servade av en webbserver genom att kontrollera data i en
91 MySQL-databas.
92
93 %prep
94 %setup -q -T -c
95 gzip -dc %{SOURCE0} > mod_%{mod_name}.c
96 %patch -p1
97
98 %build
99 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_pkglibdir}
104
105 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
106
107 install %{SOURCE1} .
108
109 gzip -9nf *.txt
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
116 if [ -f /var/lock/subsys/httpd ]; then
117         /etc/rc.d/init.d/httpd restart 1>&2
118 fi
119
120 %preun
121 if [ "$1" = "0" ]; then
122         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
123         if [ -f /var/lock/subsys/httpd ]; then
124                 /etc/rc.d/init.d/httpd restart 1>&2
125         fi
126 fi
127
128 %files
129 %defattr(644,root,root,755)
130 %doc *.gz
131 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.075707 seconds and 4 git commands to generate.