]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
- translated Summaries are back
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ autentykacji MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        2.20a
17 Release:        1
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://web.oyvax.com/src/mod_auth_mysql-%{version}.tar.gz
21 URL:            http://www.diegonet.com/support/mod_auth_mysql.shtml
22 BuildRequires:  mysql-devel
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache(EAPI)-devel
25 Prereq:         %{_sbindir}/apxs
26 Requires:       apache(EAPI)
27 Requires:       apache-mod_auth
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
31
32 %description
33 This is an authentication module for Apache that allows you to
34 authenticate HTTP clients using mysql RDBMS.
35
36 %description -l cs
37 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
38 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
39 MySQL.
40
41 %description -l de
42 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
43 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
44 einer MySQL-Datenbank prüft.
45
46 %description -l es
47 mod_auth_mysql puede usarse para limitar el acceso a documentos
48 servidos por un servidor web verificando datos en una base de datos
49 MySQL.
50
51 %description -l fr
52 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
53 servis par un serveur Web en vérifiant les données dans une base de
54 données MySQL.
55
56 %description -l it
57 mod_auth_mysql può essere usato per limitare l'accesso a documenti
58 serviti da un server Web controllando i dati in un database MySQL.
59
60 %description -l ja
61 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
62 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
63 ¤¬¤Ç¤­¤Þ¤¹¡£
64
65 %description -l pl
66 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
67 klientów HTTP z u¿yciem bazy danych mysql.
68
69 %description -l pt_BR
70 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
71 MySQL.
72
73 %description -l sv
74 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
75 servade av en webbserver genom att kontrollera data i en
76 MySQL-databas.
77
78 %prep
79 %setup -q -n mod_%{mod_name}-%{version}
80
81 %build
82 %{configure2_13} \
83         --with-apxs=%{apxs} \
84         --with-mysql=%{_prefix}
85
86 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_pkglibdir}
91
92 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
93
94 gzip -9nf README README-2.20a USAGE
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
101 if [ -f /var/lock/subsys/httpd ]; then
102         /etc/rc.d/init.d/httpd restart 1>&2
103 fi
104
105 %preun
106 if [ "$1" = "0" ]; then
107         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
108         if [ -f /var/lock/subsys/httpd ]; then
109                 /etc/rc.d/init.d/httpd restart 1>&2
110         fi
111 fi
112
113 %files
114 %defattr(644,root,root,755)
115 %doc *.gz
116 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.080286 seconds and 4 git commands to generate.