]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
- fix md5 location
[packages/aom.git] / aom.spec
1 #
2 # Conditional build:
3 %bcond_without  wxwidgets       # wxWidgets based analyzer
4
5 Summary:        Royalty-free next-generation video format
6 Summary(pl.UTF-8):      Format wideo nowej generacji bez opłat licencyjnych
7 Name:           aom
8 Version:        2.0.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 # tarball is recreated with different md5 on each download
13 #Source0:       https://aomedia.googlesource.com/aom/+archive/v%{version}.tar.gz?fake=/%{name}-%{version}.tar.gz
14 Source0:        %{name}-%{version}.tar.gz
15 # Source0-md5:  28cfda7b3d9b7e9f4ef89437cb96d6ff
16 URL:            https://aomedia.org/
17 BuildRequires:  cmake >= 3.5
18 BuildRequires:  doxygen
19 BuildRequires:  graphviz
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  sed >= 4.0
22 %{?with_wxwidgets:BuildRequires:        wxGTK3-unicode-devel}
23 BuildRequires:  yasm
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Alliance for Open Media's focus is to deliver a next-generation
28 video format that is:
29 - Interoperable and open;
30 - Optimized for the Internet;
31 - Scalable to any modern device at any bandwidth;
32 - Designed with a low computational footprint and optimized for
33   hardware;
34 - Capable of consistent, highest-quality, real-time video delivery;
35   and
36 - Flexible for both commercial and non-commercial content, including
37   user-generated content.
38
39 %description -l pl.UTF-8
40 Celem Alliance for Open Media jest dostarczenie nowej generacji
41 formatu wideo, który jest:
42 - interoperacyjny i otwarty
43 - zoptymalizowany dla Internetu
44 - skalowalny na dowolne współczesne urządzenie przy dowolnym paśmie
45 - zaprojektowany z myślą o małym narzucie obliczeniowym,
46   zoptymalizowany dla sprzętu
47 - umożliwiający spójne udostępnianie wysokiej jakości obrazu w czasie
48   rzeczywistym
49 - elastyczny zarówno dla treści komercyjnych, jak i niekomercyjnych, w
50   tym wygenerowanych przez użytkownika.
51
52 %package devel
53 Summary:        Development files for AOM
54 Summary(pl.UTF-8):      Pliki programistyczne AOM
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Development files for AOM the royalty-free next-generation video
60 format.
61
62 %description devel -l pl.UTF-8
63 Pliki programistyczne AOM - formatu obrazu nowej generacji, bez opłat
64 licencyjnych.
65
66 %package static
67 Summary:        Static AOM library
68 Summary(pl.UTF-8):      Statyczna biblioteka AOM
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static AOM library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka AOM.
77
78 %package apidocs
79 Summary:        API documentation for AOM library
80 Summary(pl.UTF-8):      Dokumentacja API biblioteki AOM
81 Group:          Documentation
82 %if "%{_rpmversion}" >= "4.6"
83 BuildArch:      noarch
84 %endif
85
86 %description apidocs
87 API documentation for AOM library.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API biblioteki AOM.
91
92 %package gui
93 Summary:        Graphical analyzer for AOM
94 Summary(pl.UTF-8):      Graficzny analizator formatu AOM
95 Group:          X11/Applications/Multimedia
96 Requires:       %{name} = %{version}-%{release}
97
98 %description gui
99 Graphical analyzer for AOM.
100
101 %description gui -l pl.UTF-8
102 Graficzny analizator formatu AOM.
103
104 %prep
105 %setup -qc
106
107 %build
108 install -d builddir
109 cd builddir
110 # build/cmake/aom_install.cmake and .pc creation expect relative ..._{BINDIR,INCLUDEDIR,LIBDIR}
111 %cmake .. \
112         -DCMAKE_INSTALL_BINDIR:PATH=bin \
113         -DCMAKE_INSTALL_INCLUDEDIR:PATH=include \
114         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
115 %ifnarch aarch64 %{arm} %{ix86} %{x8664}
116         -DAOM_TARGET_CPU=generic \
117 %endif
118 %ifarch %{arm}
119         -DAOM_TARGET_CPU=arm \
120 %endif
121 %ifarch aarch64
122         -DAOM_TARGET_CPU=arm64 \
123 %endif
124 %ifarch %{ix86}
125         -DAOM_TARGET_CPU=x86 \
126 %endif
127 %ifarch %{x8664}
128         -DAOM_TARGET_CPU=x86_64 \
129 %endif
130         -DCMAKE_SKIP_RPATH=1 \
131         %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
132         -DCONFIG_WEBM_IO=1 \
133         -DENABLE_CCACHE=1 \
134         -DENABLE_DOCS=1 \
135         -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk3-unicode-config
136
137 %{__make}
138
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} -C builddir install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %{?with_wxwidgets:install -p builddir/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc AUTHORS CHANGELOG LICENSE PATENTS README.md
157 %attr(755,root,root) %{_bindir}/aomdec
158 %attr(755,root,root) %{_bindir}/aomenc
159 %attr(755,root,root) %{_libdir}/libaom.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libaom.so.2
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libaom.so
165 %{_includedir}/aom
166 %{_pkgconfigdir}/aom.pc
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libaom.a
171
172 %files apidocs
173 %defattr(644,root,root,755)
174 %doc builddir/docs/html/*
175
176 %if %{with wxwidgets}
177 %files gui
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/aomanalyzer
180 %endif
This page took 0.13314 seconds and 3 git commands to generate.