]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
b9f2d9d300454aeae847256b8abc8243b1dfbff4
[packages/aom.git] / aom.spec
1 #
2 # Conditional build:
3 %bcond_without  wxwidgets       # wxWidgets based analyzer
4
5 %ifarch %{arm_with_neon}
6 %define         with_neon       1
7 %endif
8
9 Summary:        Royalty-free next-generation video format
10 Summary(pl.UTF-8):      Format wideo nowej generacji bez opłat licencyjnych
11 Name:           aom
12 Version:        3.3.0
13 Release:        1
14 License:        BSD
15 Group:          Libraries
16 #Source0Download: https://aomedia.googlesource.com/aom/
17 # tarball is recreated with different md5 on each download
18 #Source0:       https://aomedia.googlesource.com/aom/+archive/v%{version}.tar.gz?fake=/%{name}-%{version}.tar.gz
19 Source0:        %{name}-%{version}.tar.gz
20 # Source0-md5:  07e428c79ea3e81720c13f75f391b955
21 Patch0:         %{name}-examples.patch
22 URL:            https://aomedia.org/
23 BuildRequires:  cmake >= 3.6
24 BuildRequires:  doxygen >= 1:1.8.10
25 BuildRequires:  graphviz
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpmbuild(macros) >= 2.007
29 BuildRequires:  sed >= 4.0
30 %{?with_wxwidgets:BuildRequires:        wxGTK3-unicode-devel}
31 BuildRequires:  yasm
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Alliance for Open Media's focus is to deliver a next-generation
36 video format that is:
37 - Interoperable and open;
38 - Optimized for the Internet;
39 - Scalable to any modern device at any bandwidth;
40 - Designed with a low computational footprint and optimized for
41   hardware;
42 - Capable of consistent, highest-quality, real-time video delivery;
43   and
44 - Flexible for both commercial and non-commercial content, including
45   user-generated content.
46
47 %description -l pl.UTF-8
48 Celem Alliance for Open Media jest dostarczenie nowej generacji
49 formatu wideo, który jest:
50 - interoperacyjny i otwarty
51 - zoptymalizowany dla Internetu
52 - skalowalny na dowolne współczesne urządzenie przy dowolnym paśmie
53 - zaprojektowany z myślą o małym narzucie obliczeniowym,
54   zoptymalizowany dla sprzętu
55 - umożliwiający spójne udostępnianie wysokiej jakości obrazu w czasie
56   rzeczywistym
57 - elastyczny zarówno dla treści komercyjnych, jak i niekomercyjnych, w
58   tym wygenerowanych przez użytkownika.
59
60 %package devel
61 Summary:        Development files for AOM
62 Summary(pl.UTF-8):      Pliki programistyczne AOM
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Development files for AOM the royalty-free next-generation video
68 format.
69
70 %description devel -l pl.UTF-8
71 Pliki programistyczne AOM - formatu obrazu nowej generacji, bez opłat
72 licencyjnych.
73
74 %package static
75 Summary:        Static AOM library
76 Summary(pl.UTF-8):      Statyczna biblioteka AOM
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static AOM library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka AOM.
85
86 %package apidocs
87 Summary:        API documentation for AOM library
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki AOM
89 Group:          Documentation
90 BuildArch:      noarch
91
92 %description apidocs
93 API documentation for AOM library.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki AOM.
97
98 %package gui
99 Summary:        Graphical analyzer for AOM
100 Summary(pl.UTF-8):      Graficzny analizator formatu AOM
101 Group:          X11/Applications/Multimedia
102 Requires:       %{name} = %{version}-%{release}
103
104 %description gui
105 Graphical analyzer for AOM.
106
107 %description gui -l pl.UTF-8
108 Graficzny analizator formatu AOM.
109
110 %prep
111 %setup -qc
112 %patch0 -p1
113
114 %build
115 install -d builddir
116 cd builddir
117 # build/cmake/aom_install.cmake and .pc creation expect relative ..._{BINDIR,INCLUDEDIR,LIBDIR}
118 %cmake .. \
119         -DCMAKE_INSTALL_BINDIR:PATH=bin \
120         -DCMAKE_INSTALL_INCLUDEDIR:PATH=include \
121         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
122 %ifnarch aarch64 %{arm} %{ix86} %{x8664}
123         -DAOM_TARGET_CPU=generic \
124 %endif
125 %ifarch %{arm}
126         -DAOM_TARGET_CPU=arm \
127 %endif
128 %ifarch aarch64
129         -DAOM_TARGET_CPU=arm64 \
130 %endif
131 %ifarch %{ix86}
132         -DAOM_TARGET_CPU=x86 \
133 %endif
134 %ifarch %{x8664}
135         -DAOM_TARGET_CPU=x86_64 \
136 %endif
137         -DCMAKE_SKIP_RPATH=1 \
138         %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
139         -DCONFIG_WEBM_IO=1 \
140         -DENABLE_CCACHE=1 \
141         -DENABLE_DOCS=1 \
142         %{cmake_on_off neon ENABLE_NEON} \
143         -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk3-unicode-config
144
145 %{__make}
146
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} -C builddir install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 %{?with_wxwidgets:install -p builddir/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc AUTHORS CHANGELOG LICENSE PATENTS README.md
165 %attr(755,root,root) %{_bindir}/aomdec
166 %attr(755,root,root) %{_bindir}/aomenc
167 %attr(755,root,root) %{_libdir}/libaom.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libaom.so.3
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libaom.so
173 %{_includedir}/aom
174 %{_pkgconfigdir}/aom.pc
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libaom.a
179
180 %files apidocs
181 %defattr(644,root,root,755)
182 %doc builddir/docs/html/*.{css,html,js,png}
183
184 %if %{with wxwidgets}
185 %files gui
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/aomanalyzer
188 %endif
This page took 0.050336 seconds and 2 git commands to generate.