]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
71312e67c6d29bd9b2611264153eef36cde611da
[packages/aom.git] / aom.spec
1 %bcond_with     wxwidgets
2
3 Summary:        Royalty-free next-generation video format
4 Name:           aom
5 Version:        1.0.0
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 URL:            http://aomedia.org/
10 Source0:        https://aomedia.googlesource.com/aom/+archive/v%{version}.tar.gz
11 # Source0-md5:  65ee0b22640557ee82e11852912f90bb
12 Patch0:         %{name}-build.patch
13 BuildRequires:  cmake
14 BuildRequires:  doxygen
15 BuildRequires:  graphviz
16 BuildRequires:  libstdc++-devel
17 %{?with_wxwidgets:BuildRequires:        wxGTK3-devel}
18 BuildRequires:  yasm
19
20 %description
21 The Alliance for Open Media's focus is to deliver a next-generation
22 video format that is:
23
24  - Interoperable and open;
25  - Optimized for the Internet;
26  - Scalable to any modern device at any bandwidth;
27  - Designed with a low computational footprint and optimized for
28    hardware;
29  - Capable of consistent, highest-quality, real-time video delivery;
30    and
31  - Flexible for both commercial and non-commercial content, including
32    user-generated content.
33
34 %package devel
35 Summary:        Development files for aom
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Development files for aom the royalty-free next-generation video
41 format.
42
43 %prep
44 %setup -qc
45 %patch0 -p1
46
47 %build
48 install -d build; cd build
49 %cmake \
50    -DLIB_INSTALL_DIR=%{_libdir} \
51    -DENABLE_CCACHE=1 \
52    -DCMAKE_SKIP_RPATH=1 \
53 %ifnarch aarch64 %{arm} %{ix86} x86_64
54    -DAOM_TARGET_CPU=generic \
55 %endif
56 %ifarch %{arm}
57    -DAOM_TARGET_CPU=arm \
58 %endif
59 %ifarch aarch64
60    -DAOM_TARGET_CPU=arm64 \
61 %endif
62 %ifarch %{ix86}
63    -DAOM_TARGET_CPU=x86 \
64 %endif
65 %ifarch x86_64
66    -DAOM_TARGET_CPU=x86_64 \
67 %endif
68    -DCONFIG_WEBM_IO=1 \
69    -DENABLE_DOCS=1 \
70    %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
71    ..
72
73 %{__make}
74
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} -C build install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %{?with_wxwidgets:install -pm 0755 build/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS CHANGELOG README.md PATENTS
93 %{?with_wxwidgets:%attr(755,root,root) %{_bindir}/aomanalyzer}
94 %attr(755,root,root) %{_bindir}/aomdec
95 %attr(755,root,root) %{_bindir}/aomenc
96 %attr(755,root,root) %{_libdir}/libaom.so.0
97
98 %files devel
99 %defattr(644,root,root,755)
100 %doc build/docs/html
101 %{_includedir}/%{name}
102 %attr(755,root,root) %{_libdir}/libaom.so
103 %{_pkgconfigdir}/%{name}.pc
This page took 0.128632 seconds and 2 git commands to generate.