]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
- updated to 3.2.0
[packages/aom.git] / aom.spec
1 #
2 # Conditional build:
3 %bcond_without  wxwidgets       # wxWidgets based analyzer
4
5 Summary:        Royalty-free next-generation video format
6 Summary(pl.UTF-8):      Format wideo nowej generacji bez opłat licencyjnych
7 Name:           aom
8 Version:        3.2.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://aomedia.googlesource.com/aom/
13 # tarball is recreated with different md5 on each download
14 #Source0:       https://aomedia.googlesource.com/aom/+archive/v%{version}.tar.gz?fake=/%{name}-%{version}.tar.gz
15 Source0:        %{name}-%{version}.tar.gz
16 # Source0-md5:  94dd35ee7161ac51b65fe0b83a88a1d6
17 Patch0:         %{name}-examples.patch
18 URL:            https://aomedia.org/
19 BuildRequires:  cmake >= 3.6
20 BuildRequires:  doxygen >= 1:1.8.10
21 BuildRequires:  graphviz
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  rpm-build >= 4.6
24 BuildRequires:  rpmbuild(macros) >= 1.752
25 BuildRequires:  sed >= 4.0
26 %{?with_wxwidgets:BuildRequires:        wxGTK3-unicode-devel}
27 BuildRequires:  yasm
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Alliance for Open Media's focus is to deliver a next-generation
32 video format that is:
33 - Interoperable and open;
34 - Optimized for the Internet;
35 - Scalable to any modern device at any bandwidth;
36 - Designed with a low computational footprint and optimized for
37   hardware;
38 - Capable of consistent, highest-quality, real-time video delivery;
39   and
40 - Flexible for both commercial and non-commercial content, including
41   user-generated content.
42
43 %description -l pl.UTF-8
44 Celem Alliance for Open Media jest dostarczenie nowej generacji
45 formatu wideo, który jest:
46 - interoperacyjny i otwarty
47 - zoptymalizowany dla Internetu
48 - skalowalny na dowolne współczesne urządzenie przy dowolnym paśmie
49 - zaprojektowany z myślą o małym narzucie obliczeniowym,
50   zoptymalizowany dla sprzętu
51 - umożliwiający spójne udostępnianie wysokiej jakości obrazu w czasie
52   rzeczywistym
53 - elastyczny zarówno dla treści komercyjnych, jak i niekomercyjnych, w
54   tym wygenerowanych przez użytkownika.
55
56 %package devel
57 Summary:        Development files for AOM
58 Summary(pl.UTF-8):      Pliki programistyczne AOM
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Development files for AOM the royalty-free next-generation video
64 format.
65
66 %description devel -l pl.UTF-8
67 Pliki programistyczne AOM - formatu obrazu nowej generacji, bez opłat
68 licencyjnych.
69
70 %package static
71 Summary:        Static AOM library
72 Summary(pl.UTF-8):      Statyczna biblioteka AOM
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static AOM library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka AOM.
81
82 %package apidocs
83 Summary:        API documentation for AOM library
84 Summary(pl.UTF-8):      Dokumentacja API biblioteki AOM
85 Group:          Documentation
86 BuildArch:      noarch
87
88 %description apidocs
89 API documentation for AOM library.
90
91 %description apidocs -l pl.UTF-8
92 Dokumentacja API biblioteki AOM.
93
94 %package gui
95 Summary:        Graphical analyzer for AOM
96 Summary(pl.UTF-8):      Graficzny analizator formatu AOM
97 Group:          X11/Applications/Multimedia
98 Requires:       %{name} = %{version}-%{release}
99
100 %description gui
101 Graphical analyzer for AOM.
102
103 %description gui -l pl.UTF-8
104 Graficzny analizator formatu AOM.
105
106 %prep
107 %setup -qc
108 %patch0 -p1
109
110 %build
111 install -d builddir
112 cd builddir
113 # build/cmake/aom_install.cmake and .pc creation expect relative ..._{BINDIR,INCLUDEDIR,LIBDIR}
114 %cmake .. \
115         -DCMAKE_INSTALL_BINDIR:PATH=bin \
116         -DCMAKE_INSTALL_INCLUDEDIR:PATH=include \
117         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
118 %ifnarch aarch64 %{arm} %{ix86} %{x8664}
119         -DAOM_TARGET_CPU=generic \
120 %endif
121 %ifarch %{arm}
122         -DAOM_TARGET_CPU=arm \
123 %endif
124 %ifarch aarch64
125         -DAOM_TARGET_CPU=arm64 \
126 %endif
127 %ifarch %{ix86}
128         -DAOM_TARGET_CPU=x86 \
129 %endif
130 %ifarch %{x8664}
131         -DAOM_TARGET_CPU=x86_64 \
132 %endif
133         -DCMAKE_SKIP_RPATH=1 \
134         %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
135         -DCONFIG_WEBM_IO=1 \
136         -DENABLE_CCACHE=1 \
137         -DENABLE_DOCS=1 \
138         -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk3-unicode-config
139
140 %{__make}
141
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} -C builddir install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %{?with_wxwidgets:install -p builddir/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %doc AUTHORS CHANGELOG LICENSE PATENTS README.md
160 %attr(755,root,root) %{_bindir}/aomdec
161 %attr(755,root,root) %{_bindir}/aomenc
162 %attr(755,root,root) %{_libdir}/libaom.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libaom.so.3
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libaom.so
168 %{_includedir}/aom
169 %{_pkgconfigdir}/aom.pc
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libaom.a
174
175 %files apidocs
176 %defattr(644,root,root,755)
177 %doc builddir/docs/html/*.{css,html,js,png}
178
179 %if %{with wxwidgets}
180 %files gui
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/aomanalyzer
183 %endif
This page took 0.055689 seconds and 3 git commands to generate.