]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
3375ad56a1478231b8b70dd1af4cec2b5a23e1f9
[packages/aom.git] / aom.spec
1 %bcond_with     wxwidgets
2
3 Summary:        Royalty-free next-generation video format
4 Name:           aom
5 Version:        1.0.0
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 URL:            http://aomedia.org/
10 # Source0:      https://aomedia.googlesource.com/aom/+archive/v%{version}.tar.gz
11 Source0:        v%{version}.tar.gz
12 # Source0-md5:  dd4689f0425e55dbc255eab73989dca5
13 Patch0:         %{name}-build.patch
14 BuildRequires:  cmake
15 BuildRequires:  doxygen
16 BuildRequires:  graphviz
17 BuildRequires:  libstdc++-devel
18 %{?with_wxwidgets:BuildRequires:        wxGTK3-devel}
19 BuildRequires:  yasm
20
21 %description
22 The Alliance for Open Media's focus is to deliver a next-generation
23 video format that is:
24
25  - Interoperable and open;
26  - Optimized for the Internet;
27  - Scalable to any modern device at any bandwidth;
28  - Designed with a low computational footprint and optimized for
29    hardware;
30  - Capable of consistent, highest-quality, real-time video delivery;
31    and
32  - Flexible for both commercial and non-commercial content, including
33    user-generated content.
34
35 %package devel
36 Summary:        Development files for aom
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Development files for aom the royalty-free next-generation video
42 format.
43
44 %prep
45 %setup -qc
46 %patch0 -p1
47
48 %build
49 install -d build; cd build
50 %cmake \
51    -DLIB_INSTALL_DIR=%{_libdir} \
52    -DENABLE_CCACHE=1 \
53    -DCMAKE_SKIP_RPATH=1 \
54 %ifnarch aarch64 %{arm} %{ix86} x86_64
55    -DAOM_TARGET_CPU=generic \
56 %endif
57 %ifarch %{arm}
58    -DAOM_TARGET_CPU=arm \
59 %endif
60 %ifarch aarch64
61    -DAOM_TARGET_CPU=arm64 \
62 %endif
63 %ifarch %{ix86}
64    -DAOM_TARGET_CPU=x86 \
65 %endif
66 %ifarch x86_64
67    -DAOM_TARGET_CPU=x86_64 \
68 %endif
69    -DCONFIG_WEBM_IO=1 \
70    -DENABLE_DOCS=1 \
71    %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
72    ..
73
74 %{__make}
75
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %{?with_wxwidgets:install -pm 0755 build/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS CHANGELOG README.md PATENTS
94 %{?with_wxwidgets:%attr(755,root,root) %{_bindir}/aomanalyzer}
95 %attr(755,root,root) %{_bindir}/aomdec
96 %attr(755,root,root) %{_bindir}/aomenc
97 %attr(755,root,root) %{_libdir}/libaom.so.0
98
99 %files devel
100 %defattr(644,root,root,755)
101 %doc build/docs/html
102 %{_includedir}/%{name}
103 %attr(755,root,root) %{_libdir}/libaom.so
104 %{_pkgconfigdir}/%{name}.pc
This page took 0.099216 seconds and 2 git commands to generate.