]> git.pld-linux.org Git - packages/antlr.git/blob - antlr.spec
- Be more specific in BR for Ac builders.
[packages/antlr.git] / antlr.spec
1 # Note:
2 # Requires jdk and jar.
3 # For AC builders prolly we need to be more specific about BRs.
4
5 %define         _snap   20030911
6
7 Summary:        ANother Tool for Language Recognition
8 Summary(pl):    Jeszcze jedno narzêdzie do rozpoznawania jêzyka
9 Name:           antlr
10 Version:        2.7.3
11 Release:        0.%{_snap}.3
12 License:        Public Domain
13 Group:          Development/Tools
14 #Source0:       http://www.antlr.org/download/%{name}-%{version}.tar.gz
15 #Source0:       http://wwwhome.cs.utwente.nl/~klaren/antlr/%{name}-%{_snap}.tar.gz
16 Source0:        %{name}-%{_snap}.tar.gz
17 # Source0-md5:  de00ded0f1922587bb24628152fc3f62
18 Patch0:         %{name}-Makefile.patch
19 Patch1:         %{name}-runscript.patch
20 URL:            http://www.antlr.org/
21 BuildRequires:  gcc-java
22 BuildRequires:  gcc-java-tools
23 # BuildRequires:        jar
24 # BuildRequires:        jdk
25 Requires:       jre
26 Conflicts:      pccts < 1.33MR33-6
27 Obsoletes:      pccts-antlr
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ANTLR, ANother Tool for Language Recognition, (formerly PCCTS) is a language
32 tool that provides a framework for constructing recognizers, compilers, and
33 translators from grammatical descriptions containing Java, C#, or C++ actions.
34 ANTLR is popular because it is easy to understand, powerful, flexible,
35 generates human-readable output, and comes with complete source. ANTLR provides
36 excellent support for tree construction, tree walking, and translation. 
37
38 %description -l pl
39 ANTLR (ANother Tool for Language Recognition; poprzednio znane jako
40 PCCTS) to narzêdzie jêzykowe dostarczaj±ce szkielet do tworzenia
41 programów rozpoznaj±cych jêzyki, kompilatorów, translatorów z opisów
42 gramatycznych obejmuj±cych Javê, C# lub C++. ANTLR jest popularne
43 poniewa¿ jest ³atwe do zrozumienia, potê¿ne, elastyczne, generuje
44 wyj¶cie czytelne dla cz³owieka i jset dostêpne z pe³nymi ¼ród³ami.
45 ANTLR ma ¶wietne wsparcie dla tworzenia drzew, przechodzenia po
46 drzewach oraz translacji.
47
48 %prep
49 %setup -q -n %{name}-%{_snap}
50 %patch0 -p1
51 %patch1 -p1
52
53 %build
54 export CLASSPATH=$RPM_BUILD_DIR/%{name}-%{_snap}
55
56 %configure \
57     --enable-gcj
58
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc RIGHTS
73 %attr(755,root,root) %{_bindir}/antlr
74 %attr(755,root,root) %{_bindir}/antlr-config
75 %attr(755,root,root) %{_bindir}/antlr-java
76 %{_includedir}/%{name}
77 %{_libdir}/libantlr.a
78 %{_datadir}/%{name}-%{version}
This page took 0.03103 seconds and 4 git commands to generate.