]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- added helixplayer-morearchs patch (fixes build on alpha and possibly others)
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_without  helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 #
22 Summary:        A KDE audio player
23 Summary(pl):    Odtwarzacz audio dla KDE
24 Name:           amarok
25 Version:        1.3.7
26 Release:        1
27 License:        GPL
28 Group:          X11/Applications/Multimedia
29 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
30 # Source0-md5:  e2297042070643c105f8bb0e524c73ad
31 Patch0:         kde-common-gcc4.patch
32 Patch1:         %{name}-lyricsurl.patch
33 Patch2:         %{name}-libtunepimp-0.4.0.patch
34 Patch3:         %{name}-helixplayer-morearchs.patch
35 URL:            http://amarok.kde.org/
36 #BuildRequires: kdebindings-kjsembed-devel
37 #BuildRequires: unsermake >= 040511
38 BuildRequires:  SDL-devel
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  arts-qt-devel
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
44 BuildRequires:  kdebase-devel
45 %{?with_akode:BuildRequires:    kdemultimedia-akode}
46 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
47 BuildRequires:  libltdl-devel
48 BuildRequires:  libtunepimp-devel >= 0.4.0
49 BuildRequires:  libvisual-devel >= 0.2.0
50 %{?with_mysql:BuildRequires:            mysql-devel}
51 %{?with_pgsql:BuildRequires:            libpqxx-devel}
52 BuildRequires:  pcre-devel
53 BuildRequires:  rpm-pythonprov
54 BuildRequires:  rpmbuild(macros) >= 1.129
55 BuildRequires:  sed >= 4.0
56 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
57 BuildRequires:  taglib-devel >= 1.4
58 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
59 %{?with_xmms:BuildRequires:             xmms-devel}
60 Requires:       %{name}-plugin = %{version}-%{release}
61 Requires:       kdebase-core >= 9:3.1.93
62 Requires:       kdemultimedia-audiocd >= 9:3.1.93
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 A KDE audio player.
67
68 %description -l pl
69 Odtwarzacz audio dla KDE.
70
71 %package arts
72 Summary:        Plugin arts
73 Summary(pl):    Wtyczka arts
74 Group:          X11/Applications/Multimedia
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-plugin = %{version}-%{release}
77
78 %description arts
79 Plugin arts.
80
81 %description arts -l pl
82 Wtyczka arts.
83
84 %package akode
85 Summary:        Plugin akode
86 Summary(pl):    Wtyczka akode
87 Group:          X11/Applications/Multimedia
88 Requires:       %{name} = %{version}-%{release}
89 Provides:       %{name}-plugin = %{version}-%{release}
90
91 %description akode
92 Plugin akode.
93
94 %description akode -l pl
95 Wtyczka akode.
96
97 %package helix
98 Summary:        Helix/Realplayer playback support for amarok
99 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       helix-core
103 Provides:       %{name}-plugin = %{version}-%{release}
104
105 %description helix
106 Helix/Realplayer playback support for amarok.
107
108 %description helix -l pl
109 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
110
111
112 %package gstreamer
113 Summary:        Plugin gstreamer
114 Summary(pl):    Wtyczka gstreamer
115 Group:          X11/Applications/Multimedia
116 # deps, to get it working:
117 # mp3 decoder: gstreamer-mad
118 # ogg decoder: gstreamer-vorbis
119 # audio output driver: gstreamer-audiosink-alsa
120 # from gstreamer-audio-effects to control volume, etc
121 # needed libs:
122 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
123 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
124 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
125 # gstreamer-musicbrainz for being able to edit id3 tags on files.
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       gstreamer-audio-effects
128 Requires:       gstreamer-audiosink
129 Requires:       gstreamer-mad
130 Requires:       gstreamer-musicbrainz
131 Requires:       gstreamer-vorbis
132 Provides:       %{name}-plugin = %{version}-%{release}
133
134 %description gstreamer
135 Plugin gstreamer.
136
137 %description gstreamer -l pl
138 Wtyczka gstreamer.
139
140 %package xine
141 Summary:        Plugin xine
142 Summary(pl):    Wtyczka xine
143 Group:          X11/Applications/Multimedia
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       xine-plugin-audio
146 Provides:       %{name}-plugin = %{version}-%{release}
147
148 %description xine
149 Plugin xine.
150
151 %description xine -l pl
152 Wtyczka xine.
153
154 %package zeroconf
155 Summary:        Zeroconf data
156 Summary(pl):    Dane dla zeroconf
157 Group:          X11/Applications/Multimedia
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       kdenetwork-kdnssd
160 Provides:       %{name}-plugin = %{version}-%{release}
161
162 %description zeroconf
163 Zeroconf data.
164
165 %description zeroconf -l pl
166 Dane dla zeroconf.
167
168 %package scripts
169 Summary:        amaroK scripts
170 Summary(pl):    Skrypty amaroKa
171 Group:          X11/Applications/Multimedia
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       kdebase-kdialog
174 Requires:       python-PyQt
175
176 %description scripts
177 amaroK scripts allow you extend amaroK functionality.
178
179 You can learn more about scripts in amaroK from here:
180 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
181
182 %description scripts -l pl
183 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
184
185 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
186 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
187
188 %prep
189 %setup -q
190 %patch0 -p1
191 %{?with_altlyrics:%patch1 -p1}
192 %patch2 -p1
193 %patch3 -p1
194 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
195         amarok/src/amarok.desktop \
196
197 # see kde bug #110909
198 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
199
200 %build
201 cp -f /usr/share/automake/config.sub admin
202
203 #export UNSERMAKE=/usr/share/unsermake/unsermake
204
205 %{__make} -f admin/Makefile.common cvs
206
207 # hack: passing something other than "no" or "yes" to --with-helix allows
208 # us to pass HELIX_LIBS
209 %configure \
210         HELIX_LIBS=%{_libdir}/helixplayer \
211         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
212         --disable-rpath \
213         --with%{!?with_arts:out}-arts \
214         --with%{!?with_mas:out}-mas \
215         --with%{!?with_xine:out}-xine \
216         --with%{!?with_gstreamer:out}-gstreamer \
217         --with%{!?with_akode:out}-akode \
218         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
219         --with%{!?with_nmm:out}-nmm \
220         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
221         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
222         --disable-final \
223         --with-qt-libraries=%{_libdir} \
224         --with%{!?with_included_sqlite:out}-included-sqlite
225
226 %{__make}
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230
231 %{__make} install \
232         DESTDIR=$RPM_BUILD_ROOT \
233         kde_htmldir=%{_kdedocdir} \
234         kde_libs_htmldir=%{_kdedocdir}
235
236 # remove bogus dir
237 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
238
239 %find_lang amarok --all-name --with-kde
240
241 %clean
242 rm -rf $RPM_BUILD_ROOT
243
244 %post
245 if [ "$1" = 1 ]; then
246         echo "Remember to install libvisual-plugins-* packages if you"
247         echo "want to have a visualizations in amaroK."
248 fi
249
250 %files -f %{name}.lang
251 %defattr(644,root,root,755)
252 %doc AUTHORS ChangeLog README
253 %attr(755,root,root) %{_bindir}/amarok
254 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
255 %attr(755,root,root) %{_bindir}/amarokapp
256 %attr(755,root,root) %{_bindir}/amarok_libvisual
257 #%attr(755,root,root) %{_bindir}/release_amarok
258 %{_libdir}/kde3/konqsidebar_universalamarok.la
259 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
260 %{_libdir}/kde3/libamarok_void-engine_plugin.la
261 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
262 %dir %{_datadir}/apps/amarok
263 %dir %{_datadir}/apps/amarok/scripts
264 %{_datadir}/apps/amarok/*.rc
265 %{_datadir}/apps/amarok/data
266 %{_datadir}/apps/amarok/icons
267 %{_datadir}/apps/amarok/images
268 %{_datadir}/apps/amarok/themes
269 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
270 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
271 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
272 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
273 %{_datadir}/apps/profiles/amarok.profile.xml
274 %{_datadir}/config/amarokrc
275 %{_datadir}/config.kcfg/amarok.kcfg
276 %{_datadir}/services/amarok_void-engine_plugin.desktop
277 %{_datadir}/servicetypes/amarok_plugin.desktop
278 %{_desktopdir}/kde/amarok.desktop
279 %{_iconsdir}/*/*/apps/amarok.*
280
281 %if %{with arts}
282 %files arts
283 %defattr(644,root,root,755)
284 %{_libdir}/kde3/libamarok_artsengine_plugin.la
285 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
286 %{_libdir}/libamarokarts.la
287 %attr(755,root,root) %{_libdir}/libamarokarts.so
288 %{_libdir}/mcop/Amarok
289 %{_libdir}/mcop/amarokarts.mcopclass
290 %{_libdir}/mcop/amarokarts.mcoptype
291 %{_datadir}/services/amarok_artsengine_plugin.desktop
292 %endif
293
294 %if %{with akode}
295 %files akode
296 %defattr(644,root,root,755)
297 %{_libdir}/kde3/libamarok_aKode-engine.la
298 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
299 %{_datadir}/services/amarok_aKode-engine.desktop
300 %endif
301
302 %if %{with gstreamer}
303 %files gstreamer
304 %defattr(644,root,root,755)
305 %{_libdir}/kde3/libamarok_gstengine_plugin.la
306 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
307 %{_datadir}/config.kcfg/gstconfig.kcfg
308 %{_datadir}/services/amarok_gstengine_plugin.desktop
309 %endif
310
311 %if %{with helix}
312 %files helix
313 %defattr(644,root,root,755)
314 %{_libdir}/kde3/libamarok_helixengine_plugin.la
315 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
316 %{_datadir}/config.kcfg/helixconfig.kcfg
317 %{_datadir}/services/amarok_helixengine_plugin.desktop
318 %endif
319
320 %if %{with xine}
321 %files xine
322 %defattr(644,root,root,755)
323 %{_libdir}/kde3/libamarok_xine-engine.la
324 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
325 %{_datadir}/config.kcfg/xinecfg.kcfg
326 %{_datadir}/services/amarok_xine-engine.desktop
327 #%{_datadir}/services/amarok_xineengine_plugin.desktop
328 %endif
329
330 %if %{with zeroconf}
331 %files zeroconf
332 %defattr(644,root,root,755)
333 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
334 %endif
335
336 %files scripts
337 %defattr(644,root,root,755)
338
339 %dir %{_datadir}/apps/amarok/scripts/alarm
340 %{_datadir}/apps/amarok/scripts/alarm/README
341 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
342
343 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
344 %{_datadir}/apps/amarok/scripts/graphequalizer/README
345 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
346
347 %dir %{_datadir}/apps/amarok/scripts/playlist2html
348 %{_datadir}/apps/amarok/scripts/playlist2html/README
349 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
350 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
351 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
352
353 %dir %{_datadir}/apps/amarok/scripts/templates
354 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
355 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
356 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
357
358 %dir %{_datadir}/apps/amarok/scripts/webcontrol
359 %{_datadir}/apps/amarok/scripts/webcontrol/README
360 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
361 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
362 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
363 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
364 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
365 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
366 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
367 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
368 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
369 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
370 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
371 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
372 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
373 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
374 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
375 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
376
377 %dir %{_datadir}/apps/amarok/scripts/common
378 %{_datadir}/apps/amarok/scripts/common/Publisher.py
379 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
380
381 #%dir %{_datadir}/apps/amarok/scripts/shouter
382 #%{_datadir}/apps/amarok/scripts/shouter/README
383 #%{_datadir}/apps/amarok/scripts/shouter/ChangeLog
384 #%{_datadir}/apps/amarok/scripts/shouter/Amarok.py
385 #%{_datadir}/apps/amarok/scripts/shouter/Globals.py
386 #%{_datadir}/apps/amarok/scripts/shouter/Playlist.py
387 #%{_datadir}/apps/amarok/scripts/shouter/Services.py
388 #%{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
389 #%{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
390 #%{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
391 #%{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
392 #%{_datadir}/apps/amarok/scripts/shouter/StreamController.py
393 #%{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
394 #%{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
395 #%{_datadir}/apps/amarok/scripts/shouter/debug.py
396 #%{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
397 #%dir %{_datadir}/apps/amarok/scripts/shouter/silence
398 #%{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
399 #%dir %{_datadir}/apps/amarok/scripts/shouter/test
400 #%{_datadir}/apps/amarok/scripts/shouter/test/client.py
401 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
402
403 %if 0
404 %dir %{_datadir}/apps/amarok/scripts/amarok_live
405 %{_datadir}/apps/amarok/scripts/amarok_live/README
406 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
407 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
408 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
409 %endif
This page took 0.060362 seconds and 4 git commands to generate.