]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- merged 1.4.0a from DEVEL
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
9 %bcond_without  mas             # disable MAS audio backend
10 %bcond_without  xine            # disable xine engine
11 %bcond_without  xmms            # disable xmms wrapping
12 %bcond_without  zeroconf        # disable support for zeroconf
13 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
14 %bcond_without  helix           # disable HelixPlayer engine
15 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 #
20 %ifarch i386
21 %undefine       with_helix
22 %endif
23
24 Summary:        A KDE audio player
25 Summary(pl):    Odtwarzacz audio dla KDE
26 Name:           amarok
27 %define         _ver 1.4.0
28 %define         _rel a
29 Version:        %{_ver}%{_rel}
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
34 # Source0-md5:  3ceffe6465290eef618861cdb81b420a
35 Patch0:         %{name}-helixplayer-morearchs.patch
36 URL:            http://amarok.kde.org/
37 BuildRequires:  SDL-devel
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  dbus-glib-devel
42 BuildRequires:  gettext-devel
43 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
44 BuildRequires:  gtk+2-devel
45 BuildRequires:  kdebase-devel
46 %{?with_akode:BuildRequires:    kdemultimedia-akode}
47 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
48 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
49 %{?with_mp3players:BuildRequires:       libifp-devel}
50 BuildRequires:  libltdl-devel
51 %{?with_pgsql:BuildRequires:            libpqxx-devel}
52 BuildRequires:  libtunepimp-devel >= 0.4.0
53 BuildRequires:  libvisual-devel >= 0.2.0
54 BuildRequires:  mpeg4ip-devel
55 %{?with_mysql:BuildRequires:            mysql-devel}
56 BuildRequires:  pcre-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  rpm-pythonprov
59 BuildRequires:  rpmbuild(macros) >= 1.129
60 BuildRequires:  sed >= 4.0
61 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
62 BuildRequires:  taglib-devel >= 1.4
63 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
64 %{?with_xmms:BuildRequires:     xmms-devel}
65 Requires:       %{name}-plugin = %{version}-%{release}
66 Requires:       kdebase-core >= 9:3.1.93
67 Requires:       kdemultimedia-audiocd >= 9:3.1.93
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 A KDE audio player.
72
73 %description -l pl
74 Odtwarzacz audio dla KDE.
75
76 %package akode
77 Summary:        Plugin akode
78 Summary(pl):    Wtyczka akode
79 Group:          X11/Applications/Multimedia
80 Requires:       %{name} = %{version}-%{release}
81 Provides:       %{name}-plugin = %{version}-%{release}
82
83 %description akode
84 Plugin akode.
85
86 %description akode -l pl
87 Wtyczka akode.
88
89 %package helix
90 Summary:        Helix/Realplayer playback support for amarok
91 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
92 Group:          X11/Applications/Multimedia
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       helix-core
95 Provides:       %{name}-plugin = %{version}-%{release}
96
97 %description helix
98 Helix/Realplayer playback support for amarok.
99
100 %description helix -l pl
101 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
102
103 %package gstreamer
104 Summary:        Plugin gstreamer
105 Summary(pl):    Wtyczka gstreamer
106 Group:          X11/Applications/Multimedia
107 # deps, to get it working:
108 # mp3 decoder:  gstreamer-mad
109 # ogg decoder:  gstreamer-vorbis
110 # audio output driver:  gstreamer-audiosink-alsa
111 # from gstreamer-audio-effects to control volume, etc
112 # needed libs:
113 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
114 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
115 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
116 # gstreamer-musicbrainz for being able to edit id3 tags on files.
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       gstreamer-audio-effects
119 Requires:       gstreamer-audiosink
120 Requires:       gstreamer-mad
121 Requires:       gstreamer-musicbrainz
122 Requires:       gstreamer-vorbis
123 Provides:       %{name}-plugin = %{version}-%{release}
124
125 %description gstreamer
126 Plugin gstreamer.
127
128 %description gstreamer -l pl
129 Wtyczka gstreamer.
130
131 %package xine
132 Summary:        Plugin xine
133 Summary(pl):    Wtyczka xine
134 Group:          X11/Applications/Multimedia
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       xine-plugin-audio
137 Provides:       %{name}-plugin = %{version}-%{release}
138
139 %description xine
140 Plugin xine.
141
142 %description xine -l pl
143 Wtyczka xine.
144
145 %package xmms
146 Summary:        Xmms wrapper
147 Summary(pl):    Wrapper xmms
148 Group:          X11/Applications/Multimedia
149 Requires:       %{name} = %{version}-%{release}
150
151 %description xmms
152 Xmms wrapper.
153
154 %description xmms -l pl
155 Wrapper xmms.
156
157 %package zeroconf
158 Summary:        Zeroconf data
159 Summary(pl):    Dane dla zeroconf
160 Group:          X11/Applications/Multimedia
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       kdenetwork-kdnssd
163 Provides:       %{name}-plugin = %{version}-%{release}
164
165 %description zeroconf
166 Zeroconf data.
167
168 %description zeroconf -l pl
169 Dane dla zeroconf.
170
171 %package scripts
172 Summary:        amaroK scripts
173 Summary(pl):    Skrypty amaroKa
174 Group:          X11/Applications/Multimedia
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       kdebase-kdialog
177 Requires:       python-PyQt
178 Requires:       ruby-modules
179
180 %description scripts
181 amaroK scripts allow you extend amaroK functionality.
182
183 You can learn more about scripts in amaroK from here:
184 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
185
186 %description scripts -l pl
187 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
188
189 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
190 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
191
192 %prep
193 %setup -q -n %{name}-%{_ver}
194 %patch0 -p1
195 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
196         amarok/src/amarok.desktop \
197
198 # see kde bug #110909
199 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
200
201 # kill env, call interpreter directly, so rpm automatics could rule
202 sed -i -e '
203         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
204         1s,#!.*bin/env.*python,#!%{_bindir}/python,
205         1s,#!.*bin/env.*bash,#!/bin/bash,
206 ' amarok/src/scripts/*/*.{py,rb,sh}
207
208 %build
209 cp -f /usr/share/automake/config.sub admin
210 %{__make} -f admin/Makefile.common cvs
211
212 # hack: passing something other than "no" or "yes" to --with-helix allows
213 # us to pass HELIX_LIBS
214 %configure \
215         HELIX_LIBS=%{_libdir}/helixplayer \
216         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
217         --disable-rpath \
218         --with%{!?with_mas:out}-mas \
219         --with%{!?with_xine:out}-xine \
220         --with%{!?with_gstreamer:out}-gstreamer10 \
221         --with%{!?with_akode:out}-akode \
222         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
223         --with%{!?with_nmm:out}-nmm \
224         --with%{!?with_mp3players:out}-libgpod \
225         --with%{!?with_mp3players:out}-ifp \
226         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
227         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
228         --disable-final \
229         --with-mp4v2 \
230         --with-qt-libraries=%{_libdir} \
231         --with%{!?with_included_sqlite:out}-included-sqlite
232
233 %{__make}
234
235 %install
236 rm -rf $RPM_BUILD_ROOT
237
238 %{__make} install \
239         DESTDIR=$RPM_BUILD_ROOT \
240         kde_htmldir=%{_kdedocdir} \
241         kde_libs_htmldir=%{_kdedocdir}
242
243 # remove bogus dir
244 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
245
246 %find_lang amarok --all-name --with-kde
247
248 %clean
249 rm -rf $RPM_BUILD_ROOT
250
251 %post
252 if [ "$1" = 1 ]; then
253         echo "Remember to install libvisual-plugins-* packages if you"
254         echo "want to have a visualizations in amaroK."
255 fi
256 /sbin/ldconfig
257
258 %postun -p /sbin/ldconfig
259
260 %files -f %{name}.lang
261 %defattr(644,root,root,755)
262 %doc AUTHORS ChangeLog README
263 %attr(755,root,root) %{_bindir}/amarok
264 %attr(755,root,root) %{_bindir}/amarokapp
265 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
266 #%attr(755,root,root) %{_bindir}/amarok_libvisual
267 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
268 %{_libdir}/kde3/konqsidebar_universalamarok.la
269 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
270 %{_libdir}/kde3/libamarok_generic-mediadevice.la
271 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
272 %{_libdir}/kde3/libamarok_void-engine_plugin.la
273 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
274 %{_libdir}/libamarok.la
275 %dir %{_datadir}/apps/amarok
276 %dir %{_datadir}/apps/amarok/scripts
277 %{_datadir}/apps/amarok/*.rc
278 %{_datadir}/apps/amarok/data
279 %{_datadir}/apps/amarok/icons
280 %{_datadir}/apps/amarok/images
281 %{_datadir}/apps/amarok/themes
282 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
283 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
284 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
285 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
286 %{_datadir}/apps/profiles/amarok.profile.xml
287 %{_datadir}/config/amarokrc
288 %{_datadir}/config.kcfg/amarok.kcfg
289 %{_datadir}/services/amarok_generic-mediadevice.desktop
290 %{_datadir}/services/amarok_void-engine_plugin.desktop
291 %{_datadir}/servicetypes/amarok_plugin.desktop
292 %{_desktopdir}/kde/amarok.desktop
293 %{_iconsdir}/*/*/apps/amarok.*
294 # TODO: move to subpackage
295 %if %{with mp3players}
296 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
297 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
298 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
299 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
300 %{_datadir}/services/amarok_ipod-mediadevice.desktop
301 %{_datadir}/services/amarok_ifp-mediadevice.desktop
302 %endif
303
304 %if %{with akode}
305 %files akode
306 %defattr(644,root,root,755)
307 %{_libdir}/kde3/libamarok_aKode-engine.la
308 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
309 %{_datadir}/services/amarok_aKode-engine.desktop
310 %endif
311
312 %if %{with gstreamer}
313 %files gstreamer
314 %defattr(644,root,root,755)
315 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
316 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
317 %{_datadir}/config.kcfg/gstconfig.kcfg
318 %{_datadir}/services/amarok_gst10engine_plugin.desktop
319 %endif
320
321 %if %{with helix}
322 %files helix
323 %defattr(644,root,root,755)
324 %{_libdir}/kde3/libamarok_helixengine_plugin.la
325 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
326 %{_datadir}/config.kcfg/helixconfig.kcfg
327 %{_datadir}/services/amarok_helixengine_plugin.desktop
328 %endif
329
330 %if %{with xine}
331 %files xine
332 %defattr(644,root,root,755)
333 %{_libdir}/kde3/libamarok_xine-engine.la
334 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
335 %{_datadir}/config.kcfg/xinecfg.kcfg
336 %{_datadir}/services/amarok_xine-engine.desktop
337 #%{_datadir}/services/amarok_xineengine_plugin.desktop
338 %endif
339
340 %if %{with xmms}
341 %files xmms
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
344 %endif
345
346 %if 0
347 %if %{with zeroconf}
348 %files zeroconf
349 %defattr(644,root,root,755)
350 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
351 %endif
352 %endif
353
354 %files scripts
355 %defattr(644,root,root,755)
356 %dir %{_datadir}/apps/amarok/scripts/common
357 %{_datadir}/apps/amarok/scripts/common/Publisher.py
358 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
359
360 %dir %{_datadir}/apps/amarok/scripts/templates
361 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
362 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
363 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
364
365 # amarok searches for executable programs for scripts
366 # to figure out which files need to have execute permission, use this
367 # find command:
368 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
369
370 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
371 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
372 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
373
374 %dir %{_datadir}/apps/amarok/scripts/playlist2html
375 %{_datadir}/apps/amarok/scripts/playlist2html/README
376 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
377 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
378 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
379
380 %dir %{_datadir}/apps/amarok/scripts/webcontrol
381 %{_datadir}/apps/amarok/scripts/webcontrol/README
382 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
383 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
384 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
385 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
386 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
387 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
388 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
389 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
390 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
391 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
392 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
393 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
394 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
395 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
396 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
397 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
398 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
399 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
400 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
401
402 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
403 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
404 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
405 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
406 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
407
408 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
409 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
410 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
411 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
412 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
413
414 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
415 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
416
417 %if 0
418 %dir %{_datadir}/apps/amarok/scripts/amarok_live
419 %{_datadir}/apps/amarok/scripts/amarok_live/README
420 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
421 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
422 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
423 %endif
This page took 0.058324 seconds and 4 git commands to generate.