]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- Obsoletes: amarok-arts
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
9 %bcond_without  mas             # disable MAS audio backend
10 %bcond_without  xine            # disable xine engine
11 %bcond_without  xmms            # disable xmms wrapping
12 %bcond_without  zeroconf        # disable support for zeroconf
13 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
14 %bcond_without  helix           # disable HelixPlayer engine
15 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable MySQL support
18 %bcond_with     pgsql           # enable PostgreSQL support
19 #
20 %ifarch i386
21 %undefine       with_helix
22 %endif
23
24 Summary:        A KDE audio player
25 Summary(pl):    Odtwarzacz audio dla KDE
26 Name:           amarok
27 %define         _ver 1.4.0
28 %define         _rel a
29 Version:        %{_ver}%{_rel}
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
34 # Source0-md5:  3ceffe6465290eef618861cdb81b420a
35 Patch0:         %{name}-helixplayer-morearchs.patch
36 URL:            http://amarok.kde.org/
37 BuildRequires:  SDL-devel
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  dbus-glib-devel
42 BuildRequires:  gettext-devel
43 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
44 BuildRequires:  kdebase-devel
45 %{?with_akode:BuildRequires:    kdemultimedia-akode}
46 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
47 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
48 %{?with_mp3players:BuildRequires:       libifp-devel}
49 BuildRequires:  libltdl-devel
50 %{?with_pgsql:BuildRequires:            libpqxx-devel}
51 BuildRequires:  libtunepimp-devel >= 0.4.0
52 #BuildRequires: libvisual-devel >= 0.2.0
53 #BuildRequires: libvisual-devel < 0.3
54 BuildRequires:  mpeg4ip-devel
55 %{?with_mysql:BuildRequires:            mysql-devel}
56 BuildRequires:  pcre-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  rpm-pythonprov
59 BuildRequires:  rpmbuild(macros) >= 1.129
60 BuildRequires:  sed >= 4.0
61 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
62 BuildRequires:  taglib-devel >= 1.4
63 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
64 %{?with_xmms:BuildRequires:     xmms-devel}
65 Requires:       %{name}-plugin = %{version}-%{release}
66 Requires:       kdebase-core >= 9:3.1.93
67 Requires:       kdemultimedia-audiocd >= 9:3.1.93
68 Obsoletes:      amarok-arts
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 A KDE audio player.
73
74 %description -l pl
75 Odtwarzacz audio dla KDE.
76
77 %package akode
78 Summary:        Plugin akode
79 Summary(pl):    Wtyczka akode
80 Group:          X11/Applications/Multimedia
81 Requires:       %{name} = %{version}-%{release}
82 Provides:       %{name}-plugin = %{version}-%{release}
83
84 %description akode
85 Plugin akode.
86
87 %description akode -l pl
88 Wtyczka akode.
89
90 %package helix
91 Summary:        Helix/Realplayer playback support for amarok
92 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
93 Group:          X11/Applications/Multimedia
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       helix-core
96 Provides:       %{name}-plugin = %{version}-%{release}
97
98 %description helix
99 Helix/Realplayer playback support for amarok.
100
101 %description helix -l pl
102 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
103
104 %package gstreamer
105 Summary:        Plugin gstreamer
106 Summary(pl):    Wtyczka gstreamer
107 Group:          X11/Applications/Multimedia
108 # deps, to get it working:
109 # mp3 decoder:  gstreamer-mad
110 # ogg decoder:  gstreamer-vorbis
111 # audio output driver:  gstreamer-audiosink-alsa
112 # from gstreamer-audio-effects to control volume, etc
113 # needed libs:
114 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
115 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
116 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
117 # gstreamer-musicbrainz for being able to edit id3 tags on files.
118 Requires:       %{name} = %{version}-%{release}
119 Requires:       gstreamer-audio-effects
120 Requires:       gstreamer-audiosink
121 Requires:       gstreamer-mad
122 Requires:       gstreamer-musicbrainz
123 Requires:       gstreamer-vorbis
124 Provides:       %{name}-plugin = %{version}-%{release}
125
126 %description gstreamer
127 Plugin gstreamer.
128
129 %description gstreamer -l pl
130 Wtyczka gstreamer.
131
132 %package xine
133 Summary:        Plugin xine
134 Summary(pl):    Wtyczka xine
135 Group:          X11/Applications/Multimedia
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       xine-plugin-audio
138 Provides:       %{name}-plugin = %{version}-%{release}
139
140 %description xine
141 Plugin xine.
142
143 %description xine -l pl
144 Wtyczka xine.
145
146 %package xmms
147 Summary:        Xmms wrapper
148 Summary(pl):    Wrapper xmms
149 Group:          X11/Applications/Multimedia
150 Requires:       %{name} = %{version}-%{release}
151
152 %description xmms
153 Xmms wrapper.
154
155 %description xmms -l pl
156 Wrapper xmms.
157
158 %package zeroconf
159 Summary:        Zeroconf data
160 Summary(pl):    Dane dla zeroconf
161 Group:          X11/Applications/Multimedia
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       kdenetwork-kdnssd
164 Provides:       %{name}-plugin = %{version}-%{release}
165
166 %description zeroconf
167 Zeroconf data.
168
169 %description zeroconf -l pl
170 Dane dla zeroconf.
171
172 %package scripts
173 Summary:        amaroK scripts
174 Summary(pl):    Skrypty amaroKa
175 Group:          X11/Applications/Multimedia
176 Requires:       %{name} = %{version}-%{release}
177 Requires:       kdebase-kdialog
178 Requires:       python-PyQt
179 Requires:       ruby-modules
180
181 %description scripts
182 amaroK scripts allow you extend amaroK functionality.
183
184 You can learn more about scripts in amaroK from here:
185 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
186
187 %description scripts -l pl
188 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
189
190 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
191 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
192
193 %prep
194 %setup -q -n %{name}-%{_ver}
195 %patch0 -p1
196 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
197         amarok/src/amarok.desktop \
198
199 # see kde bug #110909
200 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
201
202 # kill env, call interpreter directly, so rpm automatics could rule
203 sed -i -e '
204         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
205         1s,#!.*bin/env.*python,#!%{_bindir}/python,
206         1s,#!.*bin/env.*bash,#!/bin/bash,
207 ' amarok/src/scripts/*/*.{py,rb,sh}
208
209 %build
210 cp -f /usr/share/automake/config.sub admin
211 %{__make} -f admin/Makefile.common cvs
212
213 # hack: passing something other than "no" or "yes" to --with-helix allows
214 # us to pass HELIX_LIBS
215 %configure \
216         HELIX_LIBS=%{_libdir}/helixplayer \
217         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
218         --disable-rpath \
219         --with%{!?with_mas:out}-mas \
220         --with%{!?with_xine:out}-xine \
221         --with%{!?with_gstreamer:out}-gstreamer10 \
222         --with%{!?with_akode:out}-akode \
223         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
224         --with%{!?with_nmm:out}-nmm \
225         --with%{!?with_mp3players:out}-libgpod \
226         --with%{!?with_mp3players:out}-ifp \
227         --without-libvisual \
228         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
229         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
230         --disable-final \
231         --with-mp4v2 \
232         --with-qt-libraries=%{_libdir} \
233         --with%{!?with_included_sqlite:out}-included-sqlite
234
235 %{__make}
236
237 %install
238 rm -rf $RPM_BUILD_ROOT
239
240 %{__make} install \
241         DESTDIR=$RPM_BUILD_ROOT \
242         kde_htmldir=%{_kdedocdir} \
243         kde_libs_htmldir=%{_kdedocdir}
244
245 # remove bogus dir
246 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
247
248 %find_lang amarok --all-name --with-kde
249
250 %clean
251 rm -rf $RPM_BUILD_ROOT
252
253 #if [ "$1" = 1 ]; then
254 #       echo "Remember to install libvisual-plugins-* packages if you"
255 #       echo "want to have a visualizations in amaroK."
256 #fi
257
258 %post   -p /sbin/ldconfig
259 %postun -p /sbin/ldconfig
260
261 %files -f %{name}.lang
262 %defattr(644,root,root,755)
263 %doc AUTHORS ChangeLog README
264 %attr(755,root,root) %{_bindir}/amarok
265 %attr(755,root,root) %{_bindir}/amarokapp
266 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
267 #%attr(755,root,root) %{_bindir}/amarok_libvisual
268 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
269 %{_libdir}/kde3/konqsidebar_universalamarok.la
270 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
271 %{_libdir}/kde3/libamarok_generic-mediadevice.la
272 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
273 %{_libdir}/kde3/libamarok_void-engine_plugin.la
274 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
275 %{_libdir}/libamarok.la
276 %dir %{_datadir}/apps/amarok
277 %dir %{_datadir}/apps/amarok/scripts
278 %{_datadir}/apps/amarok/*.rc
279 %{_datadir}/apps/amarok/data
280 %{_datadir}/apps/amarok/icons
281 %{_datadir}/apps/amarok/images
282 %{_datadir}/apps/amarok/themes
283 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
284 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
285 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
286 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
287 %{_datadir}/apps/profiles/amarok.profile.xml
288 %{_datadir}/config/amarokrc
289 %{_datadir}/config.kcfg/amarok.kcfg
290 %{_datadir}/services/amarok_generic-mediadevice.desktop
291 %{_datadir}/services/amarok_void-engine_plugin.desktop
292 %{_datadir}/servicetypes/amarok_plugin.desktop
293 %{_desktopdir}/kde/amarok.desktop
294 %{_iconsdir}/*/*/apps/amarok.*
295 # TODO: move to subpackage
296 %if %{with mp3players}
297 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
298 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
299 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
300 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
301 %{_datadir}/services/amarok_ipod-mediadevice.desktop
302 %{_datadir}/services/amarok_ifp-mediadevice.desktop
303 %endif
304
305 %if %{with akode}
306 %files akode
307 %defattr(644,root,root,755)
308 %{_libdir}/kde3/libamarok_aKode-engine.la
309 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
310 %{_datadir}/services/amarok_aKode-engine.desktop
311 %endif
312
313 %if %{with gstreamer}
314 %files gstreamer
315 %defattr(644,root,root,755)
316 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
317 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
318 %{_datadir}/config.kcfg/gstconfig.kcfg
319 %{_datadir}/services/amarok_gst10engine_plugin.desktop
320 %endif
321
322 %if %{with helix}
323 %files helix
324 %defattr(644,root,root,755)
325 %{_libdir}/kde3/libamarok_helixengine_plugin.la
326 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
327 %{_datadir}/config.kcfg/helixconfig.kcfg
328 %{_datadir}/services/amarok_helixengine_plugin.desktop
329 %endif
330
331 %if %{with xine}
332 %files xine
333 %defattr(644,root,root,755)
334 %{_libdir}/kde3/libamarok_xine-engine.la
335 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
336 %{_datadir}/config.kcfg/xinecfg.kcfg
337 %{_datadir}/services/amarok_xine-engine.desktop
338 #%{_datadir}/services/amarok_xineengine_plugin.desktop
339 %endif
340
341 %if %{with xmms}
342 %files xmms
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
345 %endif
346
347 %if 0
348 %if %{with zeroconf}
349 %files zeroconf
350 %defattr(644,root,root,755)
351 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
352 %endif
353 %endif
354
355 %files scripts
356 %defattr(644,root,root,755)
357 %dir %{_datadir}/apps/amarok/scripts/common
358 %{_datadir}/apps/amarok/scripts/common/Publisher.py
359 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
360
361 %dir %{_datadir}/apps/amarok/scripts/templates
362 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
363 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
364 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
365
366 # amarok searches for executable programs for scripts
367 # to figure out which files need to have execute permission, use this
368 # find command:
369 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
370
371 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
372 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
373 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
374
375 %dir %{_datadir}/apps/amarok/scripts/playlist2html
376 %{_datadir}/apps/amarok/scripts/playlist2html/README
377 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
378 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
379 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
380
381 %dir %{_datadir}/apps/amarok/scripts/webcontrol
382 %{_datadir}/apps/amarok/scripts/webcontrol/README
383 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
384 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
385 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
386 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
387 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
388 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
389 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
390 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
391 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
392 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
393 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
394 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
395 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
396 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
397 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
398 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
399 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
400 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
401 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
402
403 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
404 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
405 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
406 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
407 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
408
409 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
410 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
411 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
412 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
413 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
414
415 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
416 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
417
418 %if 0
419 %dir %{_datadir}/apps/amarok/scripts/amarok_live
420 %{_datadir}/apps/amarok/scripts/amarok_live/README
421 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
422 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
423 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
424 %endif
This page took 0.061304 seconds and 4 git commands to generate.