]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- tatü tata, die Ausbesserungspolizei ist da!!
[packages/amarok.git] / amarok.spec
1 # TODO
2 # - try not to link with static mysql
3
4 %define         state   stable
5 %define         qtver   4.7.1
6 %define         kdever  4.5.5
7
8 Summary:        A KDE audio player
9 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        2.4.0
12 Release:        2
13 License:        GPL v2+ and LGPL v2.1+
14 Group:          X11/Applications/Multimedia
15 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  bdb6ddc8e38d0982a0786ff8ac96d923
17 Patch0:         %{name}-disable_qtscriptbindings_check_fix.patch
18 URL:            http://amarok.kde.org/
19 BuildRequires:  QtNetwork-devel >= %{qtver}
20 BuildRequires:  QtSql-devel >= %{qtver}
21 BuildRequires:  automoc4 >= 0.9.88
22 BuildRequires:  cmake >= 2.8.0
23 BuildRequires:  curl-devel
24 BuildRequires:  gettext-devel
25 BuildRequires:  glib2-devel
26 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
27 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
28 BuildRequires:  libgpod-devel >= 0.7.0
29 BuildRequires:  liblastfm-devel
30 BuildRequires:  libmtp-devel >= 0.3.0
31 BuildRequires:  libofa-devel
32 BuildRequires:  libwrap-devel
33 BuildRequires:  loudmouth-devel
34 BuildRequires:  mysql-devel >= 5.1.31-3
35 BuildRequires:  pcre-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  qca-devel
38 BuildRequires:  qt4-build >= %{qtver}
39 BuildRequires:  qt4-qmake >= %{qtver}
40 BuildRequires:  qtscriptbindings
41 BuildRequires:  rpmbuild(macros) >= 1.600
42 BuildRequires:  soprano-devel
43 BuildRequires:  strigi-devel >= 0.7.0
44 BuildRequires:  taglib-devel >= 1.6
45 BuildRequires:  taglib-extras-devel >= 1.0.0
46 BuildRequires:  xorg-lib-libXpm-devel
47 Requires(post,postun):  /sbin/ldconfig
48 Requires:       kde4-kdemultimedia-audiocd
49 Requires:       kde4-phonon
50 Requires:       qtscriptbindings
51 Suggests:       libvisual-plugin-actor-JESS
52 Suggests:       libvisual-plugin-actor-bumpscope
53 Suggests:       libvisual-plugin-actor-corona
54 Suggests:       libvisual-plugin-actor-flower
55 Suggests:       libvisual-plugin-actor-gdkpixbuf
56 Suggests:       libvisual-plugin-actor-gforce
57 Suggests:       libvisual-plugin-actor-gstreamer
58 Suggests:       libvisual-plugin-actor-infinite
59 Suggests:       libvisual-plugin-actor-jakdaw
60 Suggests:       libvisual-plugin-actor-lv_analyzer
61 Suggests:       libvisual-plugin-actor-lv_gltest
62 Suggests:       libvisual-plugin-actor-lv_scope
63 Suggests:       libvisual-plugin-actor-madspin
64 Suggests:       libvisual-plugin-actor-nastyfft
65 Suggests:       libvisual-plugin-actor-oinksie
66 Suggests:       libvisual-plugin-input-alsa
67 Suggests:       libvisual-plugin-input-esd
68 Suggests:       libvisual-plugin-input-jack
69 Suggests:       libvisual-plugin-input-mplayer
70 Suggests:       libvisual-plugin-morph-alphablend
71 Suggests:       libvisual-plugin-morph-flash
72 Suggests:       libvisual-plugin-morph-slide
73 Suggests:       libvisual-plugin-morph-tentacle
74 Obsoletes:      amarok-arts
75 Obsoletes:      amarok-xmms
76 # It should require mysql-embeded
77 Requires:       mysql >= 5.1.31-3
78 Conflicts:      mysql < 5.1.31-3
79 # sr@Latn vs. sr@latin
80 Conflicts:      glibc-misc < 6:2.7
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 A KDE audio player.
85
86 %description -l pl.UTF-8
87 Odtwarzacz audio dla KDE.
88
89 %package scripts
90 Summary:        amaroK scripts
91 Summary(pl.UTF-8):      Skrypty amaroKa
92 Group:          X11/Applications/Multimedia
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       kde4-kdebase-kdialog
95
96 %description scripts
97 amaroK scripts allow you extend amaroK functionality.
98
99 You can learn more about scripts in amaroK from here:
100 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
101
102 %description scripts -l pl.UTF-8
103 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
104
105 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
106 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 %build
113 install -d build
114 cd build
115 %cmake \
116         ../
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} -C build install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         kde_htmldir=%{_kdedocdir} \
126         kde_libs_htmldir=%{_kdedocdir}
127
128 # remove unsupported locale
129 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
130
131 # remove .so symlinks so that noone gets the stupid idea to package them
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
133
134 %find_lang %{name} --all-name --with-kde
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post           -p /sbin/ldconfig
140 %postun         -p /sbin/ldconfig
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog README
145 %attr(755,root,root) %{_bindir}/amarok
146 %attr(755,root,root) %{_bindir}/amarokpkg
147 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
148 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
149 %attr(755,root,root) %{_bindir}/amarok_afttagger
150 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
151 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
153 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
155 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
157 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
159 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
161 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
163 %attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
164 %attr(755,root,root) %{_libdir}/libampache_account_login.so
165 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
166 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
167 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
168 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
169 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
170 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
171 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
172 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
173 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
174 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
201 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
202 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
203 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
204 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
209 %dir %{_datadir}/apps/amarok
210 %dir %{_datadir}/apps/amarok/scripts
211 %{_datadir}/apps/amarok/data
212 %{_datadir}/apps/amarok/icons
213 %{_datadir}/apps/amarok/images
214 %{_datadir}/apps/amarok/amarok.notifyrc
215 %{_datadir}/apps/desktoptheme
216 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
217 %{_datadir}/config.kcfg/amarokconfig.kcfg
218 %{_datadir}/config/amarok.knsrc
219 %{_datadir}/config/amarokapplets.knsrc
220 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
221 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
222 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
223 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
224 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
225 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
226 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
227 %{_datadir}/applications/kde4/amarok_containers.desktop
228 %{_datadir}/kde4/services/amarok.protocol
229 %{_datadir}/kde4/services/amaroklastfm.protocol
230 %{_datadir}/kde4/services/amarokitpc.protocol
231 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
232 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
233 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
234 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
235 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
236 %{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
237 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
238 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
239 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
240 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
241 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
242 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
243 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
244 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
245 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
246 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
247 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
248 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
250 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
251 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
252 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
253 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
254 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
255 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
256 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
257 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
258 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
259 %{_datadir}/kde4/services/amarok_massstorage-device.desktop
260 %{_datadir}/kde4/services/amarok_service_ampache.desktop
261 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
262 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
263 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
264 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
265 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
266 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
267 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
268 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
269 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
270 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
271 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
272 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
273 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
274 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
275 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
276 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
277 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
278 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
279 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
280 %{_desktopdir}/kde4/amarok.desktop
281 %{_iconsdir}/*/*/apps/amarok.*
282 %{_datadir}/config/amarok_homerc
283
284 %files scripts
285 %defattr(644,root,root,755)
286 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
287 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
288 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
289 %dir %{_datadir}/apps/amarok/scripts/script_console
290 %{_datadir}/apps/amarok/scripts/script_console/main.js
291 %{_datadir}/apps/amarok/scripts/script_console/script.spec
292 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
293 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
294 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
295 %dir %{_datadir}/apps/amarok/scripts/librivox_service
296 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
297 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
298 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
299 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
300 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
301 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
302 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
303 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.066006 seconds and 4 git commands to generate.