]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- Separated xmms wrapper to omit gtk+ & xmms-libs reqs for main package
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_without  helix           # disable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25 Summary:        A KDE audio player
26 Summary(pl):    Odtwarzacz audio dla KDE
27 Name:           amarok
28 Version:        1.3.8
29 Release:        2
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33 # Source0-md5:  fd1ee0509568e5f9f7d0aeb9af094786
34 Patch0:         kde-common-gcc4.patch
35 Patch1:         %{name}-lyricsurl.patch
36 Patch2:         %{name}-libtunepimp-0.4.0.patch
37 Patch3:         %{name}-helixplayer-morearchs.patch
38 URL:            http://amarok.kde.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  arts-qt-devel
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  gettext-devel
45 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
46 BuildRequires:  kdebase-devel
47 %{?with_akode:BuildRequires:    kdemultimedia-akode}
48 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
49 BuildRequires:  libltdl-devel
50 BuildRequires:  libtunepimp-devel >= 0.4.0
51 BuildRequires:  libvisual-devel >= 0.2.0
52 %{?with_pgsql:BuildRequires:            libpqxx-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 BuildRequires:  pcre-devel
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  rpmbuild(macros) >= 1.129
57 BuildRequires:  sed >= 4.0
58 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
59 BuildRequires:  taglib-devel >= 1.4
60 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
61 %{?with_xmms:BuildRequires:             xmms-devel}
62 Requires:       %{name}-plugin = %{version}-%{release}
63 Requires:       kdebase-core >= 9:3.1.93
64 Requires:       kdemultimedia-audiocd >= 9:3.1.93
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 A KDE audio player.
69
70 %description -l pl
71 Odtwarzacz audio dla KDE.
72
73 %package arts
74 Summary:        Plugin arts
75 Summary(pl):    Wtyczka arts
76 Group:          X11/Applications/Multimedia
77 Requires:       %{name} = %{version}-%{release}
78 Provides:       %{name}-plugin = %{version}-%{release}
79
80 %description arts
81 Plugin arts.
82
83 %description arts -l pl
84 Wtyczka arts.
85
86 %package akode
87 Summary:        Plugin akode
88 Summary(pl):    Wtyczka akode
89 Group:          X11/Applications/Multimedia
90 Requires:       %{name} = %{version}-%{release}
91 Provides:       %{name}-plugin = %{version}-%{release}
92
93 %description akode
94 Plugin akode.
95
96 %description akode -l pl
97 Wtyczka akode.
98
99 %package helix
100 Summary:        Helix/Realplayer playback support for amarok
101 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
102 Group:          X11/Applications/Multimedia
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       helix-core
105 Provides:       %{name}-plugin = %{version}-%{release}
106
107 %description helix
108 Helix/Realplayer playback support for amarok.
109
110 %description helix -l pl
111 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
112
113
114 %package gstreamer
115 Summary:        Plugin gstreamer
116 Summary(pl):    Wtyczka gstreamer
117 Group:          X11/Applications/Multimedia
118 # deps, to get it working:
119 # mp3 decoder: gstreamer-mad
120 # ogg decoder: gstreamer-vorbis
121 # audio output driver: gstreamer-audiosink-alsa
122 # from gstreamer-audio-effects to control volume, etc
123 # needed libs:
124 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
125 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
126 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
127 # gstreamer-musicbrainz for being able to edit id3 tags on files.
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       gstreamer-audio-effects
130 Requires:       gstreamer-audiosink
131 Requires:       gstreamer-mad
132 Requires:       gstreamer-musicbrainz
133 Requires:       gstreamer-vorbis
134 Provides:       %{name}-plugin = %{version}-%{release}
135
136 %description gstreamer
137 Plugin gstreamer.
138
139 %description gstreamer -l pl
140 Wtyczka gstreamer.
141
142 %package xine
143 Summary:        Plugin xine
144 Summary(pl):    Wtyczka xine
145 Group:          X11/Applications/Multimedia
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       xine-plugin-audio
148 Provides:       %{name}-plugin = %{version}-%{release}
149
150 %description xine
151 Plugin xine.
152
153 %description xine -l pl
154 Wtyczka xine.
155
156 %package xmms
157 Summary:        Xmms wrapper
158 Summary(pl):    Wrapper xmms
159 Group:          X11/Applications/Multimedia
160 Conflicts:      amarok < 1.3.8-2
161 Requires:       %{name} = %{version}-%{release}
162
163 %description xmms
164 Xmms wrapper.
165
166 %description xmms -l pl
167 Wrapper xmms.
168
169 %package zeroconf
170 Summary:        Zeroconf data
171 Summary(pl):    Dane dla zeroconf
172 Group:          X11/Applications/Multimedia
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       kdenetwork-kdnssd
175 Provides:       %{name}-plugin = %{version}-%{release}
176
177 %description zeroconf
178 Zeroconf data.
179
180 %description zeroconf -l pl
181 Dane dla zeroconf.
182
183 %package scripts
184 Summary:        amaroK scripts
185 Summary(pl):    Skrypty amaroKa
186 Group:          X11/Applications/Multimedia
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       kdebase-kdialog
189 Requires:       python-PyQt
190
191 %description scripts
192 amaroK scripts allow you extend amaroK functionality.
193
194 You can learn more about scripts in amaroK from here:
195 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
196
197 %description scripts -l pl
198 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
199
200 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
201 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
202
203 %prep
204 %setup -q
205 %patch0 -p1
206 %{?with_altlyrics:%patch1 -p1}
207 %patch2 -p1
208 %patch3 -p1
209 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
210         amarok/src/amarok.desktop \
211
212 # see kde bug #110909
213 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
214
215 %build
216 cp -f /usr/share/automake/config.sub admin
217
218 %{__make} -f admin/Makefile.common cvs
219
220 # hack: passing something other than "no" or "yes" to --with-helix allows
221 # us to pass HELIX_LIBS
222 %configure \
223         HELIX_LIBS=%{_libdir}/helixplayer \
224         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
225         --disable-rpath \
226         --with%{!?with_arts:out}-arts \
227         --with%{!?with_mas:out}-mas \
228         --with%{!?with_xine:out}-xine \
229         --with%{!?with_gstreamer:out}-gstreamer \
230         --with%{!?with_akode:out}-akode \
231         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
232         --with%{!?with_nmm:out}-nmm \
233         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
234         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
235         --disable-final \
236         --with-qt-libraries=%{_libdir} \
237         --with%{!?with_included_sqlite:out}-included-sqlite
238
239 %{__make}
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243
244 %{__make} install \
245         DESTDIR=$RPM_BUILD_ROOT \
246         kde_htmldir=%{_kdedocdir} \
247         kde_libs_htmldir=%{_kdedocdir}
248
249 # remove bogus dir
250 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
251
252 %find_lang amarok --all-name --with-kde
253
254 %clean
255 rm -rf $RPM_BUILD_ROOT
256
257 %post
258 if [ "$1" = 1 ]; then
259         echo "Remember to install libvisual-plugins-* packages if you"
260         echo "want to have a visualizations in amaroK."
261 fi
262
263 %files -f %{name}.lang
264 %defattr(644,root,root,755)
265 %doc AUTHORS ChangeLog README
266 %attr(755,root,root) %{_bindir}/amarok
267 %attr(755,root,root) %{_bindir}/amarokapp
268 %attr(755,root,root) %{_bindir}/amarok_libvisual
269 #%attr(755,root,root) %{_bindir}/release_amarok
270 %{_libdir}/kde3/konqsidebar_universalamarok.la
271 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
272 %{_libdir}/kde3/libamarok_void-engine_plugin.la
273 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
274 %dir %{_datadir}/apps/amarok
275 %dir %{_datadir}/apps/amarok/scripts
276 %{_datadir}/apps/amarok/*.rc
277 %{_datadir}/apps/amarok/data
278 %{_datadir}/apps/amarok/icons
279 %{_datadir}/apps/amarok/images
280 %{_datadir}/apps/amarok/themes
281 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
282 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
283 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
284 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
285 %{_datadir}/apps/profiles/amarok.profile.xml
286 %{_datadir}/config/amarokrc
287 %{_datadir}/config.kcfg/amarok.kcfg
288 %{_datadir}/services/amarok_void-engine_plugin.desktop
289 %{_datadir}/servicetypes/amarok_plugin.desktop
290 %{_desktopdir}/kde/amarok.desktop
291 %{_iconsdir}/*/*/apps/amarok.*
292
293 %if %{with arts}
294 %files arts
295 %defattr(644,root,root,755)
296 %{_libdir}/kde3/libamarok_artsengine_plugin.la
297 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
298 %{_libdir}/libamarokarts.la
299 %attr(755,root,root) %{_libdir}/libamarokarts.so
300 %{_libdir}/mcop/Amarok
301 %{_libdir}/mcop/amarokarts.mcopclass
302 %{_libdir}/mcop/amarokarts.mcoptype
303 %{_datadir}/services/amarok_artsengine_plugin.desktop
304 %endif
305
306 %if %{with akode}
307 %files akode
308 %defattr(644,root,root,755)
309 %{_libdir}/kde3/libamarok_aKode-engine.la
310 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
311 %{_datadir}/services/amarok_aKode-engine.desktop
312 %endif
313
314 %if %{with gstreamer}
315 %files gstreamer
316 %defattr(644,root,root,755)
317 %{_libdir}/kde3/libamarok_gstengine_plugin.la
318 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
319 %{_datadir}/config.kcfg/gstconfig.kcfg
320 %{_datadir}/services/amarok_gstengine_plugin.desktop
321 %endif
322
323 %if %{with helix}
324 %files helix
325 %defattr(644,root,root,755)
326 %{_libdir}/kde3/libamarok_helixengine_plugin.la
327 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
328 %{_datadir}/config.kcfg/helixconfig.kcfg
329 %{_datadir}/services/amarok_helixengine_plugin.desktop
330 %endif
331
332 %if %{with xine}
333 %files xine
334 %defattr(644,root,root,755)
335 %{_libdir}/kde3/libamarok_xine-engine.la
336 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
337 %{_datadir}/config.kcfg/xinecfg.kcfg
338 %{_datadir}/services/amarok_xine-engine.desktop
339 #%{_datadir}/services/amarok_xineengine_plugin.desktop
340 %endif
341
342 %if %{with xmms}
343 %files xmms
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
346 %endif
347
348 %if 0
349 %if %{with zeroconf}
350 %files zeroconf
351 %defattr(644,root,root,755)
352 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
353 %endif
354 %endif
355
356 %files scripts
357 %defattr(644,root,root,755)
358
359 %dir %{_datadir}/apps/amarok/scripts/alarm
360 %{_datadir}/apps/amarok/scripts/alarm/README
361 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
362
363 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
364 %{_datadir}/apps/amarok/scripts/graphequalizer/README
365 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
366
367 %dir %{_datadir}/apps/amarok/scripts/playlist2html
368 %{_datadir}/apps/amarok/scripts/playlist2html/README
369 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
370 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
371 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
372
373 %dir %{_datadir}/apps/amarok/scripts/templates
374 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
375 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
376 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
377
378 %dir %{_datadir}/apps/amarok/scripts/webcontrol
379 %{_datadir}/apps/amarok/scripts/webcontrol/README
380 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
381 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
382 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
383 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
384 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
385 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
386 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
387 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
388 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
389 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
390 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
391 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
392 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
393 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
394 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
395 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
396
397 %dir %{_datadir}/apps/amarok/scripts/common
398 %{_datadir}/apps/amarok/scripts/common/Publisher.py
399 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
400
401 #%dir %{_datadir}/apps/amarok/scripts/shouter
402 #%{_datadir}/apps/amarok/scripts/shouter/README
403 #%{_datadir}/apps/amarok/scripts/shouter/ChangeLog
404 #%{_datadir}/apps/amarok/scripts/shouter/Amarok.py
405 #%{_datadir}/apps/amarok/scripts/shouter/Globals.py
406 #%{_datadir}/apps/amarok/scripts/shouter/Playlist.py
407 #%{_datadir}/apps/amarok/scripts/shouter/Services.py
408 #%{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
409 #%{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
410 #%{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
411 #%{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
412 #%{_datadir}/apps/amarok/scripts/shouter/StreamController.py
413 #%{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
414 #%{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
415 #%{_datadir}/apps/amarok/scripts/shouter/debug.py
416 #%{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
417 #%dir %{_datadir}/apps/amarok/scripts/shouter/silence
418 #%{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
419 #%dir %{_datadir}/apps/amarok/scripts/shouter/test
420 #%{_datadir}/apps/amarok/scripts/shouter/test/client.py
421 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
422
423 %if 0
424 %dir %{_datadir}/apps/amarok/scripts/amarok_live
425 %{_datadir}/apps/amarok/scripts/amarok_live/README
426 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
427 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
428 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
429 %endif
This page took 0.056859 seconds and 4 git commands to generate.