]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- BR: gettext-devel, sorted, cleanups
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_without  helix           # disable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25 Summary:        A KDE audio player
26 Summary(pl):    Odtwarzacz audio dla KDE
27 Name:           amarok
28 Version:        1.3.8
29 Release:        1
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33 # Source0-md5:  fd1ee0509568e5f9f7d0aeb9af094786
34 Patch0:         kde-common-gcc4.patch
35 Patch1:         %{name}-lyricsurl.patch
36 Patch2:         %{name}-libtunepimp-0.4.0.patch
37 Patch3:         %{name}-helixplayer-morearchs.patch
38 URL:            http://amarok.kde.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  arts-qt-devel
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  gettext-devel
45 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
46 BuildRequires:  kdebase-devel
47 %{?with_akode:BuildRequires:    kdemultimedia-akode}
48 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
49 BuildRequires:  libltdl-devel
50 BuildRequires:  libtunepimp-devel >= 0.4.0
51 BuildRequires:  libvisual-devel >= 0.2.0
52 %{?with_pgsql:BuildRequires:            libpqxx-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 BuildRequires:  pcre-devel
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  rpmbuild(macros) >= 1.129
57 BuildRequires:  sed >= 4.0
58 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
59 BuildRequires:  taglib-devel >= 1.4
60 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
61 %{?with_xmms:BuildRequires:             xmms-devel}
62 Requires:       %{name}-plugin = %{version}-%{release}
63 Requires:       kdebase-core >= 9:3.1.93
64 Requires:       kdemultimedia-audiocd >= 9:3.1.93
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 A KDE audio player.
69
70 %description -l pl
71 Odtwarzacz audio dla KDE.
72
73 %package arts
74 Summary:        Plugin arts
75 Summary(pl):    Wtyczka arts
76 Group:          X11/Applications/Multimedia
77 Requires:       %{name} = %{version}-%{release}
78 Provides:       %{name}-plugin = %{version}-%{release}
79
80 %description arts
81 Plugin arts.
82
83 %description arts -l pl
84 Wtyczka arts.
85
86 %package akode
87 Summary:        Plugin akode
88 Summary(pl):    Wtyczka akode
89 Group:          X11/Applications/Multimedia
90 Requires:       %{name} = %{version}-%{release}
91 Provides:       %{name}-plugin = %{version}-%{release}
92
93 %description akode
94 Plugin akode.
95
96 %description akode -l pl
97 Wtyczka akode.
98
99 %package helix
100 Summary:        Helix/Realplayer playback support for amarok
101 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
102 Group:          X11/Applications/Multimedia
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       helix-core
105 Provides:       %{name}-plugin = %{version}-%{release}
106
107 %description helix
108 Helix/Realplayer playback support for amarok.
109
110 %description helix -l pl
111 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
112
113
114 %package gstreamer
115 Summary:        Plugin gstreamer
116 Summary(pl):    Wtyczka gstreamer
117 Group:          X11/Applications/Multimedia
118 # deps, to get it working:
119 # mp3 decoder: gstreamer-mad
120 # ogg decoder: gstreamer-vorbis
121 # audio output driver: gstreamer-audiosink-alsa
122 # from gstreamer-audio-effects to control volume, etc
123 # needed libs:
124 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
125 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
126 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
127 # gstreamer-musicbrainz for being able to edit id3 tags on files.
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       gstreamer-audio-effects
130 Requires:       gstreamer-audiosink
131 Requires:       gstreamer-mad
132 Requires:       gstreamer-musicbrainz
133 Requires:       gstreamer-vorbis
134 Provides:       %{name}-plugin = %{version}-%{release}
135
136 %description gstreamer
137 Plugin gstreamer.
138
139 %description gstreamer -l pl
140 Wtyczka gstreamer.
141
142 %package xine
143 Summary:        Plugin xine
144 Summary(pl):    Wtyczka xine
145 Group:          X11/Applications/Multimedia
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       xine-plugin-audio
148 Provides:       %{name}-plugin = %{version}-%{release}
149
150 %description xine
151 Plugin xine.
152
153 %description xine -l pl
154 Wtyczka xine.
155
156 %package zeroconf
157 Summary:        Zeroconf data
158 Summary(pl):    Dane dla zeroconf
159 Group:          X11/Applications/Multimedia
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       kdenetwork-kdnssd
162 Provides:       %{name}-plugin = %{version}-%{release}
163
164 %description zeroconf
165 Zeroconf data.
166
167 %description zeroconf -l pl
168 Dane dla zeroconf.
169
170 %package scripts
171 Summary:        amaroK scripts
172 Summary(pl):    Skrypty amaroKa
173 Group:          X11/Applications/Multimedia
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       kdebase-kdialog
176 Requires:       python-PyQt
177
178 %description scripts
179 amaroK scripts allow you extend amaroK functionality.
180
181 You can learn more about scripts in amaroK from here:
182 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
183
184 %description scripts -l pl
185 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
186
187 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
188 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
189
190 %prep
191 %setup -q
192 %patch0 -p1
193 %{?with_altlyrics:%patch1 -p1}
194 %patch2 -p1
195 %patch3 -p1
196 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
197         amarok/src/amarok.desktop \
198
199 # see kde bug #110909
200 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
201
202 %build
203 cp -f /usr/share/automake/config.sub admin
204
205 #export UNSERMAKE=/usr/share/unsermake/unsermake
206
207 %{__make} -f admin/Makefile.common cvs
208
209 # hack: passing something other than "no" or "yes" to --with-helix allows
210 # us to pass HELIX_LIBS
211 %configure \
212         HELIX_LIBS=%{_libdir}/helixplayer \
213         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
214         --disable-rpath \
215         --with%{!?with_arts:out}-arts \
216         --with%{!?with_mas:out}-mas \
217         --with%{!?with_xine:out}-xine \
218         --with%{!?with_gstreamer:out}-gstreamer \
219         --with%{!?with_akode:out}-akode \
220         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
221         --with%{!?with_nmm:out}-nmm \
222         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
223         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
224         --disable-final \
225         --with-qt-libraries=%{_libdir} \
226         --with%{!?with_included_sqlite:out}-included-sqlite
227
228 %{__make}
229
230 %install
231 rm -rf $RPM_BUILD_ROOT
232
233 %{__make} install \
234         DESTDIR=$RPM_BUILD_ROOT \
235         kde_htmldir=%{_kdedocdir} \
236         kde_libs_htmldir=%{_kdedocdir}
237
238 # remove bogus dir
239 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
240
241 %find_lang amarok --all-name --with-kde
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %post
247 if [ "$1" = 1 ]; then
248         echo "Remember to install libvisual-plugins-* packages if you"
249         echo "want to have a visualizations in amaroK."
250 fi
251
252 %files -f %{name}.lang
253 %defattr(644,root,root,755)
254 %doc AUTHORS ChangeLog README
255 %attr(755,root,root) %{_bindir}/amarok
256 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
257 %attr(755,root,root) %{_bindir}/amarokapp
258 %attr(755,root,root) %{_bindir}/amarok_libvisual
259 #%attr(755,root,root) %{_bindir}/release_amarok
260 %{_libdir}/kde3/konqsidebar_universalamarok.la
261 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
262 %{_libdir}/kde3/libamarok_void-engine_plugin.la
263 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
264 %dir %{_datadir}/apps/amarok
265 %dir %{_datadir}/apps/amarok/scripts
266 %{_datadir}/apps/amarok/*.rc
267 %{_datadir}/apps/amarok/data
268 %{_datadir}/apps/amarok/icons
269 %{_datadir}/apps/amarok/images
270 %{_datadir}/apps/amarok/themes
271 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
272 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
273 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
274 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
275 %{_datadir}/apps/profiles/amarok.profile.xml
276 %{_datadir}/config/amarokrc
277 %{_datadir}/config.kcfg/amarok.kcfg
278 %{_datadir}/services/amarok_void-engine_plugin.desktop
279 %{_datadir}/servicetypes/amarok_plugin.desktop
280 %{_desktopdir}/kde/amarok.desktop
281 %{_iconsdir}/*/*/apps/amarok.*
282
283 %if %{with arts}
284 %files arts
285 %defattr(644,root,root,755)
286 %{_libdir}/kde3/libamarok_artsengine_plugin.la
287 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
288 %{_libdir}/libamarokarts.la
289 %attr(755,root,root) %{_libdir}/libamarokarts.so
290 %{_libdir}/mcop/Amarok
291 %{_libdir}/mcop/amarokarts.mcopclass
292 %{_libdir}/mcop/amarokarts.mcoptype
293 %{_datadir}/services/amarok_artsengine_plugin.desktop
294 %endif
295
296 %if %{with akode}
297 %files akode
298 %defattr(644,root,root,755)
299 %{_libdir}/kde3/libamarok_aKode-engine.la
300 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
301 %{_datadir}/services/amarok_aKode-engine.desktop
302 %endif
303
304 %if %{with gstreamer}
305 %files gstreamer
306 %defattr(644,root,root,755)
307 %{_libdir}/kde3/libamarok_gstengine_plugin.la
308 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
309 %{_datadir}/config.kcfg/gstconfig.kcfg
310 %{_datadir}/services/amarok_gstengine_plugin.desktop
311 %endif
312
313 %if %{with helix}
314 %files helix
315 %defattr(644,root,root,755)
316 %{_libdir}/kde3/libamarok_helixengine_plugin.la
317 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
318 %{_datadir}/config.kcfg/helixconfig.kcfg
319 %{_datadir}/services/amarok_helixengine_plugin.desktop
320 %endif
321
322 %if %{with xine}
323 %files xine
324 %defattr(644,root,root,755)
325 %{_libdir}/kde3/libamarok_xine-engine.la
326 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
327 %{_datadir}/config.kcfg/xinecfg.kcfg
328 %{_datadir}/services/amarok_xine-engine.desktop
329 #%{_datadir}/services/amarok_xineengine_plugin.desktop
330 %endif
331
332 %if 0
333 %if %{with zeroconf}
334 %files zeroconf
335 %defattr(644,root,root,755)
336 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
337 %endif
338 %endif
339
340 %files scripts
341 %defattr(644,root,root,755)
342
343 %dir %{_datadir}/apps/amarok/scripts/alarm
344 %{_datadir}/apps/amarok/scripts/alarm/README
345 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
346
347 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
348 %{_datadir}/apps/amarok/scripts/graphequalizer/README
349 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
350
351 %dir %{_datadir}/apps/amarok/scripts/playlist2html
352 %{_datadir}/apps/amarok/scripts/playlist2html/README
353 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
354 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
355 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
356
357 %dir %{_datadir}/apps/amarok/scripts/templates
358 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
359 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
360 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
361
362 %dir %{_datadir}/apps/amarok/scripts/webcontrol
363 %{_datadir}/apps/amarok/scripts/webcontrol/README
364 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
365 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
366 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
367 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
368 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
369 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
370 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
371 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
372 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
373 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
374 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
375 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
376 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
377 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
378 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
379 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
380
381 %dir %{_datadir}/apps/amarok/scripts/common
382 %{_datadir}/apps/amarok/scripts/common/Publisher.py
383 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
384
385 #%dir %{_datadir}/apps/amarok/scripts/shouter
386 #%{_datadir}/apps/amarok/scripts/shouter/README
387 #%{_datadir}/apps/amarok/scripts/shouter/ChangeLog
388 #%{_datadir}/apps/amarok/scripts/shouter/Amarok.py
389 #%{_datadir}/apps/amarok/scripts/shouter/Globals.py
390 #%{_datadir}/apps/amarok/scripts/shouter/Playlist.py
391 #%{_datadir}/apps/amarok/scripts/shouter/Services.py
392 #%{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
393 #%{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
394 #%{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
395 #%{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
396 #%{_datadir}/apps/amarok/scripts/shouter/StreamController.py
397 #%{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
398 #%{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
399 #%{_datadir}/apps/amarok/scripts/shouter/debug.py
400 #%{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
401 #%dir %{_datadir}/apps/amarok/scripts/shouter/silence
402 #%{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
403 #%dir %{_datadir}/apps/amarok/scripts/shouter/test
404 #%{_datadir}/apps/amarok/scripts/shouter/test/client.py
405 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
406
407 %if 0
408 %dir %{_datadir}/apps/amarok/scripts/amarok_live
409 %{_datadir}/apps/amarok/scripts/amarok_live/README
410 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
411 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
412 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
413 %endif
This page took 0.063274 seconds and 4 git commands to generate.