]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- kdever up to 4.3.3
[packages/amarok.git] / amarok.spec
1 # TODO
2 # - try not to link with static mysql
3
4 %define         state   stable
5 %define         qtver   4.5.3
6 %define         kdever  4.3.3
7
8 Summary:        A KDE audio player
9 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        2.2.1
12 Release:        2
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  4f6f45f0c25f85f2a2a1fff169ac7193
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-qthreadpool.patch
19 URL:            http://amarok.kde.org/
20 BuildRequires:  Qt3Support-devel >= %{qtver}
21 BuildRequires:  QtCore-devel >= %{qtver}
22 BuildRequires:  QtDBus-devel >= %{qtver}
23 BuildRequires:  QtDesigner-devel >= %{qtver}
24 BuildRequires:  QtNetwork-devel >= %{qtver}
25 BuildRequires:  QtOpenGL-devel >= %{qtver}
26 BuildRequires:  QtScript-devel >= %{qtver}
27 BuildRequires:  QtSql-devel >= %{qtver}
28 BuildRequires:  QtSvg-devel >= %{qtver}
29 BuildRequires:  QtTest-devel >= %{qtver}
30 BuildRequires:  QtUiTools-devel >= %{qtver}
31 BuildRequires:  QtWebKit-devel >= %{qtver}
32 BuildRequires:  QtXml-devel >= %{qtver}
33 BuildRequires:  automoc4
34 BuildRequires:  cmake >= 2.6.1-2
35 BuildRequires:  curl-devel
36 BuildRequires:  giflib-devel
37 BuildRequires:  glib2-devel
38 BuildRequires:  kde4-kdebase-devel >= %{kdever}
39 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
40 BuildRequires:  libgpod-devel >= 0.7.0
41 BuildRequires:  libifp-devel >= 1.0.0.2
42 BuildRequires:  liblastfm-devel
43 BuildRequires:  libmtp-devel >= 0.3.0
44 BuildRequires:  libnjb-devel >= 2.2.4
45 BuildRequires:  libvisual-devel >= 0.4.0
46 BuildRequires:  loudmouth-devel
47 BuildRequires:  mpeg4ip-devel >= 1:1.6
48 BuildRequires:  mysql-devel >= 5.1.31-3
49 BuildRequires:  pcre-devel
50 BuildRequires:  pkgconfig
51 BuildRequires:  qca-devel
52 BuildRequires:  qt4-build >= %{qtver}
53 BuildRequires:  qt4-qmake >= %{qtver}
54 BuildRequires:  qtscriptbindings
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  rpmbuild(macros) >= 1.129
57 BuildRequires:  soprano-devel >= 2.1
58 BuildRequires:  strigi-devel >= 0.5.10
59 BuildRequires:  taglib-devel >= 1.6
60 BuildRequires:  taglib-extras-devel >= 1.0.0
61 BuildRequires:  utempter-devel
62 BuildRequires:  xorg-lib-libXpm-devel
63 Requires(post,postun):  /sbin/ldconfig
64 Requires:       kde4-kdebase-core
65 Requires:       kde4-kdemultimedia-audiocd
66 Requires:       kde4-phonon
67 Requires:       qtscriptbindings
68 Suggests:       libvisual-plugin-actor-JESS
69 Suggests:       libvisual-plugin-actor-bumpscope
70 Suggests:       libvisual-plugin-actor-corona
71 Suggests:       libvisual-plugin-actor-flower
72 Suggests:       libvisual-plugin-actor-gdkpixbuf
73 Suggests:       libvisual-plugin-actor-gforce
74 Suggests:       libvisual-plugin-actor-gstreamer
75 Suggests:       libvisual-plugin-actor-infinite
76 Suggests:       libvisual-plugin-actor-jakdaw
77 Suggests:       libvisual-plugin-actor-lv_analyzer
78 Suggests:       libvisual-plugin-actor-lv_gltest
79 Suggests:       libvisual-plugin-actor-lv_scope
80 Suggests:       libvisual-plugin-actor-madspin
81 Suggests:       libvisual-plugin-actor-nastyfft
82 Suggests:       libvisual-plugin-actor-oinksie
83 Suggests:       libvisual-plugin-input-alsa
84 Suggests:       libvisual-plugin-input-esd
85 Suggests:       libvisual-plugin-input-jack
86 Suggests:       libvisual-plugin-input-mplayer
87 Suggests:       libvisual-plugin-morph-alphablend
88 Suggests:       libvisual-plugin-morph-flash
89 Suggests:       libvisual-plugin-morph-slide
90 Suggests:       libvisual-plugin-morph-tentacle
91 Obsoletes:      amarok-arts
92 Obsoletes:      amarok-xmms
93 # It should require mysql-embeded
94 Requires:       mysql >= 5.1.31-3
95 Conflicts:      mysql < 5.1.31-3
96 # sr@Latn vs. sr@latin
97 Conflicts:      glibc-misc < 6:2.7
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 A KDE audio player.
102
103 %description -l pl.UTF-8
104 Odtwarzacz audio dla KDE.
105
106 %package scripts
107 Summary:        amaroK scripts
108 Summary(pl.UTF-8):      Skrypty amaroKa
109 Group:          X11/Applications/Multimedia
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       kde4-kdebase-kdialog
112
113 %description scripts
114 amaroK scripts allow you extend amaroK functionality.
115
116 You can learn more about scripts in amaroK from here:
117 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
118
119 %description scripts -l pl.UTF-8
120 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
121
122 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
123 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
124
125 %prep
126 %setup -q
127 #%patch0 -p0
128 #%patch1 -p0
129
130 %build
131 install -d build
132 cd build
133 %cmake \
134         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
135         -DLIB_INSTALL_DIR=%{_libdir} \
136         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
137 %if "%{_lib}" == "lib64"
138         -DLIB_SUFFIX=64 \
139 %endif
140         ../
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} -C build install \
148         DESTDIR=$RPM_BUILD_ROOT \
149         kde_htmldir=%{_kdedocdir} \
150         kde_libs_htmldir=%{_kdedocdir}
151
152 # remove bogus dir
153 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
154
155 %find_lang %{name} --with-kde
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post           -p /sbin/ldconfig
161 %postun         -p /sbin/ldconfig
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog README
166 %attr(755,root,root) %{_bindir}/amarok
167 %attr(755,root,root) %{_bindir}/amarokpkg
168 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
169 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
170 %attr(755,root,root) %{_bindir}/amarok_afttagger
171 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
172 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
174 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
175 %attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
176 %attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
191 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
192 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
193 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
194 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
211 %dir %{_datadir}/apps/amarok
212 %attr(755,root,root) %{_libdir}/libamaroklib.so
213 %attr(755,root,root) %{_libdir}/libamarokocsclient.so
214 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.4
215 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.4.3.0
216 %attr(755,root,root) %{_libdir}/libamarokpud.so
217 %dir %{_datadir}/apps/amarok/scripts
218 %{_datadir}/apps/amarok/data
219 %{_datadir}/apps/amarok/icons
220 %{_datadir}/apps/amarok/images
221 %{_datadir}/apps/amarok/amarok.notifyrc
222 %{_datadir}/apps/desktoptheme
223 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
224 %{_datadir}/config.kcfg/amarokconfig.kcfg
225 %{_datadir}/config/amarok.knsrc
226 %{_datadir}/config/amarokapplets.knsrc
227 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
228 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
229 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
230 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
231 %{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
232 %{_datadir}/kde4/services/amarok.protocol
233 %{_datadir}/kde4/services/amaroklastfm.protocol
234 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
235 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
236 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
237 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
238 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
239 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
240 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
241 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
242 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
243 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
244 %{_datadir}/kde4/services/amarok_service_ampache.desktop
245 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
246 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
247 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
248 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
249 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
250 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
251 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
252 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
253 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
254 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
255 %{_datadir}/kde4/services/amarok_massstorage-device.desktop
256 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
257 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
258 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
259 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
260 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
261 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
262 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
263 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
264 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
265 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
266 %{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
267 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
268 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
269 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
270 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
271 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
272 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
273 %{_desktopdir}/kde4/amarok.desktop
274 %{_iconsdir}/*/*/apps/amarok.*
275 %{_datadir}/config/amarok_homerc
276
277 %files scripts
278 %defattr(644,root,root,755)
279 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
280 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
281 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
282 %dir %{_datadir}/apps/amarok/scripts/script_console
283 %{_datadir}/apps/amarok/scripts/script_console/main.js
284 %{_datadir}/apps/amarok/scripts/script_console/script.spec
285 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
286 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
287 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
288 %dir %{_datadir}/apps/amarok/scripts/librivox_service
289 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
290 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
291 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
292 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
293 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
294 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
295 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
296 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.076513 seconds and 4 git commands to generate.