]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- release 6 (by relup.sh)
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - amarok now requires his own database which is not automaticly created
5 # Add spec:
6 # libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
7 #     Enable gpodder.net service
8 # -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
9 # /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
10 %define         state   stable
11 %define         qtver   4.7.1
12 %define         kdever  4.5.5
13
14 Summary:        A KDE audio player
15 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
16 Name:           amarok
17 Version:        2.8.0
18 Release:        6
19 License:        GPL v2+ and LGPL v2.1+
20 Group:          X11/Applications/Multimedia
21 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
22 # Source0-md5:  53cfcb4819668b10e13b061478c7b32a
23 Patch0:         %{name}-upnp-dep.patch
24 URL:            http://amarok.kde.org/
25 BuildRequires:  QtNetwork-devel >= %{qtver}
26 BuildRequires:  QtSql-devel >= %{qtver}
27 BuildRequires:  automoc4 >= 0.9.88
28 BuildRequires:  cmake >= 2.8.0
29 BuildRequires:  curl-devel
30 BuildRequires:  ffmpeg-devel >= 0.7.1
31 BuildRequires:  gettext-devel
32 BuildRequires:  glib2-devel
33 BuildRequires:  herqq-devel
34 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
35 BuildRequires:  kde4-nepomuk-core-devel
36 BuildRequires:  libaio-devel
37 BuildRequires:  libgpod-devel >= 0.7.0
38 BuildRequires:  liblastfm-devel
39 BuildRequires:  libmtp-devel >= 1.0.4
40 BuildRequires:  libofa-devel
41 BuildRequires:  libwrap-devel
42 BuildRequires:  loudmouth-devel
43 BuildRequires:  mysql-devel >= 5.1.31-3
44 BuildRequires:  pcre-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  qca-devel
47 BuildRequires:  qjson-devel >= 0.5
48 BuildRequires:  qt4-build >= %{qtver}
49 BuildRequires:  qt4-qmake >= %{qtver}
50 BuildRequires:  qtscriptbindings
51 BuildRequires:  rpmbuild(macros) >= 1.600
52 BuildRequires:  soprano-devel
53 BuildRequires:  strigi-devel >= 0.7.0
54 BuildRequires:  taglib-devel >= 1.7
55 BuildRequires:  taglib-extras-devel >= 1.0.0
56 BuildRequires:  xorg-lib-libXpm-devel
57 Requires(post,postun):  /sbin/ldconfig
58 Requires:       kde4-phonon
59 Requires:       qtscriptbindings
60 Suggests:       libvisual-plugin-actor-JESS
61 Suggests:       libvisual-plugin-actor-bumpscope
62 Suggests:       libvisual-plugin-actor-corona
63 Suggests:       libvisual-plugin-actor-flower
64 Suggests:       libvisual-plugin-actor-gdkpixbuf
65 Suggests:       libvisual-plugin-actor-gforce
66 Suggests:       libvisual-plugin-actor-gstreamer
67 Suggests:       libvisual-plugin-actor-infinite
68 Suggests:       libvisual-plugin-actor-jakdaw
69 Suggests:       libvisual-plugin-actor-lv_analyzer
70 Suggests:       libvisual-plugin-actor-lv_gltest
71 Suggests:       libvisual-plugin-actor-lv_scope
72 Suggests:       libvisual-plugin-actor-madspin
73 Suggests:       libvisual-plugin-actor-nastyfft
74 Suggests:       libvisual-plugin-actor-oinksie
75 Suggests:       libvisual-plugin-input-alsa
76 Suggests:       libvisual-plugin-input-jack
77 Suggests:       libvisual-plugin-input-mplayer
78 Suggests:       libvisual-plugin-morph-alphablend
79 Suggests:       libvisual-plugin-morph-flash
80 Suggests:       libvisual-plugin-morph-slide
81 Suggests:       libvisual-plugin-morph-tentacle
82 Obsoletes:      amarok-arts
83 Obsoletes:      amarok-xmms
84 # It should require mysql-embeded
85 Requires:       mysql >= 5.1.31-3
86 Conflicts:      mysql < 5.1.31-3
87 # sr@Latn vs. sr@latin
88 Conflicts:      glibc-misc < 6:2.7
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %description
92 A KDE audio player.
93
94 %description -l pl.UTF-8
95 Odtwarzacz audio dla KDE.
96
97 %package scripts
98 Summary:        amaroK scripts
99 Summary(pl.UTF-8):      Skrypty amaroKa
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       kde4-kdebase-kdialog
103
104 %description scripts
105 amaroK scripts allow you extend amaroK functionality.
106
107 You can learn more about scripts in amaroK from here:
108 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
109
110 %description scripts -l pl.UTF-8
111 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
112
113 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
114 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %build
121 install -d build
122 cd build
123 %cmake \
124         -DKDE4_BUILD_TESTS=OFF \
125         -DWITH_MYSQL_EMBEDDED=OFF \
126         ../
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} -C build install \
134         DESTDIR=$RPM_BUILD_ROOT \
135         kde_htmldir=%{_kdedocdir} \
136         kde_libs_htmldir=%{_kdedocdir}
137
138 # remove unsupported locale
139 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavian*
140
141 # remove .so symlinks so that noone gets the stupid idea to package them
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
143
144 %find_lang %{name} --all-name --with-kde
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post           -p /sbin/ldconfig
150 %postun         -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog README
155 %attr(755,root,root) %{_bindir}/amarok
156 %attr(755,root,root) %{_bindir}/amarokpkg
157 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
158 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
159 %attr(755,root,root) %{_bindir}/amarok_afttagger
160 %attr(755,root,root) %{_bindir}/amzdownloader
161 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
162 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
164 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
166 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
168 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
170 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libamarokshared.so.?
172 %attr(755,root,root) %{_libdir}/libamarokshared.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
174 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
175 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
176 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
177 %attr(755,root,root) %{_libdir}/libampache_account_login.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
182 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_analyzer.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
206 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
208 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
209 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-nepomukcollection.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
214 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
215 %dir %{_datadir}/apps/amarok
216 %dir %{_datadir}/apps/amarok/scripts
217 %{_datadir}/apps/amarok/data
218 %{_datadir}/apps/amarok/icons
219 %{_datadir}/apps/amarok/images
220 %{_datadir}/apps/amarok/amarok.notifyrc
221 %{_datadir}/apps/desktoptheme
222 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
223 %{_datadir}/config.kcfg/amarokconfig.kcfg
224 %{_datadir}/config/amarok.knsrc
225 %{_datadir}/config/amarokapplets.knsrc
226 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
227 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
228 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
229 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
230 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
231 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
232 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
233 %{_desktopdir}/kde4/amarok_containers.desktop
234 %{_desktopdir}/kde4/amzdownloader.desktop
235 %{_datadir}/kde4/services/amarok.protocol
236 %{_datadir}/kde4/services/amarokitpc.protocol
237 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
238 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
239 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
240 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
241 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
242 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
243 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
244 %{_datadir}/kde4/services/amarok_collection-nepomukcollection.desktop
245 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
246 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
247 %{_datadir}/kde4/services/amarok-context-applet-analyzer.desktop
248 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
250 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
251 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
252 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
253 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
254 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
255 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
256 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
257 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
258 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
259 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
260 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
261 %{_datadir}/kde4/services/amarok_service_amazonstore.desktop
262 %{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
263 %{_datadir}/kde4/services/amarok_service_ampache.desktop
264 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
265 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
266 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
267 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
268 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
269 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
270 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
271 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
272 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
273 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
274 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
275 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
276 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
277 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
278 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
279 %{_desktopdir}/kde4/amarok.desktop
280 %{_iconsdir}/*/*/apps/amarok.*
281 %{_datadir}/config/amarok_homerc
282 %attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
283 %{_datadir}/apps/kconf_update/amarok.upd
284 %{_datadir}/mime/packages/amzdownloader.xml
285
286 %files scripts
287 %defattr(644,root,root,755)
288 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
289 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
290 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
291 %dir %{_datadir}/apps/amarok/scripts/script_console
292 %{_datadir}/apps/amarok/scripts/script_console/main.js
293 %{_datadir}/apps/amarok/scripts/script_console/script.spec
294 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
295 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
296 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
297 %dir %{_datadir}/apps/amarok/scripts/librivox_service
298 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
299 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
300 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
301 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
302 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
303 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
304 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
305 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
306 %dir %{_datadir}/apps/amarok/scripts/free_music_charts_service
307 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCEmblem.png
308 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCIcon.png
309 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCShow.png
310 %{_datadir}/apps/amarok/scripts/free_music_charts_service/main.js
311 %{_datadir}/apps/amarok/scripts/free_music_charts_service/script.spec
This page took 0.043107 seconds and 3 git commands to generate.