]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- more %files
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - does not run
5 #
6
7 %define         state   stable
8 %define         qtver   4.7.1
9 %define         kdever  4.5.5
10
11 Summary:        A KDE audio player
12 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        2.4.1
15 Release:        0.1
16 License:        GPL v2+ and LGPL v2.1+
17 Group:          X11/Applications/Multimedia
18 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  4c65c5cd4d7bd267bdbef8e912fd6cb6
20 Patch0:         %{name}-disable_qtscriptbindings_check_fix.patch
21 Patch1:         %{name}-ffmpeg08.patch
22 Patch2:         %{name}-upnp-dep.patch
23 URL:            http://amarok.kde.org/
24 BuildRequires:  QtNetwork-devel >= %{qtver}
25 BuildRequires:  QtSql-devel >= %{qtver}
26 BuildRequires:  automoc4 >= 0.9.88
27 BuildRequires:  cmake >= 2.8.0
28 BuildRequires:  curl-devel
29 BuildRequires:  ffmpeg-devel >= 0.7.1
30 BuildRequires:  gettext-devel
31 BuildRequires:  glib2-devel
32 BuildRequires:  herqq-devel
33 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
34 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
35 BuildRequires:  libaio-devel
36 BuildRequires:  libgpod-devel >= 0.7.0
37 BuildRequires:  liblastfm-devel
38 BuildRequires:  libmtp-devel >= 1.0.4
39 BuildRequires:  libofa-devel
40 BuildRequires:  libwrap-devel
41 BuildRequires:  loudmouth-devel
42 BuildRequires:  mysql-devel >= 5.1.31-3
43 BuildRequires:  pcre-devel
44 BuildRequires:  pkgconfig
45 BuildRequires:  qca-devel
46 BuildRequires:  qjson-devel >= 0.5
47 BuildRequires:  qt4-build >= %{qtver}
48 BuildRequires:  qt4-qmake >= %{qtver}
49 BuildRequires:  qtscriptbindings
50 BuildRequires:  rpmbuild(macros) >= 1.600
51 BuildRequires:  soprano-devel
52 BuildRequires:  strigi-devel >= 0.7.0
53 BuildRequires:  taglib-devel >= 1.6
54 BuildRequires:  taglib-extras-devel >= 1.0.0
55 BuildRequires:  xorg-lib-libXpm-devel
56 Requires(post,postun):  /sbin/ldconfig
57 Requires:       kde4-kdemultimedia-audiocd
58 Requires:       kde4-phonon
59 Requires:       qtscriptbindings
60 Suggests:       libvisual-plugin-actor-JESS
61 Suggests:       libvisual-plugin-actor-bumpscope
62 Suggests:       libvisual-plugin-actor-corona
63 Suggests:       libvisual-plugin-actor-flower
64 Suggests:       libvisual-plugin-actor-gdkpixbuf
65 Suggests:       libvisual-plugin-actor-gforce
66 Suggests:       libvisual-plugin-actor-gstreamer
67 Suggests:       libvisual-plugin-actor-infinite
68 Suggests:       libvisual-plugin-actor-jakdaw
69 Suggests:       libvisual-plugin-actor-lv_analyzer
70 Suggests:       libvisual-plugin-actor-lv_gltest
71 Suggests:       libvisual-plugin-actor-lv_scope
72 Suggests:       libvisual-plugin-actor-madspin
73 Suggests:       libvisual-plugin-actor-nastyfft
74 Suggests:       libvisual-plugin-actor-oinksie
75 Suggests:       libvisual-plugin-input-alsa
76 Suggests:       libvisual-plugin-input-jack
77 Suggests:       libvisual-plugin-input-mplayer
78 Suggests:       libvisual-plugin-morph-alphablend
79 Suggests:       libvisual-plugin-morph-flash
80 Suggests:       libvisual-plugin-morph-slide
81 Suggests:       libvisual-plugin-morph-tentacle
82 Obsoletes:      amarok-arts
83 Obsoletes:      amarok-xmms
84 # It should require mysql-embeded
85 Requires:       mysql >= 5.1.31-3
86 Conflicts:      mysql < 5.1.31-3
87 # sr@Latn vs. sr@latin
88 Conflicts:      glibc-misc < 6:2.7
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %description
92 A KDE audio player.
93
94 %description -l pl.UTF-8
95 Odtwarzacz audio dla KDE.
96
97 %package scripts
98 Summary:        amaroK scripts
99 Summary(pl.UTF-8):      Skrypty amaroKa
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       kde4-kdebase-kdialog
103
104 %description scripts
105 amaroK scripts allow you extend amaroK functionality.
106
107 You can learn more about scripts in amaroK from here:
108 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
109
110 %description scripts -l pl.UTF-8
111 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
112
113 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
114 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119 %patch1 -p1
120 %patch2 -p1
121
122 %build
123 install -d build
124 cd build
125 %cmake \
126         -DWITH_MYSQL_EMBEDDED=OFF \
127         ../
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} -C build install \
135         DESTDIR=$RPM_BUILD_ROOT \
136         kde_htmldir=%{_kdedocdir} \
137         kde_libs_htmldir=%{_kdedocdir}
138
139 # remove unsupported locale
140 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
141
142 # remove .so symlinks so that noone gets the stupid idea to package them
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
144
145 %find_lang %{name} --all-name --with-kde
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post           -p /sbin/ldconfig
151 %postun         -p /sbin/ldconfig
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog README
156 %attr(755,root,root) %{_bindir}/amarok
157 %attr(755,root,root) %{_bindir}/amarokpkg
158 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
159 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
160 %attr(755,root,root) %{_bindir}/amarok_afttagger
161 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
162 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
164 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
166 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
168 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
170 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
172 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
173 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
174 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
175 %attr(755,root,root) %{_libdir}/libampache_account_login.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
181 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
214 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
215 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
216 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
217 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
218 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
219 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
220 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
221 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
222 %dir %{_datadir}/apps/amarok
223 %dir %{_datadir}/apps/amarok/scripts
224 %{_datadir}/apps/amarok/data
225 %{_datadir}/apps/amarok/icons
226 %{_datadir}/apps/amarok/images
227 %{_datadir}/apps/amarok/amarok.notifyrc
228 %{_datadir}/apps/desktoptheme
229 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
230 %{_datadir}/config.kcfg/amarokconfig.kcfg
231 %{_datadir}/config/amarok.knsrc
232 %{_datadir}/config/amarokapplets.knsrc
233 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
234 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
235 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
236 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
237 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
238 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
239 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
240 %{_desktopdir}/kde4/amarok_containers.desktop
241 %{_datadir}/kde4/services/amarok.protocol
242 %{_datadir}/kde4/services/amaroklastfm.protocol
243 %{_datadir}/kde4/services/amarokitpc.protocol
244 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
245 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
246 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
247 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
248 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
249 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
250 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
251 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
252 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
253 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
254 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
255 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
256 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
257 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
258 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
259 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
260 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
261 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
262 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
263 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
264 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
265 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
266 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
267 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
268 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
269 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
270 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
271 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
272 %{_datadir}/kde4/services/amarok_device_massstorage.desktop
273 %{_datadir}/kde4/services/amarok_device_nfs.desktop
274 %{_datadir}/kde4/services/amarok_device_smb.desktop
275 %{_datadir}/kde4/services/amarok_service_ampache.desktop
276 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
277 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
278 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
279 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
280 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
281 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
282 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
283 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
284 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
285 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
286 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
287 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
288 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
289 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
290 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
291 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
292 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
293 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
294 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
295 %{_desktopdir}/kde4/amarok.desktop
296 %{_iconsdir}/*/*/apps/amarok.*
297 %{_datadir}/config/amarok_homerc
298 %attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
299 %{_datadir}/apps/kconf_update/amarok.upd
300
301 %files scripts
302 %defattr(644,root,root,755)
303 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
304 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
305 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
306 %dir %{_datadir}/apps/amarok/scripts/script_console
307 %{_datadir}/apps/amarok/scripts/script_console/main.js
308 %{_datadir}/apps/amarok/scripts/script_console/script.spec
309 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
310 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
311 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
312 %dir %{_datadir}/apps/amarok/scripts/librivox_service
313 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
314 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
315 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
316 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
317 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
318 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
319 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
320 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.044792 seconds and 3 git commands to generate.