]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
a930706f989451a171698e49822378baff2dc146
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       - postgresql support alongside mysql
3 #       - NMM audio backend support (fix build - propably some BRs)
4 #       - make descriptions less useless
5 #       - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #       - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 #
8 # Conditional builds:
9 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
15 %bcond_without  helix           # disable HelixPlayer engine
16 %bcond_with     mp3players      # disable iPod and iRiver MP3 players support
17 %bcond_with     nmm             # enable NMM audio backend
18 %bcond_with     mysql           # enable MySQL support
19 %bcond_with     pgsql           # enable PostgreSQL support
20 #
21 %ifarch i386
22 %undefine       with_helix
23 %endif
24
25 Summary:        A KDE audio player
26 Summary(pl):    Odtwarzacz audio dla KDE
27 Name:           amarok
28 Version:        1.4.2
29 Release:        1
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33 Source0:        http://sunsite.icm.edu.pl/pub/unix/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
34 # Source0-md5:  a1e5aac4294eb049021d1e2889c0d214
35 Patch0:         %{name}-helixplayer-morearchs.patch
36 Patch1:         %{name}-libnjb.patch
37 URL:            http://amarok.kde.org/
38 BuildRequires:  SDL-devel
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  dbus-glib-devel
43 BuildRequires:  gettext-devel
44 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
45 BuildRequires:  kdebase-devel
46 %{?with_akode:BuildRequires:    kdemultimedia-akode}
47 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
48 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
49 %{?with_mp3players:BuildRequires:       libifp-devel}
50 %{?with_mp3players:BuildRequires:       libmtp-devel}
51 %{?with_mp3players:BuildRequires:       libnjb-devel}
52 BuildRequires:  libltdl-devel
53 %{?with_pgsql:BuildRequires:            libpqxx-devel}
54 BuildRequires:  libtunepimp-devel >= 0.4.0
55 BuildRequires:  libvisual-devel >= 0.4.0
56 BuildRequires:  mpeg4ip-devel
57 %{?with_mysql:BuildRequires:            mysql-devel}
58 BuildRequires:  pcre-devel
59 BuildRequires:  pkgconfig
60 BuildRequires:  rpm-pythonprov
61 BuildRequires:  rpmbuild(macros) >= 1.129
62 BuildRequires:  ruby-devel >= 1.8
63 BuildRequires:  sed >= 4.0
64 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
65 BuildRequires:  taglib-devel >= 1.4
66 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
67 %{?with_xmms:BuildRequires:     xmms-devel}
68 Requires:       %{name}-plugin = %{version}-%{release}
69 Requires:       kdebase-core >= 9:3.1.93
70 Requires:       kdemultimedia-audiocd >= 9:3.1.93
71 Obsoletes:      amarok-arts
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 A KDE audio player.
76
77 %description -l pl
78 Odtwarzacz audio dla KDE.
79
80 %package akode
81 Summary:        Plugin akode
82 Summary(pl):    Wtyczka akode
83 Group:          X11/Applications/Multimedia
84 Requires:       %{name} = %{version}-%{release}
85 Provides:       %{name}-plugin = %{version}-%{release}
86
87 %description akode
88 Plugin akode.
89
90 %description akode -l pl
91 Wtyczka akode.
92
93 %package helix
94 Summary:        Helix/Realplayer playback support for amarok
95 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
96 Group:          X11/Applications/Multimedia
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       helix-core
99 Provides:       %{name}-plugin = %{version}-%{release}
100
101 %description helix
102 Helix/Realplayer playback support for amarok.
103
104 %description helix -l pl
105 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
106
107 %package gstreamer
108 Summary:        Plugin gstreamer
109 Summary(pl):    Wtyczka gstreamer
110 Group:          X11/Applications/Multimedia
111 # deps, to get it working:
112 # mp3 decoder:  gstreamer-mad
113 # ogg decoder:  gstreamer-vorbis
114 # audio output driver:  gstreamer-audiosink-alsa
115 # from gstreamer-audio-effects to control volume, etc
116 # needed libs:
117 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
118 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
119 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
120 # gstreamer-musicbrainz for being able to edit id3 tags on files.
121 Requires:       %{name} = %{version}-%{release}
122 Requires:       gstreamer-audio-effects
123 Requires:       gstreamer-audiosink
124 Requires:       gstreamer-mad
125 Requires:       gstreamer-musicbrainz
126 Requires:       gstreamer-vorbis
127 Provides:       %{name}-plugin = %{version}-%{release}
128
129 %description gstreamer
130 Plugin gstreamer.
131
132 %description gstreamer -l pl
133 Wtyczka gstreamer.
134
135 %package xine
136 Summary:        Plugin xine
137 Summary(pl):    Wtyczka xine
138 Group:          X11/Applications/Multimedia
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       xine-plugin-audio
141 Provides:       %{name}-plugin = %{version}-%{release}
142
143 %description xine
144 Plugin xine.
145
146 %description xine -l pl
147 Wtyczka xine.
148
149 %package xmms
150 Summary:        Xmms wrapper
151 Summary(pl):    Wrapper xmms
152 Group:          X11/Applications/Multimedia
153 Requires:       %{name} = %{version}-%{release}
154
155 %description xmms
156 Xmms wrapper.
157
158 %description xmms -l pl
159 Wrapper xmms.
160
161 %package zeroconf
162 Summary:        Zeroconf data
163 Summary(pl):    Dane dla zeroconf
164 Group:          X11/Applications/Multimedia
165 Requires:       %{name} = %{version}-%{release}
166 Requires:       kdenetwork-kdnssd
167 Provides:       %{name}-plugin = %{version}-%{release}
168
169 %description zeroconf
170 Zeroconf data.
171
172 %description zeroconf -l pl
173 Dane dla zeroconf.
174
175 %package scripts
176 Summary:        amaroK scripts
177 Summary(pl):    Skrypty amaroKa
178 Group:          X11/Applications/Multimedia
179 Requires:       %{name} = %{version}-%{release}
180 Requires:       kdebase-kdialog
181 Requires:       python-PyQt
182 Requires:       ruby-modules
183
184 %description scripts
185 amaroK scripts allow you extend amaroK functionality.
186
187 You can learn more about scripts in amaroK from here:
188 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
189
190 %description scripts -l pl
191 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
192
193 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
194 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
195
196 %prep
197 %setup -q
198 %patch0 -p1
199 %patch1 -p1
200 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
201         amarok/src/amarok.desktop \
202
203 # see kde bug #110909
204 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
205
206 # kill env, call interpreter directly, so rpm automatics could rule
207 %{__sed} -i -e '
208         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
209         1s,#!.*bin/env.*python,#!%{_bindir}/python,
210         1s,#!.*bin/env.*bash,#!/bin/bash,
211 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
212
213 %build
214 cp -f /usr/share/automake/config.sub admin
215 %{__make} -f admin/Makefile.common cvs
216
217 # hack: passing something other than "no" or "yes" to --with-helix allows
218 # us to pass HELIX_LIBS
219 %configure \
220         HELIX_LIBS=%{_libdir}/helixplayer \
221         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
222         --disable-rpath \
223         --with%{!?with_mas:out}-mas \
224         --with%{!?with_xine:out}-xine \
225         --with%{!?with_gstreamer:out}-gstreamer10 \
226         --with%{!?with_akode:out}-akode \
227         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
228         --with%{!?with_nmm:out}-nmm \
229         --with%{!?with_mp3players:out}-libgpod \
230         --with%{!?with_mp3players:out}-libnjb \
231         --with%{!?with_mp3players:out}-libmtp \
232         --with%{!?with_mp3players:out}-ifp \
233         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
234         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
235         --disable-final \
236         --with-mp4v2 \
237         --with-qt-libraries=%{_libdir} \
238         --with%{!?with_included_sqlite:out}-included-sqlite
239
240 %{__make}
241
242 %install
243 rm -rf $RPM_BUILD_ROOT
244
245 %{__make} install \
246         DESTDIR=$RPM_BUILD_ROOT \
247         kde_htmldir=%{_kdedocdir} \
248         kde_libs_htmldir=%{_kdedocdir}
249
250 # remove bogus dir
251 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
252
253 %find_lang amarok --all-name --with-kde
254
255 %clean
256 rm -rf $RPM_BUILD_ROOT
257
258 if [ "$1" = 1 ]; then
259         echo "Remember to install libvisual-plugins-* packages if you"
260         echo "want to have a visualizations in amaroK."
261 fi
262
263 %post   -p /sbin/ldconfig
264 %postun -p /sbin/ldconfig
265
266 %files -f %{name}.lang
267 %defattr(644,root,root,755)
268 %doc AUTHORS ChangeLog README
269 %attr(755,root,root) %{_bindir}/amarok
270 %attr(755,root,root) %{_bindir}/amarokapp
271 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
272 %attr(755,root,root) %{_bindir}/amarok_libvisual
273 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
274 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
275 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
276 %{_libdir}/kde3/konqsidebar_universalamarok.la
277 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
278 %{_libdir}/kde3/libamarok_generic-mediadevice.la
279 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
280 %{_libdir}/kde3/libamarok_void-engine_plugin.la
281 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
282 %{_libdir}/libamarok.la
283 %{_libdir}/kde3/libamarok_daap-mediadevice.la
284 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
285 %{_libdir}/kde3/libamarok_massstorage-device.la
286 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
287 %{_libdir}/kde3/libamarok_nfs-device.la
288 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
289 %{_libdir}/kde3/libamarok_smb-device.la
290 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
291 %dir %{_datadir}/apps/amarok
292 %dir %{_datadir}/apps/amarok/scripts
293 %{_datadir}/apps/amarok/ruby_lib
294 %{_datadir}/apps/amarok/*.rc
295 %{_datadir}/apps/amarok/data
296 %{_datadir}/apps/amarok/icons
297 %{_datadir}/apps/amarok/images
298 %{_datadir}/apps/amarok/themes
299 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
300 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
301 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
302 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
303 %{_datadir}/apps/profiles/amarok.profile.xml
304 %{_datadir}/config/amarokrc
305 %{_datadir}/config.kcfg/amarok.kcfg
306 %{_datadir}/services/amarok_generic-mediadevice.desktop
307 %{_datadir}/services/amarok_void-engine_plugin.desktop
308 %{_datadir}/services/amarok_daap-mediadevice.desktop
309 %{_datadir}/services/amarok_massstorage-device.desktop
310 %{_datadir}/services/amarok_nfs-device.desktop
311 %{_datadir}/services/amarok_smb-device.desktop
312 %{_datadir}/services/amaroklastfm.protocol
313 %{_datadir}/services/amarokitpc.protocol
314 %{_datadir}/services/amarokpcast.protocol
315 %{_datadir}/servicetypes/amarok_codecinstall.desktop
316 %{_datadir}/servicetypes/amarok_plugin.desktop
317 %{_desktopdir}/kde/amarok.desktop
318 %{_iconsdir}/*/*/apps/amarok.*
319 # TODO: move to subpackage
320 %if %{with mp3players}
321 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
322 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
323 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
324 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
325 %{_libdir}/kde3/libamarok_njb-mediadevice.la
326 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
327 %{_datadir}/services/amarok_ifp-mediadevice.desktop
328 %{_datadir}/services/amarok_ipod-mediadevice.desktop
329 %{_datadir}/services/amarok_njb-mediadevice.desktop
330 %endif
331
332 %if %{with akode}
333 %files akode
334 %defattr(644,root,root,755)
335 %{_libdir}/kde3/libamarok_aKode-engine.la
336 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
337 %{_datadir}/services/amarok_aKode-engine.desktop
338 %endif
339
340 %if %{with gstreamer}
341 %files gstreamer
342 %defattr(644,root,root,755)
343 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
344 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
345 %{_datadir}/config.kcfg/gstconfig.kcfg
346 %{_datadir}/services/amarok_gst10engine_plugin.desktop
347 %endif
348
349 %if %{with helix}
350 %files helix
351 %defattr(644,root,root,755)
352 %{_libdir}/kde3/libamarok_helixengine_plugin.la
353 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
354 %{_datadir}/config.kcfg/helixconfig.kcfg
355 %{_datadir}/services/amarok_helixengine_plugin.desktop
356 %endif
357
358 %if %{with xine}
359 %files xine
360 %defattr(644,root,root,755)
361 %{_libdir}/kde3/libamarok_xine-engine.la
362 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
363 %{_datadir}/config.kcfg/xinecfg.kcfg
364 %{_datadir}/services/amarok_xine-engine.desktop
365 %endif
366
367 %if %{with xmms}
368 %files xmms
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
371 %endif
372
373 %if 0
374 %if %{with zeroconf}
375 %files zeroconf
376 %defattr(644,root,root,755)
377 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
378 %endif
379 %endif
380
381 %files scripts
382 %defattr(644,root,root,755)
383 %dir %{_datadir}/apps/amarok/scripts/common
384 %{_datadir}/apps/amarok/scripts/common/Publisher.py
385 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
386
387 %dir %{_datadir}/apps/amarok/scripts/templates
388 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
389 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
390 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
391
392 # amarok searches for executable programs for scripts
393 # to figure out which files need to have execute permission, use this
394 # find command:
395 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
396
397 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
398 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
399 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
400
401 %dir %{_datadir}/apps/amarok/scripts/playlist2html
402 %{_datadir}/apps/amarok/scripts/playlist2html/README
403 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
404 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
405 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
406
407 %dir %{_datadir}/apps/amarok/scripts/webcontrol
408 %{_datadir}/apps/amarok/scripts/webcontrol/README
409 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
410 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
411 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
412 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
413 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
414 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
415 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
416 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
417 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
418 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
419 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
420 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
421 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
422 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
423 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
424 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
425 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
426 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
427 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
428
429 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
430 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
431 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
432 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
433 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
434
435 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
436 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
437 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
438 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
439 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
440
441 %dir %{_datadir}/apps/amarok/scripts/score_default
442 %{_datadir}/apps/amarok/scripts/score_default/COPYING
443 %{_datadir}/apps/amarok/scripts/score_default/README
444 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
445 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
446 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
447 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
448 %{_datadir}/apps/amarok/scripts/score_impulsive/README
449 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
450 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
451
452 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
453 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
454
455 %if 0
456 %dir %{_datadir}/apps/amarok/scripts/amarok_live
457 %{_datadir}/apps/amarok/scripts/amarok_live/README
458 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
459 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
460 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
461 %endif
This page took 0.201058 seconds and 2 git commands to generate.