]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- added score_{default,impulsive} scripts, added desktop file for njb
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
9 %bcond_without  mas             # disable MAS audio backend
10 %bcond_without  xine            # disable xine engine
11 %bcond_without  xmms            # disable xmms wrapping
12 %bcond_without  zeroconf        # disable support for zeroconf
13 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
14 %bcond_without  helix           # disable HelixPlayer engine
15 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable MySQL support
18 %bcond_with     pgsql           # enable PostgreSQL support
19 #
20 %ifarch i386
21 %undefine       with_helix
22 %endif
23
24 %define         _beta   beta1
25
26 Summary:        A KDE audio player
27 Summary(pl):    Odtwarzacz audio dla KDE
28 Name:           amarok
29 Version:        1.4.1
30 Release:        0.%{_beta}.1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
34 # Source0-md5:  ee043cf6efa3f2ac7b470eb6c050c0f7
35 Patch0:         %{name}-helixplayer-morearchs.patch
36 Patch1:         %{name}-libnjb.patch
37 URL:            http://amarok.kde.org/
38 BuildRequires:  SDL-devel
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  dbus-glib-devel
43 BuildRequires:  gettext-devel
44 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
45 BuildRequires:  kdebase-devel
46 %{?with_akode:BuildRequires:    kdemultimedia-akode}
47 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
48 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
49 %{?with_mp3players:BuildRequires:       libifp-devel}
50 BuildRequires:  libltdl-devel
51 %{?with_mp3players:BuildRequires:       libnjb-devel}
52 %{?with_pgsql:BuildRequires:            libpqxx-devel}
53 BuildRequires:  libtunepimp-devel >= 0.4.0
54 BuildRequires:  libvisual-devel >= 0.4.0
55 BuildRequires:  mpeg4ip-devel
56 %{?with_mysql:BuildRequires:            mysql-devel}
57 BuildRequires:  pcre-devel
58 BuildRequires:  pkgconfig
59 BuildRequires:  rpm-pythonprov
60 BuildRequires:  rpmbuild(macros) >= 1.129
61 BuildRequires:  ruby-devel >= 1.8
62 BuildRequires:  sed >= 4.0
63 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
64 BuildRequires:  taglib-devel >= 1.4
65 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
66 %{?with_xmms:BuildRequires:     xmms-devel}
67 Requires:       %{name}-plugin = %{version}-%{release}
68 Requires:       kdebase-core >= 9:3.1.93
69 Requires:       kdemultimedia-audiocd >= 9:3.1.93
70 Obsoletes:      amarok-arts
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 A KDE audio player.
75
76 %description -l pl
77 Odtwarzacz audio dla KDE.
78
79 %package akode
80 Summary:        Plugin akode
81 Summary(pl):    Wtyczka akode
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       %{name}-plugin = %{version}-%{release}
85
86 %description akode
87 Plugin akode.
88
89 %description akode -l pl
90 Wtyczka akode.
91
92 %package helix
93 Summary:        Helix/Realplayer playback support for amarok
94 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
95 Group:          X11/Applications/Multimedia
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       helix-core
98 Provides:       %{name}-plugin = %{version}-%{release}
99
100 %description helix
101 Helix/Realplayer playback support for amarok.
102
103 %description helix -l pl
104 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
105
106 %package gstreamer
107 Summary:        Plugin gstreamer
108 Summary(pl):    Wtyczka gstreamer
109 Group:          X11/Applications/Multimedia
110 # deps, to get it working:
111 # mp3 decoder:  gstreamer-mad
112 # ogg decoder:  gstreamer-vorbis
113 # audio output driver:  gstreamer-audiosink-alsa
114 # from gstreamer-audio-effects to control volume, etc
115 # needed libs:
116 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
117 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
118 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
119 # gstreamer-musicbrainz for being able to edit id3 tags on files.
120 Requires:       %{name} = %{version}-%{release}
121 Requires:       gstreamer-audio-effects
122 Requires:       gstreamer-audiosink
123 Requires:       gstreamer-mad
124 Requires:       gstreamer-musicbrainz
125 Requires:       gstreamer-vorbis
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description gstreamer
129 Plugin gstreamer.
130
131 %description gstreamer -l pl
132 Wtyczka gstreamer.
133
134 %package xine
135 Summary:        Plugin xine
136 Summary(pl):    Wtyczka xine
137 Group:          X11/Applications/Multimedia
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       xine-plugin-audio
140 Provides:       %{name}-plugin = %{version}-%{release}
141
142 %description xine
143 Plugin xine.
144
145 %description xine -l pl
146 Wtyczka xine.
147
148 %package xmms
149 Summary:        Xmms wrapper
150 Summary(pl):    Wrapper xmms
151 Group:          X11/Applications/Multimedia
152 Requires:       %{name} = %{version}-%{release}
153
154 %description xmms
155 Xmms wrapper.
156
157 %description xmms -l pl
158 Wrapper xmms.
159
160 %package zeroconf
161 Summary:        Zeroconf data
162 Summary(pl):    Dane dla zeroconf
163 Group:          X11/Applications/Multimedia
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       kdenetwork-kdnssd
166 Provides:       %{name}-plugin = %{version}-%{release}
167
168 %description zeroconf
169 Zeroconf data.
170
171 %description zeroconf -l pl
172 Dane dla zeroconf.
173
174 %package scripts
175 Summary:        amaroK scripts
176 Summary(pl):    Skrypty amaroKa
177 Group:          X11/Applications/Multimedia
178 Requires:       %{name} = %{version}-%{release}
179 Requires:       kdebase-kdialog
180 Requires:       python-PyQt
181 Requires:       ruby-modules
182
183 %description scripts
184 amaroK scripts allow you extend amaroK functionality.
185
186 You can learn more about scripts in amaroK from here:
187 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
188
189 %description scripts -l pl
190 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
191
192 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
193 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
194
195 %prep
196 %setup -q -n %{name}-%{version}-%{_beta}
197 %patch0 -p1
198 %patch1 -p1
199 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
200         amarok/src/amarok.desktop \
201
202 # see kde bug #110909
203 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
204
205 # kill env, call interpreter directly, so rpm automatics could rule
206 %{__sed} -i -e '
207         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
208         1s,#!.*bin/env.*python,#!%{_bindir}/python,
209         1s,#!.*bin/env.*bash,#!/bin/bash,
210 ' amarok/src/scripts/*/*.{py,rb,sh}
211
212 %build
213 cp -f /usr/share/automake/config.sub admin
214 %{__make} -f admin/Makefile.common cvs
215
216 # hack: passing something other than "no" or "yes" to --with-helix allows
217 # us to pass HELIX_LIBS
218 %configure \
219         HELIX_LIBS=%{_libdir}/helixplayer \
220         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
221         --disable-rpath \
222         --with%{!?with_mas:out}-mas \
223         --with%{!?with_xine:out}-xine \
224         --with%{!?with_gstreamer:out}-gstreamer10 \
225         --with%{!?with_akode:out}-akode \
226         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
227         --with%{!?with_nmm:out}-nmm \
228         --with%{!?with_mp3players:out}-libgpod \
229         --with%{!?with_mp3players:out}-libnjb \
230         --with%{!?with_mp3players:out}-ifp \
231         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
232         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
233         --disable-final \
234         --with-mp4v2 \
235         --with-qt-libraries=%{_libdir} \
236         --with%{!?with_included_sqlite:out}-included-sqlite
237
238 %{__make}
239
240 %install
241 rm -rf $RPM_BUILD_ROOT
242
243 %{__make} install \
244         DESTDIR=$RPM_BUILD_ROOT \
245         kde_htmldir=%{_kdedocdir} \
246         kde_libs_htmldir=%{_kdedocdir}
247
248 # remove bogus dir
249 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
250
251 %find_lang amarok --all-name --with-kde
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 if [ "$1" = 1 ]; then
257         echo "Remember to install libvisual-plugins-* packages if you"
258         echo "want to have a visualizations in amaroK."
259 fi
260
261 %post   -p /sbin/ldconfig
262 %postun -p /sbin/ldconfig
263
264 %files -f %{name}.lang
265 %defattr(644,root,root,755)
266 %doc AUTHORS ChangeLog README
267 %attr(755,root,root) %{_bindir}/amarok
268 %attr(755,root,root) %{_bindir}/amarokapp
269 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
270 %attr(755,root,root) %{_bindir}/amarok_libvisual
271 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
272 %{_libdir}/kde3/konqsidebar_universalamarok.la
273 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
274 %{_libdir}/kde3/libamarok_generic-mediadevice.la
275 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
276 %{_libdir}/kde3/libamarok_njb-mediadevice.la
277 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
278 %{_libdir}/kde3/libamarok_void-engine_plugin.la
279 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
280 %{_libdir}/libamarok.la
281 %dir %{_datadir}/apps/amarok
282 %dir %{_datadir}/apps/amarok/scripts
283 %{_datadir}/apps/amarok/*.rc
284 %{_datadir}/apps/amarok/data
285 %{_datadir}/apps/amarok/icons
286 %{_datadir}/apps/amarok/images
287 %{_datadir}/apps/amarok/themes
288 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
289 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
290 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
291 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
292 %{_datadir}/apps/profiles/amarok.profile.xml
293 %{_datadir}/config/amarokrc
294 %{_datadir}/config.kcfg/amarok.kcfg
295 %{_datadir}/services/amarok_generic-mediadevice.desktop
296 %{_datadir}/services/amarok_void-engine_plugin.desktop
297 %{_datadir}/servicetypes/amarok_plugin.desktop
298 %{_desktopdir}/kde/amarok.desktop
299 %{_iconsdir}/*/*/apps/amarok.*
300 # TODO: move to subpackage
301 %if %{with mp3players}
302 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
303 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
304 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
305 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
306 %{_datadir}/services/amarok_ipod-mediadevice.desktop
307 %{_datadir}/services/amarok_ifp-mediadevice.desktop
308 %{_datadir}/services/amarok_njb-mediadevice.desktop
309 %endif
310
311 %if %{with akode}
312 %files akode
313 %defattr(644,root,root,755)
314 %{_libdir}/kde3/libamarok_aKode-engine.la
315 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
316 %{_datadir}/services/amarok_aKode-engine.desktop
317 %endif
318
319 %if %{with gstreamer}
320 %files gstreamer
321 %defattr(644,root,root,755)
322 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
323 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
324 %{_datadir}/config.kcfg/gstconfig.kcfg
325 %{_datadir}/services/amarok_gst10engine_plugin.desktop
326 %endif
327
328 %if %{with helix}
329 %files helix
330 %defattr(644,root,root,755)
331 %{_libdir}/kde3/libamarok_helixengine_plugin.la
332 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
333 %{_datadir}/config.kcfg/helixconfig.kcfg
334 %{_datadir}/services/amarok_helixengine_plugin.desktop
335 %endif
336
337 %if %{with xine}
338 %files xine
339 %defattr(644,root,root,755)
340 %{_libdir}/kde3/libamarok_xine-engine.la
341 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
342 %{_datadir}/config.kcfg/xinecfg.kcfg
343 %{_datadir}/services/amarok_xine-engine.desktop
344 #%{_datadir}/services/amarok_xineengine_plugin.desktop
345 %endif
346
347 %if %{with xmms}
348 %files xmms
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
351 %endif
352
353 %if 0
354 %if %{with zeroconf}
355 %files zeroconf
356 %defattr(644,root,root,755)
357 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
358 %endif
359 %endif
360
361 %files scripts
362 %defattr(644,root,root,755)
363 %dir %{_datadir}/apps/amarok/scripts/common
364 %{_datadir}/apps/amarok/scripts/common/Publisher.py
365 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
366
367 %dir %{_datadir}/apps/amarok/scripts/templates
368 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
369 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
370 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
371
372 # amarok searches for executable programs for scripts
373 # to figure out which files need to have execute permission, use this
374 # find command:
375 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
376
377 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
378 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
379 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
380
381 %dir %{_datadir}/apps/amarok/scripts/playlist2html
382 %{_datadir}/apps/amarok/scripts/playlist2html/README
383 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
384 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
385 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
386
387 %dir %{_datadir}/apps/amarok/scripts/webcontrol
388 %{_datadir}/apps/amarok/scripts/webcontrol/README
389 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
390 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
391 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
392 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
393 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
394 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
395 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
396 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
397 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
398 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
399 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
400 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
401 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
402 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
403 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
404 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
405 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
406 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
407 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
408
409 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
410 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
411 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
412 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
413 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
414
415 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
416 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
417 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
418 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
419 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
420
421 %dir %{_datadir}/apps/amarok/scripts/score_default
422 %{_datadir}/apps/amarok/scripts/score_default/COPYING
423 %{_datadir}/apps/amarok/scripts/score_default/README
424 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
425 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
426 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
427 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
428 %{_datadir}/apps/amarok/scripts/score_impulsive/README
429 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
430 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
431
432 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
433 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
434
435 %if 0
436 %dir %{_datadir}/apps/amarok/scripts/amarok_live
437 %{_datadir}/apps/amarok/scripts/amarok_live/README
438 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
439 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
440 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
441 %endif
This page took 0.074264 seconds and 3 git commands to generate.