]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- simplify krb5 libs detection
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_without  xfs     # without (possible) support for xfsdump
4 %bcond_without  samba   # without smbclient support
5 %bcond_without  client  # without client package
6 %bcond_without  server  # without server package
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        A network-capable tape backup solution
10 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
11 Name:           amanda
12 Version:        3.3.6
13 Release:        6
14 License:        BSD
15 Group:          Networking/Utilities
16 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
17 # Source0-md5:  99559bd84b358701cf943fcc347d8914
18 Source1:        %{name}-srv.crontab
19 Source2:        %{name}.inetd
20 Source3:        %{name}idx.inetd
21 Source4:        amidxtape.inetd
22 Source5:        k5%{name}.inet
23 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
24 Source6:        convert-zd-mtx-to-robot.sh
25 Source7:        %{name}-ssh_config
26 # https://github.com/janekr/amlvm-snapshot
27 Source8:        amlvm-snapshot.conf
28 Source9:        amlvm-snapshot.pl
29 Source10:       amlvm-snapshot.README
30 Patch0:         %{name}-no_libnsl.patch
31 Patch1:         %{name}-chg-zd-mtx-sh.patch
32 Patch2:         %{name}-tar.patch
33 Patch3:         %{name}-common.patch
34 Patch4:         %{name}-as_needed.patch
35 Patch5:         %{name}-tapetypes.patch
36 Patch6:         %{name}-FHS.patch
37 Patch7:         %{name}-no-buildtime-ipv6.patch
38 Patch8:         %{name}-heimdal.patch
39 Patch9:         %{name}-ac.patch
40 Patch11:        %{name}-amstar-exclude-fix.patch
41 Patch12:        %{name}-krb5-auth.patch
42 Patch13:        %{name}-amstar-device.patch
43 Patch14:        swig.patch
44 Patch15:        krb5-ac.patch
45 URL:            http://www.amanda.org/
46 %{?with_samba:BuildRequires:    /usr/bin/smbclient}
47 BuildRequires:  autoconf >= 2.53
48 BuildRequires:  automake
49 BuildRequires:  curl-devel >= 7.10.0
50 BuildRequires:  dump
51 BuildRequires:  flex
52 BuildRequires:  glib2-devel
53 BuildRequires:  gnuplot
54 BuildRequires:  heimdal-devel
55 BuildRequires:  rpmbuild(macros) >= 1.654
56 # curl is broken, see curl-config --libs (c8cba693)
57 BuildRequires:  keyutils-devel
58 BuildRequires:  libtool
59 BuildRequires:  libxslt-progs
60 BuildRequires:  ncurses-devel
61 BuildRequires:  openssh-clients
62 BuildRequires:  openssl-devel
63 BuildRequires:  perl-devel >= 5.6.0
64 BuildRequires:  pkgconfig
65 BuildRequires:  readline-devel >= 4.2
66 BuildRequires:  rpm-perlprov
67 BuildRequires:  rpmbuild(macros) >= 1.654
68 BuildRequires:  swig
69 %{?with_xfs:BuildRequires:      xfsdump}
70 Conflicts:      pwdutils < 3.1.2-2
71 Conflicts:      shadow < 1:4.0.4.1-4
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
75 %define         _noautoreq_perl Tie::StdHash Amanda::Recovery::Clerk::Feedback Amanda::Taper::Scribe::Feedback
76
77 %define         _ulibdir        %{_prefix}/lib
78
79 %description
80 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
81 backup system that allows the administrator of a LAN to set up a
82 single master backup server to back up multiple hosts to a single
83 large capacity tape drive. AMANDA uses native dump and/or GNU tar
84 facilities and can back up a large number of workstations running
85 multiple versions of Unix. Newer versions of AMANDA (including this
86 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
87 The amanda package contains the core AMANDA programs and will need to
88 be installed on both AMANDA clients and AMANDA servers. Note that you
89 will have to install the amanda-client and amanda-server packages as
90 well.
91
92 %description -l pl.UTF-8
93 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
94 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
95 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
96 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
97 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
98 podstawowe pliki programu i powinien być zainstalowany zarówno na
99 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
100 amanda-client i amanda-server!
101
102 %package common
103 Summary:        Amanda common files
104 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
105 Group:          Networking/Utilities
106 Requires(postun):       /usr/sbin/groupdel
107 Requires(postun):       /usr/sbin/userdel
108 Requires(pre):  /bin/id
109 Requires(pre):  /usr/bin/chsh
110 Requires(pre):  /usr/bin/getgid
111 Requires(pre):  /usr/sbin/groupadd
112 Requires(pre):  /usr/sbin/useradd
113 %requires_ge glib2
114 Requires:       setup >= 2.6.1-1
115 Provides:       group(amanda)
116 Provides:       user(amanda)
117 Obsoletes:      amanda-libs
118 Obsoletes:      amanda-perl
119
120 %description common
121 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
122 backup system that allows the administrator of a LAN to set up a
123 single master backup server to back up multiple hosts to a single
124 large capacity tape drive. AMANDA uses native dump and/or GNU tar
125 facilities and can back up a large number of workstations running
126 multiple versions of Unix. Newer versions of AMANDA (including this
127 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
128 The amanda package contains the core AMANDA programs and will need to
129 be installed on both AMANDA clients and AMANDA servers. Note that you
130 will have to install the amanda-client and amanda-server packages as
131 well.
132
133 Amanda common files.
134
135 %description common -l pl.UTF-8
136 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
137 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
138 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
139 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
140 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
141 podstawowe pliki programu i powinien być zainstalowany zarówno na
142 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
143 amanda-client i amanda-server!
144
145 Wspólne pliki pakietu amanda.
146
147 %package client
148 Summary:        The client side of Amanda
149 Summary(pl.UTF-8):      Klient Amandy
150 Group:          Networking/Utilities
151 Requires(post): /bin/hostname
152 Requires(post): /usr/bin/ssh-keygen
153 Requires:       %{name}-common = %{version}-%{release}
154 Requires:       rc-inetd
155 Suggests:       gzip
156 Suggests:       openssh-clients
157 Suggests:       openssh-server
158 Suggests:       star
159 Suggests:       tar
160 Conflicts:      tar < 1.15
161
162 %description client
163 The Amanda-client package should be installed on any machine that will
164 be backed up by AMANDA (including the server if it also needs to be
165 backed up). You will also need to install the amanda package to each
166 AMANDA client. It requires at least one of dump and GNU tar installed.
167
168 %description client -l pl.UTF-8
169 Ten pakiet powinien być zainstalowany ma maszynach, z których
170 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
171 najmniej jednego z pakietów dump i GNU tar.
172
173 %package server
174 Summary:        The server side of Amanda
175 Summary(pl.UTF-8):      Serwer Amandy
176 Group:          Networking/Utilities
177 Requires(post): /bin/hostname
178 Requires(post): /usr/bin/ssh-keygen
179 Requires:       %{name}-common = %{version}-%{release}
180 Requires:       /etc/cron.d
181 Requires:       crondaemon
182 Requires:       gnuplot
183 Requires:       mt-st
184 Requires:       mtx
185 Requires:       rc-inetd
186 Suggests:       openssh-clients
187 Suggests:       openssh-server
188 Obsoletes:      amanda
189 Obsoletes:      amanda-perl-server
190
191 %description server
192 The amanda-server package should be installed on the AMANDA server,
193 the machine attached to the device (such as a tape drive) where
194 backups will be written. You will also need to install the amanda
195 package to the AMANDA server. And, if the server is also to be backed
196 up, the server also needs to have the amanda-client package installed.
197
198 %description server -l pl.UTF-8
199 Ten pakiet powinien być zainstalowany na maszynach, na których będą
200 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
201 typu streamer).
202
203 %prep
204 %setup -q
205 %patch0 -p1
206 %patch1 -p1
207 %patch2 -p1
208 %patch3 -p1
209 %patch4 -p1
210 %patch5 -p1
211 %patch6 -p1
212 %patch7 -p1
213 %patch8 -p1
214 %patch9 -p1
215 %patch11 -p1
216 %patch12 -p1
217 %patch13 -p1
218 %patch14 -p1
219 %patch15 -p1
220 cp -a %{SOURCE10} .
221
222 find perl/ -name '*.swg' -print0 | xargs -0 touch
223
224 %build
225 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
226 %{__autoconf}
227 %{__automake}
228 %configure \
229         DUMP=/sbin/dump \
230         GZIP=/bin/gzip \
231         MAILER=/bin/mail \
232         MT=/bin/mt \
233         MTX=/usr/sbin/mtx \
234         PRINT=/usr/bin/lpr \
235         RESTORE=/sbin/restore \
236         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
237         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
238         --disable-static \
239         --enable-shared \
240         %{!?with_server:--without-server} \
241         %{!?with_client:--without-client} \
242         --with-index-server=localhost \
243         --with-user=amanda \
244         --with-group=amanda \
245         --with-tape-device=/dev/null \
246         --with-fqdn \
247         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
248         --with-star=%{_bindir}/star \
249         --with-gnuplot=%{_bindir}/gnuplot \
250         --with-bsd-security \
251         --with-bsdtcp-security \
252         --with-ssh-security \
253         --with-krb5-security \
254         --with-buffered-dump \
255         --with-amandahosts \
256         --with-configdir=%{_sysconfdir}/amanda \
257         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
258         --with-amandates=%{_sharedstatedir}/amanda/amandates \
259         --with-debugging=%{_sharedstatedir}/amanda/debug \
260         --with-tmpdir=/var/tmp/amanda \
261         --with-amperldir=%{perl_vendorarch} \
262         --with-ipv6 \
263         --with-readline \
264         --disable-installperms
265
266 %{__make}
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
271         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
272         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
273
274 %{__make} install \
275         DESTDIR=$RPM_BUILD_ROOT
276
277 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
278 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
279 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
280 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
281 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
282
283 cp -p example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
284 cp -p example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
285 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
286
287 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
288
289 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
290 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
291 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
292 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
293
294 %if %{with server}
295 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
296 %endif
297
298 %if %{with client}
299 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libdir}/amanda/application/amlvm-snapshot
300 %endif
301
302 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
303
304 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
305 # Tools can't be "fixed" because keys generated on server are to be used on client
306 if [ "%{_lib}" != "lib" ] ; then
307         install -d $RPM_BUILD_ROOT%{_ulibdir}
308         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
309 fi
310
311 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
312
313 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
314 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
315
316 %clean
317 rm -rf $RPM_BUILD_ROOT
318
319 %triggerpostun common -- amanda-libs < 2.6.0p2-3
320 echo "Adding amanda to disk and tape groups"
321 /usr/sbin/usermod -G disk,tape amanda
322 echo "Setting amanda shell to /bin/sh"
323 /usr/bin/chsh -s /bin/sh amanda
324 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
325         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
326         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
327         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
328 fi
329
330 %triggerpostun common -- amanda-common < 3.3
331 %banner %{name}-common -e << EOF
332 In amanda 3.3 the default auth has changed to "bsdtcp",
333 if you are using the default "bsd" then you must add it
334 to your configuration:
335
336  *   in amanda.conf
337  *   in amanda-client.conf
338  *   in dumptype/disklist
339  *   in inetd (if no '-auth' argument to amandad)
340 EOF
341
342 %pre common
343 %groupadd -P %{name}-common -g 80 amanda
344 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
345
346 %postun common
347 if [ "$1" = "0" ]; then
348         %userremove amanda
349         %groupremove amanda
350 fi
351
352 %post client
353 %service -q rc-inetd reload
354 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
355         HOST="`/bin/hostname`"
356         FQDNHOST="`/bin/hostname -f`"
357         if [ -z "$HOST" ] ; then
358                 COMMENT="root@client"
359         else
360                 COMMENT="root@$HOST"
361         fi
362         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
363         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
364         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
365         if [ -n "$FQDNHOST" ]; then
366                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
367                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
368
369                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
370                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
371         fi
372 fi
373
374 %postun client
375 if [ "$1" = 0 ]; then
376         %service -q rc-inetd reload
377 fi
378
379 %post server
380 %service -q rc-inetd reload
381 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
382         HOST="`/bin/hostname`"
383         if [ -z "$HOST" ] ; then
384                 COMMENT="amanda@server"
385         else
386                 COMMENT="amanda@$HOST"
387         fi
388         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
389         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
390         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
391 fi
392 if [ "$1" = "1" ]; then
393         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
394 fi
395
396 %postun server
397 if [ "$1" = 0 ]; then
398         %service -q rc-inetd reload
399 fi
400
401 %triggerpostun server -- amanda-server < 3.2.0
402 %banner %{name} -e << EOF
403 Warning: Tape changer configuration has chaged, please read
404 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
405 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
406 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
407 to upgrade to chg-robot.
408 EOF
409
410 %files common
411 %defattr(644,root,root,755)
412 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
413 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
414 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
415 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
416 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
417 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
418 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
419 %attr(755,root,root) %{_libdir}/amanda/amndmjob
420 %attr(755,root,root) %{_libdir}/amanda/ndmjob
421 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
422 %dir %{_libdir}/amanda
423 %if %{_lib} != "lib"
424 %{_ulibdir}/amanda
425 %endif
426 %{_libdir}/amanda/amanda-sh-lib.sh
427 %attr(755,root,root) %{_sbindir}/amaespipe
428 %attr(755,root,root) %{_sbindir}/amarchiver
429 %attr(755,root,root) %{_sbindir}/amcrypt*
430 %attr(755,root,root) %{_sbindir}/amgetconf
431 %attr(755,root,root) %{_sbindir}/amgpgcrypt
432 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
433 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
434 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
435 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
436 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
437 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
438 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
439 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
440 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
441 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
442 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
443 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
444 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
445 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
446 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
447 # Commented out so it won't get removed on uninstall
448 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
449 %{_mandir}/man5/amanda-archive-format.5*
450 %{_mandir}/man7/amanda-auth.7*
451 %{_mandir}/man7/amanda-match.7*
452 %{_mandir}/man7/amanda-scripts.7*
453 %{_mandir}/man8/amaespipe.8*
454 %{_mandir}/man8/amanda.8*
455 %{_mandir}/man8/amarchiver.8*
456 %{_mandir}/man8/amcrypt*.8*
457 %{_mandir}/man8/amgetconf.8*
458 %{_mandir}/man8/amgpgcrypt.8*
459 %{_mandir}/man8/script-email.8*
460
461 %dir %{perl_vendorarch}/Amanda
462 %dir %{perl_vendorarch}/Amanda/Config
463 %dir %{perl_vendorarch}/Amanda/IPC
464 %{perl_vendorarch}/Amanda/Archive.pm
465 %{perl_vendorarch}/Amanda/BigIntCompat.pm
466 %{perl_vendorarch}/Amanda/ClientService.pm
467 %{perl_vendorarch}/Amanda/Config.pm
468 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
469 %{perl_vendorarch}/Amanda/Constants.pm
470 %{perl_vendorarch}/Amanda/Debug.pm
471 %{perl_vendorarch}/Amanda/Feature.pm
472 %{perl_vendorarch}/Amanda/Header.pm
473 %{perl_vendorarch}/Amanda/IPC/Binary.pm
474 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
475 %{perl_vendorarch}/Amanda/MainLoop.pm
476 %{perl_vendorarch}/Amanda/NDMP.pm
477 %{perl_vendorarch}/Amanda/Paths.pm
478 %{perl_vendorarch}/Amanda/Process.pm
479 %{perl_vendorarch}/Amanda/Script.pm
480 %{perl_vendorarch}/Amanda/Script_App.pm
481 %{perl_vendorarch}/Amanda/Tests.pm
482 %{perl_vendorarch}/Amanda/Util.pm
483 %{perl_vendorarch}/Amanda/Xfer.pm
484 %dir %{perl_vendorarch}/auto/Amanda
485 %dir %{perl_vendorarch}/auto/Amanda/Archive
486 %dir %{perl_vendorarch}/auto/Amanda/Config
487 %dir %{perl_vendorarch}/auto/Amanda/Debug
488 %dir %{perl_vendorarch}/auto/Amanda/Feature
489 %dir %{perl_vendorarch}/auto/Amanda/Header
490 %dir %{perl_vendorarch}/auto/Amanda/IPC
491 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
492 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
493 %dir %{perl_vendorarch}/auto/Amanda/NDMP
494 %dir %{perl_vendorarch}/auto/Amanda/Tests
495 %dir %{perl_vendorarch}/auto/Amanda/Util
496 %dir %{perl_vendorarch}/auto/Amanda/Xfer
497 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
498 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
499 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
500 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
501 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
502 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
503 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
504 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
505 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
506 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
507 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
508
509 %if %{with server}
510 %files server
511 %defattr(644,root,root,755)
512 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
513 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
514
515 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
516 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
517
518 # Commented out so it won't get removed on uninstall
519 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
520 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
521
522 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
523
524 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
525
526 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
527 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
528
529 %attr(755,root,root) %{_libdir}/amanda/amcat.awk
530 %attr(755,root,root) %{_libdir}/amanda/amcheck-device
531 %attr(755,root,root) %{_libdir}/amanda/amdumpd
532 %attr(755,root,root) %{_libdir}/amanda/amidxtaped
533 %attr(755,root,root) %{_libdir}/amanda/amindexd
534 %attr(755,root,root) %{_libdir}/amanda/amlogroll
535 %attr(755,root,root) %{_libdir}/amanda/amplot.awk
536 %attr(755,root,root) %{_libdir}/amanda/amplot.g
537 %attr(755,root,root) %{_libdir}/amanda/amplot.gp
538 %attr(755,root,root) %{_libdir}/amanda/amtrmidx
539 %attr(755,root,root) %{_libdir}/amanda/amtrmlog
540 %attr(755,root,root) %{_libdir}/amanda/chg-disk
541 %attr(755,root,root) %{_libdir}/amanda/chg-lib.sh
542 %attr(755,root,root) %{_libdir}/amanda/chg-manual
543 %attr(755,root,root) %{_libdir}/amanda/chg-multi
544 %attr(755,root,root) %{_libdir}/amanda/chg-zd-mtx
545 %attr(755,root,root) %{_libdir}/amanda/chunker
546 %attr(755,root,root) %{_libdir}/amanda/driver
547 %attr(4750,root,amanda) %{_libdir}/amanda/dumper
548 %attr(4750,root,amanda) %{_libdir}/amanda/planner
549 %attr(755,root,root) %{_libdir}/amanda/taper
550
551 %attr(755,root,root) %{_sbindir}/activate-devpay
552 %attr(755,root,root) %{_sbindir}/amaddclient
553 %attr(755,root,root) %{_sbindir}/amadmin
554 %attr(4750,root,amanda) %{_sbindir}/amcheck
555 %attr(755,root,root) %{_sbindir}/amcheckdb
556 %attr(755,root,root) %{_sbindir}/amcheckdump
557 %attr(755,root,root) %{_sbindir}/amcleanup
558 %attr(755,root,root) %{_sbindir}/amcleanupdisk
559 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
560 %attr(755,root,root) %{_sbindir}/amdevcheck
561 %attr(755,root,root) %{_sbindir}/amdump
562 %attr(755,root,root) %{_sbindir}/amfetchdump
563 %attr(755,root,root) %{_sbindir}/amflush
564 %attr(755,root,root) %{_sbindir}/amlabel
565 %attr(755,root,root) %{_sbindir}/amoverview
566 %attr(755,root,root) %{_sbindir}/amplot
567 %attr(755,root,root) %{_sbindir}/amreport
568 %attr(755,root,root) %{_sbindir}/amrestore
569 %attr(755,root,root) %{_sbindir}/amrmtape
570 %attr(755,root,root) %{_sbindir}/amserverconfig
571 %attr(755,root,root) %{_sbindir}/amservice
572 %attr(755,root,root) %{_sbindir}/amstatus
573 %attr(755,root,root) %{_sbindir}/amtape
574 %attr(755,root,root) %{_sbindir}/amtapetype
575 %attr(755,root,root) %{_sbindir}/amtoc
576 %attr(755,root,root) %{_sbindir}/amvault
577 %{_mandir}/man5/amanda.conf.5*
578 %{_mandir}/man5/disklist.5*
579 %{_mandir}/man5/tapelist.5*
580 %{_mandir}/man7/amanda-changers.7*
581 %{_mandir}/man7/amanda-compatibility.7*
582 %{_mandir}/man7/amanda-devices.7*
583 %{_mandir}/man7/amanda-interactivity.7*
584 %{_mandir}/man7/amanda-taperscan.7*
585 %{_mandir}/man8/amaddclient.8*
586 %{_mandir}/man8/amadmin.8*
587 %{_mandir}/man8/amcheck.8*
588 %{_mandir}/man8/amcheckdb.8*
589 %{_mandir}/man8/amcheckdump.8*
590 %{_mandir}/man8/amcleanup.8*
591 %{_mandir}/man8/amcleanupdisk.8*
592 %{_mandir}/man8/amdevcheck.8*
593 %{_mandir}/man8/amdump.8*
594 %{_mandir}/man8/amfetchdump.8*
595 %{_mandir}/man8/amflush.8*
596 %{_mandir}/man8/amlabel.8*
597 %{_mandir}/man8/amoverview.8*
598 %{_mandir}/man8/amplot.8*
599 %{_mandir}/man8/amreport.8*
600 %{_mandir}/man8/amrestore.8*
601 %{_mandir}/man8/amrmtape.8*
602 %{_mandir}/man8/amserverconfig.8*
603 %{_mandir}/man8/amservice.8*
604 %{_mandir}/man8/amstatus.8*
605 %{_mandir}/man8/amtape.8*
606 %{_mandir}/man8/amtapetype.8*
607 %{_mandir}/man8/amtoc.8*
608 %{_mandir}/man8/amvault.8*
609
610 %{perl_vendorarch}/Amanda/Changer.pm
611 %dir %{perl_vendorarch}/Amanda/Changer
612 %{perl_vendorarch}/Amanda/Changer/*.pm
613 %{perl_vendorarch}/Amanda/Cmdline.pm
614 %{perl_vendorarch}/Amanda/Curinfo.pm
615 %dir %{perl_vendorarch}/Amanda/Curinfo
616 %{perl_vendorarch}/Amanda/Curinfo/*.pm
617 %dir %{perl_vendorarch}/Amanda/DB
618 %{perl_vendorarch}/Amanda/DB/*.pm
619 %{perl_vendorarch}/Amanda/Device.pm
620 %{perl_vendorarch}/Amanda/Extract.pm
621 %{perl_vendorarch}/Amanda/Disklist.pm
622 %{perl_vendorarch}/Amanda/Holding.pm
623 %{perl_vendorarch}/Amanda/Interactivity.pm
624 %dir %{perl_vendorarch}/Amanda/Interactivity
625 %{perl_vendorarch}/Amanda/Interactivity/*.pm
626 %{perl_vendorarch}/Amanda/Logfile.pm
627 %dir %{perl_vendorarch}/Amanda/Recovery
628 %{perl_vendorarch}/Amanda/Recovery/*.pm
629 %{perl_vendorarch}/Amanda/Report.pm
630 %dir %{perl_vendorarch}/Amanda/Report
631 %{perl_vendorarch}/Amanda/Report/*.pm
632 %{perl_vendorarch}/Amanda/ScanInventory.pm
633 %{perl_vendorarch}/Amanda/Tapelist.pm
634 %dir %{perl_vendorarch}/Amanda/Taper
635 %{perl_vendorarch}/Amanda/Taper/*.pm
636 %dir %{perl_vendorarch}/Amanda/Taper/Scan
637 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
638 %{perl_vendorarch}/Amanda/XferServer.pm
639 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
640 %dir %{perl_vendorarch}/auto/Amanda/Device
641 %dir %{perl_vendorarch}/auto/Amanda/Disklist
642 %dir %{perl_vendorarch}/auto/Amanda/Logfile
643 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
644 %dir %{perl_vendorarch}/auto/Amanda/XferServer
645 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
646 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
647 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
648 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
649 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
650 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
651 %endif
652
653 %if %{with client}
654 %files client
655 %defattr(644,root,root,755)
656 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
657 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
658 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
659 # Commented out so it won't get removed on uninstall
660 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
661 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
662
663 %dir %{_libdir}/amanda/application
664 %attr(4750,root,amanda) %{_libdir}/amanda/application/ambsdtar
665 %attr(4750,root,amanda) %{_libdir}/amanda/application/amgtar
666 %attr(755,root,root) %{_libdir}/amanda/application/amlog-script
667 %attr(755,root,root) %{_libdir}/amanda/application/amlvm-snapshot
668 %attr(755,root,root) %{_libdir}/amanda/application/ampgsql
669 %attr(755,root,root) %{_libdir}/amanda/application/amraw
670 %attr(755,root,root) %{_libdir}/amanda/application/amsamba
671 %attr(4750,root,amanda) %{_libdir}/amanda/application/amstar
672 %attr(755,root,root) %{_libdir}/amanda/application/amsuntar
673 %attr(755,root,root) %{_libdir}/amanda/application/amzfs*
674 %attr(755,root,root) %{_libdir}/amanda/application/script-email
675
676 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
677 %attr(755,root,root) %{_libdir}/amanda/amandad
678 %attr(755,root,root) %{_libdir}/amanda/noop
679 %attr(755,root,root) %{_libdir}/amanda/patch-system
680 %attr(755,root,root) %{_libdir}/amanda/sendbackup
681 %attr(755,root,root) %{_libdir}/amanda/sendsize
682 %attr(755,root,root) %{_libdir}/amanda/teecount
683 %attr(4750,root,amanda) %{_libdir}/amanda/calcsize
684 %attr(4750,root,amanda) %{_libdir}/amanda/killpgrp
685 %attr(4750,root,amanda) %{_libdir}/amanda/rundump
686 %attr(4750,root,amanda) %{_libdir}/amanda/runtar
687 %attr(755,root,root) %{_libdir}/amanda/selfcheck
688 %attr(755,root,root) %{_sbindir}/amdump_client
689 %attr(755,root,root) %{_sbindir}/amoldrecover
690 %attr(755,root,root) %{_sbindir}/amrecover
691 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
692 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
693 %{_mandir}/man7/amanda-applications.7*
694 %{_mandir}/man5/amanda-client.conf.5*
695 %{_mandir}/man8/amdump_client.8*
696 %{_mandir}/man8/ambsdtar.8*
697 %{_mandir}/man8/amgtar.8*
698 %{_mandir}/man8/ampgsql.8*
699 %{_mandir}/man8/amrecover.8*
700 %{_mandir}/man8/amraw.8*
701 %{_mandir}/man8/amsamba.8*
702 %{_mandir}/man8/amstar.8*
703 %{_mandir}/man8/amsuntar.8*
704 %{_mandir}/man8/amzfs*.8*
705
706 %{perl_vendorarch}/Amanda/Application.pm
707 %dir %{perl_vendorarch}/Amanda/Application
708 %{perl_vendorarch}/Amanda/Application/Zfs.pm
709 %dir %{perl_vendorarch}/auto/Amanda/Application
710 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
711 %endif
This page took 0.065221 seconds and 3 git commands to generate.