]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- add build by default tool for generate tape description for unknown tape type.
[packages/amanda.git] / amanda.spec
1 Summary:        A network-capable tape backup solution
2 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
3 Name:           amanda
4 Version:        2.4.2p2
5 Release:        1
6 License:        BSD
7 Group:          Networking/Utilities
8 Group(de):      Netzwerkwesen/Werkzeuge
9 Group(pl):      Sieciowe/Narzêdzia
10 Source0:        ftp://ftp.amanda.org/pub/amanda/%{name}-%{version}.tar.gz
11 Source1:        %{name}-srv.crontab
12 Source2:        %{name}.inetd
13 Source3:        %{name}idx.inetd
14 Source4:        amidxtape.inetd
15 Source5:        %{name}.conf
16 Patch0:         %{name}-no_libnsl.patch
17 Patch1:         %{name}-am_fixes.patch
18 Patch2:         %{name}-bug18322.patch
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  flex
22 BuildRequires:  dump
23 BuildRequires:  gnuplot
24 BuildRequires:  tar
25 BuildRequires:  cpio
26 BuildRequires:  readline-devel >= 4.2
27 Prereq:         /sbin/ldconfig
28 URL:            http://www.amanda.org/
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _sysconfdir     /etc
32 %define         _localstatedir  /var
33 %define         _libexecdir     %{_libdir}/amanda
34
35 %description 
36 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
37 backup system that allows the administrator of a LAN to set up a
38 single master backup server to back up multiple hosts to a single
39 large capacity tape drive. AMANDA uses native dump and/or GNU tar
40 facilities and can back up a large number of workstations running
41 multiple versions of Unix. Newer versions of AMANDA (including this
42 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
43 The amanda package contains the core AMANDA programs and will need to
44 be installed on both AMANDA clients and AMANDA servers. Note that you
45 will have to install the amanda-client and amanda-server packages as
46 well.
47
48 %description -l pl
49 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
50 zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
51 hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
52 Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
53 Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
54 podstawowe pliki programu i powinien byæ zainstalowany zarówno na
55 serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
56 amanda-client i amanda-server!
57
58 %package libs
59 Summary:        Amanda shared libraries
60 Summary(pl):    Biblioteki wspó³dzielone pakietu amanda
61 Group:          Networking/Utilities
62 Group(de):      Netzwerkwesen/Werkzeuge
63 Group(pl):      Sieciowe/Narzêdzia
64
65 %description libs
66 Amanda shared libraries.
67
68 %description -l pl libs
69 Biblioteki wspó³dzielone pakietu amanda.
70
71 %package client
72 Summary:        The client side of Amanda
73 Summary(pl):    Klient Amandy
74 Group:          Networking/Utilities
75 Group(de):      Netzwerkwesen/Werkzeuge
76 Group(pl):      Sieciowe/Narzêdzia
77 Prereq:         /sbin/ldconfig
78 Prereq:         %{name}-libs = %{version}
79
80 %description client
81 The Amanda-client package should be installed on any machine that will
82 be backed up by AMANDA (including the server if it also needs to be
83 backed up). You will also need to install the amanda package to each
84 AMANDA client.
85
86 %description -l pl client
87 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
88 zawarto¶ci bêd± tworzone kopie zapasowe.
89
90 %package server
91 Summary:        The server side of Amanda
92 Summary(pl):    Serwer Amandy
93 Group:          Networking/Utilities
94 Group(de):      Netzwerkwesen/Werkzeuge
95 Group(pl):      Sieciowe/Narzêdzia
96 Prereq:         rc-inetd
97 Prereq:         /sbin/ldconfig
98 Requires:       gnuplot
99 Requires:       tar
100 Requires:       cpio
101 Requires:       dump
102 Requires:       crondaemon
103 Requires:       /etc/cron.d
104 Prereq:         %{name}-libs = %{version}
105
106 %description server
107 The amanda-server package should be installed on the AMANDA server,
108 the machine attached to the device (such as a tape drive) where
109 backups will be written. You will also need to install the amanda
110 package to the AMANDA server. And, if the server is also to be backed
111 up, the server also needs to have the amanda-client package installed.
112
113 %description -l pl server
114 Ten pakiet powinien byæ zainstalowanych na maszynach, na których bêd±
115 magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
116 typu streamer).
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p1
123
124 %build
125 aclocal
126 autoconf
127 touch COPYING
128 automake -a -c
129 %configure \
130         --disable-static \
131         --enable-shared \
132         --with-index-server=localhost \
133         --with-user=amanda \
134         --with-group=amanda \
135         --with-tape-device=/dev/null \
136         --with-ftape-rawdevice=/dev/null \
137         --with-changer-device=/dev/null \
138         --with-fqdn \
139         --with-smbclient=%{_bindir}/smbclient \
140         --with-bsd-security \
141         --with-buffered-dump \
142         --with-amandahosts \
143         --with-debugging=%{_localstatedir}/lib/amanda/debug
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
150         $RPM_BUILD_ROOT%{_localstatedir}/lib/amanda
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT \
154         SETUID_GROUP=`id -g`
155
156 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
157 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
158 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
159 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
160
161 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/amanda
162 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/lib/amanda
163
164 gzip -9nf docs/*
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %pre libs
170 /usr/sbin/groupadd -g 80 -r -f amanda
171 /usr/sbin/useradd -u 80 -r -d /var/lib/amanda -s /bin/false -c "Amanda Backup user" -g amanda amanda
172
173 %post   libs -p /sbin/ldconfig
174
175 %preun libs
176 /sbin/ldconfig
177 if [ "$1" = "0" ]; then
178         /usr/sbin/groupdel amanda
179         /usr/sbin/userdel amanda
180 fi
181
182 %post client
183 /sbin/ldconfig
184 if [ -f /var/lock/subsys/rc-inetd ]; then
185         /etc/rc.d/init.d/rc-inetd restart 1>&2
186 else
187         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
188 fi
189
190 %postun client
191 /sbin/ldconfig
192 if [ -f /var/lock/subsys/rc-inetd ]; then
193         /etc/rc.d/init.d/rc-inetd restart
194 fi
195
196 %post server
197 /sbin/ldconfig
198 if [ -f /var/lock/subsys/rc-inetd ]; then
199         /etc/rc.d/init.d/rc-inetd restart 1>&2
200 else
201         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
202 fi
203
204 %postun server
205 /sbin/ldconfig
206 if [ -f /var/lock/subsys/rc-inetd ]; then
207         /etc/rc.d/init.d/rc-inetd restart
208 fi
209
210 %files libs
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/libamanda*.so
213 %attr(755,root,root) %{_libdir}/libamtape*.so
214 %attr(770,root,amanda) %dir %{_libexecdir}
215
216 %files server
217 %defattr(644,root,root,755)
218 %doc docs/*.gz
219 %config(noreplace) /etc/sysconfig/rc-inetd/amidxtape
220 %config(noreplace) /etc/sysconfig/rc-inetd/amandaidx
221
222 %dir %{_sysconfdir}/amanda
223 %attr(640,root,amanda) %{_sysconfdir}/amanda/*
224
225 %attr(660,root,amanda) %dir %{_localstatedir}/lib/amanda
226 %{_localstatedir}/lib/amanda/*
227
228 %attr(640,root,root) /etc/cron.d/amanda-srv
229
230 %attr(755,root,root) %{_libdir}/libamserver*.so
231 %attr(755,root,root) %{_libexecdir}/amindexd
232 %attr(755,root,root) %{_libexecdir}/amtrmidx
233 %attr(755,root,root) %{_libexecdir}/driver
234 %attr(4754,root,amanda) %{_libexecdir}/dumper
235 %attr(4754,root,amanda) %{_libexecdir}/planner
236 %attr(755,root,root) %{_libexecdir}/amcat.awk
237 %attr(755,root,root) %{_libexecdir}/amcleanupdisk
238 %attr(755,root,root) %{_libexecdir}/amidxtaped
239 %attr(755,root,root) %{_libexecdir}/amlogroll
240 %attr(755,root,root) %{_libexecdir}/amplot.awk
241 %attr(755,root,root) %{_libexecdir}/amplot.g
242 %attr(755,root,root) %{_libexecdir}/amplot.gp
243 %attr(755,root,root) %{_libexecdir}/amtrmlog
244 %attr(755,root,root) %{_libexecdir}/chg-chio
245 %attr(755,root,root) %{_libexecdir}/chg-chs
246 %attr(755,root,root) %{_libexecdir}/chg-manual
247 %attr(755,root,root) %{_libexecdir}/chg-mtx
248 %attr(755,root,root) %{_libexecdir}/chg-multi
249 %attr(755,root,root) %{_libexecdir}/chg-rth
250 %attr(755,root,root) %{_libexecdir}/chg-scsi
251 %attr(755,root,root) %{_libexecdir}/chg-zd-mtx
252 %attr(755,root,root) %{_libexecdir}/selfcheck
253 %attr(755,root,root) %{_libexecdir}/taper
254 %attr(755,root,root) %{_sbindir}/amadmin
255 %attr(4754,root,amanda) %{_sbindir}/amcheck
256 %attr(755,root,root) %{_sbindir}/amcheckdb
257 %attr(755,root,root) %{_sbindir}/amcleanup
258 %attr(755,root,root) %{_sbindir}/amdump
259 %attr(755,root,root) %{_sbindir}/amflush
260 %attr(755,root,root) %{_sbindir}/amgetconf
261 %attr(755,root,root) %{_sbindir}/amlabel
262 %attr(755,root,root) %{_sbindir}/amoverview
263 %attr(755,root,root) %{_sbindir}/amplot
264 %attr(755,root,root) %{_sbindir}/amrmtape
265 %attr(755,root,root) %{_sbindir}/amreport
266 %attr(755,root,root) %{_sbindir}/amstatus
267 %attr(755,root,root) %{_sbindir}/amtape
268 %attr(755,root,root) %{_sbindir}/amtoc
269 %attr(755,root,root) %{_sbindir}/amverify
270 %{_mandir}/man8/amadmin.8*
271 %{_mandir}/man8/amrmtape.8*
272 %{_mandir}/man8/amtape.8*
273 %{_mandir}/man8/amtoc.8*
274 %{_mandir}/man8/amanda.8*
275 %{_mandir}/man8/amcheck.8*
276 %{_mandir}/man8/amcleanup.8*
277 %{_mandir}/man8/amdump.8*
278 %{_mandir}/man8/amflush.8*
279 %{_mandir}/man8/amlabel.8*
280 %{_mandir}/man8/amplot.8*
281 %{_mandir}/man8/amreport.8*
282 %{_mandir}/man8/amstatus.8*
283
284 %files client
285 %defattr(644,root,root,755)
286 %config(noreplace) /etc/sysconfig/rc-inetd/amanda
287
288 %attr(755,root,root) %{_libdir}/libamclient*.so
289 %attr(755,root,root) %{_libexecdir}/versionsuffix
290 %attr(755,root,root) %{_libexecdir}/amandad
291 %attr(4754,root,amanda) %{_libexecdir}/calcsize
292 %attr(4754,root,amanda) %{_libexecdir}/rundump
293 %attr(4754,root,amanda) %{_libexecdir}/runtar
294 %attr(4754,root,amanda) %{_libexecdir}/selfcheck
295 %attr(755,root,root) %{_libexecdir}/sendbackup
296 %attr(755,root,root) %{_libexecdir}/sendsize
297 %attr(755,root,root) %{_libexecdir}/patch-system
298 %attr(4754,root,amanda) %{_libexecdir}/killpgrp
299 %attr(755,root,root) %{_sbindir}/amrecover
300 %attr(755,root,root) %{_sbindir}/amrestore
301 %{_mandir}/man8/amrecover.8*
302 %{_mandir}/man8/amrestore.8*
This page took 0.313325 seconds and 3 git commands to generate.