]> git.pld-linux.org Git - packages/afflib.git/blob - afflib.spec
- updated to 3.7.19, PLDified more
[packages/afflib.git] / afflib.spec
1 # TODO:
2 # - build against system lzma if possible
3 # - some bundled qemu source?
4 #
5 # Conditional build:
6 %bcond_without  fuse            # FUSE support
7 %bcond_without  python          # Python support
8 %bcond_with     system_lzma     # building against system lzma instead of local copy
9 %bcond_without  static_libs     # static library
10 %bcond_without  s3              # Amazon S3 support
11 %bcond_without  qemu            # QEMU support
12 #
13 Summary:        Library to support the Advanced Forensic Format
14 Summary(pl.UTF-8):      Biblioteka do obsługi firmatu plików AFF (Advanced Forensic Format)
15 Name:           afflib
16 Version:        3.7.19
17 Release:        1
18 License:        BSD with advertising
19 Group:          Libraries
20 #Source0Download: https://github.com/sshock/AFFLIBv3/releases/
21 Source0:        https://github.com/sshock/AFFLIBv3/archive/v%{version}/AFFLIBv3-%{version}.tar.gz
22 # Source0-md5:  83b2b89e23090930905547e7e47f9e09
23 Patch0:         Sanity-check-size-passed-to-malloc.patch
24 Patch1:         %{name}-x32-x64.patch
25 URL:            https://github.com/sshock/AFFLIBv3
26 BuildRequires:  autoconf >= 2.50
27 BuildRequires:  automake
28 %if %{with s3}
29 BuildRequires:  curl-devel
30 BuildRequires:  expat-devel >= 1.95
31 %endif
32 BuildRequires:  intltool
33 %if %{with fuse}
34 BuildRequires:  libfuse3-devel
35 %endif
36 BuildRequires:  libmd-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool
39 %if %{with system_lzma}
40 BuildRequires:  lzma-devel
41 %endif
42 BuildRequires:  ncurses-devel
43 BuildRequires:  openssl-devel
44 %{?with_python:BuildRequires:   python-devel >= 2}
45 BuildRequires:  readline-devel
46 BuildRequires:  rpmbuild(macros) >= 1.527
47 BuildRequires:  zlib-devel
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 AFF(R) is an open and extensible file format designed to store disk
52 images and associated metadata. afflib is library for support of the
53 Advanced Forensic Format (AFF).
54
55 %description -l pl.UTF-8
56 AFF(R) to otwarty i rozszerzalny format pliku zaprojektowany do zapisu
57 obrazów dysków i powiązanych metadanych. afflib to biblioteka do
58 obsługi formatu AFF (Advanced Forensic Format).
59
60 %package -n afftools
61 Summary:        Utilities for AFFLIB library
62 Summary(pl.UTF-8):      Narzędzia do biblioteki AFFLIB
63 Group:          Applications/File
64 Requires:       %{name} = %{version}-%{release}
65
66 %description -n afftools
67 This package contains utilities for using AFFLIB library.
68
69 %description -n afftools -l pl.UTF-8
70 Ten pakiet zawiera narzędzia korzystające z biblioteki AFFLIB.
71
72 %package devel
73 Summary:        Development files for AFFLIB
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AFFLIB
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       libmd-devel
78 Requires:       openssl-devel
79
80 %description devel
81 This package contains the header files for developing applications
82 that use AFFLIB library.
83
84 %description devel -l pl.UTF-8
85 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
86 wykorzystujących bibliotekę AFFLIB.
87
88 %package static
89 Summary:        Static AFFLIB library
90 Summary(pl.UTF-8):      Statyczna biblioteka AFFLIB
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Static AFFLIB library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka AFFLIB.
99
100 %package python
101 Summary:        Python bindings for AFFLIB
102 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki AFFLIB
103 Group:          Libraries/Python
104 Requires:       %{name} = %{version}-%{release}
105
106 %description python
107 These bindings currently support a read-only file-like interface to
108 AFFLIB and basic metadata accessor functions. The binding is not
109 currently complete.
110
111 %description python -l pl.UTF-8
112 Te wiązania obecnie obsługują zbliżony do plików interfejs tylko do
113 odczytu do biblioteki AFFLIB oraz podstawowe funkcje dostępu do
114 metadanych. Wiązania nie są jeszcze kompletne.
115
116 %prep:
117 %setup -q -n AFFLIBv3-%{version}
118 %patch0 -p1
119 %patch1 -p1
120
121 %if %{with system_lzma}
122         # prevent internal lzma to be built - testing
123         #rm -rf lzma443
124 %else
125         #fix spurious permissions with lzma443
126         find lzma443 -type f -exec chmod 0644 {} ';'
127 %endif
128
129 %build
130 %{__libtoolize}
131 %{__aclocal} -I m4
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         %{__enable_disable fuse} \
137         %{__enable_disable python} \
138         %{__enable_disable s3} \
139         %{__enable_disable qemu}
140
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
150
151 %if %{with python}
152 %py_postclean
153 %endif
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS BUGLIST.txt COPYING ChangeLog NEWS README doc/announce_2.2.txt
164 %attr(755,root,root) %{_libdir}/libafflib.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libafflib.so.0
166
167 %files -n afftools
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/aff*
170 %{_mandir}/man1/aff*.1.*
171
172 %files devel
173 %defattr(644,root,root,755)
174 %doc doc/crypto_design.txt doc/crypto_doc.txt
175 %attr(755,root,root) %{_libdir}/libafflib.so
176 %{_includedir}/afflib
177 %{_pkgconfigdir}/afflib.pc
178
179 %if %{with static_libs}
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libafflib.a
183 %endif
184
185 %if %{with python}
186 %files python
187 %defattr(644,root,root,755)
188 %doc pyaff/README
189 %attr(755,root,root) %{py_sitedir}/pyaff.so
190 %{py_sitedir}/PyAFF-0.1-py*.egg-info
191 %endif
This page took 0.100888 seconds and 3 git commands to generate.