]> git.pld-linux.org Git - packages/aegisub.git/blob - aegisub.spec
revert accidental change in previous commit
[packages/aegisub.git] / aegisub.spec
1 # TODO
2 # - make 4.3 breaks build
3 # - unvendor vendor/luabins
4 # - unvendor vendor/luajit
5 # - unvendor vendor/universalchardet
6 # - our cxxflags
7
8 # Conditional build:
9 %bcond_without  ffms2   # build ffms2 A/V provider
10
11 Summary:        Subtitle editor
12 Summary(pl.UTF-8):      Edytor napisów
13 Name:           aegisub
14 Version:        3.2.2
15 Release:        14
16 License:        BSD
17 Group:          X11/Applications
18 Source0:        http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
19 # Source0-md5:  d80e852c34811add358c06d77f5cd40d
20 Patch0:         pthread.patch
21 Patch1:         %{name}-icu.patch
22 Patch2:         %{name}-icu64.patch
23 Patch3:         %{name}-boost-1.70.patch
24 Patch4:         cflags.patch
25 URL:            http://www.aegisub.org/
26 # AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
27 #BuildRequires: OpenAL-devel >= 0.0.8
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  autoconf >= 2.57
31 BuildRequires:  automake
32 BuildRequires:  boost-devel >= 1.50.0
33 %{?with_ffms2:BuildRequires:    ffms2-devel >= 2.16}
34 BuildRequires:  fftw3-devel >= 3.3
35 BuildRequires:  fontconfig-devel >= 1:2.4
36 # pkgconfig(freetype2) >= 9.7.0
37 BuildRequires:  freetype-devel >= 1:2.1.9
38 BuildRequires:  gettext-tools
39 BuildRequires:  hunspell-devel >= 1.2.0
40 BuildRequires:  intltool
41 BuildRequires:  libass-devel >= 0.9.7
42 BuildRequires:  libicu-devel >= 4.8.1.1
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  lua51-devel
45 BuildRequires:  pkgconfig >= 1:0.20
46 BuildRequires:  portaudio-devel >= 19
47 BuildRequires:  pulseaudio-devel >= 0.5
48 BuildRequires:  tar >= 1:1.22
49 BuildRequires:  wxGTK2-unicode-gl-devel >= 3.0.0
50 BuildRequires:  wxWidgets-devel >= 3.0.0
51 BuildRequires:  xz
52 BuildRequires:  zlib-devel
53 Requires(post,postun):  desktop-file-utils
54 Requires(post,postun):  gtk-update-icon-cache
55 Requires:       ffms2 >= 2.16
56 Requires:       fftw3 >= 3.3
57 Requires:       fontconfig-libs >= 1:2.4
58 Requires:       freetype >= 1:2.1.9
59 Requires:       hunspell >= 1.2.0
60 Requires:       libass >= 0.9.7
61 Requires:       libicu >= 4.8.1.1
62 Requires:       pulseaudio-libs >= 0.5
63 # due to luajit usage
64 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
65 # missing atomic_ops
66 ExcludeArch:    i386 i486
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Aegisub is an advanced subtitle editor for Windows, and UNIX-like
71 systems, such as Linux, Mac OS X and BSD. It is open source software
72 and free for any use.
73
74 Aegisub natively works with the Advanced SubStation Alpha format
75 (aptly abbreviated ASS) which allows for many advanced effects in the
76 subtitles, apart from just basic timed text. Aegisubs goal is to
77 support using these advanced functions with ease.
78
79 %description -l pl.UTF-8
80 Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
81 uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
82 otwartych źródłach, darmowy do dowolnego użytku.
83
84 Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
85 stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
86 napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
87 obsługa tych zaawansowanych funkcji.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 %patch3 -p1
95 %patch4 -p1
96
97 %{__mv} vendor{,.keep}
98 mkdir vendor
99 %{__mv} vendor.keep/{luabins,luajit,universalchardet} vendor
100
101 %build
102 %{__aclocal} -I m4macros
103 %{__autoconf}
104 %{__autoheader}
105 %configure \
106         --disable-update-checker \
107         %{__with_without ffms2} \
108         --without-oss \
109         --with-player-audio=PulseAudio \
110         --with-wx-config=wx-gtk2-unicode-config
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 ln -s %{name}-3.2 $RPM_BUILD_ROOT%{_bindir}/%{name}
120
121 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
122 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
123 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
124 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
125 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
126
127 %find_lang %{name}-32
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 %update_desktop_database
134 %update_icon_cache hicolor
135
136 %postun
137 %update_desktop_database
138 %update_icon_cache hicolor
139
140 %files -f %{name}-32.lang
141 %defattr(644,root,root,755)
142 %doc LICENCE README.md
143 %attr(755,root,root) %{_bindir}/%{name}
144 %attr(755,root,root) %{_bindir}/%{name}-3.2
145 %{_datadir}/%{name}
146 %{_desktopdir}/%{name}.desktop
147 %{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.037616 seconds and 3 git commands to generate.