]> git.pld-linux.org Git - packages/acpid.git/blob - acpid.spec
- many small fixes, mostly inpired by kloczek
[packages/acpid.git] / acpid.spec
1 Summary:        ACPI Event Daemon
2 Summary(pl):    Demon zdarzeñ ACPI
3 Name:           acpid
4 Version:        1.0.2
5 Release:        1
6 License:        GPL
7 Group:          Daemons
8 # Source0-md5:  15884aaf0b82717954f9366b5c00808b
9 Source0:        http://dl.sourceforge.net/acpid/%{name}-%{version}.tar.gz
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 URL:            http://acpid.sourceforge.net/
14 PreReq:         rc-scripts
15 Requires(post,preun):   /sbin/chkconfig
16 Obsoletes:      apmd
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 acpid is a daemon that dispatches ACPI events to user-space programs.
21
22 %description -l pl
23 acpid to demon przekazuj±cy zdarzenia ACPI do programów w user-space.
24
25 %prep
26 %setup -q
27
28 %build
29 %{__make}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{logrotate.d,rc.d/init.d,sysconfig},/var/log} \
34         $RPM_BUILD_ROOT{%{_sysconfdir}/acpi/{events,actions},%{_sbindir},%{_mandir}/man8}
35
36 install acpid $RPM_BUILD_ROOT%{_sbindir}
37 install acpid.8 $RPM_BUILD_ROOT%{_mandir}/man8
38 install samples/sample.conf $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events
39 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/acpid
40 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/acpid
41 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/acpid
42 install samples/acpi_handler.sh $RPM_BUILD_ROOT%{_sbindir}/power.sh
43
44 > $RPM_BUILD_ROOT/var/log/acpid
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 /sbin/chkconfig --add acpid
51 if [ -f /var/lock/subsys/acpid ]; then
52         /etc/rc.d/init.d/acpid restart >&2
53 else
54         echo "Run \"/etc/rc.d/init.d/acpid start\" to start ACPI daemon."
55 fi
56
57 %preun
58 if [ "$1" = "0" ]; then
59         if [ -f /var/lock/subsys/acpid ]; then
60                 /etc/rc.d/init.d/acpid stop>&2
61         fi
62         /sbin/chkconfig --del acpid
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changelog README
68 %dir %{_sysconfdir}/acpi
69 %dir %{_sysconfdir}/acpi/events
70 %dir %{_sysconfdir}/acpi/actions
71 %attr(640,root,root) /etc/logrotate.d/acpid
72 %attr(754,root,root) /etc/rc.d/init.d/acpid
73 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/acpid
74 %config(noreplace,missingok) %verify(not size mtime md5) %{_sysconfdir}/acpi/events/sample.conf
75 %attr(755,root,root) %{_sbindir}/acpid
76 %attr(755,root,root) %{_sbindir}/power.sh
77 %attr(640,root,root) %ghost /var/log/acpid
78 %{_mandir}/man8/acpid.8*
This page took 0.030232 seconds and 4 git commands to generate.