]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
Requires python-pyinotify
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - handle obsolete packages: abrt-plugin-{catcut,rhfastcheck,rhticket,ticketuploader}
4 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
5 %define         libreport_ver   2.1.9
6 Summary:        Automatic bug detection and reporting tool
7 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
8 Name:           abrt
9 Version:        2.1.9
10 Release:        1
11 License:        GPL v2+
12 Group:          Applications/System
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  b70b03cfb9f496152949ebf92abe6479
15 Source1:        %{name}.init
16 Patch0:         %{name}-rpm5.patch
17 Patch1:         %{name}-rpm45.patch
18 Patch2:         format_security.patch
19 Patch3:         %{name}-link.patch
20 Patch4:         %{name}-pythondir.patch
21 URL:            https://fedorahosted.org/abrt/
22 BuildRequires:  asciidoc
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  dbus-devel
26 BuildRequires:  gettext-devel >= 0.17
27 BuildRequires:  glib2-devel >= 1:2.21
28 BuildRequires:  gtk+3-devel >= 3.0
29 BuildRequires:  intltool >= 0.35.0
30 BuildRequires:  json-c-devel
31 BuildRequires:  libmagic-devel
32 BuildRequires:  libnotify-devel
33 BuildRequires:  libreport-devel >= %{libreport_ver}
34 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
35 BuildRequires:  libreport-web-devel >= %{libreport_ver}
36 BuildRequires:  libtool
37 BuildRequires:  libxml2-devel >= 2
38 BuildRequires:  nss-devel
39 BuildRequires:  pkgconfig
40 BuildRequires:  polkit-devel
41 BuildRequires:  python-devel
42 BuildRequires:  python-modules
43 BuildRequires:  rpm-devel >= 4.5
44 BuildRequires:  rpm-devel >= 4.5-28
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  rpmbuild(macros) >= 1.219
47 BuildRequires:  satyr-devel
48 BuildRequires:  xmlto
49 Requires(postun):       /usr/sbin/groupdel
50 Requires(postun):       /usr/sbin/userdel
51 Requires(pre):  /bin/id
52 Requires(pre):  /usr/bin/getgid
53 Requires(pre):  /usr/sbin/groupadd
54 Requires(pre):  /usr/sbin/useradd
55 Requires:       %{name}-libs = %{version}-%{release}
56 Requires:       python-pyinotify
57 Provides:       group(abrt)
58 Provides:       user(abrt)
59 Obsoletes:      abrt-plugin-filetransfer
60 Obsoletes:      abrt-plugin-runapp
61 Obsoletes:      abrt-plugin-sosreport
62 Obsoletes:      abrt-plugin-sqlite3
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 ABRT is a tool to help users to detect defects in applications and to
67 create a bug report with all informations needed by maintainer to fix
68 it. It uses plugin system to extend its functionality.
69
70 %description -l pl.UTF-8
71 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
72 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
73 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
74 system wtyczek do rozszerzania funkcjonalności.
75
76 %package libs
77 Summary:        ABRT shared library
78 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
79 Group:          Libraries
80 Requires:       glib2 >= 1:2.21
81 Requires:       libreport >= %{libreport_ver}
82
83 %description libs
84 ABRT shared library.
85
86 %description libs -l pl.UTF-8
87 Biblioteka współdzielona ABRT.
88
89 %package devel
90 Summary:        Header files for ABRT livrary
91 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
92 Group:          Development/Libraries
93 Requires:       %{name}-libs = %{version}-%{release}
94 Requires:       glib2-devel >= 1:2.21
95 Requires:       libreport-devel >= %{libreport_ver}
96
97 %description devel
98 Header files for ABRT livrary.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe biblioteki ABRT.
102
103 %package addon-ccpp
104 Summary:        ABRT's C/C++ addon
105 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       %{name}-retrace-client = %{version}-%{release}
109 Requires:       cpio
110 Requires:       elfutils
111 Requires:       gdb >= 7.0-3
112 Requires:       satyr
113 Requires:       yum-utils
114
115 %description addon-ccpp
116 This package contains hook for C/C++ crashed programs and abrt's C/C++
117 analyzer plugin.
118
119 %description addon-ccpp -l pl.UTF-8
120 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
121 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
122
123 %package addon-kerneloops
124 Summary:        ABRT's kerneloops addon
125 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
126 Group:          Libraries
127 Requires:       %{name} = %{version}-%{release}
128 Requires:       curl
129 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
130 Obsoletes:      abrt-plugin-kerneloops
131 Obsoletes:      abrt-plugin-kerneloopsreporter
132 Obsoletes:      kerneloops
133
134 %description addon-kerneloops
135 This package contains plugin for collecting kernel crash information
136 from system log.
137
138 %description addon-kerneloops -l pl.UTF-8
139 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
140 logu systemowego.
141
142 %package addon-pstoreoops
143 Summary:        ABRT's pstoreoops addon
144 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
145 Group:          Libraries
146 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
147 Obsoletes:      abrt-addon-uefioops
148
149 %description addon-pstoreoops
150 This package contains plugin for collecting kernel oopses from pstore
151 storage.
152
153 %description addon-pstoreoops -l pl.UTF-8
154 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
155
156 %package addon-python
157 Summary:        ABRT's addon for catching and analyzing Python exceptions
158 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona
159 Group:          Libraries
160 Requires:       %{name} = %{version}-%{release}
161 Obsoletes:      gnome-python2-bugbuddy
162
163 %description addon-python
164 This package contains Python hook and Python analyzer plugin for
165 handling uncaught exception in Python programs.
166
167 %description addon-python -l pl.UTF-8
168 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
169 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
170 Pythonie.
171
172 %package addon-upload-watch
173 Summary:        ABRT's upload addon
174 Summary(pl.UTF-8):      Dodatek upload do ABRT
175 Group:          Libraries
176 Requires:       %{name} = %{version}-%{release}
177
178 %description addon-upload-watch
179 This package contains hook for uploaded problems.
180
181 %description addon-upload-watch -l pl.UTF-8
182 Ten pakiet zawiera uchwyt dla problemów przysłanych.
183
184 %package addon-vmcore
185 Summary:        ABRT's vmcore addon
186 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
187 Group:          Libraries
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
190 # not available in PLD
191 #Requires:      crash
192
193 %description addon-vmcore
194 This package contains plugin for collecting kernel crash information
195 from vmcore files.
196
197 %description addon-vmcore -l pl.UTF-8
198 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
199 plików vmcore.
200
201 %package addon-xorg
202 Summary:        ABRT's Xorg addon
203 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
204 Group:          Libraries
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       curl
207
208 %description addon-xorg
209 This package contains plugin for collecting Xorg crash information
210 from Xorg log.
211
212 %description addon-xorg -l pl.UTF-8
213 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
214 logu Xorg.
215
216 %package plugin-bodhi
217 Summary:        ABRT's bodhi plugin
218 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
219 Group:          Libraries
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       libreport-web >= %{libreport_ver}
222 Obsoletes:      libreport-plugin-bodhi
223
224 %description plugin-bodhi
225 Plugin to search for a new updates in bodhi server.
226
227 %description plugin-bodhi -l pl.UTF-8
228 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
229
230 %package retrace-client
231 Summary:        ABRT's retrace client
232 Summary(pl.UTF-8):      Klient Retrace dla ABRT
233 Group:          Libraries
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       xz
236
237 %description retrace-client
238 This package contains the client application for Retrace server which
239 is able to analyze C/C++ crashes remotely.
240
241 %description retrace-client -l pl.UTF-8
242 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
243 potrafi zdalnie przeanalizować awarię programu w C/C++.
244
245 %package dbus
246 Summary:        ABRT DBus service
247 Summary(pl.UTF-8):      Usługa DBus ABRT
248 Group:          Applications/System
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       libreport >= %{libreport_ver}
251
252 %description dbus
253 ABRT DBus service which provides org.freedesktop.problems API on DBus
254 and uses PolicyKit to authorize to access the problem data.
255
256 %description dbus -l pl.UTF-8
257 Usługa DBus ABRT, udostępniająca poprzez DBus API
258 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
259 do danych o problemach.
260
261 %package python
262 Summary:        ABRT Python API
263 Summary(pl.UTF-8):      API Pythona do ABRT
264 Group:          Libraries/Python
265 Requires:       %{name} = %{version}-%{release}
266
267 %description python
268 High-level API for querying, creating and manipulating problems
269 handled by ABRT in Python.
270
271 %description python -l pl.UTF-8
272 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
273 Pythona problemów obsługiwanych przez ABRT.
274
275 %package cli
276 Summary:        ABRT's command line interface
277 Summary(pl.UTF-8):      Interfejs linii poleceń ABRT
278 Group:          Applications/System
279 Requires:       %{name} = %{version}-%{release}
280 # analyzers
281 Requires:       %{name}-addon-ccpp = %{version}-%{release}
282 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
283 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
284 Requires:       %{name}-addon-python = %{version}-%{release}
285 # reporters
286 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
287 Requires:       libreport-plugin-logger >= %{libreport_ver}
288
289 %description cli
290 This package contains simple command line client for controling ABRT
291 daemon over the sockets.
292
293 %description cli -l pl.UTF-8
294 Ten pakiet zawiera prostego klienta obsługiwanego z linii poleceń,
295 pozwalającego na sterowanie demonem poprzez gniazda.
296
297 %package gui
298 Summary:        ABRT's GUI
299 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
300 Group:          X11/Applications
301 Requires(post,postun):  /sbin/ldconfig
302 Requires(post,postun):  gtk-update-icon-cache
303 Requires(post,postun):  hicolor-icon-theme
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       %{name}-dbus = %{version}-%{release}
306 Requires:       %{name}-gui-libs = %{version}-%{release}
307 Suggests:       gnome-abrt
308 Provides:       abrt-applet = %{version}-%{release}
309 Obsoletes:      abrt-applet < 0.0.5
310 Conflicts:      abrt-applet < 0.0.5
311
312 %description gui
313 GTK+ wizard for convenient bug reporting.
314
315 %description gui -l pl.UTF-8
316 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
317
318 %package gui-libs
319 Summary:        ABRT's GUI library
320 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
321 Group:          X11/Libraries
322 Requires:       %{name}-libs = %{version}-%{release}
323 Requires:       gtk+3 >= 3.0
324
325 %description gui-libs
326 ABRT's GUI library.
327
328 %description gui-libs -l pl.UTF-8
329 Biblioteka graficznego interfejsu użytkownika ABRT.
330
331 %package gui-devel
332 Summary:        Header files for ABRT GUI library
333 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
334 Group:          X11/Development/Libraries
335 Requires:       %{name}-devel = %{version}-%{release}
336 Requires:       %{name}-gui-libs = %{version}-%{release}
337 Requires:       gtk+3-devel >= 3.0
338
339 %description gui-devel
340 Header files for ABRT GUI library.
341
342 %description gui-devel -l pl.UTF-8
343 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
344
345 %package desktop
346 Summary:        Virtual package to install all necessary packages for usage from desktop environment
347 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
348 Group:          X11/Applications
349 # This package should be installed when anything requests bug-buddy;
350 # installing abrt-desktop should result in the abrt which works without
351 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
352 Requires:       %{name} = %{version}-%{release}
353 Requires:       %{name}-addon-ccpp = %{version}-%{release}
354 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
355 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
356 Requires:       %{name}-addon-python = %{version}-%{release}
357 Requires:       %{name}-addon-vmcore = %{version}-%{release}
358 Requires:       %{name}-addon-xorg = %{version}-%{release}
359 Requires:       %{name}-gui = %{version}-%{release}
360 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
361 Requires:       %{name}-retrace-client = %{version}-%{release}
362 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
363 Requires:       libreport-plugin-logger >= %{libreport_ver}
364 Requires:       libreport-plugin-ureport >= %{libreport_ver}
365 Provides:       bug-buddy
366 Obsoletes:      bug-buddy
367
368 %description desktop
369 Virtual package to make easy default installation on desktop
370 environments.
371
372 %description desktop -l pl.UTF-8
373 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
374 graficznych.
375
376 %package console-notification
377 Summary:        ABRT console notification script
378 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
379 Group:          Applications/System
380 Requires:       %{name} = %{version}-%{release}
381 Requires:       %{name}-cli = %{version}-%{release}
382
383 %description console-notification
384 A small script which prints a count of detected problems when someone
385 logs in to the shell.
386
387 %description console-notification -l pl.UTF-8
388 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
389 się do powłoki.
390
391 %prep
392 %setup -q
393 %if "%{_rpmversion}" >= "5.0"
394 %patch0 -p1
395 %else
396 %patch1 -p1
397 %endif
398 %patch2 -p1
399 %patch3 -p1
400 %patch4 -p1
401
402 %build
403 %{__libtoolize}
404 %{__aclocal}
405 %{__autoconf}
406 %{__autoheader}
407 %{__automake}
408 %configure \
409         --disable-silent-rules \
410         --with-systemdsystemunitdir=%{systemdunitdir}
411
412 %{__make}
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416 %{__make} install \
417         DESTDIR=$RPM_BUILD_ROOT
418
419 %py_postclean
420
421 # obsoleted by pkg-config
422 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
423
424 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
425 install -d $RPM_BUILD_ROOT/var/cache/%{name}
426 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
427 install -d $RPM_BUILD_ROOT/var/run/%{name}
428
429 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
430 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
431 d /var/run/%{name} 0755 root root -
432 EOF
433
434 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/problem/*.la
435 # examples
436 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/problem_examples
437 # outdated copy of lt
438 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/lt_LT
439
440 %find_lang %{name}
441
442 %clean
443 rm -rf $RPM_BUILD_ROOT
444
445 %pre
446 %groupadd -g 248 abrt
447 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
448
449 %post
450 /sbin/chkconfig --add abrtd
451 %service abrtd restart
452 %systemd_post abrtd.service
453
454 %preun
455 if [ "$1" = "0" ]; then
456         %service abrtd stop
457         /sbin/chkconfig --del abrtd
458 fi
459 %systemd_preun abrtd.service
460
461 %postun
462 if [ "$1" = "0" ]; then
463         %userremove abrt
464         %groupremove abrt
465 fi
466
467 %post   libs -p /sbin/ldconfig
468 %postun libs -p /sbin/ldconfig
469
470 %post addon-ccpp
471 %systemd_post abrt-ccpp.service
472
473 %preun addon-ccpp
474 %systemd_preun abrt-ccpp.service
475
476 %post addon-kerneloops
477 %systemd_post abrt-oops.service
478
479 %preun addon-kerneloops
480 %systemd_preun abrt-oops.service
481
482 %post addon-pstoreoops
483 %systemd_post abrt-pstoreoops.service
484
485 %preun addon-pstoreoops
486 %systemd_preun abrt-pstoreoops.service
487
488 %post addon-upload-watch
489 %systemd_post abrt-upload-watch.service
490
491 %preun addon-upload-watch
492 %systemd_preun abrt-upload-watch.service
493
494 %post addon-vmcore
495 %systemd_post abrt-vmcore.service
496
497 %preun addon-vmcore
498 %systemd_preun abrt-vmcore.service
499
500 %post addon-xorg
501 %systemd_post abrt-xorg.service
502
503 %preun addon-xorg
504 %systemd_preun abrt-xorg.service
505
506 %post gui
507 %update_icon_cache hicolor
508
509 %postun gui
510 %update_icon_cache hicolor
511
512 %post   gui-libs -p /sbin/ldconfig
513 %postun gui-libs -p /sbin/ldconfig
514
515 %files -f %{name}.lang
516 %defattr(644,root,root,755)
517 %doc README
518 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
519 %attr(755,root,root) %{_bindir}/abrt-handle-upload
520 %attr(755,root,root) %{_bindir}/abrt-watch-log
521 %attr(755,root,root) %{_sbindir}/abrt-server
522 %attr(755,root,root) %{_sbindir}/abrtd
523 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
524 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
525 %dir %{_sysconfdir}/%{name}
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
527 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
528 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
529 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xorg.conf
530 %dir %{_sysconfdir}/%{name}/plugins
531 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
532 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
533 %attr(754,root,root) /etc/rc.d/init.d/abrtd
534 %{systemdunitdir}/abrtd.service
535 %attr(775,root,abrt) %dir /var/cache/%{name}
536 %dir /var/run/%{name}
537 %{systemdtmpfilesdir}/abrt.conf
538 %{_mandir}/man1/abrt-action-save-package-data.1*
539 %{_mandir}/man1/abrt-handle-upload.1*
540 %{_mandir}/man1/abrt-server.1*
541 %{_mandir}/man1/abrt-watch-log.1*
542 %{_mandir}/man5/abrt.conf.5*
543 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
544 %{_mandir}/man8/abrtd.8*
545
546 %files libs
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
549 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
550
551 %files devel
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/libabrt.so
554 %dir %{_includedir}/abrt
555 %{_includedir}/abrt/abrt-dbus.h
556 %{_includedir}/abrt/hooklib.h
557 %{_includedir}/abrt/libabrt.h
558 %{_includedir}/abrt/problem_api.h
559 %{_pkgconfigdir}/abrt.pc
560
561 %files addon-ccpp
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
564 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
565 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
566 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
567 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
568 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
569 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
570 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
571 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
572 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
573 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
574 %attr(755,root,root) %{_sbindir}/abrt-install-ccpp-hook
575 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
576 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
577 %attr(755,root,root) %{_libexecdir}/abrt-hook-ccpp
578 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
580 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
581 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
582 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
583 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
584 %{_datadir}/libreport/events/analyze_CCpp.xml
585 %{_datadir}/libreport/events/analyze_LocalGDB.xml
586 %{_datadir}/libreport/events/collect_GConf.xml
587 %{_datadir}/libreport/events/collect_vimrc_system.xml
588 %{_datadir}/libreport/events/collect_vimrc_user.xml
589 %{_datadir}/libreport/events/collect_xsession_errors.xml
590 %{_datadir}/libreport/events/post_report.xml
591 %{systemdunitdir}/abrt-ccpp.service
592 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
593 %{_mandir}/man1/abrt-action-analyze-c.1*
594 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
595 %{_mandir}/man1/abrt-action-analyze-core.1*
596 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
597 %{_mandir}/man1/abrt-action-generate-backtrace.1*
598 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
599 %{_mandir}/man1/abrt-action-install-debuginfo.1*
600 %{_mandir}/man1/abrt-action-list-dsos.1*
601 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
602 %{_mandir}/man1/abrt-action-trim-files.1*
603 %{_mandir}/man1/abrt-install-ccpp-hook.1*
604
605 %files addon-kerneloops
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
608 %attr(755,root,root) %{_bindir}/abrt-action-save-kernel-data
609 %attr(755,root,root) %{_bindir}/abrt-dump-oops
610 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
611 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
612 %{systemdunitdir}/abrt-oops.service
613 %{_mandir}/man1/abrt-action-analyze-oops.1*
614 %{_mandir}/man1/abrt-action-save-kernel-data.1*
615 %{_mandir}/man1/abrt-dump-oops.1*
616
617 %files addon-pstoreoops
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
620 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
621 %{systemdunitdir}/abrt-pstoreoops.service
622 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
623 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
624 %{_mandir}/man1/abrt-merge-pstoreoops.1*
625
626 %files addon-python
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
629 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python.conf
630 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python_event.conf
631 %{py_sitedir}/abrt_exception_handler.py[co]
632 %{py_sitedir}/abrt.pth
633 %{_mandir}/man1/abrt-action-analyze-python.1*
634
635 %files addon-upload-watch
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
638 %{systemdunitdir}/abrt-upload-watch.service
639 %{_mandir}/man1/abrt-upload-watch.1*
640
641 %files addon-vmcore
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
644 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-harvest-vmcore.conf
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
647 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
648 %{_datadir}/libreport/events/analyze_VMcore.xml
649 %{systemdunitdir}/abrt-vmcore.service
650 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
651 %{_mandir}/man1/abrt-harvest-vmcore.1*
652
653 %files addon-xorg
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
656 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
657 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
658 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
659 %{systemdunitdir}/abrt-xorg.service
660 %{_mandir}/man1/abrt-action-analyze-xorg.1*
661 %{_mandir}/man1/abrt-dump-xorg.1*
662 %{_mandir}/man5/abrt-xorg.conf.5*
663
664 %files plugin-bodhi
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_bindir}/abrt-bodhi
667 %{_mandir}/man1/abrt-bodhi.1*
668
669 %files retrace-client
670 %defattr(644,root,root,755)
671 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
672 %attr(755,root,root) %{_bindir}/abrt-retrace-client
673 %{_datadir}/libreport/events/analyze_RetraceServer.xml
674 %{_mandir}/man1/abrt-retrace-client.1*
675
676 %files dbus
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_sbindir}/abrt-dbus
679 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/dbus_event.conf
680 /etc/dbus-1/system.d/dbus-abrt.conf
681 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
682 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
683 %{_datadir}/polkit-1/actions/abrt_polkit.policy
684 %{_mandir}/man8/abrt-dbus.8*
685 %{_docdir}/abrt-dbus-%{version}
686
687 %files python
688 %defattr(644,root,root,755)
689 %dir %{py_sitedir}/problem
690 %attr(755,root,root) %{py_sitedir}/problem/_pyabrt.so
691 %{py_sitedir}/problem/*.py[co]
692 %{_mandir}/man5/abrt-python.5*
693
694 %files cli
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_bindir}/abrt-cli
697 %{_mandir}/man1/abrt-cli.1*
698
699 %files gui
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_bindir}/abrt-applet
702 %attr(755,root,root) %{_bindir}/system-config-abrt
703 %dir %{_datadir}/%{name}
704 %{_datadir}/%{name}/icons
705 %{_datadir}/%{name}/ui
706 %{_iconsdir}/hicolor/*/apps/abrt.png
707 %{_iconsdir}/hicolor/*/status/abrt.png
708 %{_sysconfdir}/xdg/autostart/abrt-applet.desktop
709 %{_mandir}/man1/abrt-applet.1*
710 %{_mandir}/man1/system-config-abrt.1*
711
712 %files gui-libs
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
716
717 %files gui-devel
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libabrt_gui.so
720 %{_includedir}/abrt/abrt-config-widget.h
721 %{_includedir}/abrt/system-config-abrt.h
722 %{_pkgconfigdir}/abrt_gui.pc
723
724 %files desktop
725 %defattr(644,root,root,755)
726
727 %files console-notification
728 %defattr(644,root,root,755)
729 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.086607 seconds and 4 git commands to generate.