]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- python 3.4
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - handle obsolete packages: abrt-plugin-{catcut,rhfastcheck,rhticket,ticketuploader}
4 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
5 # - teach build system to use python3.2+ __pycache__
6 %define         libreport_ver   2.3.0
7 Summary:        Automatic bug detection and reporting tool
8 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
9 Name:           abrt
10 Version:        2.3.0
11 Release:        2
12 License:        GPL v2+
13 Group:          Applications/System
14 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
15 # Source0-md5:  faa666301f4512723486300212cd7e58
16 Source1:        %{name}.init
17 Patch0:         %{name}-rpm5.patch
18 Patch1:         %{name}-rpm45.patch
19 Patch2:         format_security.patch
20 Patch3:         %{name}-link.patch
21 Patch4:         profile.sh.patch
22 URL:            https://fedorahosted.org/abrt/
23 BuildRequires:  asciidoc
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake
26 BuildRequires:  dbus-devel
27 BuildRequires:  gettext-devel >= 0.17
28 BuildRequires:  glib2-devel >= 1:2.21
29 BuildRequires:  gtk+3-devel >= 3.0
30 BuildRequires:  intltool >= 0.35.0
31 BuildRequires:  json-c-devel
32 BuildRequires:  libmagic-devel
33 BuildRequires:  libnotify-devel
34 BuildRequires:  libreport-devel >= %{libreport_ver}
35 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
36 BuildRequires:  libreport-web-devel >= %{libreport_ver}
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 2
39 BuildRequires:  nss-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  polkit-devel
42 BuildRequires:  python-devel >= 2
43 BuildRequires:  python-modules >= 2
44 BuildRequires:  python3-devel >= 3
45 BuildRequires:  python3-modules >= 3
46 BuildRequires:  rpm-devel >= 4.5-28
47 BuildRequires:  rpm-pythonprov
48 BuildRequires:  rpmbuild(macros) >= 1.219
49 BuildRequires:  satyr-devel
50 BuildRequires:  systemd-devel
51 BuildRequires:  xmlto
52 BuildRequires:  xorg-lib-libICE-devel
53 BuildRequires:  xorg-lib-libSM-devel
54 Requires(postun):       /usr/sbin/groupdel
55 Requires(postun):       /usr/sbin/userdel
56 Requires(pre):  /bin/id
57 Requires(pre):  /usr/bin/getgid
58 Requires(pre):  /usr/sbin/groupadd
59 Requires(pre):  /usr/sbin/useradd
60 Requires:       %{name}-libs = %{version}-%{release}
61 Provides:       group(abrt)
62 Provides:       user(abrt)
63 Obsoletes:      abrt-plugin-filetransfer
64 Obsoletes:      abrt-plugin-runapp
65 Obsoletes:      abrt-plugin-sosreport
66 Obsoletes:      abrt-plugin-sqlite3
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 ABRT is a tool to help users to detect defects in applications and to
71 create a bug report with all informations needed by maintainer to fix
72 it. It uses plugin system to extend its functionality.
73
74 %description -l pl.UTF-8
75 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
76 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
77 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
78 system wtyczek do rozszerzania funkcjonalności.
79
80 %package libs
81 Summary:        ABRT shared library
82 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
83 Group:          Libraries
84 Requires:       glib2 >= 1:2.21
85 Requires:       libreport >= %{libreport_ver}
86
87 %description libs
88 ABRT shared library.
89
90 %description libs -l pl.UTF-8
91 Biblioteka współdzielona ABRT.
92
93 %package devel
94 Summary:        Header files for ABRT livrary
95 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
96 Group:          Development/Libraries
97 Requires:       %{name}-libs = %{version}-%{release}
98 Requires:       glib2-devel >= 1:2.21
99 Requires:       libreport-devel >= %{libreport_ver}
100
101 %description devel
102 Header files for ABRT livrary.
103
104 %description devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki ABRT.
106
107 %package addon-ccpp
108 Summary:        ABRT's C/C++ addon
109 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
110 Group:          Libraries
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       %{name}-retrace-client = %{version}-%{release}
113 Requires:       cpio
114 Requires:       elfutils
115 Requires:       gdb >= 7.0-3
116 Requires:       satyr
117 Requires:       yum-utils
118
119 %description addon-ccpp
120 This package contains hook for C/C++ crashed programs and abrt's C/C++
121 analyzer plugin.
122
123 %description addon-ccpp -l pl.UTF-8
124 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
125 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
126
127 %package addon-kerneloops
128 Summary:        ABRT's kerneloops addon
129 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
130 Group:          Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       curl
133 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
134 Obsoletes:      abrt-plugin-kerneloops
135 Obsoletes:      abrt-plugin-kerneloopsreporter
136 Obsoletes:      kerneloops
137
138 %description addon-kerneloops
139 This package contains plugin for collecting kernel crash information
140 from system log.
141
142 %description addon-kerneloops -l pl.UTF-8
143 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
144 logu systemowego.
145
146 %package addon-pstoreoops
147 Summary:        ABRT's pstoreoops addon
148 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
149 Group:          Libraries
150 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
151 Obsoletes:      abrt-addon-uefioops
152
153 %description addon-pstoreoops
154 This package contains plugin for collecting kernel oopses from pstore
155 storage.
156
157 %description addon-pstoreoops -l pl.UTF-8
158 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
159
160 %package addon-python
161 Summary:        ABRT's addon for catching and analyzing Python 2 exceptions
162 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 2
163 Group:          Libraries
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       %{name}-python = %{version}-%{release}
166 # for detecting package name containing offending file
167 Suggests:       python-rpm
168 # for logging to journal
169 Suggests:       python-systemd
170 Obsoletes:      gnome-python2-bugbuddy
171
172 %description addon-python
173 This package contains Python hook and Python analyzer plugin for
174 handling uncaught exception in Python 2 programs.
175
176 %description addon-python -l pl.UTF-8
177 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
178 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
179 Pythonie 2.
180
181 %package addon-python3
182 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
183 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       %{name}-python3 = %{version}-%{release}
187 # for detecting package name containing offending file (TODO: python3-rpm package)
188 #Suggests:      python3-rpm
189 # for logging to journal (TODO: python3-systemd package)
190 #Suggests:      python3-systemd
191
192 %description addon-python3
193 This package contains Python hook and Python analyzer plugin for
194 handling uncaught exception in Python 3 programs.
195
196 %description addon-python3 -l pl.UTF-8
197 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
198 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
199 Pythonie 3.
200
201 %package addon-upload-watch
202 Summary:        ABRT's upload addon
203 Summary(pl.UTF-8):      Dodatek upload do ABRT
204 Group:          Libraries
205 Requires:       %{name} = %{version}-%{release}
206
207 %description addon-upload-watch
208 This package contains hook for uploaded problems.
209
210 %description addon-upload-watch -l pl.UTF-8
211 Ten pakiet zawiera uchwyt dla problemów przysłanych.
212
213 %package addon-vmcore
214 Summary:        ABRT's vmcore addon
215 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
219 Requires:       crash
220
221 %description addon-vmcore
222 This package contains plugin for collecting kernel crash information
223 from vmcore files.
224
225 %description addon-vmcore -l pl.UTF-8
226 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
227 plików vmcore.
228
229 %package addon-xorg
230 Summary:        ABRT's Xorg addon
231 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
232 Group:          Libraries
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       curl
235
236 %description addon-xorg
237 This package contains plugin for collecting Xorg crash information
238 from Xorg log.
239
240 %description addon-xorg -l pl.UTF-8
241 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
242 logu Xorg.
243
244 %package plugin-bodhi
245 Summary:        ABRT's bodhi plugin
246 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       libreport-web >= %{libreport_ver}
250 Obsoletes:      libreport-plugin-bodhi
251
252 %description plugin-bodhi
253 Plugin to search for a new updates in bodhi server.
254
255 %description plugin-bodhi -l pl.UTF-8
256 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
257
258 %package retrace-client
259 Summary:        ABRT's retrace client
260 Summary(pl.UTF-8):      Klient Retrace dla ABRT
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263 Requires:       xz
264
265 %description retrace-client
266 This package contains the client application for Retrace server which
267 is able to analyze C/C++ crashes remotely.
268
269 %description retrace-client -l pl.UTF-8
270 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
271 potrafi zdalnie przeanalizować awarię programu w C/C++.
272
273 %package dbus
274 Summary:        ABRT DBus service
275 Summary(pl.UTF-8):      Usługa DBus ABRT
276 Group:          Applications/System
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       libreport >= %{libreport_ver}
279
280 %description dbus
281 ABRT DBus service which provides org.freedesktop.problems API on DBus
282 and uses PolicyKit to authorize to access the problem data.
283
284 %description dbus -l pl.UTF-8
285 Usługa DBus ABRT, udostępniająca poprzez DBus API
286 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
287 do danych o problemach.
288
289 %package python
290 Summary:        ABRT Python 2 API
291 Summary(pl.UTF-8):      API Pythona 2 do ABRT
292 Group:          Libraries/Python
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       python-libreport >= %{libreport_ver}
295
296 %description python
297 High-level API for querying, creating and manipulating problems
298 handled by ABRT in Python 2.
299
300 %description python -l pl.UTF-8
301 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
302 Pythona 2 problemów obsługiwanych przez ABRT.
303
304 %package python3
305 Summary:        ABRT Python 3 API
306 Summary(pl.UTF-8):      API Pythona 3 do ABRT
307 Group:          Libraries/Python
308 Requires:       %{name} = %{version}-%{release}
309 Requires:       python3-libreport >= %{libreport_ver}
310
311 %description python3
312 High-level API for querying, creating and manipulating problems
313 handled by ABRT in Python.
314
315 %description python3 -l pl.UTF-8
316 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
317 Pythona 3 problemów obsługiwanych przez ABRT.
318
319 %package cli
320 Summary:        ABRT's command line interface
321 Summary(pl.UTF-8):      Interfejs linii poleceń ABRT
322 Group:          Applications/System
323 Requires:       %{name} = %{version}-%{release}
324 # analyzers
325 Requires:       %{name}-addon-ccpp = %{version}-%{release}
326 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
327 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
328 Requires:       %{name}-addon-python = %{version}-%{release}
329 # reporters
330 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
331 Requires:       libreport-plugin-logger >= %{libreport_ver}
332
333 %description cli
334 This package contains simple command line client for controling ABRT
335 daemon over the sockets.
336
337 %description cli -l pl.UTF-8
338 Ten pakiet zawiera prostego klienta obsługiwanego z linii poleceń,
339 pozwalającego na sterowanie demonem poprzez gniazda.
340
341 %package gui
342 Summary:        ABRT's GUI
343 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
344 Group:          X11/Applications
345 Requires(post,postun):  /sbin/ldconfig
346 Requires(post,postun):  gtk-update-icon-cache
347 Requires(post,postun):  hicolor-icon-theme
348 Requires:       %{name} = %{version}-%{release}
349 Requires:       %{name}-dbus = %{version}-%{release}
350 Requires:       %{name}-gui-libs = %{version}-%{release}
351 Suggests:       gnome-abrt
352 Provides:       abrt-applet = %{version}-%{release}
353 Obsoletes:      abrt-applet < 0.0.5
354 Conflicts:      abrt-applet < 0.0.5
355
356 %description gui
357 GTK+ wizard for convenient bug reporting.
358
359 %description gui -l pl.UTF-8
360 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
361
362 %package gui-libs
363 Summary:        ABRT's GUI library
364 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
365 Group:          X11/Libraries
366 Requires:       %{name}-libs = %{version}-%{release}
367 Requires:       gtk+3 >= 3.0
368
369 %description gui-libs
370 ABRT's GUI library.
371
372 %description gui-libs -l pl.UTF-8
373 Biblioteka graficznego interfejsu użytkownika ABRT.
374
375 %package gui-devel
376 Summary:        Header files for ABRT GUI library
377 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
378 Group:          X11/Development/Libraries
379 Requires:       %{name}-devel = %{version}-%{release}
380 Requires:       %{name}-gui-libs = %{version}-%{release}
381 Requires:       gtk+3-devel >= 3.0
382
383 %description gui-devel
384 Header files for ABRT GUI library.
385
386 %description gui-devel -l pl.UTF-8
387 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
388
389 %package desktop
390 Summary:        Virtual package to install all necessary packages for usage from desktop environment
391 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
392 Group:          X11/Applications
393 # This package should be installed when anything requests bug-buddy;
394 # installing abrt-desktop should result in the abrt which works without
395 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
396 Requires:       %{name} = %{version}-%{release}
397 Requires:       %{name}-addon-ccpp = %{version}-%{release}
398 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
399 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
400 Requires:       %{name}-addon-python = %{version}-%{release}
401 Requires:       %{name}-addon-vmcore = %{version}-%{release}
402 Requires:       %{name}-addon-xorg = %{version}-%{release}
403 Requires:       %{name}-gui = %{version}-%{release}
404 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
405 Requires:       %{name}-retrace-client = %{version}-%{release}
406 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
407 Requires:       libreport-plugin-logger >= %{libreport_ver}
408 Requires:       libreport-plugin-ureport >= %{libreport_ver}
409 Provides:       bug-buddy
410 Obsoletes:      bug-buddy
411
412 %description desktop
413 Virtual package to make easy default installation on desktop
414 environments.
415
416 %description desktop -l pl.UTF-8
417 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
418 graficznych.
419
420 %package console-notification
421 Summary:        ABRT console notification script
422 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
423 Group:          Applications/System
424 Requires:       %{name} = %{version}-%{release}
425 Requires:       %{name}-cli = %{version}-%{release}
426
427 %description console-notification
428 A small script which prints a count of detected problems when someone
429 logs in to the shell.
430
431 %description console-notification -l pl.UTF-8
432 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
433 się do powłoki.
434
435 %prep
436 %setup -q
437 %if "%{_rpmversion}" >= "5.0"
438 %patch0 -p1
439 %else
440 %patch1 -p1
441 %endif
442 %patch2 -p1
443 %patch3 -p1
444 %patch4 -p1
445
446 %build
447 %{__libtoolize}
448 %{__aclocal}
449 %{__autoconf}
450 %{__autoheader}
451 %{__automake}
452 %configure \
453         --disable-silent-rules \
454         --with-systemdsystemunitdir=%{systemdunitdir}
455
456 %{__make}
457
458 %install
459 rm -rf $RPM_BUILD_ROOT
460 %{__make} install \
461         DESTDIR=$RPM_BUILD_ROOT
462
463 %py_postclean
464
465 # obsoleted by pkg-config
466 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
467
468 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
469 install -d $RPM_BUILD_ROOT/var/cache/%{name}
470 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
471 install -d $RPM_BUILD_ROOT/var/run/%{name}
472
473 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
474 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
475 d /var/run/%{name} 0755 root root -
476 EOF
477
478 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/problem/*.la
479 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
480 # examples
481 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/problem_examples
482 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
483 # empty, same as af / hr / ms resp.
484 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{af_ZA,hr_HR,ms_MY}
485 # empty version of cs / es / eu / fa / it / ja / ru / ta / uk resp.
486 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{cs_CZ,es_ES,eu_ES,fa_IR,it_IT,ja_JP,ru_RU,ta_IN,uk_UA}
487 # outdated copy of lt
488 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/lt_LT
489
490 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
491 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
492
493 %find_lang %{name}
494
495 %clean
496 rm -rf $RPM_BUILD_ROOT
497
498 %pre
499 %groupadd -g 248 abrt
500 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
501
502 %post
503 /sbin/chkconfig --add abrtd
504 %service abrtd restart
505 %systemd_post abrtd.service
506
507 %preun
508 if [ "$1" = "0" ]; then
509         %service abrtd stop
510         /sbin/chkconfig --del abrtd
511 fi
512 %systemd_preun abrtd.service
513
514 %postun
515 if [ "$1" = "0" ]; then
516         %userremove abrt
517         %groupremove abrt
518 fi
519
520 %post   libs -p /sbin/ldconfig
521 %postun libs -p /sbin/ldconfig
522
523 %post addon-ccpp
524 %systemd_post abrt-ccpp.service
525
526 %preun addon-ccpp
527 %systemd_preun abrt-ccpp.service
528
529 %post addon-kerneloops
530 %systemd_post abrt-oops.service
531
532 %preun addon-kerneloops
533 %systemd_preun abrt-oops.service
534
535 %post addon-pstoreoops
536 %systemd_post abrt-pstoreoops.service
537
538 %preun addon-pstoreoops
539 %systemd_preun abrt-pstoreoops.service
540
541 %post addon-upload-watch
542 %systemd_post abrt-upload-watch.service
543
544 %preun addon-upload-watch
545 %systemd_preun abrt-upload-watch.service
546
547 %post addon-vmcore
548 %systemd_post abrt-vmcore.service
549
550 %preun addon-vmcore
551 %systemd_preun abrt-vmcore.service
552
553 %post addon-xorg
554 %systemd_post abrt-xorg.service
555
556 %preun addon-xorg
557 %systemd_preun abrt-xorg.service
558
559 %post gui
560 %update_icon_cache hicolor
561
562 %postun gui
563 %update_icon_cache hicolor
564
565 %post   gui-libs -p /sbin/ldconfig
566 %postun gui-libs -p /sbin/ldconfig
567
568 %files -f %{name}.lang
569 %defattr(644,root,root,755)
570 %doc README
571 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
572 %attr(755,root,root) %{_bindir}/abrt-action-notify
573 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
574 %attr(755,root,root) %{_bindir}/abrt-handle-upload
575 %attr(755,root,root) %{_bindir}/abrt-watch-log
576 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
577 %attr(755,root,root) %{_sbindir}/abrt-server
578 %attr(755,root,root) %{_sbindir}/abrtd
579 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
580 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
581 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
582 %dir %{_datadir}/%{name}
583 %dir %{_datadir}/%{name}/conf.d
584 %{_datadir}/%{name}/conf.d/abrt.conf
585 %{_datadir}/%{name}/conf.d/abrt-action-save-package-data.conf
586 %{_datadir}/%{name}/conf.d/gpg_keys.conf
587 %dir %{_datadir}/%{name}/conf.d/plugins
588 %{_datadir}/augeas/lenses/abrt.aug
589 %dir %{_sysconfdir}/%{name}
590 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
591 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
592 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
593 %dir %{_sysconfdir}/%{name}/plugins
594 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
595 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
596 %attr(754,root,root) /etc/rc.d/init.d/abrtd
597 %{systemdunitdir}/abrtd.service
598 %attr(775,root,abrt) %dir /var/cache/%{name}
599 %dir /var/run/%{name}
600 %{systemdtmpfilesdir}/abrt.conf
601 %{_mandir}/man1/abrt-action-analyze-python.1*
602 %{_mandir}/man1/abrt-action-notify.1*
603 %{_mandir}/man1/abrt-action-save-package-data.1*
604 %{_mandir}/man1/abrt-auto-reporting.1*
605 %{_mandir}/man1/abrt-handle-upload.1*
606 %{_mandir}/man1/abrt-server.1*
607 %{_mandir}/man1/abrt-watch-log.1*
608 %{_mandir}/man5/abrt.conf.5*
609 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
610 %{_mandir}/man5/abrt_event.conf.5*
611 %{_mandir}/man5/gpg_keys.conf.5*
612 %{_mandir}/man5/smart_event.conf.5*
613 %{_mandir}/man8/abrtd.8*
614
615 %files libs
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
618 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
619
620 %files devel
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_libdir}/libabrt.so
623 %dir %{_includedir}/abrt
624 %{_includedir}/abrt/abrt-dbus.h
625 %{_includedir}/abrt/hooklib.h
626 %{_includedir}/abrt/libabrt.h
627 %{_includedir}/abrt/problem_api.h
628 %{_pkgconfigdir}/abrt.pc
629
630 %files addon-ccpp
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
633 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
634 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
635 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
636 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
637 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
638 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
639 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
640 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
641 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
642 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
643 %attr(755,root,root) %{_sbindir}/abrt-install-ccpp-hook
644 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
645 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
646 %attr(755,root,root) %{_libexecdir}/abrt-hook-ccpp
647 %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
649 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
650 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
651 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
652 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
653 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
654 %{_datadir}/libreport/events/analyze_CCpp.xml
655 %{_datadir}/libreport/events/analyze_LocalGDB.xml
656 %{_datadir}/libreport/events/collect_GConf.xml
657 %{_datadir}/libreport/events/collect_vimrc_system.xml
658 %{_datadir}/libreport/events/collect_vimrc_user.xml
659 %{_datadir}/libreport/events/collect_xsession_errors.xml
660 %{_datadir}/libreport/events/post_report.xml
661 %{systemdunitdir}/abrt-ccpp.service
662 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
663 %{_mandir}/man1/abrt-action-analyze-c.1*
664 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
665 %{_mandir}/man1/abrt-action-analyze-core.1*
666 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
667 %{_mandir}/man1/abrt-action-generate-backtrace.1*
668 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
669 %{_mandir}/man1/abrt-action-install-debuginfo.1*
670 %{_mandir}/man1/abrt-action-list-dsos.1*
671 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
672 %{_mandir}/man1/abrt-action-trim-files.1*
673 %{_mandir}/man1/abrt-install-ccpp-hook.1*
674 %{_mandir}/man5/abrt-CCpp.conf.5*
675 %{_mandir}/man5/ccpp_event.conf.5*
676 %{_mandir}/man5/ccpp_retrace_event.conf.5*
677 %{_mandir}/man5/gconf_event.conf.5*
678 %{_mandir}/man5/vimrc_event.conf.5*
679
680 %files addon-kerneloops
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
683 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
684 %attr(755,root,root) %{_bindir}/abrt-action-save-kernel-data
685 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
686 %attr(755,root,root) %{_bindir}/abrt-dump-oops
687 %{_datadir}/%{name}/conf.d/plugins/oops.conf
688 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
689 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
690 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.oops.xml
691 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
692 %{systemdunitdir}/abrt-oops.service
693 %{_mandir}/man1/abrt-action-analyze-oops.1*
694 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
695 %{_mandir}/man1/abrt-action-save-kernel-data.1*
696 %{_mandir}/man1/abrt-dump-journal-oops.1*
697 %{_mandir}/man1/abrt-dump-oops.1*
698 %{_mandir}/man5/abrt-oops.conf.5*
699 %{_mandir}/man5/koops_event.conf.5*
700
701 %files addon-pstoreoops
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
704 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
705 %{systemdunitdir}/abrt-pstoreoops.service
706 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
707 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
708 %{_mandir}/man1/abrt-merge-pstoreoops.1*
709
710 %files addon-python
711 %defattr(644,root,root,755)
712 %{_datadir}/%{name}/conf.d/plugins/python.conf
713 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python.conf
714 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python_event.conf
715 %{py_sitedir}/abrt_exception_handler.py[co]
716 %{py_sitedir}/abrt.pth
717 %{_mandir}/man5/abrt-python.conf.5*
718 %{_mandir}/man5/python_event.conf.5*
719
720 %files addon-python3
721 %defattr(644,root,root,755)
722 %{_datadir}/%{name}/conf.d/plugins/python3.conf
723 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
724 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
725 %{py3_sitedir}/abrt_exception_handler3.py*
726 %{py3_sitedir}/abrt3.pth
727 %{_mandir}/man5/abrt-python3.conf.5*
728 %{_mandir}/man5/python3_event.conf.5*
729
730 %files addon-upload-watch
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
733 %{systemdunitdir}/abrt-upload-watch.service
734 %{_mandir}/man1/abrt-upload-watch.1*
735
736 %files addon-vmcore
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
739 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
740 %dir %{_datadir}/%{name}/conf.d/plugins/vmcore.conf
741 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
742 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
743 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
744 %{_datadir}/libreport/events/analyze_VMcore.xml
745 %{systemdunitdir}/abrt-vmcore.service
746 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
747 %{_mandir}/man1/abrt-harvest-vmcore.1*
748 %{_mandir}/man5/abrt-vmcore.conf.5*
749 %{_mandir}/man5/vmcore_event.conf.5*
750
751 %files addon-xorg
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
754 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
755 %dir %{_datadir}/%{name}/conf.d/plugins/xorg.conf
756 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
757 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
758 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
759 %{systemdunitdir}/abrt-xorg.service
760 %{_mandir}/man1/abrt-action-analyze-xorg.1*
761 %{_mandir}/man1/abrt-dump-xorg.1*
762 %{_mandir}/man5/abrt-xorg.conf.5*
763 %{_mandir}/man5/xorg_event.conf.5*
764
765 %files plugin-bodhi
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_bindir}/abrt-bodhi
768 %{_mandir}/man1/abrt-bodhi.1*
769
770 %files retrace-client
771 %defattr(644,root,root,755)
772 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
773 %attr(755,root,root) %{_bindir}/abrt-retrace-client
774 %{_datadir}/libreport/events/analyze_RetraceServer.xml
775 %{_mandir}/man1/abrt-retrace-client.1*
776
777 %files dbus
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_sbindir}/abrt-configuration
780 %attr(755,root,root) %{_sbindir}/abrt-dbus
781 /etc/dbus-1/system.d/dbus-abrt.conf
782 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.abrt.xml
783 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ccpp.xml
784 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.python.xml
785 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.vmcore.xml
786 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xml
787 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xorg.xml
788 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
789 %{_datadir}/dbus-1/system-services/com.redhat.problems.configuration.service
790 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
791 %{_datadir}/polkit-1/actions/abrt_polkit.policy
792 %{_mandir}/man8/abrt-configuration.8*
793 %{_mandir}/man8/abrt-dbus.8*
794 %{_docdir}/abrt-dbus-%{version}
795
796 %files python
797 %defattr(644,root,root,755)
798 %dir %{py_sitedir}/problem
799 %attr(755,root,root) %{py_sitedir}/problem/_pyabrt.so
800 %{py_sitedir}/problem/*.py[co]
801 %{_mandir}/man5/abrt-python.5*
802
803 %files python3
804 %defattr(644,root,root,755)
805 %dir %{py3_sitedir}/problem
806 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
807 %{py3_sitedir}/problem/*.py*
808 %{_mandir}/man5/abrt-python3.5*
809
810 %files cli
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_bindir}/abrt-cli
813 %{_mandir}/man1/abrt-cli.1*
814
815 %files gui
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_bindir}/abrt-applet
818 %attr(755,root,root) %{_bindir}/system-config-abrt
819 %dir %{_datadir}/%{name}
820 %{_datadir}/%{name}/icons
821 %{_datadir}/%{name}/ui
822 %{_iconsdir}/hicolor/*/apps/abrt.png
823 %{_iconsdir}/hicolor/*/status/abrt.png
824 %{_sysconfdir}/xdg/autostart/abrt-applet.desktop
825 %{_mandir}/man1/abrt-applet.1*
826 %{_mandir}/man1/system-config-abrt.1*
827
828 %files gui-libs
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
831 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
832
833 %files gui-devel
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_libdir}/libabrt_gui.so
836 %{_includedir}/abrt/abrt-config-widget.h
837 %{_includedir}/abrt/system-config-abrt.h
838 %{_pkgconfigdir}/abrt_gui.pc
839
840 %files desktop
841 %defattr(644,root,root,755)
842
843 %files console-notification
844 %defattr(644,root,root,755)
845 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.112289 seconds and 4 git commands to generate.