]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
profile script: do not leak vars, do not run if not interactive
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - handle obsolete packages: abrt-plugin-{catcut,rhfastcheck,rhticket,ticketuploader}
4 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
5 # - teach build system to use python3.2+ __pycache__
6 %define         libreport_ver   2.2.0
7 Summary:        Automatic bug detection and reporting tool
8 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
9 Name:           abrt
10 Version:        2.2.0
11 Release:        2
12 License:        GPL v2+
13 Group:          Applications/System
14 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
15 # Source0-md5:  7d5325ece7728a6058c94999ce2ceccb
16 Source1:        %{name}.init
17 Patch0:         %{name}-rpm5.patch
18 Patch1:         %{name}-rpm45.patch
19 Patch2:         format_security.patch
20 Patch3:         %{name}-link.patch
21 Patch4:         %{name}-po.patch
22 Patch5:         profile.sh.patch
23 URL:            https://fedorahosted.org/abrt/
24 BuildRequires:  asciidoc
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake
27 BuildRequires:  dbus-devel
28 BuildRequires:  gettext-devel >= 0.17
29 BuildRequires:  glib2-devel >= 1:2.21
30 BuildRequires:  gtk+3-devel >= 3.0
31 BuildRequires:  intltool >= 0.35.0
32 BuildRequires:  json-c-devel
33 BuildRequires:  libmagic-devel
34 BuildRequires:  libnotify-devel
35 BuildRequires:  libreport-devel >= %{libreport_ver}
36 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
37 BuildRequires:  libreport-web-devel >= %{libreport_ver}
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 2
40 BuildRequires:  nss-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  polkit-devel
43 BuildRequires:  python-devel >= 2
44 BuildRequires:  python-modules >= 2
45 BuildRequires:  python3-devel >= 3
46 BuildRequires:  python3-modules >= 3
47 BuildRequires:  rpm-devel >= 4.5-28
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  rpmbuild(macros) >= 1.219
50 BuildRequires:  satyr-devel
51 BuildRequires:  xmlto
52 BuildRequires:  xorg-lib-libICE-devel
53 BuildRequires:  xorg-lib-libSM-devel
54 Requires(postun):       /usr/sbin/groupdel
55 Requires(postun):       /usr/sbin/userdel
56 Requires(pre):  /bin/id
57 Requires(pre):  /usr/bin/getgid
58 Requires(pre):  /usr/sbin/groupadd
59 Requires(pre):  /usr/sbin/useradd
60 Requires:       %{name}-libs = %{version}-%{release}
61 Provides:       group(abrt)
62 Provides:       user(abrt)
63 Obsoletes:      abrt-plugin-filetransfer
64 Obsoletes:      abrt-plugin-runapp
65 Obsoletes:      abrt-plugin-sosreport
66 Obsoletes:      abrt-plugin-sqlite3
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 ABRT is a tool to help users to detect defects in applications and to
71 create a bug report with all informations needed by maintainer to fix
72 it. It uses plugin system to extend its functionality.
73
74 %description -l pl.UTF-8
75 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
76 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
77 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
78 system wtyczek do rozszerzania funkcjonalności.
79
80 %package libs
81 Summary:        ABRT shared library
82 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
83 Group:          Libraries
84 Requires:       glib2 >= 1:2.21
85 Requires:       libreport >= %{libreport_ver}
86
87 %description libs
88 ABRT shared library.
89
90 %description libs -l pl.UTF-8
91 Biblioteka współdzielona ABRT.
92
93 %package devel
94 Summary:        Header files for ABRT livrary
95 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
96 Group:          Development/Libraries
97 Requires:       %{name}-libs = %{version}-%{release}
98 Requires:       glib2-devel >= 1:2.21
99 Requires:       libreport-devel >= %{libreport_ver}
100
101 %description devel
102 Header files for ABRT livrary.
103
104 %description devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki ABRT.
106
107 %package addon-ccpp
108 Summary:        ABRT's C/C++ addon
109 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
110 Group:          Libraries
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       %{name}-retrace-client = %{version}-%{release}
113 Requires:       cpio
114 Requires:       elfutils
115 Requires:       gdb >= 7.0-3
116 Requires:       satyr
117 Requires:       yum-utils
118
119 %description addon-ccpp
120 This package contains hook for C/C++ crashed programs and abrt's C/C++
121 analyzer plugin.
122
123 %description addon-ccpp -l pl.UTF-8
124 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
125 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
126
127 %package addon-kerneloops
128 Summary:        ABRT's kerneloops addon
129 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
130 Group:          Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       curl
133 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
134 Obsoletes:      abrt-plugin-kerneloops
135 Obsoletes:      abrt-plugin-kerneloopsreporter
136 Obsoletes:      kerneloops
137
138 %description addon-kerneloops
139 This package contains plugin for collecting kernel crash information
140 from system log.
141
142 %description addon-kerneloops -l pl.UTF-8
143 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
144 logu systemowego.
145
146 %package addon-pstoreoops
147 Summary:        ABRT's pstoreoops addon
148 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
149 Group:          Libraries
150 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
151 Obsoletes:      abrt-addon-uefioops
152
153 %description addon-pstoreoops
154 This package contains plugin for collecting kernel oopses from pstore
155 storage.
156
157 %description addon-pstoreoops -l pl.UTF-8
158 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
159
160 %package addon-python
161 Summary:        ABRT's addon for catching and analyzing Python 2 exceptions
162 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 2
163 Group:          Libraries
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       %{name}-python = %{version}-%{release}
166 # for detecting package name containing offending file
167 Suggests:       python-rpm
168 # for logging to journal
169 Suggests:       python-systemd
170 Obsoletes:      gnome-python2-bugbuddy
171
172 %description addon-python
173 This package contains Python hook and Python analyzer plugin for
174 handling uncaught exception in Python 2 programs.
175
176 %description addon-python -l pl.UTF-8
177 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
178 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
179 Pythonie 2.
180
181 %package addon-python3
182 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
183 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       %{name}-python3 = %{version}-%{release}
187 # for detecting package name containing offending file (TODO: python3-rpm package)
188 #Suggests:      python3-rpm
189 # for logging to journal (TODO: python3-systemd package)
190 #Suggests:      python3-systemd
191
192 %description addon-python3
193 This package contains Python hook and Python analyzer plugin for
194 handling uncaught exception in Python 3 programs.
195
196 %description addon-python3 -l pl.UTF-8
197 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
198 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
199 Pythonie 3.
200
201 %package addon-upload-watch
202 Summary:        ABRT's upload addon
203 Summary(pl.UTF-8):      Dodatek upload do ABRT
204 Group:          Libraries
205 Requires:       %{name} = %{version}-%{release}
206
207 %description addon-upload-watch
208 This package contains hook for uploaded problems.
209
210 %description addon-upload-watch -l pl.UTF-8
211 Ten pakiet zawiera uchwyt dla problemów przysłanych.
212
213 %package addon-vmcore
214 Summary:        ABRT's vmcore addon
215 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
219 Requires:       crash
220
221 %description addon-vmcore
222 This package contains plugin for collecting kernel crash information
223 from vmcore files.
224
225 %description addon-vmcore -l pl.UTF-8
226 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
227 plików vmcore.
228
229 %package addon-xorg
230 Summary:        ABRT's Xorg addon
231 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
232 Group:          Libraries
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       curl
235
236 %description addon-xorg
237 This package contains plugin for collecting Xorg crash information
238 from Xorg log.
239
240 %description addon-xorg -l pl.UTF-8
241 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
242 logu Xorg.
243
244 %package plugin-bodhi
245 Summary:        ABRT's bodhi plugin
246 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       libreport-web >= %{libreport_ver}
250 Obsoletes:      libreport-plugin-bodhi
251
252 %description plugin-bodhi
253 Plugin to search for a new updates in bodhi server.
254
255 %description plugin-bodhi -l pl.UTF-8
256 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
257
258 %package retrace-client
259 Summary:        ABRT's retrace client
260 Summary(pl.UTF-8):      Klient Retrace dla ABRT
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263 Requires:       xz
264
265 %description retrace-client
266 This package contains the client application for Retrace server which
267 is able to analyze C/C++ crashes remotely.
268
269 %description retrace-client -l pl.UTF-8
270 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
271 potrafi zdalnie przeanalizować awarię programu w C/C++.
272
273 %package dbus
274 Summary:        ABRT DBus service
275 Summary(pl.UTF-8):      Usługa DBus ABRT
276 Group:          Applications/System
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       libreport >= %{libreport_ver}
279
280 %description dbus
281 ABRT DBus service which provides org.freedesktop.problems API on DBus
282 and uses PolicyKit to authorize to access the problem data.
283
284 %description dbus -l pl.UTF-8
285 Usługa DBus ABRT, udostępniająca poprzez DBus API
286 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
287 do danych o problemach.
288
289 %package python
290 Summary:        ABRT Python 2 API
291 Summary(pl.UTF-8):      API Pythona 2 do ABRT
292 Group:          Libraries/Python
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       python-libreport >= %{libreport_ver}
295
296 %description python
297 High-level API for querying, creating and manipulating problems
298 handled by ABRT in Python 2.
299
300 %description python -l pl.UTF-8
301 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
302 Pythona 2 problemów obsługiwanych przez ABRT.
303
304 %package python3
305 Summary:        ABRT Python 3 API
306 Summary(pl.UTF-8):      API Pythona 3 do ABRT
307 Group:          Libraries/Python
308 Requires:       %{name} = %{version}-%{release}
309 Requires:       python3-libreport >= %{libreport_ver}
310
311 %description python3
312 High-level API for querying, creating and manipulating problems
313 handled by ABRT in Python.
314
315 %description python3 -l pl.UTF-8
316 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
317 Pythona 3 problemów obsługiwanych przez ABRT.
318
319 %package cli
320 Summary:        ABRT's command line interface
321 Summary(pl.UTF-8):      Interfejs linii poleceń ABRT
322 Group:          Applications/System
323 Requires:       %{name} = %{version}-%{release}
324 # analyzers
325 Requires:       %{name}-addon-ccpp = %{version}-%{release}
326 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
327 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
328 Requires:       %{name}-addon-python = %{version}-%{release}
329 # reporters
330 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
331 Requires:       libreport-plugin-logger >= %{libreport_ver}
332
333 %description cli
334 This package contains simple command line client for controling ABRT
335 daemon over the sockets.
336
337 %description cli -l pl.UTF-8
338 Ten pakiet zawiera prostego klienta obsługiwanego z linii poleceń,
339 pozwalającego na sterowanie demonem poprzez gniazda.
340
341 %package gui
342 Summary:        ABRT's GUI
343 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
344 Group:          X11/Applications
345 Requires(post,postun):  /sbin/ldconfig
346 Requires(post,postun):  gtk-update-icon-cache
347 Requires(post,postun):  hicolor-icon-theme
348 Requires:       %{name} = %{version}-%{release}
349 Requires:       %{name}-dbus = %{version}-%{release}
350 Requires:       %{name}-gui-libs = %{version}-%{release}
351 Suggests:       gnome-abrt
352 Provides:       abrt-applet = %{version}-%{release}
353 Obsoletes:      abrt-applet < 0.0.5
354 Conflicts:      abrt-applet < 0.0.5
355
356 %description gui
357 GTK+ wizard for convenient bug reporting.
358
359 %description gui -l pl.UTF-8
360 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
361
362 %package gui-libs
363 Summary:        ABRT's GUI library
364 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
365 Group:          X11/Libraries
366 Requires:       %{name}-libs = %{version}-%{release}
367 Requires:       gtk+3 >= 3.0
368
369 %description gui-libs
370 ABRT's GUI library.
371
372 %description gui-libs -l pl.UTF-8
373 Biblioteka graficznego interfejsu użytkownika ABRT.
374
375 %package gui-devel
376 Summary:        Header files for ABRT GUI library
377 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
378 Group:          X11/Development/Libraries
379 Requires:       %{name}-devel = %{version}-%{release}
380 Requires:       %{name}-gui-libs = %{version}-%{release}
381 Requires:       gtk+3-devel >= 3.0
382
383 %description gui-devel
384 Header files for ABRT GUI library.
385
386 %description gui-devel -l pl.UTF-8
387 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
388
389 %package desktop
390 Summary:        Virtual package to install all necessary packages for usage from desktop environment
391 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
392 Group:          X11/Applications
393 # This package should be installed when anything requests bug-buddy;
394 # installing abrt-desktop should result in the abrt which works without
395 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
396 Requires:       %{name} = %{version}-%{release}
397 Requires:       %{name}-addon-ccpp = %{version}-%{release}
398 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
399 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
400 Requires:       %{name}-addon-python = %{version}-%{release}
401 Requires:       %{name}-addon-vmcore = %{version}-%{release}
402 Requires:       %{name}-addon-xorg = %{version}-%{release}
403 Requires:       %{name}-gui = %{version}-%{release}
404 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
405 Requires:       %{name}-retrace-client = %{version}-%{release}
406 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
407 Requires:       libreport-plugin-logger >= %{libreport_ver}
408 Requires:       libreport-plugin-ureport >= %{libreport_ver}
409 Provides:       bug-buddy
410 Obsoletes:      bug-buddy
411
412 %description desktop
413 Virtual package to make easy default installation on desktop
414 environments.
415
416 %description desktop -l pl.UTF-8
417 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
418 graficznych.
419
420 %package console-notification
421 Summary:        ABRT console notification script
422 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
423 Group:          Applications/System
424 Requires:       %{name} = %{version}-%{release}
425 Requires:       %{name}-cli = %{version}-%{release}
426
427 %description console-notification
428 A small script which prints a count of detected problems when someone
429 logs in to the shell.
430
431 %description console-notification -l pl.UTF-8
432 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
433 się do powłoki.
434
435 %prep
436 %setup -q
437 %if "%{_rpmversion}" >= "5.0"
438 %patch0 -p1
439 %else
440 %patch1 -p1
441 %endif
442 %patch2 -p1
443 %patch3 -p1
444 %patch4 -p1
445 %patch5 -p1
446
447 %build
448 %{__libtoolize}
449 %{__aclocal}
450 %{__autoconf}
451 %{__autoheader}
452 %{__automake}
453 %configure \
454         --disable-silent-rules \
455         --with-systemdsystemunitdir=%{systemdunitdir}
456
457 %{__make}
458
459 %install
460 rm -rf $RPM_BUILD_ROOT
461 %{__make} install \
462         DESTDIR=$RPM_BUILD_ROOT
463
464 %py_postclean
465
466 # obsoleted by pkg-config
467 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
468
469 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
470 install -d $RPM_BUILD_ROOT/var/cache/%{name}
471 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
472 install -d $RPM_BUILD_ROOT/var/run/%{name}
473
474 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
475 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
476 d /var/run/%{name} 0755 root root -
477 EOF
478
479 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/problem/*.la
480 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
481 # examples
482 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/problem_examples
483 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
484 # outdated copy of lt
485 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/lt_LT
486
487 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
488 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
489
490 %find_lang %{name}
491
492 %clean
493 rm -rf $RPM_BUILD_ROOT
494
495 %pre
496 %groupadd -g 248 abrt
497 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
498
499 %post
500 /sbin/chkconfig --add abrtd
501 %service abrtd restart
502 %systemd_post abrtd.service
503
504 %preun
505 if [ "$1" = "0" ]; then
506         %service abrtd stop
507         /sbin/chkconfig --del abrtd
508 fi
509 %systemd_preun abrtd.service
510
511 %postun
512 if [ "$1" = "0" ]; then
513         %userremove abrt
514         %groupremove abrt
515 fi
516
517 %post   libs -p /sbin/ldconfig
518 %postun libs -p /sbin/ldconfig
519
520 %post addon-ccpp
521 %systemd_post abrt-ccpp.service
522
523 %preun addon-ccpp
524 %systemd_preun abrt-ccpp.service
525
526 %post addon-kerneloops
527 %systemd_post abrt-oops.service
528
529 %preun addon-kerneloops
530 %systemd_preun abrt-oops.service
531
532 %post addon-pstoreoops
533 %systemd_post abrt-pstoreoops.service
534
535 %preun addon-pstoreoops
536 %systemd_preun abrt-pstoreoops.service
537
538 %post addon-upload-watch
539 %systemd_post abrt-upload-watch.service
540
541 %preun addon-upload-watch
542 %systemd_preun abrt-upload-watch.service
543
544 %post addon-vmcore
545 %systemd_post abrt-vmcore.service
546
547 %preun addon-vmcore
548 %systemd_preun abrt-vmcore.service
549
550 %post addon-xorg
551 %systemd_post abrt-xorg.service
552
553 %preun addon-xorg
554 %systemd_preun abrt-xorg.service
555
556 %post gui
557 %update_icon_cache hicolor
558
559 %postun gui
560 %update_icon_cache hicolor
561
562 %post   gui-libs -p /sbin/ldconfig
563 %postun gui-libs -p /sbin/ldconfig
564
565 %files -f %{name}.lang
566 %defattr(644,root,root,755)
567 %doc README
568 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
569 %attr(755,root,root) %{_bindir}/abrt-action-notify
570 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
571 %attr(755,root,root) %{_bindir}/abrt-handle-upload
572 %attr(755,root,root) %{_bindir}/abrt-watch-log
573 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
574 %attr(755,root,root) %{_sbindir}/abrt-server
575 %attr(755,root,root) %{_sbindir}/abrtd
576 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
577 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
578 %dir %{_datadir}/%{name}
579 %dir %{_datadir}/%{name}/conf.d
580 %{_datadir}/%{name}/conf.d/abrt.conf
581 %{_datadir}/%{name}/conf.d/abrt-action-save-package-data.conf
582 %{_datadir}/%{name}/conf.d/gpg_keys.conf
583 %dir %{_datadir}/%{name}/conf.d/plugins
584 %{_datadir}/augeas/lenses/abrt.aug
585 %dir %{_sysconfdir}/%{name}
586 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
587 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
588 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
589 %dir %{_sysconfdir}/%{name}/plugins
590 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
591 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
592 %attr(754,root,root) /etc/rc.d/init.d/abrtd
593 %{systemdunitdir}/abrtd.service
594 %attr(775,root,abrt) %dir /var/cache/%{name}
595 %dir /var/run/%{name}
596 %{systemdtmpfilesdir}/abrt.conf
597 %{_mandir}/man1/abrt-action-analyze-python.1*
598 %{_mandir}/man1/abrt-action-notify.1*
599 %{_mandir}/man1/abrt-action-save-package-data.1*
600 %{_mandir}/man1/abrt-auto-reporting.1*
601 %{_mandir}/man1/abrt-handle-upload.1*
602 %{_mandir}/man1/abrt-server.1*
603 %{_mandir}/man1/abrt-watch-log.1*
604 %{_mandir}/man5/abrt.conf.5*
605 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
606 %{_mandir}/man5/abrt_event.conf.5*
607 %{_mandir}/man5/gpg_keys.conf.5*
608 %{_mandir}/man5/smart_event.conf.5*
609 %{_mandir}/man8/abrtd.8*
610
611 %files libs
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
614 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
615
616 %files devel
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_libdir}/libabrt.so
619 %dir %{_includedir}/abrt
620 %{_includedir}/abrt/abrt-dbus.h
621 %{_includedir}/abrt/hooklib.h
622 %{_includedir}/abrt/libabrt.h
623 %{_includedir}/abrt/problem_api.h
624 %{_pkgconfigdir}/abrt.pc
625
626 %files addon-ccpp
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
629 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
630 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
631 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
632 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
633 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
634 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
635 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
636 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
637 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
638 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
639 %attr(755,root,root) %{_sbindir}/abrt-install-ccpp-hook
640 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
641 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
642 %attr(755,root,root) %{_libexecdir}/abrt-hook-ccpp
643 %dir %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
644 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
647 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
648 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
649 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
650 %{_datadir}/libreport/events/analyze_CCpp.xml
651 %{_datadir}/libreport/events/analyze_LocalGDB.xml
652 %{_datadir}/libreport/events/collect_GConf.xml
653 %{_datadir}/libreport/events/collect_vimrc_system.xml
654 %{_datadir}/libreport/events/collect_vimrc_user.xml
655 %{_datadir}/libreport/events/collect_xsession_errors.xml
656 %{_datadir}/libreport/events/post_report.xml
657 %{systemdunitdir}/abrt-ccpp.service
658 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
659 %{_mandir}/man1/abrt-action-analyze-c.1*
660 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
661 %{_mandir}/man1/abrt-action-analyze-core.1*
662 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
663 %{_mandir}/man1/abrt-action-generate-backtrace.1*
664 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
665 %{_mandir}/man1/abrt-action-install-debuginfo.1*
666 %{_mandir}/man1/abrt-action-list-dsos.1*
667 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
668 %{_mandir}/man1/abrt-action-trim-files.1*
669 %{_mandir}/man1/abrt-install-ccpp-hook.1*
670 %{_mandir}/man5/abrt-CCpp.conf.5*
671 %{_mandir}/man5/ccpp_event.conf.5*
672 %{_mandir}/man5/ccpp_retrace_event.conf.5*
673 %{_mandir}/man5/gconf_event.conf.5*
674 %{_mandir}/man5/vimrc_event.conf.5*
675
676 %files addon-kerneloops
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
679 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
680 %attr(755,root,root) %{_bindir}/abrt-action-save-kernel-data
681 %attr(755,root,root) %{_bindir}/abrt-dump-oops
682 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
683 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
684 %{systemdunitdir}/abrt-oops.service
685 %{_mandir}/man1/abrt-action-analyze-oops.1*
686 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
687 %{_mandir}/man1/abrt-action-save-kernel-data.1*
688 %{_mandir}/man1/abrt-dump-oops.1*
689 %{_mandir}/man5/koops_event.conf.5*
690
691 %files addon-pstoreoops
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
694 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
695 %{systemdunitdir}/abrt-pstoreoops.service
696 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
697 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
698 %{_mandir}/man1/abrt-merge-pstoreoops.1*
699
700 %files addon-python
701 %defattr(644,root,root,755)
702 %{_datadir}/%{name}/conf.d/plugins/python.conf
703 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python.conf
704 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python_event.conf
705 %{py_sitedir}/abrt_exception_handler.py[co]
706 %{py_sitedir}/abrt.pth
707 %{_mandir}/man5/abrt-python.conf.5*
708 %{_mandir}/man5/python_event.conf.5*
709
710 %files addon-python3
711 %defattr(644,root,root,755)
712 %{_datadir}/%{name}/conf.d/plugins/python3.conf
713 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
714 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
715 %{py3_sitedir}/abrt_exception_handler3.py*
716 %{py3_sitedir}/abrt3.pth
717 %{_mandir}/man5/abrt-python3.conf.5*
718 %{_mandir}/man5/python3_event.conf.5*
719
720 %files addon-upload-watch
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
723 %{systemdunitdir}/abrt-upload-watch.service
724 %{_mandir}/man1/abrt-upload-watch.1*
725
726 %files addon-vmcore
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
729 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
730 %dir %{_datadir}/%{name}/conf.d/plugins/vmcore.conf
731 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
732 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
733 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
734 %{_datadir}/libreport/events/analyze_VMcore.xml
735 %{systemdunitdir}/abrt-vmcore.service
736 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
737 %{_mandir}/man1/abrt-harvest-vmcore.1*
738 %{_mandir}/man5/abrt-vmcore.conf.5*
739 %{_mandir}/man5/vmcore_event.conf.5*
740
741 %files addon-xorg
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
744 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
745 %dir %{_datadir}/%{name}/conf.d/plugins/xorg.conf
746 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
747 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
748 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
749 %{systemdunitdir}/abrt-xorg.service
750 %{_mandir}/man1/abrt-action-analyze-xorg.1*
751 %{_mandir}/man1/abrt-dump-xorg.1*
752 %{_mandir}/man5/abrt-xorg.conf.5*
753 %{_mandir}/man5/xorg_event.conf.5*
754
755 %files plugin-bodhi
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/abrt-bodhi
758 %{_mandir}/man1/abrt-bodhi.1*
759
760 %files retrace-client
761 %defattr(644,root,root,755)
762 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
763 %attr(755,root,root) %{_bindir}/abrt-retrace-client
764 %{_datadir}/libreport/events/analyze_RetraceServer.xml
765 %{_mandir}/man1/abrt-retrace-client.1*
766
767 %files dbus
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_sbindir}/abrt-configuration
770 %attr(755,root,root) %{_sbindir}/abrt-dbus
771 /etc/dbus-1/system.d/dbus-abrt.conf
772 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.abrt.xml
773 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ccpp.xml
774 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.python.xml
775 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.vmcore.xml
776 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xml
777 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xorg.xml
778 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
779 %{_datadir}/dbus-1/system-services/com.redhat.problems.configuration.service
780 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
781 %{_datadir}/polkit-1/actions/abrt_polkit.policy
782 %{_mandir}/man8/abrt-configuration.8*
783 %{_mandir}/man8/abrt-dbus.8*
784 %{_docdir}/abrt-dbus-%{version}
785
786 %files python
787 %defattr(644,root,root,755)
788 %dir %{py_sitedir}/problem
789 %attr(755,root,root) %{py_sitedir}/problem/_pyabrt.so
790 %{py_sitedir}/problem/*.py[co]
791 %{_mandir}/man5/abrt-python.5*
792
793 %files python3
794 %defattr(644,root,root,755)
795 %dir %{py3_sitedir}/problem
796 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
797 %{py3_sitedir}/problem/*.py*
798 %{_mandir}/man5/abrt-python3.5*
799
800 %files cli
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_bindir}/abrt-cli
803 %{_mandir}/man1/abrt-cli.1*
804
805 %files gui
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_bindir}/abrt-applet
808 %attr(755,root,root) %{_bindir}/system-config-abrt
809 %dir %{_datadir}/%{name}
810 %{_datadir}/%{name}/icons
811 %{_datadir}/%{name}/ui
812 %{_iconsdir}/hicolor/*/apps/abrt.png
813 %{_iconsdir}/hicolor/*/status/abrt.png
814 %{_sysconfdir}/xdg/autostart/abrt-applet.desktop
815 %{_mandir}/man1/abrt-applet.1*
816 %{_mandir}/man1/system-config-abrt.1*
817
818 %files gui-libs
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
821 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
822
823 %files gui-devel
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libabrt_gui.so
826 %{_includedir}/abrt/abrt-config-widget.h
827 %{_includedir}/abrt/system-config-abrt.h
828 %{_pkgconfigdir}/abrt_gui.pc
829
830 %files desktop
831 %defattr(644,root,root,755)
832
833 %files console-notification
834 %defattr(644,root,root,755)
835 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.11507 seconds and 3 git commands to generate.