]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
af9182f17342f298c70c0f101d5a0fb0fd610b41
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
4 #
5 # Conditional build:
6 %bcond_without  tests   # disable pythontests
7 %bcond_with     rpm5    # build with rpm5
8
9 %define         libreport_ver   2.13.0
10 Summary:        Automatic bug detection and reporting tool
11 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
12 Name:           abrt
13 Version:        2.14.4
14 Release:        4
15 License:        GPL v2+
16 Group:          Applications/System
17 #Source0Download: https://github.com/abrt/abrt/releases
18 Source0:        https://github.com/abrt/abrt/archive/%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  c7583c001464cb2ec0067afb08cdc6cb
20 Source1:        %{name}.init
21 Patch0:         %{name}-rpm5.patch
22 Patch2:         %{name}-link.patch
23 Patch3:         %{name}-split-usr.patch
24 URL:            https://abrt.readthedocs.org/
25 BuildRequires:  asciidoc
26 %{?with_tests:BuildRequires:    augeas}
27 BuildRequires:  autoconf >= 2.50
28 BuildRequires:  automake
29 BuildRequires:  dbus-devel
30 BuildRequires:  docbook-dtd45-xml
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.55.1
33 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
34 BuildRequires:  gtk+3-devel >= 3.0
35 BuildRequires:  intltool >= 0.35.0
36 BuildRequires:  json-c-devel
37 BuildRequires:  libgomp-devel
38 BuildRequires:  libnotify-devel >= 0.7.0
39 BuildRequires:  libreport-devel >= %{libreport_ver}
40 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
41 BuildRequires:  libreport-web-devel >= %{libreport_ver}
42 BuildRequires:  libselinux-devel
43 BuildRequires:  libsoup-devel >= 2.4
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2
46 BuildRequires:  pkgconfig
47 BuildRequires:  polkit-devel
48 BuildRequires:  python3-devel >= 1:3.6
49 BuildRequires:  python3-modules >= 1:3.6
50 %{?with_tests:BuildRequires:    python3-nose}
51 %{?with_tests:BuildRequires:    python3-pytest}
52 BuildRequires:  rpm-build >= 4.6
53 BuildRequires:  rpm-devel >= 4.5-28
54 BuildRequires:  rpm-pythonprov
55 BuildRequires:  rpmbuild(macros) >= 1.752
56 BuildRequires:  satyr-devel >= 0.21
57 BuildRequires:  sphinx-pdg-3
58 BuildRequires:  systemd-devel >= 1:209
59 BuildRequires:  xmlto
60 Requires(postun):       /usr/sbin/groupdel
61 Requires(postun):       /usr/sbin/userdel
62 Requires(pre):  /bin/id
63 Requires(pre):  /usr/bin/getgid
64 Requires(pre):  /usr/sbin/groupadd
65 Requires(pre):  /usr/sbin/useradd
66 Requires:       %{name}-libs = %{version}-%{release}
67 Provides:       group(abrt)
68 Provides:       user(abrt)
69 Obsoletes:      abrt-addon-coredump-helper < 2.13.0
70 Obsoletes:      abrt-addon-python < 2.13.0
71 Obsoletes:      abrt-atomic < 2.13.0
72 Obsoletes:      abrt-cli < 2.13.0
73 Obsoletes:      abrt-plugin-catcut < 2.1
74 Obsoletes:      abrt-plugin-filetransfer < 2.1
75 Obsoletes:      abrt-plugin-rhfastcheck < 2.1
76 Obsoletes:      abrt-plugin-rhticket < 2.1
77 Obsoletes:      abrt-plugin-runapp < 2.1
78 Obsoletes:      abrt-plugin-sosreport < 2.1
79 Obsoletes:      abrt-plugin-sqlite3 < 1.0.7
80 Obsoletes:      abrt-plugin-ticketuploader < 2.1
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 ABRT is a tool to help users to detect defects in applications and to
85 create a bug report with all informations needed by maintainer to fix
86 it. It uses plugin system to extend its functionality.
87
88 %description -l pl.UTF-8
89 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
90 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
91 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
92 system wtyczek do rozszerzania funkcjonalności.
93
94 %package -n bash-completion-abrt
95 Summary:        Bash completion for abrt command
96 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla polecenia abrt
97 Group:          Applications/Shells
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       bash-completion
100 Requires:       python3-argcomplete
101 BuildArch:      noarch
102
103 %description -n bash-completion-abrt
104 Bash completion for abrt command.
105
106 %description -n bash-completion-abrt -l pl.UTF-8
107 Bashowe dopełnianie parametrów dla polecenia abrt.
108
109 %package libs
110 Summary:        ABRT shared library
111 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
112 Group:          Libraries
113 Requires:       glib2 >= 1:2.55.1
114 Requires:       libreport >= %{libreport_ver}
115
116 %description libs
117 ABRT shared library.
118
119 %description libs -l pl.UTF-8
120 Biblioteka współdzielona ABRT.
121
122 %package devel
123 Summary:        Header files for ABRT livrary
124 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
125 Group:          Development/Libraries
126 Requires:       %{name}-libs = %{version}-%{release}
127 Requires:       glib2-devel >= 1:2.55.1
128 Requires:       libreport-devel >= %{libreport_ver}
129
130 %description devel
131 Header files for ABRT livrary.
132
133 %description devel -l pl.UTF-8
134 Pliki nagłówkowe biblioteki ABRT.
135
136 %package addon-ccpp
137 Summary:        ABRT's C/C++ addon
138 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       %{name}-retrace-client = %{version}-%{release}
142 Requires:       cpio
143 Requires:       elfutils
144 Requires:       gdb >= 7.0-3
145 Requires:       satyr >= 0.21
146 Requires:       yum-utils
147 Obsoletes:      abrt-atomic < 2.13
148
149 %description addon-ccpp
150 This package contains hook for C/C++ crashed programs and abrt's C/C++
151 analyzer plugin.
152
153 %description addon-ccpp -l pl.UTF-8
154 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
155 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
156
157 %package addon-kerneloops
158 Summary:        ABRT's kerneloops addon
159 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
160 Group:          Libraries
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       curl
163 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
164 Obsoletes:      abrt-plugin-kerneloops < 0.0.7.2
165 Obsoletes:      abrt-plugin-kerneloopsreporter < 1.0.7
166 Obsoletes:      kerneloops < 0.0.7.2
167
168 %description addon-kerneloops
169 This package contains plugin for collecting kernel crash information
170 from system log.
171
172 %description addon-kerneloops -l pl.UTF-8
173 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
174 logu systemowego.
175
176 %package addon-pstoreoops
177 Summary:        ABRT's pstoreoops addon
178 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
179 Group:          Libraries
180 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
181 Obsoletes:      abrt-addon-uefioops < 2.1.7
182
183 %description addon-pstoreoops
184 This package contains plugin for collecting kernel oopses from pstore
185 storage.
186
187 %description addon-pstoreoops -l pl.UTF-8
188 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
189
190 %package addon-python3
191 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
192 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
193 Group:          Libraries
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       %{name}-python3 = %{version}-%{release}
196 # for detecting package name containing offending file
197 %{!?with_rpm5:Suggests: python3-rpm}
198 # for logging to journal
199 Suggests:       python3-systemd
200
201 %description addon-python3
202 This package contains Python hook and Python analyzer plugin for
203 handling uncaught exception in Python 3 programs.
204
205 %description addon-python3 -l pl.UTF-8
206 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
207 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
208 Pythonie 3.
209
210 %package addon-upload-watch
211 Summary:        ABRT's upload addon
212 Summary(pl.UTF-8):      Dodatek upload do ABRT
213 Group:          Libraries
214 Requires:       %{name} = %{version}-%{release}
215
216 %description addon-upload-watch
217 This package contains hook for uploaded problems.
218
219 %description addon-upload-watch -l pl.UTF-8
220 Ten pakiet zawiera uchwyt dla problemów przysłanych.
221
222 %package addon-vmcore
223 Summary:        ABRT's vmcore addon
224 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
228 Requires:       crash
229
230 %description addon-vmcore
231 This package contains plugin for collecting kernel crash information
232 from vmcore files.
233
234 %description addon-vmcore -l pl.UTF-8
235 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
236 plików vmcore.
237
238 %package addon-xorg
239 Summary:        ABRT's Xorg addon
240 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       curl
244
245 %description addon-xorg
246 This package contains plugin for collecting Xorg crash information
247 from Xorg log.
248
249 %description addon-xorg -l pl.UTF-8
250 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
251 logu Xorg.
252
253 %package plugin-bodhi
254 Summary:        ABRT's bodhi plugin
255 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
256 Group:          Libraries
257 Requires:       %{name} = %{version}-%{release}
258 Requires:       libreport-web >= %{libreport_ver}
259 Obsoletes:      libreport-plugin-bodhi < 2.0.16
260
261 %description plugin-bodhi
262 Plugin to search for a new updates in bodhi server.
263
264 %description plugin-bodhi -l pl.UTF-8
265 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
266
267 %package retrace-client
268 Summary:        ABRT's retrace client
269 Summary(pl.UTF-8):      Klient Retrace dla ABRT
270 Group:          Libraries
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       xz
273
274 %description retrace-client
275 This package contains the client application for Retrace server which
276 is able to analyze C/C++ crashes remotely.
277
278 %description retrace-client -l pl.UTF-8
279 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
280 potrafi zdalnie przeanalizować awarię programu w C/C++.
281
282 %package dbus
283 Summary:        ABRT DBus service
284 Summary(pl.UTF-8):      Usługa DBus ABRT
285 Group:          Applications/System
286 Requires:       %{name} = %{version}-%{release}
287 Requires:       libreport >= %{libreport_ver}
288
289 %description dbus
290 ABRT DBus service which provides org.freedesktop.problems API on DBus
291 and uses PolicyKit to authorize to access the problem data.
292
293 %description dbus -l pl.UTF-8
294 Usługa DBus ABRT, udostępniająca poprzez DBus API
295 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
296 do danych o problemach.
297
298 %package python3
299 Summary:        ABRT Python 3 API
300 Summary(pl.UTF-8):      API Pythona 3 do ABRT
301 Group:          Libraries/Python
302 Requires:       %{name} = %{version}-%{release}
303 Requires:       python3-libreport >= %{libreport_ver}
304 Obsoletes:      abrt-python < 2.13.0
305
306 %description python3
307 High-level API for querying, creating and manipulating problems
308 handled by ABRT in Python.
309
310 %description python3 -l pl.UTF-8
311 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
312 Pythona 3 problemów obsługiwanych przez ABRT.
313
314 %package gui
315 Summary:        ABRT's GUI
316 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
317 Group:          X11/Applications
318 Requires(post,postun):  /sbin/ldconfig
319 Requires(post,postun):  gtk-update-icon-cache
320 Requires(post,postun):  hicolor-icon-theme
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       %{name}-dbus = %{version}-%{release}
323 Requires:       %{name}-gui-libs = %{version}-%{release}
324 Suggests:       gnome-abrt
325 Provides:       abrt-applet = %{version}-%{release}
326 Obsoletes:      abrt-applet < 0.0.5
327 Conflicts:      abrt-applet < 0.0.5
328
329 %description gui
330 GTK+ wizard for convenient bug reporting.
331
332 %description gui -l pl.UTF-8
333 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
334
335 %package gui-libs
336 Summary:        ABRT's GUI library
337 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
338 Group:          X11/Libraries
339 Requires:       %{name}-libs = %{version}-%{release}
340 Requires:       gtk+3 >= 3.0
341
342 %description gui-libs
343 ABRT's GUI library.
344
345 %description gui-libs -l pl.UTF-8
346 Biblioteka graficznego interfejsu użytkownika ABRT.
347
348 %package gui-devel
349 Summary:        Header files for ABRT GUI library
350 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
351 Group:          X11/Development/Libraries
352 Requires:       %{name}-devel = %{version}-%{release}
353 Requires:       %{name}-gui-libs = %{version}-%{release}
354 Requires:       gtk+3-devel >= 3.0
355
356 %description gui-devel
357 Header files for ABRT GUI library.
358
359 %description gui-devel -l pl.UTF-8
360 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
361
362 %package desktop
363 Summary:        Virtual package to install all necessary packages for usage from desktop environment
364 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
365 Group:          X11/Applications
366 # This package should be installed when anything requests bug-buddy;
367 # installing abrt-desktop should result in the abrt which works without
368 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       %{name}-addon-ccpp = %{version}-%{release}
371 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
372 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
373 Requires:       %{name}-addon-python3 = %{version}-%{release}
374 Requires:       %{name}-addon-vmcore = %{version}-%{release}
375 Requires:       %{name}-addon-xorg = %{version}-%{release}
376 Requires:       %{name}-gui = %{version}-%{release}
377 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
378 Requires:       %{name}-retrace-client = %{version}-%{release}
379 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
380 Requires:       libreport-plugin-logger >= %{libreport_ver}
381 Requires:       libreport-plugin-ureport >= %{libreport_ver}
382 Provides:       bug-buddy
383 Obsoletes:      bug-buddy < 2.33
384
385 %description desktop
386 Virtual package to make easy default installation on desktop
387 environments.
388
389 %description desktop -l pl.UTF-8
390 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
391 graficznych.
392
393 %package console-notification
394 Summary:        ABRT console notification script
395 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
396 Group:          Applications/System
397 Requires:       %{name} = %{version}-%{release}
398
399 %description console-notification
400 A small script which prints a count of detected problems when someone
401 logs in to the shell.
402
403 %description console-notification -l pl.UTF-8
404 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
405 się do powłoki.
406
407 %prep
408 %setup -q
409 %{?with_rpm5:%patch0 -p1}
410 %patch2 -p1
411 %patch3 -p1
412
413 %{__sed} -n -e '/^%%changelog/,$p' abrt.spec.in | tail -n +2 > changelog
414
415 echo -n %{version} > abrt-version
416
417 %build
418 %{__libtoolize}
419 %{__gettextize}
420 %{__intltoolize}
421 %{__aclocal} -I m4
422 %{__autoconf}
423 %{__autoheader}
424 %{__automake}
425 %configure \
426         AUGPARSE=/usr/bin/augparse \
427         PYTHON_NOSE=/usr/bin/nosetests-%{py3_ver} \
428         --enable-dump-time-unwind \
429         --enable-native-unwinder \
430         --disable-silent-rules \
431         %{!?with_tests:--without-pythontests} \
432         --with-systemdsystemunitdir=%{systemdunitdir}
433
434 %{__make}
435
436 %install
437 rm -rf $RPM_BUILD_ROOT
438 %{__make} install \
439         DESTDIR=$RPM_BUILD_ROOT \
440         systemdsystemunitdir=%{systemdunitdir} \
441         python3dir=%{py3_sitescriptdir}
442
443 # obsoleted by pkg-config
444 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
445
446 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
447 install -d $RPM_BUILD_ROOT/var/cache/%{name}
448 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
449 install -d $RPM_BUILD_ROOT/var/run/%{name}
450
451 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
452 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
453 d /var/run/%{name} 0755 root root -
454 EOF
455
456 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
457 # examples
458 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
459 # packaged as %doc
460 %{__rm} $RPM_BUILD_ROOT%{_docdir}/abrt/README.md
461
462 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
463 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
464
465 %find_lang %{name}
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %pre
471 %groupadd -g 248 abrt
472 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
473
474 %post
475 /sbin/chkconfig --add abrtd
476 %service abrtd restart
477 %systemd_post abrtd.service
478
479 %preun
480 if [ "$1" = "0" ]; then
481         %service abrtd stop
482         /sbin/chkconfig --del abrtd
483 fi
484 %systemd_preun abrtd.service
485
486 %postun
487 if [ "$1" = "0" ]; then
488         %userremove abrt
489         %groupremove abrt
490 fi
491
492 %post   libs -p /sbin/ldconfig
493 %postun libs -p /sbin/ldconfig
494
495 %post addon-ccpp
496 %systemd_post abrt-ccpp.service
497 %systemd_post abrt-journal-core.service
498 %journal_catalog_update
499
500 %preun addon-ccpp
501 %systemd_preun abrt-ccpp.service
502 %systemd_preun abrt-journal-core.service
503
504 %post addon-kerneloops
505 %systemd_post abrt-oops.service
506 %journal_catalog_update
507
508 %preun addon-kerneloops
509 %systemd_preun abrt-oops.service
510
511 %post addon-pstoreoops
512 %systemd_post abrt-pstoreoops.service
513
514 %preun addon-pstoreoops
515 %systemd_preun abrt-pstoreoops.service
516
517 %post addon-python3
518 %journal_catalog_update
519
520 %post addon-upload-watch
521 %systemd_post abrt-upload-watch.service
522
523 %preun addon-upload-watch
524 %systemd_preun abrt-upload-watch.service
525
526 %post addon-vmcore
527 %systemd_post abrt-vmcore.service
528 %journal_catalog_update
529
530 %preun addon-vmcore
531 %systemd_preun abrt-vmcore.service
532
533 %post addon-xorg
534 %systemd_post abrt-xorg.service
535 %journal_catalog_update
536
537 %preun addon-xorg
538 %systemd_preun abrt-xorg.service
539
540 %post gui
541 %update_icon_cache hicolor
542
543 %postun gui
544 %update_icon_cache hicolor
545
546 %post   gui-libs -p /sbin/ldconfig
547 %postun gui-libs -p /sbin/ldconfig
548
549 %files -f %{name}.lang
550 %defattr(644,root,root,755)
551 %doc CHANGELOG.md README.md changelog
552 %attr(755,root,root) %{_bindir}/abrt
553 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
554 %attr(755,root,root) %{_bindir}/abrt-action-notify
555 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
556 %attr(755,root,root) %{_bindir}/abrt-handle-upload
557 %attr(755,root,root) %{_bindir}/abrt-watch-log
558 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
559 %attr(755,root,root) %{_sbindir}/abrt-server
560 %attr(755,root,root) %{_sbindir}/abrtd
561 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
562 %attr(755,root,root) %{_libexecdir}/abrt-action-save-container-data
563 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
564 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
565 %{py3_sitescriptdir}/abrtcli
566 %dir %{_datadir}/%{name}
567 %{_datadir}/augeas/lenses/abrt.aug
568 %dir %{_sysconfdir}/%{name}
569 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
570 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
571 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
572 %dir %{_sysconfdir}/%{name}/plugins
573 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/machine-id_event.conf
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
576 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/sosreport_event.conf
577 %attr(754,root,root) /etc/rc.d/init.d/abrtd
578 %{systemdunitdir}/abrtd.service
579 %attr(775,root,abrt) %dir /var/cache/%{name}
580 %dir /var/run/%{name}
581 %{systemdtmpfilesdir}/abrt.conf
582 %{_mandir}/man1/abrt.1*
583 %{_mandir}/man1/abrt-action-analyze-python.1*
584 %{_mandir}/man1/abrt-action-notify.1*
585 %{_mandir}/man1/abrt-action-save-package-data.1*
586 %{_mandir}/man1/abrt-auto-reporting.1*
587 %{_mandir}/man1/abrt-handle-upload.1*
588 %{_mandir}/man1/abrt-server.1*
589 %{_mandir}/man1/abrt-watch-log.1*
590 %{_mandir}/man5/abrt.conf.5*
591 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
592 %{_mandir}/man5/abrt_event.conf.5*
593 %{_mandir}/man5/report_event.conf.5
594 %{_mandir}/man5/gpg_keys.conf.5*
595 %{_mandir}/man5/smart_event.conf.5*
596 %{_mandir}/man8/abrtd.8*
597
598 %files -n bash-completion-abrt
599 %defattr(644,root,root,755)
600 /etc/bash_completion.d/abrt.bash_completion
601
602 %files libs
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
605 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
606
607 %files devel
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/libabrt.so
610 %dir %{_includedir}/abrt
611 %{_includedir}/abrt/abrt-dbus.h
612 %{_includedir}/abrt/hooklib.h
613 %{_includedir}/abrt/libabrt.h
614 %{_includedir}/abrt/problem_api.h
615 %{_pkgconfigdir}/abrt.pc
616
617 %files addon-ccpp
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
620 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
621 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
622 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
623 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
624 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
625 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
626 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
627 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
628 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
629 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
630 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
631 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
632 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
633 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
634 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
635 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
637 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_journal_ccpp_format.conf
638 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
639 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
640 %{_datadir}/libreport/events/analyze_CCpp.xml
641 %{_datadir}/libreport/events/analyze_LocalGDB.xml
642 %{_datadir}/libreport/events/collect_GConf.xml
643 %{_datadir}/libreport/events/collect_vimrc_system.xml
644 %{_datadir}/libreport/events/collect_vimrc_user.xml
645 %{_datadir}/libreport/events/collect_xsession_errors.xml
646 %{_datadir}/libreport/events/post_report.xml
647 %{systemdunitdir}/abrt-journal-core.service
648 %{_prefix}/lib/systemd/catalog/abrt_ccpp.catalog
649 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
650 %{_mandir}/man1/abrt-action-analyze-c.1*
651 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
652 %{_mandir}/man1/abrt-action-analyze-core.1*
653 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
654 %{_mandir}/man1/abrt-action-generate-backtrace.1*
655 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
656 %{_mandir}/man1/abrt-action-install-debuginfo.1*
657 %{_mandir}/man1/abrt-action-list-dsos.1*
658 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
659 %{_mandir}/man1/abrt-action-trim-files.1*
660 %{_mandir}/man1/abrt-dump-journal-core.1*
661 %{_mandir}/man5/abrt-CCpp.conf.5*
662 %{_mandir}/man5/ccpp_event.conf.5*
663 %{_mandir}/man5/ccpp_retrace_event.conf.5*
664 %{_mandir}/man5/gconf_event.conf.5*
665 %{_mandir}/man5/vimrc_event.conf.5*
666
667 %files addon-kerneloops
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
670 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-alt-component
671 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
672 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
673 %attr(755,root,root) %{_bindir}/abrt-dump-oops
674 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
675 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_koops_format.conf
676 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
677 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
678 %{systemdunitdir}/abrt-oops.service
679 %{_prefix}/lib/systemd/catalog/abrt_koops.catalog
680 %{_mandir}/man1/abrt-action-analyze-oops.1*
681 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
682 %{_mandir}/man1/abrt-dump-journal-oops.1*
683 %{_mandir}/man1/abrt-dump-oops.1*
684 %{_mandir}/man5/abrt-oops.conf.5*
685 %{_mandir}/man5/koops_event.conf.5*
686
687 %files addon-pstoreoops
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
690 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
691 %{systemdunitdir}/abrt-pstoreoops.service
692 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
693 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
694 %{_mandir}/man1/abrt-merge-pstoreoops.1*
695
696 %files addon-python3
697 %defattr(644,root,root,755)
698 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
699 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
700 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_python3_format.conf
701 %{py3_sitescriptdir}/abrt_exception_handler3.py*
702 %{py3_sitescriptdir}/abrt_exception_handler3_container.py*
703 %{py3_sitescriptdir}/abrt3.pth
704 %{py3_sitescriptdir}/abrt3_container.pth
705 %{py3_sitescriptdir}/__pycache__/abrt_exception_handler3*.cpython-*.py[co]
706 %{_prefix}/lib/systemd/catalog/python3_abrt.catalog
707 %{_mandir}/man5/python3_event.conf.5*
708 %{_mandir}/man5/python3-abrt.conf.5*
709
710 %files addon-upload-watch
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
713 %{systemdunitdir}/abrt-upload-watch.service
714 %{_mandir}/man1/abrt-upload-watch.1*
715
716 %files addon-vmcore
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
719 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
720 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
721 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
722 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_vmcore_format.conf
723 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
724 %{_datadir}/libreport/events/analyze_VMcore.xml
725 %{systemdunitdir}/abrt-vmcore.service
726 %{_prefix}/lib/systemd/catalog/abrt_vmcore.catalog
727 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
728 %{_mandir}/man1/abrt-harvest-vmcore.1*
729 %{_mandir}/man5/abrt-vmcore.conf.5*
730 %{_mandir}/man5/vmcore_event.conf.5*
731
732 %files addon-xorg
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
735 %attr(755,root,root) %{_bindir}/abrt-dump-journal-xorg
736 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
737 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_xorg_format.conf
740 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
741 %{systemdunitdir}/abrt-xorg.service
742 %{_prefix}/lib/systemd/catalog/abrt_xorg.catalog
743 %{_mandir}/man1/abrt-action-analyze-xorg.1*
744 %{_mandir}/man1/abrt-dump-journal-xorg.1*
745 %{_mandir}/man1/abrt-dump-xorg.1*
746 %{_mandir}/man5/abrt-xorg.conf.5*
747 %{_mandir}/man5/xorg_event.conf.5*
748
749 %files plugin-bodhi
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_bindir}/abrt-action-find-bodhi-update
752 %attr(755,root,root) %{_bindir}/abrt-bodhi
753 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/bodhi_event.conf
754 %{_datadir}/libreport/events/analyze_BodhiUpdates.xml
755 %{_mandir}/man1/abrt-action-find-bodhi-update.1*
756 %{_mandir}/man1/abrt-bodhi.1*
757
758 %files retrace-client
759 %defattr(644,root,root,755)
760 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
761 %attr(755,root,root) %{_bindir}/abrt-retrace-client
762 %{_datadir}/libreport/events/analyze_RetraceServer.xml
763 %{_mandir}/man1/abrt-retrace-client.1*
764
765 %files dbus
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_sbindir}/abrt-dbus
768 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_dbus_event.conf
769 /etc/dbus-1/system.d/dbus-abrt.conf
770 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
771 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.xml
772 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Entry.xml
773 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Session.xml
774 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Task.xml
775 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
776 %{_datadir}/polkit-1/actions/abrt_polkit.policy
777 %{_mandir}/man8/abrt-dbus.8*
778 %{_docdir}/abrt-dbus-%{version}
779
780 %files python3
781 %defattr(644,root,root,755)
782 %dir %{py3_sitedir}/problem
783 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
784 %{py3_sitedir}/problem/*.py*
785 %{py3_sitedir}/problem/__pycache__
786 %{_mandir}/man5/python3-abrt.5*
787
788 %files gui
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_bindir}/abrt-applet
791 %attr(755,root,root) %{_bindir}/system-config-abrt
792 %dir %{_datadir}/%{name}
793 %{_datadir}/%{name}/ui
794 %{_iconsdir}/hicolor/scalable/apps/abrt.svg
795 %{_iconsdir}/hicolor/symbolic/apps/abrt-symbolic.svg
796 %{_sysconfdir}/xdg/autostart/org.freedesktop.problems.applet.desktop
797 %{_datadir}/dbus-1/services/org.freedesktop.problems.applet.service
798 %{_mandir}/man1/abrt-applet.1*
799 %{_mandir}/man1/system-config-abrt.1*
800
801 %files gui-libs
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
804 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
805
806 %files gui-devel
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libabrt_gui.so
809 %{_includedir}/abrt/abrt-config-widget.h
810 %{_includedir}/abrt/system-config-abrt.h
811 %{_pkgconfigdir}/abrt_gui.pc
812
813 %files desktop
814 %defattr(644,root,root,755)
815
816 %files console-notification
817 %defattr(644,root,root,755)
818 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.099358 seconds and 2 git commands to generate.