]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- up to 2.14.1
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
4 #
5 # Conditional build:
6 %bcond_without  tests   # disable pythontests
7
8 %define         libreport_ver   2.10.0
9 Summary:        Automatic bug detection and reporting tool
10 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
11 Name:           abrt
12 Version:        2.14.1
13 Release:        1
14 License:        GPL v2+
15 Group:          Applications/System
16 #Source0Download: https://github.com/abrt/abrt/releases
17 Source0:        https://github.com/abrt/abrt/archive/%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  5b1e164ee1f705ca7000b37083775d52
19 Source1:        %{name}.init
20 Patch0:         %{name}-rpm5.patch
21 Patch1:         %{name}-rpm45.patch
22 Patch2:         %{name}-link.patch
23 Patch3:         %{name}-split-usr.patch
24 URL:            https://abrt.readthedocs.org/
25 BuildRequires:  asciidoc
26 %{?with_tests:BuildRequires:    augeas}
27 BuildRequires:  autoconf >= 2.50
28 BuildRequires:  automake
29 BuildRequires:  dbus-devel
30 BuildRequires:  docbook-dtd45-xml
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.55.1
33 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
34 BuildRequires:  gtk+3-devel >= 3.0
35 BuildRequires:  intltool >= 0.35.0
36 BuildRequires:  json-c-devel
37 BuildRequires:  libcap-devel
38 BuildRequires:  libgomp-devel
39 BuildRequires:  libnotify-devel >= 0.7.0
40 BuildRequires:  libreport-devel >= %{libreport_ver}
41 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
42 BuildRequires:  libreport-web-devel >= %{libreport_ver}
43 BuildRequires:  libselinux-devel
44 BuildRequires:  libsoup-devel >= 2.4
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2
47 BuildRequires:  pkgconfig
48 BuildRequires:  polkit-devel
49 BuildRequires:  python3-devel >= 1:3.6
50 BuildRequires:  python3-modules >= 1:3.6
51 %{?with_tests:BuildRequires:    python3-nose}
52 %{?with_tests:BuildRequires:    python3-pytest}
53 BuildRequires:  rpm-devel >= 4.5-28
54 BuildRequires:  rpm-pythonprov
55 BuildRequires:  rpmbuild(macros) >= 1.721
56 BuildRequires:  satyr-devel >= 0.21
57 BuildRequires:  sphinx-pdg-3
58 BuildRequires:  systemd-devel >= 1:209
59 BuildRequires:  xmlto
60 Requires(postun):       /usr/sbin/groupdel
61 Requires(postun):       /usr/sbin/userdel
62 Requires(pre):  /bin/id
63 Requires(pre):  /usr/bin/getgid
64 Requires(pre):  /usr/sbin/groupadd
65 Requires(pre):  /usr/sbin/useradd
66 Requires:       %{name}-libs = %{version}-%{release}
67 Provides:       group(abrt)
68 Provides:       user(abrt)
69 Obsoletes:      abrt-addon-coredump-helper < 2.13.0
70 Obsoletes:      abrt-addon-python < 2.13.0
71 Obsoletes:      abrt-atomic < 2.13.0
72 Obsoletes:      abrt-cli < 2.13.0
73 Obsoletes:      abrt-plugin-catcut
74 Obsoletes:      abrt-plugin-filetransfer
75 Obsoletes:      abrt-plugin-rhfastcheck
76 Obsoletes:      abrt-plugin-rhticket
77 Obsoletes:      abrt-plugin-runapp
78 Obsoletes:      abrt-plugin-sosreport
79 Obsoletes:      abrt-plugin-sqlite3
80 Obsoletes:      abrt-plugin-ticketuploader
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 ABRT is a tool to help users to detect defects in applications and to
85 create a bug report with all informations needed by maintainer to fix
86 it. It uses plugin system to extend its functionality.
87
88 %description -l pl.UTF-8
89 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
90 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
91 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
92 system wtyczek do rozszerzania funkcjonalności.
93
94 %package -n bash-completion-abrt
95 Summary:        Bash completion for abrt command
96 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla polecenia abrt
97 Group:          Applications/Shells
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       bash-completion
100 Requires:       python3-argcomplete
101 %if "%{_rpmversion}" >= "5"
102 BuildArch:      noarch
103 %endif
104
105 %description -n bash-completion-abrt
106 Bash completion for abrt command.
107
108 %description -n bash-completion-abrt -l pl.UTF-8
109 Bashowe dopełnianie parametrów dla polecenia abrt.
110
111 %package libs
112 Summary:        ABRT shared library
113 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
114 Group:          Libraries
115 Requires:       glib2 >= 1:2.55.1
116 Requires:       libreport >= %{libreport_ver}
117
118 %description libs
119 ABRT shared library.
120
121 %description libs -l pl.UTF-8
122 Biblioteka współdzielona ABRT.
123
124 %package devel
125 Summary:        Header files for ABRT livrary
126 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
127 Group:          Development/Libraries
128 Requires:       %{name}-libs = %{version}-%{release}
129 Requires:       glib2-devel >= 1:2.55.1
130 Requires:       libreport-devel >= %{libreport_ver}
131
132 %description devel
133 Header files for ABRT livrary.
134
135 %description devel -l pl.UTF-8
136 Pliki nagłówkowe biblioteki ABRT.
137
138 %package addon-ccpp
139 Summary:        ABRT's C/C++ addon
140 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
141 Group:          Libraries
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       %{name}-retrace-client = %{version}-%{release}
144 Requires:       cpio
145 Requires:       elfutils
146 Requires:       gdb >= 7.0-3
147 Requires:       satyr >= 0.21
148 Requires:       yum-utils
149 Obsoletes:      abrt-atomic
150
151 %description addon-ccpp
152 This package contains hook for C/C++ crashed programs and abrt's C/C++
153 analyzer plugin.
154
155 %description addon-ccpp -l pl.UTF-8
156 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
157 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
158
159 %package addon-kerneloops
160 Summary:        ABRT's kerneloops addon
161 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
162 Group:          Libraries
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       curl
165 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
166 Obsoletes:      abrt-plugin-kerneloops
167 Obsoletes:      abrt-plugin-kerneloopsreporter
168 Obsoletes:      kerneloops
169
170 %description addon-kerneloops
171 This package contains plugin for collecting kernel crash information
172 from system log.
173
174 %description addon-kerneloops -l pl.UTF-8
175 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
176 logu systemowego.
177
178 %package addon-pstoreoops
179 Summary:        ABRT's pstoreoops addon
180 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
181 Group:          Libraries
182 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
183 Obsoletes:      abrt-addon-uefioops
184
185 %description addon-pstoreoops
186 This package contains plugin for collecting kernel oopses from pstore
187 storage.
188
189 %description addon-pstoreoops -l pl.UTF-8
190 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
191
192 %package addon-python3
193 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
194 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
195 Group:          Libraries
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       %{name}-python3 = %{version}-%{release}
198 # for detecting package name containing offending file (TODO: python3-rpm package)
199 #Suggests:      python3-rpm
200 # for logging to journal
201 Suggests:       python3-systemd
202
203 %description addon-python3
204 This package contains Python hook and Python analyzer plugin for
205 handling uncaught exception in Python 3 programs.
206
207 %description addon-python3 -l pl.UTF-8
208 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
209 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
210 Pythonie 3.
211
212 %package addon-upload-watch
213 Summary:        ABRT's upload addon
214 Summary(pl.UTF-8):      Dodatek upload do ABRT
215 Group:          Libraries
216 Requires:       %{name} = %{version}-%{release}
217
218 %description addon-upload-watch
219 This package contains hook for uploaded problems.
220
221 %description addon-upload-watch -l pl.UTF-8
222 Ten pakiet zawiera uchwyt dla problemów przysłanych.
223
224 %package addon-vmcore
225 Summary:        ABRT's vmcore addon
226 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
230 Requires:       crash
231
232 %description addon-vmcore
233 This package contains plugin for collecting kernel crash information
234 from vmcore files.
235
236 %description addon-vmcore -l pl.UTF-8
237 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
238 plików vmcore.
239
240 %package addon-xorg
241 Summary:        ABRT's Xorg addon
242 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
243 Group:          Libraries
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       curl
246
247 %description addon-xorg
248 This package contains plugin for collecting Xorg crash information
249 from Xorg log.
250
251 %description addon-xorg -l pl.UTF-8
252 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
253 logu Xorg.
254
255 %package plugin-bodhi
256 Summary:        ABRT's bodhi plugin
257 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       libreport-web >= %{libreport_ver}
261 Obsoletes:      libreport-plugin-bodhi
262
263 %description plugin-bodhi
264 Plugin to search for a new updates in bodhi server.
265
266 %description plugin-bodhi -l pl.UTF-8
267 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
268
269 %package retrace-client
270 Summary:        ABRT's retrace client
271 Summary(pl.UTF-8):      Klient Retrace dla ABRT
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       xz
275
276 %description retrace-client
277 This package contains the client application for Retrace server which
278 is able to analyze C/C++ crashes remotely.
279
280 %description retrace-client -l pl.UTF-8
281 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
282 potrafi zdalnie przeanalizować awarię programu w C/C++.
283
284 %package dbus
285 Summary:        ABRT DBus service
286 Summary(pl.UTF-8):      Usługa DBus ABRT
287 Group:          Applications/System
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       libreport >= %{libreport_ver}
290
291 %description dbus
292 ABRT DBus service which provides org.freedesktop.problems API on DBus
293 and uses PolicyKit to authorize to access the problem data.
294
295 %description dbus -l pl.UTF-8
296 Usługa DBus ABRT, udostępniająca poprzez DBus API
297 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
298 do danych o problemach.
299
300 %package python3
301 Summary:        ABRT Python 3 API
302 Summary(pl.UTF-8):      API Pythona 3 do ABRT
303 Group:          Libraries/Python
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       python3-libreport >= %{libreport_ver}
306 Obsoletes:      abrt-python < 2.13.0
307
308 %description python3
309 High-level API for querying, creating and manipulating problems
310 handled by ABRT in Python.
311
312 %description python3 -l pl.UTF-8
313 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
314 Pythona 3 problemów obsługiwanych przez ABRT.
315
316 %package gui
317 Summary:        ABRT's GUI
318 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
319 Group:          X11/Applications
320 Requires(post,postun):  /sbin/ldconfig
321 Requires(post,postun):  gtk-update-icon-cache
322 Requires(post,postun):  hicolor-icon-theme
323 Requires:       %{name} = %{version}-%{release}
324 Requires:       %{name}-dbus = %{version}-%{release}
325 Requires:       %{name}-gui-libs = %{version}-%{release}
326 Suggests:       gnome-abrt
327 Provides:       abrt-applet = %{version}-%{release}
328 Obsoletes:      abrt-applet < 0.0.5
329 Conflicts:      abrt-applet < 0.0.5
330
331 %description gui
332 GTK+ wizard for convenient bug reporting.
333
334 %description gui -l pl.UTF-8
335 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
336
337 %package gui-libs
338 Summary:        ABRT's GUI library
339 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
340 Group:          X11/Libraries
341 Requires:       %{name}-libs = %{version}-%{release}
342 Requires:       gtk+3 >= 3.0
343
344 %description gui-libs
345 ABRT's GUI library.
346
347 %description gui-libs -l pl.UTF-8
348 Biblioteka graficznego interfejsu użytkownika ABRT.
349
350 %package gui-devel
351 Summary:        Header files for ABRT GUI library
352 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
353 Group:          X11/Development/Libraries
354 Requires:       %{name}-devel = %{version}-%{release}
355 Requires:       %{name}-gui-libs = %{version}-%{release}
356 Requires:       gtk+3-devel >= 3.0
357
358 %description gui-devel
359 Header files for ABRT GUI library.
360
361 %description gui-devel -l pl.UTF-8
362 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
363
364 %package desktop
365 Summary:        Virtual package to install all necessary packages for usage from desktop environment
366 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
367 Group:          X11/Applications
368 # This package should be installed when anything requests bug-buddy;
369 # installing abrt-desktop should result in the abrt which works without
370 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
371 Requires:       %{name} = %{version}-%{release}
372 Requires:       %{name}-addon-ccpp = %{version}-%{release}
373 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
374 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
375 Requires:       %{name}-addon-python3 = %{version}-%{release}
376 Requires:       %{name}-addon-vmcore = %{version}-%{release}
377 Requires:       %{name}-addon-xorg = %{version}-%{release}
378 Requires:       %{name}-gui = %{version}-%{release}
379 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
380 Requires:       %{name}-retrace-client = %{version}-%{release}
381 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
382 Requires:       libreport-plugin-logger >= %{libreport_ver}
383 Requires:       libreport-plugin-ureport >= %{libreport_ver}
384 Provides:       bug-buddy
385 Obsoletes:      bug-buddy
386
387 %description desktop
388 Virtual package to make easy default installation on desktop
389 environments.
390
391 %description desktop -l pl.UTF-8
392 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
393 graficznych.
394
395 %package console-notification
396 Summary:        ABRT console notification script
397 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
398 Group:          Applications/System
399 Requires:       %{name} = %{version}-%{release}
400
401 %description console-notification
402 A small script which prints a count of detected problems when someone
403 logs in to the shell.
404
405 %description console-notification -l pl.UTF-8
406 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
407 się do powłoki.
408
409 %prep
410 %setup -q
411 %if "%{_rpmversion}" >= "5.0"
412 %patch0 -p1
413 %else
414 %patch1 -p1
415 %endif
416 %patch2 -p1
417 %patch3 -p1
418
419 %{__sed} -n -e '/^%%changelog/,$p' abrt.spec.in | tail -n +2 > changelog
420
421 echo -n %{version} > abrt-version
422
423 %build
424 %{__libtoolize}
425 %{__gettextize}
426 %{__intltoolize}
427 %{__aclocal} -I m4
428 %{__autoconf}
429 %{__autoheader}
430 %{__automake}
431 %configure \
432         AUGPARSE=/usr/bin/augparse \
433         PYTHON_NOSE=/usr/bin/nosetests-%{py3_ver} \
434         --enable-dump-time-unwind \
435         --enable-native-unwinder \
436         --disable-silent-rules \
437         %{!?with_tests:--without-pythontests} \
438         --with-systemdsystemunitdir=%{systemdunitdir}
439
440 %{__make}
441
442 %install
443 rm -rf $RPM_BUILD_ROOT
444 %{__make} install \
445         DESTDIR=$RPM_BUILD_ROOT \
446         systemdsystemunitdir=%{systemdunitdir} \
447         python3dir=%{py3_sitescriptdir}
448
449 # obsoleted by pkg-config
450 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
451
452 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
453 install -d $RPM_BUILD_ROOT/var/cache/%{name}
454 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
455 install -d $RPM_BUILD_ROOT/var/run/%{name}
456
457 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
458 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
459 d /var/run/%{name} 0755 root root -
460 EOF
461
462 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
463 # examples
464 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
465 # packaged as %doc
466 %{__rm} $RPM_BUILD_ROOT%{_docdir}/abrt/README.md
467
468 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
469 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
470
471 %find_lang %{name}
472
473 %clean
474 rm -rf $RPM_BUILD_ROOT
475
476 %pre
477 %groupadd -g 248 abrt
478 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
479
480 %post
481 /sbin/chkconfig --add abrtd
482 %service abrtd restart
483 %systemd_post abrtd.service
484
485 %preun
486 if [ "$1" = "0" ]; then
487         %service abrtd stop
488         /sbin/chkconfig --del abrtd
489 fi
490 %systemd_preun abrtd.service
491
492 %postun
493 if [ "$1" = "0" ]; then
494         %userremove abrt
495         %groupremove abrt
496 fi
497
498 %post   libs -p /sbin/ldconfig
499 %postun libs -p /sbin/ldconfig
500
501 %post addon-ccpp
502 %systemd_post abrt-ccpp.service
503 %systemd_post abrt-journal-core.service
504 %journal_catalog_update
505
506 %preun addon-ccpp
507 %systemd_preun abrt-ccpp.service
508 %systemd_preun abrt-journal-core.service
509
510 %post addon-kerneloops
511 %systemd_post abrt-oops.service
512 %journal_catalog_update
513
514 %preun addon-kerneloops
515 %systemd_preun abrt-oops.service
516
517 %post addon-pstoreoops
518 %systemd_post abrt-pstoreoops.service
519
520 %preun addon-pstoreoops
521 %systemd_preun abrt-pstoreoops.service
522
523 %post addon-python3
524 %journal_catalog_update
525
526 %post addon-upload-watch
527 %systemd_post abrt-upload-watch.service
528
529 %preun addon-upload-watch
530 %systemd_preun abrt-upload-watch.service
531
532 %post addon-vmcore
533 %systemd_post abrt-vmcore.service
534 %journal_catalog_update
535
536 %preun addon-vmcore
537 %systemd_preun abrt-vmcore.service
538
539 %post addon-xorg
540 %systemd_post abrt-xorg.service
541 %journal_catalog_update
542
543 %preun addon-xorg
544 %systemd_preun abrt-xorg.service
545
546 %post gui
547 %update_icon_cache hicolor
548
549 %postun gui
550 %update_icon_cache hicolor
551
552 %post   gui-libs -p /sbin/ldconfig
553 %postun gui-libs -p /sbin/ldconfig
554
555 %files -f %{name}.lang
556 %defattr(644,root,root,755)
557 %doc README.md changelog
558 %attr(755,root,root) %{_bindir}/abrt
559 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
560 %attr(755,root,root) %{_bindir}/abrt-action-notify
561 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
562 %attr(755,root,root) %{_bindir}/abrt-handle-upload
563 %attr(755,root,root) %{_bindir}/abrt-watch-log
564 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
565 %attr(755,root,root) %{_sbindir}/abrt-server
566 %attr(755,root,root) %{_sbindir}/abrtd
567 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
568 %attr(755,root,root) %{_libexecdir}/abrt-action-save-container-data
569 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
570 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
571 %{py3_sitescriptdir}/abrtcli
572 %dir %{_datadir}/%{name}
573 %{_datadir}/augeas/lenses/abrt.aug
574 %dir %{_sysconfdir}/%{name}
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
576 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
577 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
578 %dir %{_sysconfdir}/%{name}/plugins
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
580 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/machine-id_event.conf
581 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
582 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/sosreport_event.conf
583 %attr(754,root,root) /etc/rc.d/init.d/abrtd
584 %{systemdunitdir}/abrtd.service
585 %attr(775,root,abrt) %dir /var/cache/%{name}
586 %dir /var/run/%{name}
587 %{systemdtmpfilesdir}/abrt.conf
588 %{_mandir}/man1/abrt.1*
589 %{_mandir}/man1/abrt-action-analyze-python.1*
590 %{_mandir}/man1/abrt-action-notify.1*
591 %{_mandir}/man1/abrt-action-save-package-data.1*
592 %{_mandir}/man1/abrt-auto-reporting.1*
593 %{_mandir}/man1/abrt-handle-upload.1*
594 %{_mandir}/man1/abrt-server.1*
595 %{_mandir}/man1/abrt-watch-log.1*
596 %{_mandir}/man5/abrt.conf.5*
597 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
598 %{_mandir}/man5/abrt_event.conf.5*
599 %{_mandir}/man5/report_event.conf.5
600 %{_mandir}/man5/gpg_keys.conf.5*
601 %{_mandir}/man5/smart_event.conf.5*
602 %{_mandir}/man8/abrtd.8*
603
604 %files -n bash-completion-abrt
605 %defattr(644,root,root,755)
606 /etc/bash_completion.d/abrt.bash_completion
607
608 %files libs
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
611 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
612
613 %files devel
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/libabrt.so
616 %dir %{_includedir}/abrt
617 %{_includedir}/abrt/abrt-dbus.h
618 %{_includedir}/abrt/hooklib.h
619 %{_includedir}/abrt/libabrt.h
620 %{_includedir}/abrt/problem_api.h
621 %{_pkgconfigdir}/abrt.pc
622
623 %files addon-ccpp
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
626 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
627 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
628 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
629 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
630 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
631 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
632 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
633 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
634 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
635 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
636 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
637 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
638 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
639 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
640 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
641 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
642 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
643 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_journal_ccpp_format.conf
644 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
645 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
646 %{_datadir}/libreport/events/analyze_CCpp.xml
647 %{_datadir}/libreport/events/analyze_LocalGDB.xml
648 %{_datadir}/libreport/events/collect_GConf.xml
649 %{_datadir}/libreport/events/collect_vimrc_system.xml
650 %{_datadir}/libreport/events/collect_vimrc_user.xml
651 %{_datadir}/libreport/events/collect_xsession_errors.xml
652 %{_datadir}/libreport/events/post_report.xml
653 %{systemdunitdir}/abrt-journal-core.service
654 %{_prefix}/lib/systemd/catalog/abrt_ccpp.catalog
655 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
656 %{_mandir}/man1/abrt-action-analyze-c.1*
657 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
658 %{_mandir}/man1/abrt-action-analyze-core.1*
659 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
660 %{_mandir}/man1/abrt-action-generate-backtrace.1*
661 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
662 %{_mandir}/man1/abrt-action-install-debuginfo.1*
663 %{_mandir}/man1/abrt-action-list-dsos.1*
664 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
665 %{_mandir}/man1/abrt-action-trim-files.1*
666 %{_mandir}/man1/abrt-dump-journal-core.1*
667 %{_mandir}/man5/abrt-CCpp.conf.5*
668 %{_mandir}/man5/ccpp_event.conf.5*
669 %{_mandir}/man5/ccpp_retrace_event.conf.5*
670 %{_mandir}/man5/gconf_event.conf.5*
671 %{_mandir}/man5/vimrc_event.conf.5*
672
673 %files addon-kerneloops
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
676 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-alt-component
677 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
678 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
679 %attr(755,root,root) %{_bindir}/abrt-dump-oops
680 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
681 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_koops_format.conf
682 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
683 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
684 %{systemdunitdir}/abrt-oops.service
685 %{_prefix}/lib/systemd/catalog/abrt_koops.catalog
686 %{_mandir}/man1/abrt-action-analyze-oops.1*
687 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
688 %{_mandir}/man1/abrt-dump-journal-oops.1*
689 %{_mandir}/man1/abrt-dump-oops.1*
690 %{_mandir}/man5/abrt-oops.conf.5*
691 %{_mandir}/man5/koops_event.conf.5*
692
693 %files addon-pstoreoops
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
696 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
697 %{systemdunitdir}/abrt-pstoreoops.service
698 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
699 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
700 %{_mandir}/man1/abrt-merge-pstoreoops.1*
701
702 %files addon-python3
703 %defattr(644,root,root,755)
704 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
705 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
706 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_python3_format.conf
707 %{py3_sitescriptdir}/abrt_exception_handler3.py*
708 %{py3_sitescriptdir}/abrt_exception_handler3_container.py*
709 %{py3_sitescriptdir}/abrt3.pth
710 %{py3_sitescriptdir}/abrt3_container.pth
711 %{py3_sitescriptdir}/__pycache__/abrt_exception_handler3*.cpython-*.py[co]
712 %{_prefix}/lib/systemd/catalog/python3_abrt.catalog
713 %{_mandir}/man5/python3_event.conf.5*
714 %{_mandir}/man5/python3-abrt.conf.5*
715
716 %files addon-upload-watch
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
719 %{systemdunitdir}/abrt-upload-watch.service
720 %{_mandir}/man1/abrt-upload-watch.1*
721
722 %files addon-vmcore
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
725 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
726 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
727 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
728 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_vmcore_format.conf
729 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
730 %{_datadir}/libreport/events/analyze_VMcore.xml
731 %{systemdunitdir}/abrt-vmcore.service
732 %{_prefix}/lib/systemd/catalog/abrt_vmcore.catalog
733 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
734 %{_mandir}/man1/abrt-harvest-vmcore.1*
735 %{_mandir}/man5/abrt-vmcore.conf.5*
736 %{_mandir}/man5/vmcore_event.conf.5*
737
738 %files addon-xorg
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
741 %attr(755,root,root) %{_bindir}/abrt-dump-journal-xorg
742 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
743 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
744 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
745 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_xorg_format.conf
746 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
747 %{systemdunitdir}/abrt-xorg.service
748 %{_prefix}/lib/systemd/catalog/abrt_xorg.catalog
749 %{_mandir}/man1/abrt-action-analyze-xorg.1*
750 %{_mandir}/man1/abrt-dump-journal-xorg.1*
751 %{_mandir}/man1/abrt-dump-xorg.1*
752 %{_mandir}/man5/abrt-xorg.conf.5*
753 %{_mandir}/man5/xorg_event.conf.5*
754
755 %files plugin-bodhi
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/abrt-action-find-bodhi-update
758 %attr(755,root,root) %{_bindir}/abrt-bodhi
759 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/bodhi_event.conf
760 %{_datadir}/libreport/events/analyze_BodhiUpdates.xml
761 %{_mandir}/man1/abrt-action-find-bodhi-update.1*
762 %{_mandir}/man1/abrt-bodhi.1*
763
764 %files retrace-client
765 %defattr(644,root,root,755)
766 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
767 %attr(755,root,root) %{_bindir}/abrt-retrace-client
768 %{_datadir}/libreport/events/analyze_RetraceServer.xml
769 %{_mandir}/man1/abrt-retrace-client.1*
770
771 %files dbus
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_sbindir}/abrt-dbus
774 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_dbus_event.conf
775 /etc/dbus-1/system.d/dbus-abrt.conf
776 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
777 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.xml
778 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Entry.xml
779 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Session.xml
780 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Task.xml
781 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
782 %{_datadir}/polkit-1/actions/abrt_polkit.policy
783 %{_mandir}/man8/abrt-dbus.8*
784 %{_docdir}/abrt-dbus-%{version}
785
786 %files python3
787 %defattr(644,root,root,755)
788 %dir %{py3_sitedir}/problem
789 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
790 %{py3_sitedir}/problem/*.py*
791 %{py3_sitedir}/problem/__pycache__
792 %{_mandir}/man5/python3-abrt.5*
793
794 %files gui
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_bindir}/abrt-applet
797 %attr(755,root,root) %{_bindir}/system-config-abrt
798 %dir %{_datadir}/%{name}
799 %{_datadir}/%{name}/ui
800 %{_iconsdir}/hicolor/scalable/apps/abrt.svg
801 %{_iconsdir}/hicolor/symbolic/apps/abrt-symbolic.svg
802 %{_sysconfdir}/xdg/autostart/org.freedesktop.problems.applet.desktop
803 %{_datadir}/dbus-1/services/org.freedesktop.problems.applet.service
804 %{_mandir}/man1/abrt-applet.1*
805 %{_mandir}/man1/system-config-abrt.1*
806
807 %files gui-libs
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
810 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
811
812 %files gui-devel
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libabrt_gui.so
815 %{_includedir}/abrt/abrt-config-widget.h
816 %{_includedir}/abrt/system-config-abrt.h
817 %{_pkgconfigdir}/abrt_gui.pc
818
819 %files desktop
820 %defattr(644,root,root,755)
821
822 %files console-notification
823 %defattr(644,root,root,755)
824 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.103108 seconds and 3 git commands to generate.