]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- added split-usr patch (fix bash path in abrtd.service); release 2
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
4 #
5 # Conditional build:
6 %bcond_without  tests   # disable pythontests
7
8 %define         libreport_ver   2.10.0
9 Summary:        Automatic bug detection and reporting tool
10 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
11 Name:           abrt
12 Version:        2.14.0
13 Release:        2
14 License:        GPL v2+
15 Group:          Applications/System
16 #Source0Download: https://github.com/abrt/abrt/releases
17 Source0:        https://github.com/abrt/abrt/archive/%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  96c227237c9d66107f3bc62b5921b8c2
19 Source1:        %{name}.init
20 Patch0:         %{name}-rpm5.patch
21 Patch1:         %{name}-rpm45.patch
22 Patch2:         %{name}-link.patch
23 Patch3:         %{name}-split-usr.patch
24 URL:            https://abrt.readthedocs.org/
25 BuildRequires:  asciidoc
26 %{?with_tests:BuildRequires:    augeas}
27 BuildRequires:  autoconf >= 2.50
28 BuildRequires:  automake
29 BuildRequires:  dbus-devel
30 BuildRequires:  docbook-dtd45-xml
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.55.1
33 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
34 BuildRequires:  gtk+3-devel >= 3.0
35 BuildRequires:  intltool >= 0.35.0
36 BuildRequires:  json-c-devel
37 BuildRequires:  libcap-devel
38 BuildRequires:  libgomp-devel
39 BuildRequires:  libnotify-devel >= 0.7.0
40 BuildRequires:  libreport-devel >= %{libreport_ver}
41 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
42 BuildRequires:  libreport-web-devel >= %{libreport_ver}
43 BuildRequires:  libselinux-devel
44 BuildRequires:  libsoup-devel >= 2.4
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2
47 BuildRequires:  pkgconfig
48 BuildRequires:  polkit-devel
49 BuildRequires:  python3-devel >= 1:3.6
50 BuildRequires:  python3-modules >= 1:3.6
51 %{?with_tests:BuildRequires:    python3-nose}
52 BuildRequires:  rpm-devel >= 4.5-28
53 BuildRequires:  rpm-pythonprov
54 BuildRequires:  rpmbuild(macros) >= 1.721
55 BuildRequires:  satyr-devel >= 0.21
56 BuildRequires:  sphinx-pdg-3
57 BuildRequires:  systemd-devel >= 1:209
58 BuildRequires:  xmlto
59 Requires(postun):       /usr/sbin/groupdel
60 Requires(postun):       /usr/sbin/userdel
61 Requires(pre):  /bin/id
62 Requires(pre):  /usr/bin/getgid
63 Requires(pre):  /usr/sbin/groupadd
64 Requires(pre):  /usr/sbin/useradd
65 Requires:       %{name}-libs = %{version}-%{release}
66 Provides:       group(abrt)
67 Provides:       user(abrt)
68 Obsoletes:      abrt-addon-coredump-helper < 2.13.0
69 Obsoletes:      abrt-addon-python < 2.13.0
70 Obsoletes:      abrt-atomic < 2.13.0
71 Obsoletes:      abrt-cli < 2.13.0
72 Obsoletes:      abrt-plugin-catcut
73 Obsoletes:      abrt-plugin-filetransfer
74 Obsoletes:      abrt-plugin-rhfastcheck
75 Obsoletes:      abrt-plugin-rhticket
76 Obsoletes:      abrt-plugin-runapp
77 Obsoletes:      abrt-plugin-sosreport
78 Obsoletes:      abrt-plugin-sqlite3
79 Obsoletes:      abrt-plugin-ticketuploader
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 ABRT is a tool to help users to detect defects in applications and to
84 create a bug report with all informations needed by maintainer to fix
85 it. It uses plugin system to extend its functionality.
86
87 %description -l pl.UTF-8
88 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
89 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
90 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
91 system wtyczek do rozszerzania funkcjonalności.
92
93 %package -n bash-completion-abrt
94 Summary:        Bash completion for abrt command
95 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla polecenia abrt
96 Group:          Applications/Shells
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       bash-completion
99 Requires:       python3-argcomplete
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description -n bash-completion-abrt
105 Bash completion for abrt command.
106
107 %description -n bash-completion-abrt -l pl.UTF-8
108 Bashowe dopełnianie parametrów dla polecenia abrt.
109
110 %package libs
111 Summary:        ABRT shared library
112 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
113 Group:          Libraries
114 Requires:       glib2 >= 1:2.55.1
115 Requires:       libreport >= %{libreport_ver}
116
117 %description libs
118 ABRT shared library.
119
120 %description libs -l pl.UTF-8
121 Biblioteka współdzielona ABRT.
122
123 %package devel
124 Summary:        Header files for ABRT livrary
125 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
126 Group:          Development/Libraries
127 Requires:       %{name}-libs = %{version}-%{release}
128 Requires:       glib2-devel >= 1:2.55.1
129 Requires:       libreport-devel >= %{libreport_ver}
130
131 %description devel
132 Header files for ABRT livrary.
133
134 %description devel -l pl.UTF-8
135 Pliki nagłówkowe biblioteki ABRT.
136
137 %package addon-ccpp
138 Summary:        ABRT's C/C++ addon
139 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
140 Group:          Libraries
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       %{name}-retrace-client = %{version}-%{release}
143 Requires:       cpio
144 Requires:       elfutils
145 Requires:       gdb >= 7.0-3
146 Requires:       satyr >= 0.21
147 Requires:       yum-utils
148 Obsoletes:      abrt-atomic
149
150 %description addon-ccpp
151 This package contains hook for C/C++ crashed programs and abrt's C/C++
152 analyzer plugin.
153
154 %description addon-ccpp -l pl.UTF-8
155 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
156 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
157
158 %package addon-kerneloops
159 Summary:        ABRT's kerneloops addon
160 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
161 Group:          Libraries
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       curl
164 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
165 Obsoletes:      abrt-plugin-kerneloops
166 Obsoletes:      abrt-plugin-kerneloopsreporter
167 Obsoletes:      kerneloops
168
169 %description addon-kerneloops
170 This package contains plugin for collecting kernel crash information
171 from system log.
172
173 %description addon-kerneloops -l pl.UTF-8
174 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
175 logu systemowego.
176
177 %package addon-pstoreoops
178 Summary:        ABRT's pstoreoops addon
179 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
180 Group:          Libraries
181 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
182 Obsoletes:      abrt-addon-uefioops
183
184 %description addon-pstoreoops
185 This package contains plugin for collecting kernel oopses from pstore
186 storage.
187
188 %description addon-pstoreoops -l pl.UTF-8
189 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
190
191 %package addon-python3
192 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
193 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
194 Group:          Libraries
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       %{name}-python3 = %{version}-%{release}
197 # for detecting package name containing offending file (TODO: python3-rpm package)
198 #Suggests:      python3-rpm
199 # for logging to journal
200 Suggests:       python3-systemd
201
202 %description addon-python3
203 This package contains Python hook and Python analyzer plugin for
204 handling uncaught exception in Python 3 programs.
205
206 %description addon-python3 -l pl.UTF-8
207 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
208 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
209 Pythonie 3.
210
211 %package addon-upload-watch
212 Summary:        ABRT's upload addon
213 Summary(pl.UTF-8):      Dodatek upload do ABRT
214 Group:          Libraries
215 Requires:       %{name} = %{version}-%{release}
216
217 %description addon-upload-watch
218 This package contains hook for uploaded problems.
219
220 %description addon-upload-watch -l pl.UTF-8
221 Ten pakiet zawiera uchwyt dla problemów przysłanych.
222
223 %package addon-vmcore
224 Summary:        ABRT's vmcore addon
225 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
226 Group:          Libraries
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
229 Requires:       crash
230
231 %description addon-vmcore
232 This package contains plugin for collecting kernel crash information
233 from vmcore files.
234
235 %description addon-vmcore -l pl.UTF-8
236 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
237 plików vmcore.
238
239 %package addon-xorg
240 Summary:        ABRT's Xorg addon
241 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
242 Group:          Libraries
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       curl
245
246 %description addon-xorg
247 This package contains plugin for collecting Xorg crash information
248 from Xorg log.
249
250 %description addon-xorg -l pl.UTF-8
251 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
252 logu Xorg.
253
254 %package plugin-bodhi
255 Summary:        ABRT's bodhi plugin
256 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
257 Group:          Libraries
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       libreport-web >= %{libreport_ver}
260 Obsoletes:      libreport-plugin-bodhi
261
262 %description plugin-bodhi
263 Plugin to search for a new updates in bodhi server.
264
265 %description plugin-bodhi -l pl.UTF-8
266 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
267
268 %package retrace-client
269 Summary:        ABRT's retrace client
270 Summary(pl.UTF-8):      Klient Retrace dla ABRT
271 Group:          Libraries
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       xz
274
275 %description retrace-client
276 This package contains the client application for Retrace server which
277 is able to analyze C/C++ crashes remotely.
278
279 %description retrace-client -l pl.UTF-8
280 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
281 potrafi zdalnie przeanalizować awarię programu w C/C++.
282
283 %package dbus
284 Summary:        ABRT DBus service
285 Summary(pl.UTF-8):      Usługa DBus ABRT
286 Group:          Applications/System
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       libreport >= %{libreport_ver}
289
290 %description dbus
291 ABRT DBus service which provides org.freedesktop.problems API on DBus
292 and uses PolicyKit to authorize to access the problem data.
293
294 %description dbus -l pl.UTF-8
295 Usługa DBus ABRT, udostępniająca poprzez DBus API
296 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
297 do danych o problemach.
298
299 %package python3
300 Summary:        ABRT Python 3 API
301 Summary(pl.UTF-8):      API Pythona 3 do ABRT
302 Group:          Libraries/Python
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       python3-libreport >= %{libreport_ver}
305 Obsoletes:      abrt-python < 2.13.0
306
307 %description python3
308 High-level API for querying, creating and manipulating problems
309 handled by ABRT in Python.
310
311 %description python3 -l pl.UTF-8
312 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
313 Pythona 3 problemów obsługiwanych przez ABRT.
314
315 %package gui
316 Summary:        ABRT's GUI
317 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
318 Group:          X11/Applications
319 Requires(post,postun):  /sbin/ldconfig
320 Requires(post,postun):  gtk-update-icon-cache
321 Requires(post,postun):  hicolor-icon-theme
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       %{name}-dbus = %{version}-%{release}
324 Requires:       %{name}-gui-libs = %{version}-%{release}
325 Suggests:       gnome-abrt
326 Provides:       abrt-applet = %{version}-%{release}
327 Obsoletes:      abrt-applet < 0.0.5
328 Conflicts:      abrt-applet < 0.0.5
329
330 %description gui
331 GTK+ wizard for convenient bug reporting.
332
333 %description gui -l pl.UTF-8
334 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
335
336 %package gui-libs
337 Summary:        ABRT's GUI library
338 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
339 Group:          X11/Libraries
340 Requires:       %{name}-libs = %{version}-%{release}
341 Requires:       gtk+3 >= 3.0
342
343 %description gui-libs
344 ABRT's GUI library.
345
346 %description gui-libs -l pl.UTF-8
347 Biblioteka graficznego interfejsu użytkownika ABRT.
348
349 %package gui-devel
350 Summary:        Header files for ABRT GUI library
351 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
352 Group:          X11/Development/Libraries
353 Requires:       %{name}-devel = %{version}-%{release}
354 Requires:       %{name}-gui-libs = %{version}-%{release}
355 Requires:       gtk+3-devel >= 3.0
356
357 %description gui-devel
358 Header files for ABRT GUI library.
359
360 %description gui-devel -l pl.UTF-8
361 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
362
363 %package desktop
364 Summary:        Virtual package to install all necessary packages for usage from desktop environment
365 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
366 Group:          X11/Applications
367 # This package should be installed when anything requests bug-buddy;
368 # installing abrt-desktop should result in the abrt which works without
369 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
370 Requires:       %{name} = %{version}-%{release}
371 Requires:       %{name}-addon-ccpp = %{version}-%{release}
372 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
373 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
374 Requires:       %{name}-addon-python3 = %{version}-%{release}
375 Requires:       %{name}-addon-vmcore = %{version}-%{release}
376 Requires:       %{name}-addon-xorg = %{version}-%{release}
377 Requires:       %{name}-gui = %{version}-%{release}
378 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
379 Requires:       %{name}-retrace-client = %{version}-%{release}
380 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
381 Requires:       libreport-plugin-logger >= %{libreport_ver}
382 Requires:       libreport-plugin-ureport >= %{libreport_ver}
383 Provides:       bug-buddy
384 Obsoletes:      bug-buddy
385
386 %description desktop
387 Virtual package to make easy default installation on desktop
388 environments.
389
390 %description desktop -l pl.UTF-8
391 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
392 graficznych.
393
394 %package console-notification
395 Summary:        ABRT console notification script
396 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
397 Group:          Applications/System
398 Requires:       %{name} = %{version}-%{release}
399
400 %description console-notification
401 A small script which prints a count of detected problems when someone
402 logs in to the shell.
403
404 %description console-notification -l pl.UTF-8
405 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
406 się do powłoki.
407
408 %prep
409 %setup -q
410 %if "%{_rpmversion}" >= "5.0"
411 %patch0 -p1
412 %else
413 %patch1 -p1
414 %endif
415 %patch2 -p1
416 %patch3 -p1
417
418 %{__sed} -n -e '/^%%changelog/,$p' abrt.spec.in | tail -n +2 > changelog
419
420 echo -n %{version} > abrt-version
421
422 %build
423 %{__libtoolize}
424 %{__gettextize}
425 %{__intltoolize}
426 %{__aclocal} -I m4
427 %{__autoconf}
428 %{__autoheader}
429 %{__automake}
430 %configure \
431         AUGPARSE=/usr/bin/augparse \
432         PYTHON_NOSE=/usr/bin/nosetests-%{py3_ver} \
433         --enable-dump-time-unwind \
434         --enable-native-unwinder \
435         --disable-silent-rules \
436         %{!?with_tests:--without-pythontests} \
437         --with-systemdsystemunitdir=%{systemdunitdir}
438
439 %{__make}
440
441 %install
442 rm -rf $RPM_BUILD_ROOT
443 %{__make} install \
444         DESTDIR=$RPM_BUILD_ROOT \
445         systemdsystemunitdir=%{systemdunitdir} \
446         python3dir=%{py3_sitescriptdir}
447
448 # obsoleted by pkg-config
449 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
450
451 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
452 install -d $RPM_BUILD_ROOT/var/cache/%{name}
453 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
454 install -d $RPM_BUILD_ROOT/var/run/%{name}
455
456 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
457 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
458 d /var/run/%{name} 0755 root root -
459 EOF
460
461 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
462 # examples
463 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
464 # packaged as %doc
465 %{__rm} $RPM_BUILD_ROOT%{_docdir}/abrt/README.md
466
467 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
468 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
469
470 %find_lang %{name}
471
472 %clean
473 rm -rf $RPM_BUILD_ROOT
474
475 %pre
476 %groupadd -g 248 abrt
477 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
478
479 %post
480 /sbin/chkconfig --add abrtd
481 %service abrtd restart
482 %systemd_post abrtd.service
483
484 %preun
485 if [ "$1" = "0" ]; then
486         %service abrtd stop
487         /sbin/chkconfig --del abrtd
488 fi
489 %systemd_preun abrtd.service
490
491 %postun
492 if [ "$1" = "0" ]; then
493         %userremove abrt
494         %groupremove abrt
495 fi
496
497 %post   libs -p /sbin/ldconfig
498 %postun libs -p /sbin/ldconfig
499
500 %post addon-ccpp
501 %systemd_post abrt-ccpp.service
502 %systemd_post abrt-journal-core.service
503 %journal_catalog_update
504
505 %preun addon-ccpp
506 %systemd_preun abrt-ccpp.service
507 %systemd_preun abrt-journal-core.service
508
509 %post addon-kerneloops
510 %systemd_post abrt-oops.service
511 %journal_catalog_update
512
513 %preun addon-kerneloops
514 %systemd_preun abrt-oops.service
515
516 %post addon-pstoreoops
517 %systemd_post abrt-pstoreoops.service
518
519 %preun addon-pstoreoops
520 %systemd_preun abrt-pstoreoops.service
521
522 %post addon-python3
523 %journal_catalog_update
524
525 %post addon-upload-watch
526 %systemd_post abrt-upload-watch.service
527
528 %preun addon-upload-watch
529 %systemd_preun abrt-upload-watch.service
530
531 %post addon-vmcore
532 %systemd_post abrt-vmcore.service
533 %journal_catalog_update
534
535 %preun addon-vmcore
536 %systemd_preun abrt-vmcore.service
537
538 %post addon-xorg
539 %systemd_post abrt-xorg.service
540 %journal_catalog_update
541
542 %preun addon-xorg
543 %systemd_preun abrt-xorg.service
544
545 %post gui
546 %update_icon_cache hicolor
547
548 %postun gui
549 %update_icon_cache hicolor
550
551 %post   gui-libs -p /sbin/ldconfig
552 %postun gui-libs -p /sbin/ldconfig
553
554 %files -f %{name}.lang
555 %defattr(644,root,root,755)
556 %doc README.md changelog
557 %attr(755,root,root) %{_bindir}/abrt
558 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
559 %attr(755,root,root) %{_bindir}/abrt-action-notify
560 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
561 %attr(755,root,root) %{_bindir}/abrt-handle-upload
562 %attr(755,root,root) %{_bindir}/abrt-watch-log
563 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
564 %attr(755,root,root) %{_sbindir}/abrt-server
565 %attr(755,root,root) %{_sbindir}/abrtd
566 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
567 %attr(755,root,root) %{_libexecdir}/abrt-action-save-container-data
568 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
569 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
570 %{py3_sitescriptdir}/abrtcli
571 %dir %{_datadir}/%{name}
572 %{_datadir}/augeas/lenses/abrt.aug
573 %dir %{_sysconfdir}/%{name}
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
576 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
577 %dir %{_sysconfdir}/%{name}/plugins
578 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/machine-id_event.conf
580 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
581 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/sosreport_event.conf
582 %attr(754,root,root) /etc/rc.d/init.d/abrtd
583 %{systemdunitdir}/abrtd.service
584 %attr(775,root,abrt) %dir /var/cache/%{name}
585 %dir /var/run/%{name}
586 %{systemdtmpfilesdir}/abrt.conf
587 %{_mandir}/man1/abrt.1*
588 %{_mandir}/man1/abrt-action-analyze-python.1*
589 %{_mandir}/man1/abrt-action-notify.1*
590 %{_mandir}/man1/abrt-action-save-package-data.1*
591 %{_mandir}/man1/abrt-auto-reporting.1*
592 %{_mandir}/man1/abrt-handle-upload.1*
593 %{_mandir}/man1/abrt-server.1*
594 %{_mandir}/man1/abrt-watch-log.1*
595 %{_mandir}/man5/abrt.conf.5*
596 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
597 %{_mandir}/man5/abrt_event.conf.5*
598 %{_mandir}/man5/report_event.conf.5
599 %{_mandir}/man5/gpg_keys.conf.5*
600 %{_mandir}/man5/smart_event.conf.5*
601 %{_mandir}/man8/abrtd.8*
602
603 %files -n bash-completion-abrt
604 %defattr(644,root,root,755)
605 /etc/bash_completion.d/abrt.bash_completion
606
607 %files libs
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
610 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
611
612 %files devel
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/libabrt.so
615 %dir %{_includedir}/abrt
616 %{_includedir}/abrt/abrt-dbus.h
617 %{_includedir}/abrt/hooklib.h
618 %{_includedir}/abrt/libabrt.h
619 %{_includedir}/abrt/problem_api.h
620 %{_pkgconfigdir}/abrt.pc
621
622 %files addon-ccpp
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
625 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
626 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
627 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
628 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
629 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
630 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
631 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
632 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
633 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
634 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
635 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
636 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
637 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
638 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
639 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
640 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
641 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
642 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_journal_ccpp_format.conf
643 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
644 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
645 %{_datadir}/libreport/events/analyze_CCpp.xml
646 %{_datadir}/libreport/events/analyze_LocalGDB.xml
647 %{_datadir}/libreport/events/collect_GConf.xml
648 %{_datadir}/libreport/events/collect_vimrc_system.xml
649 %{_datadir}/libreport/events/collect_vimrc_user.xml
650 %{_datadir}/libreport/events/collect_xsession_errors.xml
651 %{_datadir}/libreport/events/post_report.xml
652 %{systemdunitdir}/abrt-journal-core.service
653 %{_prefix}/lib/systemd/catalog/abrt_ccpp.catalog
654 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
655 %{_mandir}/man1/abrt-action-analyze-c.1*
656 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
657 %{_mandir}/man1/abrt-action-analyze-core.1*
658 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
659 %{_mandir}/man1/abrt-action-generate-backtrace.1*
660 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
661 %{_mandir}/man1/abrt-action-install-debuginfo.1*
662 %{_mandir}/man1/abrt-action-list-dsos.1*
663 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
664 %{_mandir}/man1/abrt-action-trim-files.1*
665 %{_mandir}/man1/abrt-dump-journal-core.1*
666 %{_mandir}/man5/abrt-CCpp.conf.5*
667 %{_mandir}/man5/ccpp_event.conf.5*
668 %{_mandir}/man5/ccpp_retrace_event.conf.5*
669 %{_mandir}/man5/gconf_event.conf.5*
670 %{_mandir}/man5/vimrc_event.conf.5*
671
672 %files addon-kerneloops
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
675 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-alt-component
676 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
677 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
678 %attr(755,root,root) %{_bindir}/abrt-dump-oops
679 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
680 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_koops_format.conf
681 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
682 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
683 %{systemdunitdir}/abrt-oops.service
684 %{_prefix}/lib/systemd/catalog/abrt_koops.catalog
685 %{_mandir}/man1/abrt-action-analyze-oops.1*
686 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
687 %{_mandir}/man1/abrt-dump-journal-oops.1*
688 %{_mandir}/man1/abrt-dump-oops.1*
689 %{_mandir}/man5/abrt-oops.conf.5*
690 %{_mandir}/man5/koops_event.conf.5*
691
692 %files addon-pstoreoops
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
695 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
696 %{systemdunitdir}/abrt-pstoreoops.service
697 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
698 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
699 %{_mandir}/man1/abrt-merge-pstoreoops.1*
700
701 %files addon-python3
702 %defattr(644,root,root,755)
703 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
704 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
705 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_python3_format.conf
706 %{py3_sitescriptdir}/abrt_exception_handler3.py*
707 %{py3_sitescriptdir}/abrt_exception_handler3_container.py*
708 %{py3_sitescriptdir}/abrt3.pth
709 %{py3_sitescriptdir}/abrt3_container.pth
710 %{py3_sitescriptdir}/__pycache__/abrt_exception_handler3*.cpython-*.py[co]
711 %{_prefix}/lib/systemd/catalog/python3_abrt.catalog
712 %{_mandir}/man5/python3_event.conf.5*
713 %{_mandir}/man5/python3-abrt.conf.5*
714
715 %files addon-upload-watch
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
718 %{systemdunitdir}/abrt-upload-watch.service
719 %{_mandir}/man1/abrt-upload-watch.1*
720
721 %files addon-vmcore
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
724 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
725 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
726 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
727 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_vmcore_format.conf
728 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
729 %{_datadir}/libreport/events/analyze_VMcore.xml
730 %{systemdunitdir}/abrt-vmcore.service
731 %{_prefix}/lib/systemd/catalog/abrt_vmcore.catalog
732 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
733 %{_mandir}/man1/abrt-harvest-vmcore.1*
734 %{_mandir}/man5/abrt-vmcore.conf.5*
735 %{_mandir}/man5/vmcore_event.conf.5*
736
737 %files addon-xorg
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
740 %attr(755,root,root) %{_bindir}/abrt-dump-journal-xorg
741 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
742 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
743 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
744 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_xorg_format.conf
745 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
746 %{systemdunitdir}/abrt-xorg.service
747 %{_prefix}/lib/systemd/catalog/abrt_xorg.catalog
748 %{_mandir}/man1/abrt-action-analyze-xorg.1*
749 %{_mandir}/man1/abrt-dump-journal-xorg.1*
750 %{_mandir}/man1/abrt-dump-xorg.1*
751 %{_mandir}/man5/abrt-xorg.conf.5*
752 %{_mandir}/man5/xorg_event.conf.5*
753
754 %files plugin-bodhi
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_bindir}/abrt-action-find-bodhi-update
757 %attr(755,root,root) %{_bindir}/abrt-bodhi
758 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/bodhi_event.conf
759 %{_datadir}/libreport/events/analyze_BodhiUpdates.xml
760 %{_mandir}/man1/abrt-action-find-bodhi-update.1*
761 %{_mandir}/man1/abrt-bodhi.1*
762
763 %files retrace-client
764 %defattr(644,root,root,755)
765 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
766 %attr(755,root,root) %{_bindir}/abrt-retrace-client
767 %{_datadir}/libreport/events/analyze_RetraceServer.xml
768 %{_mandir}/man1/abrt-retrace-client.1*
769
770 %files dbus
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_sbindir}/abrt-dbus
773 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_dbus_event.conf
774 /etc/dbus-1/system.d/dbus-abrt.conf
775 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
776 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.xml
777 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Entry.xml
778 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Session.xml
779 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Task.xml
780 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
781 %{_datadir}/polkit-1/actions/abrt_polkit.policy
782 %{_mandir}/man8/abrt-dbus.8*
783 %{_docdir}/abrt-dbus-%{version}
784
785 %files python3
786 %defattr(644,root,root,755)
787 %dir %{py3_sitedir}/problem
788 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
789 %{py3_sitedir}/problem/*.py*
790 %{py3_sitedir}/problem/__pycache__
791 %{_mandir}/man5/python3-abrt.5*
792
793 %files gui
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_bindir}/abrt-applet
796 %attr(755,root,root) %{_bindir}/system-config-abrt
797 %dir %{_datadir}/%{name}
798 %{_datadir}/%{name}/ui
799 %{_iconsdir}/hicolor/scalable/apps/abrt.svg
800 %{_iconsdir}/hicolor/symbolic/apps/abrt-symbolic.svg
801 %{_sysconfdir}/xdg/autostart/org.freedesktop.problems.applet.desktop
802 %{_datadir}/dbus-1/services/org.freedesktop.problems.applet.service
803 %{_mandir}/man1/abrt-applet.1*
804 %{_mandir}/man1/system-config-abrt.1*
805
806 %files gui-libs
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
809 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
810
811 %files gui-devel
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libabrt_gui.so
814 %{_includedir}/abrt/abrt-config-widget.h
815 %{_includedir}/abrt/system-config-abrt.h
816 %{_pkgconfigdir}/abrt_gui.pc
817
818 %files desktop
819 %defattr(644,root,root,755)
820
821 %files console-notification
822 %defattr(644,root,root,755)
823 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.133349 seconds and 3 git commands to generate.