]> git.pld-linux.org Git - packages/Zope3-psycopgda.git/blob - Zope3-psycopgda.spec
- cosmetics
[packages/Zope3-psycopgda.git] / Zope3-psycopgda.spec
1 %define         zope_subname    psycopgda
2 Summary:        PostgreSQL database adapter for Zope 3
3 Summary(pl):    Adapter bazy danych PostgreSQL dla Zope 3
4 Name:           Zope3-%{zope_subname}
5 Version:        1.0.0
6 Release:        1
7 License:        ZPL 2.1
8 Group:          Development/Tools
9 Source0:        http://www.zope.org/Products/Zope3-Packages/psycopgda/%{version}/%{zope_subname}-%{version}.tgz
10 # Source0-md5:  da55609e4612f2c6d431b00dfa57c369
11 Patch0:         %{name}-python_2_4_1.patch
12 URL:            http://www.zope.org/Products/Zope3-Packages/psycopgda/view
13 BuildRequires:  python
14 Requires(post,postun):  /usr/sbin/installzope3package
15 Requires(post,postun):  rc-scripts
16 %pyrequires_eq  python-modules
17 Requires:       Zope3
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         zope_libdir             /usr/lib/zope3
22 %define         zope_pyscriptdir        /usr/share/zope3/lib/python
23
24 %description
25 PostgreSQL database adapter for Zope 3.
26
27 %description -l pl
28 Adapter bazy danych PostgreSQL dla Zope 3.
29
30 %prep
31 %setup -q -n %{zope_subname}-%{version}
32 %patch0 -p1
33
34 %build
35 ./configure
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{_sysconfdir}/zope3
41
42 python install.py install \
43         --root="$RPM_BUILD_ROOT" \
44         --install-purelib="%{zope_pyscriptdir}"
45
46 mv $RPM_BUILD_ROOT%{_prefix}/zopeskel $RPM_BUILD_ROOT%{_sysconfdir}/zope3
47
48 %py_comp $RPM_BUILD_ROOT%{zope_pyscriptdir}
49 %py_ocomp $RPM_BUILD_ROOT%{zope_pyscriptdir}
50
51 find $RPM_BUILD_ROOT -type f -name "*.py" | xargs rm
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /usr/sbin/installzope3package %{zope_subname}
58 if [ -f /var/lock/subsys/zope3 ]; then
59         /etc/rc.d/init.d/zope3 restart >&2
60 fi
61
62 %postun
63 if [ "$1" = "0" ]; then
64         /usr/sbin/installzope3package -d %{zope_subname}
65         if [ -f /var/lock/subsys/zope3 ]; then
66                 /etc/rc.d/init.d/zope3 restart >&2
67         fi
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %{zope_pyscriptdir}
73 %{_sysconfdir}/zope3/zopeskel%{_sysconfdir}/package-includes/*.zcml
This page took 0.029796 seconds and 3 git commands to generate.