]> git.pld-linux.org Git - packages/Zope-LocalFS.git/blob - Zope-LocalFS.spec
- initial release
[packages/Zope-LocalFS.git] / Zope-LocalFS.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    LocalFS
3 Summary:        This product allows you to store Zope objects as human-readable files
4 Summary(pl):    Dodatek umo¿liwiaj±cy praktyczniejsze przetrzymywanie obiektów Zope
5 Name:           Zope-%{zope_subname}
6 Version:        1.1.0
7 Release:        1
8 License:        Distributable
9 Group:          Development/Tools
10 Source0:        http://dl.sourceforge.net/sourceforge/localfs/%{zope_subname}-1-1-0.tgz
11 # Source0-md5:  738c05ad9e4cb59518269bc21fa79a1d
12 URL:            http://www.my-zope.org/Members/kedai/LocalFS-1-1-0.tgz/file_view/
13 %pyrequires_eq  python-modules
14 Requires:       Zope
15 Requires(post,postun):  /usr/sbin/installzopeproduct
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This product allows you to store Zope objects as human-readable files
21 in the local file system.
22
23 %description -l pl
24 Dodatek dla Zope umo¿liwiaj±cy przetrzymywanie obiektów Zope w
25 lokalnym systemie plików.
26
27 %prep
28 %setup -q -c %{zope_subname}
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
33
34 cp -af lib/python/Products/LocalFS/{Extensions,dtml,help,www,*.py,version.txt} $RPM_BUILD_ROOT%{_datadir}/%{name}
35
36 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
37 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
38
39 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
46 if [ -f /var/lock/subsys/zope ]; then
47         /etc/rc.d/init.d/zope restart >&2
48 fi
49
50 %postun
51 if [ "$1" = "0" ]; then
52         /usr/sbin/installzopeproduct -d %{zope_subname}
53         if [ -f /var/lock/subsys/zope ]; then
54                 /etc/rc.d/init.d/zope restart >&2
55         fi
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc lib/python/Products/LocalFS/{CHANGES,LICENSE,README,TODO}
61 %{_datadir}/%{name}
This page took 0.074875 seconds and 3 git commands to generate.