]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- upgraded to 2.0RC3 version
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         zope_subname    CMFPlone
4 Summary:        Free and open source Content Management System based on Zope and CMF
5 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
6 Name:           Zope-%{zope_subname}
7 Version:        2.0
8 %define         sub_ver RC3
9 Release:        5.%{sub_ver}.1
10 License:        Zope Public License (ZPL), GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
13 # Source0-md5:  3d27488719abe082abd4082f9b8dbc16
14 URL:            http://www.plone.org/
15 %pyrequires_eq  python-modules
16 Requires:       Zope-CMF >= 1.4
17 Requires:       Zope >= 2.6.2
18 Requires:       Zope-BTreeFolder2
19 Requires:       Zope-CMFQuickInstallerTool
20 Requires:       Zope-ExternalEditor
21 Requires:       Zope-Formulator
22 Requires:       Zope-GroupUserFolder >= 2.0
23 Requires(post,postun):  /usr/sbin/installzopeproduct
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      Plone
27 Conflicts:      CMF
28
29 %description
30 Plone is a free, open source Content Management System. The focus of
31 Plone is to provide value at every level of an organization. It comes
32 with a workflow engine, pre-configured security and roles, a set of
33 content types and multi-lingual support. There are many developers,
34 writers and testers from all over the world, contributing to Plone
35 everyday. Plone is based on the Content Management Framework.
36
37 %description -l pl
38 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
39 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
40 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
41 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
42 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
43 Pythonem.
44
45 %prep
46 %setup -q -n %{zope_subname}-%{version}-%{sub_ver}
47
48 %build
49 # remove dirs - additional packages!
50 # ExternalEditor
51 rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder}
52 find . -type f -name "*.pyo" -exec rm -rf {} \;;
53
54 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n docs/PlacelessTranslationService
55 rm -rf `find . type f -name .cvsignore`
56 mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
57 mv -f CMFPlone/docs/* docs/CMFPlone
58 mv -f CMFPlone/i18n/ChangeLog docs/i18n
59 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
60 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
61 rm -rf CMFPlone/docs
62 mv -f PlacelessTranslationService/{COPYING.txt,NEWS.txt} docs/PlacelessTranslationService
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
67 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
68
69 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
70 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
71
72 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService; do
79         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
80 done
81 if [ -f /var/lock/subsys/zope ]; then
82         /etc/rc.d/init.d/zope restart >&2
83 fi
84
85 %postun
86 if [ "$1" = "0" ]; then
87         for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService; do
88                 /usr/sbin/installzopeproduct -d $p
89         done
90         if [ -f /var/lock/subsys/zope ]; then
91                 /etc/rc.d/init.d/zope restart >&2
92         fi
93 fi
94
95 %files
96 %defattr(644,root,root,755)
97 %doc docs/*
98 %{_datadir}/%{name}
This page took 0.523124 seconds and 4 git commands to generate.