]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- added BR: python
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1
2 %define         zope_subname    CMFPlone
3 Summary:        Free and open source Content Management System based on Zope and CMF
4 Summary(pl):    Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
5 Name:           Zope-%{zope_subname}
6 Version:        2.0.5
7 # %%define              sub_ver RC6
8 Release:        4
9 License:        Zope Public License (ZPL), GPL
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/plone/Plone-%{version}.tar.gz
12 # Source0-md5:  fe8ce932877c53bb22b1f88d2b4c9211
13 URL:            http://www.plone.org/
14 BuildRequires:  python
15 %pyrequires_eq  python-modules
16 Requires:       Zope-archetypes >= 1.2.5
17 Requires:       Zope-CMF = 1:1.4.7
18 Requires:       Zope >= 2.6.2
19 Requires:       Zope-BTreeFolder2
20 Requires:       Zope-CMFQuickInstallerTool >= 1.5.1
21 Requires:       Zope-ExternalEditor
22 Requires:       Zope-Formulator >= 1.6.2
23 Requires:       Zope-GroupUserFolder >= 2.0.1
24 Requires:       Zope-Epoz >= 0.8.2
25 Requires:       i18ndude
26 Requires(post,postun):  /usr/sbin/installzopeproduct
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29 Obsoletes:      Plone
30 Obsoletes:      Zope-PortalTransforms
31 #Conflicts:     Zope-CMF = 1.5.0
32 Conflicts:      CMF
33
34 %description
35 Plone is a free, open source Content Management System. The focus of
36 Plone is to provide value at every level of an organization. It comes
37 with a workflow engine, pre-configured security and roles, a set of
38 content types and multi-lingual support. There are many developers,
39 writers and testers from all over the world, contributing to Plone
40 everyday. Plone is based on the Content Management Framework.
41
42 %description -l pl
43 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
44 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
45 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
46 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
47 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
48 Pythonem.
49
50 %prep
51 %setup -q -n Plone-%{version}
52 # remove dirs - additional packages!
53 # ExternalEditor
54 rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder,Archetypes,generator,validation}
55 rm -rf {CMFCalendar,CMFCore,CMFDefault,CMFTopic,DCWorkflow,PortalTransforms,Epoz}
56 find . -type d -name debian | xargs rm -rf
57
58 %build
59 mkdir docs docs/CMFPlone docs/CMFFormController docs/PlacelessTranslationService docs/PloneErrorReporting
60 mv -f CMFPlone/{CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,UPGRADE.txt,LICENSE.txt} docs/CMFPlone
61 # mv -f CMFPlone/docs/* docs/CMFPlone
62 rm -rf CMFPlone/LICENSE.GPL
63 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
64 rm -rf CMFPlone/docs
65 mv -f PlacelessTranslationService/NEWS.txt docs/PlacelessTranslationService
66 mv -f PloneErrorReporting/{ChangeLog,README.txt} docs/PloneErrorReporting
67 rm -rf PloneErrorReporting/LICENSE.txt
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
72 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
73
74 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
75 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
76
77 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService PloneErrorReporting; do
84         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
85 done
86 if [ -f /var/lock/subsys/zope ]; then
87         /etc/rc.d/init.d/zope restart >&2
88 fi
89
90 %postun
91 if [ "$1" = "0" ]; then
92         for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService PloneErrorReporting; do
93                 /usr/sbin/installzopeproduct -d $p
94         done
95         if [ -f /var/lock/subsys/zope ]; then
96                 /etc/rc.d/init.d/zope restart >&2
97         fi
98 fi
99
100 %files
101 %defattr(644,root,root,755)
102 %doc docs/*
103 %{_datadir}/%{name}
This page took 0.036599 seconds and 4 git commands to generate.