]> git.pld-linux.org Git - packages/X11-driver-firegl.git/blob - X11-driver-firegl.spec
29d0517c096a6522c240a7cdfd05b7bd36c9eed0
[packages/X11-driver-firegl.git] / X11-driver-firegl.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel
4 #
5 # TODO:
6 # - kernel modules (SMP)
7
8 Summary:        Linux Drivers for ATI graphics accelerators
9 Summary(pl):    Sterowniki do akceleratorów graficznych ATI
10 Name:           XFree86-driver-firegl
11 Version:        2.9.13
12 Release:        2
13 License:        ATI Binary
14 Vendor:         ATI
15 Group:          X11/XFree86
16 URL:            http://www.ati.com/support/drivers/linux/radeon-linux.html
17 #Source0:       http://pdownload.mii.instacontent.net/ati/drivers/fglrx-glc22-4.2.0-%{version}.i586.rpm
18 Source0:        http://www.schneider-digital.de/download/ati/glx1_linux_X4.3.zip
19 # Source0-md5:  a4bc85bb0f68e988abd2b5cd8cd9252f
20 Patch0:         firegl-panel.patch
21 BuildRequires:  cpio
22 %{!?_without_dist_kernel:BuildRequires:         kernel-headers >= 2.2.0 }
23 BuildRequires:  rpm-utils
24 Requires:       XFree86-Xserver
25 Requires:       XFree86-libs >= 4.2.0
26 Requires:       XFree86-modules >= 4.2.0
27 Requires:       kernel-video-firegl = %{version}
28 Provides:       XFree86-OpenGL-core
29 Conflicts:      XFree86-OpenGL-devel <= 4.2.0-3
30 ExclusiveArch:  i586 i686 athlon
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32 Obsoletes:      Mesa
33 Obsoletes:      XFree86-OpenGL-core
34
35 %define         _noautoreqdep   libGL.so.1.2
36
37 %define         _prefix         /usr/X11R6
38 %define         _mandir         %{_prefix}/man
39
40 %description
41 Display driver files for the ATI Radeon 8500, 9700, Mobility M9 and
42 the FireGL 8700/8800, E1, Z1/X1 graphics accelerators. This package
43 provides 2D display drivers and hardware accelerated OpenGL.
44
45 %description -l pl
46 Sterowniki do kart graficznych ATI Radeon 8500, 9700, Mobility M9 oraz
47 graficznych akceleratorów FireGL 8700/8800, E1, Z1/X1. Pakiet
48 dostarcza sterowniki obs³uguj±ce wy¶wietlanie 2D oraz sprzêtowo
49 akcelerowany OpenGL.
50
51 %package -n kernel-video-firegl
52 Summary:        ATI kernel module for FireGL support
53 Summary(pl):    Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL
54 Release:        %{release}@%{_kernel_ver_str}
55 License:        ATI
56 Vendor:         ATI
57 Group:          Base/Kernel
58 %{!?_without_dist_kernel:%requires_releq_kernel_up}
59 PreReq:         modutils >= 2.3.18-2
60 Requires(post,postun):  /sbin/depmod
61
62 %description -n kernel-video-firegl
63 ATI kernel module for FireGL support.
64
65 %description -n kernel-video-firegl -l pl
66 Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL.
67
68 %prep
69 %setup -q -c -T
70 unzip %{SOURCE0}
71 mv Xfree4.3/Xfree4.3.0_%{version}_2/* .
72 rpm2cpio fglrx-glc22-4.3.0-%{version}.i586.rpm | cpio -i -d
73 bzip2 -d -v usr/X11R6/bin/*.bz2
74 mkdir panel_src
75 tar -xzf usr/src/fglrx_panel_sources.tgz -C panel_src
76 %patch0 -p1
77
78 %build
79 cd lib/modules/fglrx/build_mod/
80 cp make.sh make.sh.org && rm -f make.sh
81 sed -e 's#gcc#%{kgcc}#g' -e 's#`id -u` -ne 0#`id -u` -ne `id -u`#g' make.sh.org > make.sh
82 chmod 755 make.sh
83 ./make.sh
84 cd ../../../../panel_src
85 %{__make} MK_QTDIR=/usr \
86         LIBQT_DYN=qt-mt
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/X11/extensions} \
91         $RPM_BUILD_ROOT{/lib/modules/%{_kernel_ver}/misc/,/usr/lib}
92
93 install lib/modules/fglrx/build_mod/fglrx.o             $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/
94
95 install usr/X11R6/bin/{fgl_glxgears,fglrxconfig,fglrxinfo} $RPM_BUILD_ROOT%{_bindir}
96 install panel_src/{fireglcontrol.qt3.gcc3.3,fireglcontrol} $RPM_BUILD_ROOT%{_bindir}
97 cp -r usr/X11R6/lib/* $RPM_BUILD_ROOT%{_libdir}/
98
99 cd $RPM_BUILD_ROOT%{_libdir}
100 ln -s libGL.so.* libGL.so
101 ln -s %{_libdir}/libGL.so $RPM_BUILD_ROOT/usr/lib/libGL.so
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %post   -n kernel-video-firegl
110 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
111
112 %postun -n kernel-video-firegl
113 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
114
115 %files
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_bindir}/*
118 %attr(755,root,root) /usr/lib/lib*.so*
119 %attr(755,root,root) %{_libdir}/lib*.so*
120 %attr(755,root,root) %{_libdir}/modules/*/*.so
121 %attr(755,root,root) %{_libdir}/modules/*/*.o
122 %attr(644,root,root) %{_libdir}/modules/*/*.a
123
124 %files -n kernel-video-firegl
125 %defattr(644,root,root,755)
126 /lib/modules/%{_kernel_ver}/misc/*.o*
This page took 0.054866 seconds and 2 git commands to generate.