]> git.pld-linux.org Git - packages/VMware-player.git/blob - VMware-player.spec
- updated pl for modules
[packages/VMware-player.git] / VMware-player.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace utilities
6 %bcond_with     internal_libs   # internal libs stuff
7 %bcond_with     verbose         # verbose build (V=1)
8
9 %if %{without kernel}
10 %undefine       with_dist_kernel
11 %endif
12 %ifarch %{x8664}
13 %undefine       with_userspace
14 %endif
15
16 %define         ver             16.1.2
17 %define         buildid         17966106
18 %define         rel             0.1
19
20 # point to some working url
21 %define         download_url    %{nil}
22
23 Summary:        VMware player
24 Summary(pl.UTF-8):      VMware player - wirtualna platforma dla stacji roboczej
25 Name:           VMware-player
26 Version:        %{ver}.%{buildid}
27 Release:        %{rel}
28 License:        custom, non-distributable
29 Group:          Applications/Emulators
30 # https://www.vmware.com/go/downloadplayer/
31 Source0:        %{download_url}VMware-Player-%{ver}-%{buildid}.x86_64.bundle
32 # NoSource0-md5:        f50090a394730f20c0ae9c715e56f6ed
33 NoSource:       0
34 Patch0:         installer.patch
35 URL:            https://www.vmware.com/products/workstation-player.html
36 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.7}
37 BuildRequires:  rpmbuild(macros) >= 1.268
38 BuildRequires:  sed >= 4.0
39 Requires:       atk
40 Requires:       cairo
41 Requires:       cairomm
42 Requires:       curl-libs >= 7.19.7-2
43 Requires:       expat
44 Requires:       fontconfig-libs
45 Requires:       freetype
46 Requires:       glib2
47 Requires:       glibmm
48 Requires:       gtk+2
49 Requires:       gtkmm
50 Requires:       gtkmm-atk
51 Requires:       libaio
52 Requires:       libarchive
53 Requires:       libart_lgpl
54 Requires:       libgcc
55 Requires:       libpng
56 Requires:       librsvg
57 Requires:       libsexy
58 Requires:       libsexymm
59 Requires:       libsigc++
60 Requires:       libstdc++
61 Requires:       libview >= 0.5.5-2
62 Requires:       libxml2
63 Requires:       openssl >= 0.9.7
64 Requires:       pango
65 Requires:       pangomm
66 Requires:       xorg-lib-libXau
67 Requires:       xorg-lib-libXcomposite
68 Requires:       xorg-lib-libXcursor
69 Requires:       xorg-lib-libXdamage
70 Requires:       xorg-lib-libXdmcp
71 Requires:       xorg-lib-libXfixes
72 Requires:       xorg-lib-libXft
73 Requires:       xorg-lib-libXinerama
74 Requires:       xorg-lib-libXrandr
75 Requires:       xorg-lib-libXrender
76 ExclusiveArch:  %{x8664}
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         _noautoprovfiles %{_libdir}/vmware/lib/.*\.so.*
80
81 %define         debug_package   %{nil}
82
83 %description
84 VMware Player Virtual Platform is a thin software layer that allows
85 multiple guest operating systems to run concurrently on a single
86 standard PC, without repartitioning or rebooting, and without
87 significant loss of performance.
88
89 %description -l pl.UTF-8
90 VMware Player Virtual Platform to cienka warstwa oprogramowania
91 pozwalająca na jednoczesne działanie wielu gościnnych systemów
92 operacyjnych na jednym zwykłym PC, bez repartycjonowania ani
93 rebootowania, bez znacznej utraty wydajności.
94
95 %package debug
96 Summary:        VMware debug utility
97 Summary(pl.UTF-8):      Narzędzie VMware do odpluskwiania
98 Group:          Applications/Emulators
99 Requires:       %{name} = %{version}-%{release}
100
101 %description debug
102 VMware debug utility.
103
104 %description debug -l pl.UTF-8
105 Narzędzie VMware do odpluskwiania.
106
107 %package help
108 Summary:        VMware Player help files
109 Summary(pl.UTF-8):      Pliki pomocy dla VMware Player
110 Group:          Applications/Emulators
111 Requires:       %{name} = %{version}-%{release}
112
113 %description help
114 VMware Player help files.
115
116 %description help -l pl.UTF-8
117 Pliki pomocy dla VMware Player.
118
119 %package networking
120 Summary:        VMware networking utilities
121 Summary(pl.UTF-8):      Narzędzia VMware do obsługi sieci
122 Group:          Applications/Emulators
123 Requires(post,preun):   /sbin/chkconfig
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       rc-scripts
126 Obsoletes:      VMware-player-samba < 2.0
127
128 %description networking
129 VMware networking utilities.
130
131 %description networking -l pl.UTF-8
132 Narzędzia VMware do obsługi sieci.
133
134 %package -n kernel%{_alt_kernel}-misc-vmmon
135 Summary:        VMware Virtual Machine Monitor kernel module
136 Summary(pl.UTF-8):      Moduł jądra VMware Virtual Machine Monitor - monitor maszyny wirtualnej
137 Release:        %{rel}@%{_kernel_ver_str}
138 Group:          Base/Kernel
139 Requires(post,postun):  /sbin/depmod
140 Requires:       dev >= 2.9.0-7
141 %if %{with dist_kernel}
142 %requires_releq_kernel
143 Requires(postun):       %releq_kernel
144 %endif
145
146 %description -n kernel%{_alt_kernel}-misc-vmmon
147 VMware Virtual Machine Monitor kernel module.
148
149 %description -n kernel%{_alt_kernel}-misc-vmmon -l pl.UTF-8
150 Moduł jądra VMware Virtual Machine Monitor - monitor maszyny
151 wirtualnej.
152
153 %package -n kernel%{_alt_kernel}-misc-vmnet
154 Summary:        VMware Virtual Networking Driver kernel module
155 Summary(pl.UTF-8):      Moduł jądra VMware Virtual Networking Driver - sterownik sieciowy maszyny wirtualnej
156 Release:        %{rel}@%{_kernel_ver_str}
157 Group:          Base/Kernel
158 Requires(post,postun):  /sbin/depmod
159 Requires:       dev >= 2.9.0-7
160 %if %{with dist_kernel}
161 %requires_releq_kernel
162 Requires(postun):       %releq_kernel
163 %endif
164
165 %description -n kernel%{_alt_kernel}-misc-vmnet
166 VMware Virtual Networking Driver.
167
168 %description -n kernel%{_alt_kernel}-misc-vmnet -l pl.UTF-8
169 Moduł jądra VMware Virtual Networking Driver - sterownik sieciowy
170 maszyny wirtualnej.
171
172 %prep
173 %setup -qcT
174
175 export SOURCE=%{SOURCE0}
176
177 # extract installer shell blob
178 %{__sed} -ne '1,/^exit/{s,$0,$SOURCE,;p}' $SOURCE > install.sh
179 %{__sed} -i -e "2iSOURCE=$SOURCE" install.sh
180 %patch0 -p1
181 chmod a+x install.sh
182
183 ./install.sh --extract bundles
184
185 cd bundles/vmware-vmx/lib/modules
186 %{__tar} xf source/vmmon.tar
187 %{__tar} xf source/vmnet.tar
188 cd -
189
190 %build
191 %if %{with kernel}
192 cd bundles/vmware-vmx/lib/modules
193
194 %build_kernel_modules -C vmmon-only -m vmmon SRCROOT=$PWD VM_KBUILD=yes
195
196 %build_kernel_modules -C vmnet-only -m vmnet SRCROOT=$PWD VM_KBUILD=yes
197
198 cd ../../../..
199 %endif
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203
204 %if %{with kernel}
205 %install_kernel_modules -m bundles/vmware-vmx/lib/modules/vmmon-only/vmmon -d misc
206 %install_kernel_modules -m bundles/vmware-vmx/lib/modules/vmnet-only/vmnet -d misc
207 %endif
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %post   -n kernel%{_alt_kernel}-misc-vmmon
213 %depmod %{_kernel_ver}
214
215 %postun -n kernel%{_alt_kernel}-misc-vmmon
216 %depmod %{_kernel_ver}
217
218 %post   -n kernel%{_alt_kernel}-misc-vmnet
219 %depmod %{_kernel_ver}
220
221 %postun -n kernel%{_alt_kernel}-misc-vmnet
222 %depmod %{_kernel_ver}
223
224 %if %{with userspace}
225 %files
226 %defattr(644,root,root,755)
227 %endif
228
229 %files -n kernel%{_alt_kernel}-misc-vmmon
230 %defattr(644,root,root,755)
231 /lib/modules/%{_kernel_ver}/misc/vmmon.ko*
232
233 %files -n kernel%{_alt_kernel}-misc-vmnet
234 %defattr(644,root,root,755)
235 /lib/modules/%{_kernel_ver}/misc/vmnet.ko*
This page took 0.063925 seconds and 3 git commands to generate.