]> git.pld-linux.org Git - packages/SPE.git/blob - SPE.spec
- up to 0.8.1.c (should be in arekm's commitlog)
[packages/SPE.git] / SPE.spec
1 # TODO:
2 # - fix %%files (doc to %%doc, no .py, remove unused files)
3 %define _wx     2.6.1.0
4 %define _bl     2.35
5
6 Summary:        SPE - Stani's Python Editor
7 Summary(pl):    SPE - pythonowy edytor Staniego
8 Name:           SPE
9 Version:        0.8.1.c
10 Release:        2
11 License:        LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
12 Group:          Applications/Text
13 Source0:        http://download.berlios.de/python/%{name}-%{version}-wx%{_wx}.-bl%{_bl}.tar.gz
14 # Source0-md5:  b98d68d33cad1f28c0b4e8091f271f8f
15 Source1:        %{name}.desktop
16 Source2:        %{name}.png
17 URL:            http://spe.pycs.net/
18 BuildRequires:  python
19 BuildRequires:  python-devel
20 BuildRequires:  python-modules
21 Requires:       pydoc
22 %pyrequires_eq  python-modules
23 Requires:       python-wxPython >= %{_wx}
24 # below is needed - SPE doesn't start without "hacked" release of wxPython (reporting version issue)
25 Requires:       python-wxPython >= 2.6.1.0-3
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Spe is a python IDE with auto-indentation, auto completion, call tips,
31 syntax coloring, syntax highlighting, class explorer, source index,
32 auto todo list, sticky notes, integrated pycrust shell, python file
33 browser, recent file browser, drag&drop, context help, ... Special is
34 its blender support with a blender 3d object browser and its ability
35 to run interactively inside blender. Spe is extensible with boa. 
36
37 %description -l pl
38 Spe (Stani's Python Editor) to pythonowe IDE z automatycznym
39 wykonywaniem wciêæ, automatycznym dope³nianiem, podpowiedziami
40 wywo³añ, kolorowaniem sk³adni, pod¶wietlaniem sk³adni, eksploratorem
41 klas, indeksem ¼róde³, automatyczn± list± TODO, przyklejanymi
42 notatkami, zintegrowan± pow³ok± pycrust, przegl±dark± plików
43 pythonowych, przegl±dark± ostatnio u¿ywanych plików, obs³ug± w stylu
44 przeci±gnij-i-upu¶æ, pomoc± kontekstow±... Specjaln± rzecz± jest
45 wsparcie dla blendera z przegl±dark± obiektów blendera 3D i
46 mo¿liwo¶ci± automatycznego uruchamiania z poziomu blendera. Spe jest
47 rozszerzalne przy pomocy boa.
48
49 %prep
50 %setup -q -n %{name}-%{version}-wx%{_wx}.-bl%{_bl}
51
52 %build
53 python setup.py build
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
58
59 python setup.py install \
60         --optimize=2 \
61         --root=$RPM_BUILD_ROOT
62
63 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
64 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
65
66 # SPE doesn't work without *.py files so don't remove them
67 #%%py_postclean
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README.txt
75 %attr(755,root,root) %{_bindir}/*
76 %{py_sitescriptdir}/*
77 %{_desktopdir}/*
78 %{_pixmapsdir}/*
This page took 0.08532 seconds and 4 git commands to generate.