]> git.pld-linux.org Git - packages/SPE.git/blob - SPE.spec
- up to 0.8.1.d by Robert Tomasik
[packages/SPE.git] / SPE.spec
1 # TODO:
2 # - fix %%files (doc to %%doc, no .py, remove unused files)
3 %define _wx     2.6.1.0
4 #
5 Summary:        SPE - Stani's Python Editor
6 Summary(pl):    SPE - pythonowy edytor Staniego
7 Name:           SPE
8 Version:        0.8.1.d
9 Release:        1
10 License:        LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
11 Group:          Applications/Text
12 Source0:        http://download.berlios.de/python/%{name}-%{version}-wx%{_wx}.tar.gz
13 # Source0-md5:  ea3f3bdf50d4dd26d21f9fc6fab70523
14 Source1:        %{name}.desktop
15 Source2:        %{name}.png
16 URL:            http://spe.pycs.net/
17 BuildRequires:  python
18 BuildRequires:  python-devel
19 BuildRequires:  python-modules
20 Requires:       pydoc
21 %pyrequires_eq  python-modules
22 Requires:       python-wxPython >= %{_wx}
23 # below is needed - SPE doesn't start without "hacked" release of wxPython (reporting version issue)
24 Requires:       python-wxPython >= 2.6.1.0-3
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Spe is a python IDE with auto-indentation, auto completion, call tips,
30 syntax coloring, syntax highlighting, class explorer, source index,
31 auto todo list, sticky notes, integrated pycrust shell, python file
32 browser, recent file browser, drag&drop, context help, ... Special is
33 its blender support with a blender 3d object browser and its ability
34 to run interactively inside blender. Spe is extensible with boa. 
35
36 %description -l pl
37 Spe (Stani's Python Editor) to pythonowe IDE z automatycznym
38 wykonywaniem wciêæ, automatycznym dope³nianiem, podpowiedziami
39 wywo³añ, kolorowaniem sk³adni, pod¶wietlaniem sk³adni, eksploratorem
40 klas, indeksem ¼róde³, automatyczn± list± TODO, przyklejanymi
41 notatkami, zintegrowan± pow³ok± pycrust, przegl±dark± plików
42 pythonowych, przegl±dark± ostatnio u¿ywanych plików, obs³ug± w stylu
43 przeci±gnij-i-upu¶æ, pomoc± kontekstow±... Specjaln± rzecz± jest
44 wsparcie dla blendera z przegl±dark± obiektów blendera 3D i
45 mo¿liwo¶ci± automatycznego uruchamiania z poziomu blendera. Spe jest
46 rozszerzalne przy pomocy boa.
47
48 %prep
49 %setup -q -n %{name}-%{version}-wx%{_wx}
50
51 %build
52 python setup.py build
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
57
58 python setup.py install \
59         --optimize=2 \
60         --root=$RPM_BUILD_ROOT
61
62 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
63 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
64
65 # SPE doesn't work without *.py files so don't remove them
66 #%%py_postclean
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README.txt
74 %attr(755,root,root) %{_bindir}/*
75 %{py_sitescriptdir}/*
76 %{_desktopdir}/*
77 %{_pixmapsdir}/*
This page took 0.032828 seconds and 4 git commands to generate.