]> git.pld-linux.org Git - packages/SDL2_mixer.git/blob - SDL2_mixer.spec
smpeg support was dropped in favour of mpg123
[packages/SDL2_mixer.git] / SDL2_mixer.spec
1 #
2 # Conditional build:
3 %bcond_with     mikmod  # mikmod use for MOD support (modplug is used by default)
4 %bcond_without  modplug # modplug use for MOD support
5 %bcond_with     libmad  # libmad use for MP3 support (libmpg123 is used by default)
6 %bcond_without  mpg123  # libmpg123 use for MP3 support
7 #
8 # NOTE: libraries dlopened by sonames detected at build time:
9 # libFLAC.so.8
10 # libfluidsynth.so.1
11 # libmikmod.so.2
12 # libmodplug.so.1
13 # libmpg123.so.0
14 # libopusfile.so.0
15 # libvorbisfile.so.3
16 #
17 Summary:        Simple DirectMedia Layer - Sample Mixer Library
18 Summary(pl.UTF-8):      Simple DirectMedia Layer - biblioteka miksująca próbki dźwiękowe
19 Summary(pt_BR.UTF-8):   SDL2 - Biblioteca para mixagem
20 Name:           SDL2_mixer
21 Version:        2.0.4
22 Release:        2
23 License:        Zlib-like
24 Group:          Libraries
25 Source0:        http://www.libsdl.org/projects/SDL_mixer/release/%{name}-%{version}.tar.gz
26 # Source0-md5:  a36e8410cac46b00a4d01752b32c3eb1
27 URL:            http://www.libsdl.org/projects/SDL_mixer/
28 BuildRequires:  SDL2-devel >= 2.0.7
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  flac-devel >= 1.3.0
32 BuildRequires:  fluidsynth-devel
33 %{?with_libmad:BuildRequires:   libmad-devel}
34 BuildRequires:  libtool >= 2:2.0
35 %{?with_mikmod:BuildRequires:   libmikmod-devel >= 3.1.10}
36 %{?with_modplug:BuildRequires:  libmodplug-devel >= 0.8.8}
37 %{?with_mpg123:BuildRequires:   libmpg123-devel}
38 BuildRequires:  libogg-devel
39 BuildRequires:  libvorbis-devel >= 1:1.0
40 BuildRequires:  opusfile-devel >= 0.2
41 BuildRequires:  pkgconfig >= 1:0.9.0
42 Requires:       SDL2 >= 2.0.7
43 %{?with_mikmod:Suggests:        libmikmod >= 3.1.10}
44 %{?with_modplug:Suggests:       libmodplug >= 0.8.8}
45 Suggests:       opusfile >= 0.2
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Due to popular demand, here is a simple multi-channel audio mixer. It
50 supports 4 channels of 16 bit stereo audio, plus a single channel of
51 music, mixed by the popular MikMod MOD, Timidity MIDI and MPG123 MP3
52 libraries.
53
54 %description -l pl.UTF-8
55 SDL2_mixer to prosty wielokanałowy mikser audio. Obsługuje 4 kanały
56 16-bitowego dźwięku stereo plus jeden kanał dla muzyki miksowanej
57 przez popularne biblioteki MikMod MOD, Timitity MIDI i MPG123 MP3.
58
59 %description -l pt_BR.UTF-8
60 Biblioteca que suporta 4 canais de áudio estéreo 16 bit, mais um canal
61 de música, mixado pelo populares bibliotecas MOD MikMod, MIDI timidity
62 e MPG123 MP3.
63
64 %package devel
65 Summary:        Header files and more to develop SDL_mixer applications
66 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwoju aplikacji używających biblioteki SDL_mixer
67 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento de aplicações SDL
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       SDL2-devel >= 2.0.7
71
72 %description devel
73 Header files and more to develop SDL2_mixer applications.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe do rozwoju aplikacji używających biblioteki
77 SDL2_mixer.
78
79 %description devel -l pt_BR.UTF-8
80 Bibliotecas e arquivos de inclusão para desenvolvimento de aplicações
81 SDL2.
82
83 %package static
84 Summary:        Static SDL2_mixer library
85 Summary(pl.UTF-8):      Statyczna biblioteka SDL2_mixer
86 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com SDL2_mixer
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static SDL2_mixer library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka SDL2_mixer.
95
96 %description static -l pt_BR.UTF-8
97 Bibliotecas estáticas para desenvolvimento com SDL2_mixer.
98
99 %prep
100 %setup -q
101
102 %{__rm} acinclude/{libtool,lt*}.m4
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I acinclude
107 %{__autoconf}
108 %configure \
109         %{?with_mikmod:--enable-music-mod-mikmod} \
110         %{!?with_modplug:--disable-music-mod-modplug} \
111         %{?with_libmad:--enable-music-mp3-mad-gpl} \
112         %{!?with_mpg123:--disable-music-mp3-mpg123}
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install install-bin \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %{__mv} $RPM_BUILD_ROOT%{_bindir}/playmus $RPM_BUILD_ROOT%{_bindir}/playmus2
122 %{__mv} $RPM_BUILD_ROOT%{_bindir}/playwave $RPM_BUILD_ROOT%{_bindir}/playwave2
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc CHANGES.txt COPYING.txt README.txt
133 %attr(755,root,root) %{_bindir}/playmus2
134 %attr(755,root,root) %{_bindir}/playwave2
135 %attr(755,root,root) %{_libdir}/libSDL2_mixer-2.0.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libSDL2_mixer-2.0.so.0
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libSDL2_mixer.so
141 %{_libdir}/libSDL2_mixer.la
142 %{_includedir}/SDL2/SDL_mixer.h
143 %{_pkgconfigdir}/SDL2_mixer.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libSDL2_mixer.a
This page took 0.053419 seconds and 3 git commands to generate.