]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- reenabled alsa and arts on ppc
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.3
20 Release:        7
21 License:        LGPL
22 Group:          X11/Libraries
23 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
24 Patch0:         %{name}-byteorder.patch
25 Patch1:         %{name}-fixlibs.patch
26 Patch2:         %{name}-amfix.patch
27 Patch3:         %{name}-lpthread.patch
28 URL:            http://www.libsdl.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{!?_without_esound:BuildRequires:      esound-devel}
32 %{!?_without_arts:BuildRequires:        arts-devel}
33 BuildRequires:  XFree86-devel >= 4.0.2
34 BuildRequires:  OpenGL-devel
35 BuildRequires:  perl-modules
36 %ifarch %{ix86}
37 BuildRequires:  nasm
38 %endif
39 %ifnarch sparc sparc64
40 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
41 %endif
42 %{?_with_svgalib:BuildRequires: svgalib-devel}
43 %{?_with_aalib:BuildRequires:   aalib-devel}
44 %{?_with_ggi:BuildRequires:     libggi-devel}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _prefix         /usr/X11R6
48 %define         _mandir         %{_prefix}/man
49
50 %description
51 SDL (Simple DirectMedia Layer) is a library that allows you portable,
52 low level access to a video framebuffer, audio output, mouse, and
53 keyboard. It can support both windowed and DGA modes of XFree86, and
54 it is designed to be portable - applications linked with SDL can also
55 be built on Win32 and BeOS.
56
57 %description -l pl
58 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
59 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
60 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
61 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
62 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
63
64 %description -l pt_BR
65 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
66 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
67
68 Essa biblioteca é usada por alguns jogos.
69
70 %package devel
71 Summary:        SDL - Header files
72 Summary(pl):    SDL - Pliki nag³ówkowe
73 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}
76 %ifnarch sparc sparc64
77 %{!?_without_alsa:Requires:     alsa-lib-devel}
78 %endif
79 %{!?_without_esound:Requires:   esound-devel}
80 %{!?_without_arts:Requires:     arts-devel}
81 Requires:       XFree86-devel >= 4.0.2
82
83 %description devel
84 SDL - Header files.
85
86 %description devel -l pl
87 SDL - Pliki nag³ówkowe.
88
89 %description devel -l pt_BR
90 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
91 recursos para o desenvolvimento de aplicativos com SDL.
92
93 %package static
94 Summary:        SDL - static libraries
95 Summary(pl):    SDL - biblioteki statyczne
96 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
97 Group:          X11/Development/Libraries
98 Requires:       %{name}-devel = %{version}
99
100 %description static
101 SDL - static libraries.
102
103 %description static -l pl
104 SDL - biblioteki statyczne.
105
106 %description static -l pt_BR
107 Biblioteca estática para desenvolvimento de aplicações com a SDL.
108
109 %package examples
110 Summary:        SDL - example programs
111 Summary(pl):    SDL - programy przyk³adowe
112 Group:          X11/Development/Libraries
113 Requires:       %{name}-devel = %{version}
114
115 %description examples
116 SDL - example programs.
117
118 %description examples -l pl
119 SDL - przyk³adowe programy.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124 %patch1 -p1
125 %patch2 -p1
126 %patch3 -p1
127
128 %build
129 rm -f missing
130 libtoolize --copy --force
131 aclocal
132 autoconf
133 # Another hack
134 cp -f src/hermes/Makefile.in Makefile.in.ok
135 automake -a -c --foreign
136 cp -f Makefile.in.ok src/hermes/Makefile.in
137 %configure \
138 %ifarch %{ix86}
139         --enable-nasm \
140 %else
141         --disable-nasm \
142 %endif
143         --enable-pthreads \
144         --enable-pthread-sem \
145         --with-x \
146         --enable-dga \
147         --enable-video-dga \
148         --enable-video-x11-dgamouse \
149         --enable-video-x11-vm \
150         --enable-video-x11-xv \
151         --enable-video-opengl \
152         --enable-video-fbcon \
153         %{?_with_svga:--enable-video-svga} \
154         %{?_with_aalib:--enable-video-aalib} \
155         %{?_with_ggi:--enable-video-ggi} \
156 %ifnarch sparc sparc64
157         %{!?_without_alsa:--enable-alsa} \
158 %endif
159         %{!?_without_esound:--enable-esd} \
160         %{!?_without_arts:--enable-arts}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT \
167         m4datadir=%{_aclocaldir}
168
169 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
170
171 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
172 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
173
174 gzip -9nf BUGS CREDITS README TODO WhatsNew
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/lib*.so.*.*
185
186 %files devel
187 %defattr(644,root,root,755)
188 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
189 %attr(755,root,root) %{_bindir}/sdl-config
190 %attr(755,root,root) %{_libdir}/lib*.so
191 %attr(755,root,root) %{_libdir}/lib*.la
192 %{_libdir}/libSDLmain.a
193 %{_includedir}/SDL
194 %{_aclocaldir}/*
195 %{_mandir}/man3/*
196
197 %files examples
198 %{_examplesdir}/%{name}-%{version}
199
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/libSDL.a
This page took 0.077838 seconds and 4 git commands to generate.