]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- cleanup acinclude.m4, else libtool fails
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 %bcond_with     aalib           # with aalib graphics support
4 %bcond_with     caca            # with caca graphics support
5 %bcond_with     directfb        # with DirectFB graphics support
6 %bcond_with     ggi             # with GGI graphics support
7 %bcond_with     nas             # with NAS audio support
8 %bcond_with     svga            # with svgalib graphics support
9 %bcond_without  alsa            # without ALSA audio support
10 %bcond_without  arts            # without aRts audio support
11 %bcond_without  esd             # without EsounD audio support
12 %bcond_without  static_libs     # don't build static libraries
13 #
14 # NOTE: the following libraries are dlopened by soname detected at build time:
15 # libasound.so.2
16 # libesd.so.0
17 # libpulse-simple.so.0
18 # libX11.so.6
19 # libXext.so.6
20 # libXrender.so.1
21 # libXrandr.so.2
22 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
23 Summary(pl.UTF-8):      SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
24 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) Generic APIs - 游戏/多媒体库
25 Name:           SDL
26 Version:        1.2.13
27 Release:        2
28 License:        LGPL v2.1+
29 Group:          Libraries
30 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
31 # Source0-md5:  c6660feea2a6834de10bc71b2f8e4d88
32 Patch0:         %{name}-mmx-constraints.patch
33 Patch1:         %{name}-acfix.patch
34 Patch2:         %{name}-caca.patch
35 Patch3:         %{name}-libdir.patch
36 URL:            http://www.libsdl.org/
37 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.15}
38 BuildRequires:  OpenGL-GLU-devel
39 %{?with_aalib:BuildRequires:    aalib-devel}
40 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
41 %{?with_arts:BuildRequires:     artsc-devel >= 1.1}
42 BuildRequires:  autoconf >= 2.59-9
43 BuildRequires:  automake
44 %{?with_esd:BuildRequires:      esound-devel >= 0.2.8}
45 BuildRequires:  gcc >= 5:4.0
46 %{?with_caca:BuildRequires:     libcaca-devel}
47 %{?with_ggi:BuildRequires:      libggi-devel}
48 BuildRequires:  libtool >= 2:1.4d
49 %{?with_nas:BuildRequires:      nas-devel}
50 %ifarch %{ix86}
51 BuildRequires:  nasm
52 %endif
53 BuildRequires:  perl-modules
54 %{?with_directfb:BuildRequires: pkgconfig >= 1:0.7}
55 BuildRequires:  pulseaudio-devel >= 0.9
56 %{?with_svga:BuildRequires:     svgalib-devel >= 1.4.0}
57 BuildRequires:  tslib-devel
58 BuildRequires:  xorg-lib-libX11-devel
59 BuildRequires:  xorg-lib-libXext-devel
60 BuildRequires:  xorg-lib-libXrandr-devel
61 BuildRequires:  xorg-lib-libXrender-devel
62 BuildRequires:  xorg-proto-xextproto-devel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         specflags_ppc   -maltivec
66
67 %description
68 SDL (Simple DirectMedia Layer) is a library that allows you portable,
69 low level access to a video framebuffer, audio output, mouse, and
70 keyboard. It can support both windowed and DGA modes of XFree86, and
71 it is designed to be portable - applications linked with SDL can also
72 be built on Win32 and BeOS.
73
74 %description -l pl.UTF-8
75 SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
76 przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
77 myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
78 jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
79 konsolidowane z SDL można również budować w systemach Win32 i BeOS.
80
81 %description -l pt_BR.UTF-8
82 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
83 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
84
85 Essa biblioteca é usada por alguns jogos.
86
87 %description -l ru.UTF-8
88 SDL (Simple DirectMedia Layer) это набор функций, предоставляющий
89 низкоуровневый доступ к звуку, клавиатуре, манипулятору мышь и к
90 буферу экрана на множестве различных платформ.
91
92 %package devel
93 Summary:        SDL - Header files
94 Summary(pl.UTF-8):      SDL - Pliki nagłówkowe
95 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de cabeçalho para aplicações SDL
96 Summary(ru.UTF-8):      Файлы, необходимые для разработки программ, использующих SDL
97 Summary(uk.UTF-8):      Файли, необхідні для розробки програм, що використовують SDL
98 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) 开发库
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 Suggests:       OpenGL-GLU-devel
102 %{?with_directfb:Requires:      DirectFB-devel >= 0.9.15}
103 %{?with_aa:Requires:    aalib-devel}
104 %{?with_caca:Requires:  libcaca-devel}
105 %{?with_ggi:Requires:   libggi-devel}
106 %{?with_nas:Requires:   nas-devel}
107 %{?with_svga:Requires:  svgalib-devel >= 1.4.0}
108 Requires:       tslib-devel
109
110 %description devel
111 SDL - Header files.
112
113 %description devel -l pl.UTF-8
114 SDL - Pliki nagłówkowe.
115
116 %description devel -l pt_BR.UTF-8
117 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
118 recursos para o desenvolvimento de aplicativos com SDL.
119
120 %description devel -l ru.UTF-8
121 Этот пакет содержит файлы, необходимые для разработки программ,
122 использующих SDL.
123
124 %description devel -l uk.UTF-8
125 Цей пакет містить файли, необхідні для розробки програм, що
126 використовують SDL.
127
128 %package static
129 Summary:        SDL - static libraries
130 Summary(pl.UTF-8):      SDL - biblioteki statyczne
131 Summary(pt_BR.UTF-8):   Biblioteca estática para desenvolvimento de aplicações com a SDL
132 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием SDL
133 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням SDL
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136
137 %description static
138 SDL - static libraries.
139
140 %description static -l pl.UTF-8
141 SDL - biblioteki statyczne.
142
143 %description static -l pt_BR.UTF-8
144 Biblioteca estática para desenvolvimento de aplicações com a SDL.
145
146 %description static -l ru.UTF-8
147 Этот пакет содержит статические библиотеки для разработки программ,
148 использующих SDL.
149
150 %description static -l uk.UTF-8
151 Цей пакет містить статичні бібліотеки для розробки програм, що
152 використовують SDL.
153
154 %package examples
155 Summary:        SDL - example programs
156 Summary(pl.UTF-8):      SDL - programy przykładowe
157 License:        Public Domain
158 Group:          Development/Libraries
159 Requires:       %{name}-devel = %{version}-%{release}
160
161 %description examples
162 SDL - example programs.
163
164 %description examples -l pl.UTF-8
165 SDL - przykładowe programy.
166
167 %prep
168 %setup -q
169 %patch0 -p1
170 %patch1 -p1
171 #%patch2 -p1    # needs rewrite
172 %patch3 -p1
173
174 : > acinclude.m4
175 %{!?with_alsa:echo 'AC_DEFUN([AM_PATH_ALSA],[$3])' >> acinclude.m4}
176 %{!?with_esd:echo 'AC_DEFUN([AM_PATH_ESD],[$3])' >> acinclude.m4}
177
178 %build
179 %{__libtoolize}
180 %{__aclocal}
181 %{__autoconf}
182 %configure \
183 %ifarch %{ix86}
184         --enable-nasm \
185 %else
186         --disable-nasm \
187 %endif
188         --disable-rpath \
189         %{!?with_alsa:--disable-alsa} \
190         %{!?with_arts:--disable-arts} \
191         --enable-dga \
192         %{!?with_esd:--disable-esd} \
193         %{!?with_nas:--disable-nas} \
194         --enable-pthreads \
195         --enable-pthread-sem \
196         %{?with_aalib:--enable-video-aalib} \
197         %{?with_caca:--enable-video-caca} \
198         %{!?with_directfb:--disable-video-directfb} \
199         --enable-video-dga \
200         --enable-video-fbcon \
201         %{?with_ggi:--enable-video-ggi} \
202         --enable-video-opengl \
203         %{!?with_svga:--disable-video-svga} \
204         --enable-video-x11-dgamouse \
205         --enable-video-x11-vm \
206         --enable-video-x11-xinerama \
207         --enable-video-x11-xme \
208         --enable-video-x11-xrandr \
209         --enable-video-x11-xv \
210         --with-x \
211         %{!?with_static_libs:--disable-static}
212
213 %{__make}
214
215 %install
216 rm -rf $RPM_BUILD_ROOT
217 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
218
219 %{__make} install \
220         DESTDIR=$RPM_BUILD_ROOT \
221         m4datadir=%{_aclocaldir}
222
223 rm -rf test/autom4te.cache
224 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
225
226 rm -rf docs/man3
227
228 %clean
229 rm -rf $RPM_BUILD_ROOT
230
231 %post   -p /sbin/ldconfig
232 %postun -p /sbin/ldconfig
233
234 %files
235 %defattr(644,root,root,755)
236 %doc BUGS CREDITS README README-SDL.txt TODO WhatsNew
237 %attr(755,root,root) %{_libdir}/libSDL-1.2.so.*.*.*
238 %attr(755,root,root) %ghost %{_libdir}/libSDL-1.2.so.0
239
240 %files devel
241 %defattr(644,root,root,755)
242 %doc docs.html docs
243 %attr(755,root,root) %{_bindir}/sdl-config
244 %attr(755,root,root) %{_libdir}/libSDL.so
245 %{_libdir}/libSDL.la
246 %{_libdir}/libSDLmain.a
247 %{_includedir}/SDL
248 %{_aclocaldir}/sdl.m4
249 %{_pkgconfigdir}/sdl.pc
250 %{_mandir}/man3/SDL*.3*
251
252 %if %{with static_libs}
253 %files static
254 %defattr(644,root,root,755)
255 %{_libdir}/libSDL.a
256 %endif
257
258 %files examples
259 %defattr(644,root,root,755)
260 %{_examplesdir}/%{name}-%{version}
This page took 0.105227 seconds and 4 git commands to generate.