]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- added using %%{__make} macro.
[packages/SDL.git] / SDL.spec
1 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
2 Name:           SDL
3 Version:        1.1.3
4 Release:        1
5 License:        LGPL
6 Group:          X11/Libraries
7 Group(pl):      X11/Biblioteki
8 Source0:        http://www.devolution.com/~slouken/SDL/release/%{name}-%{version}.tar.gz
9 URL:            http://www.devolution.com/~slouken/SDL/
10 BuildRequires:  esound-devel
11 BuildRequires:  gtk+-devel >= 1.2.1
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         _prefix         /usr/X11R6
15 %define         _mandir         %{_prefix}/man
16
17 %description
18 SDL (Simple DirectMedia Layer) is a library that allows you portable,
19 low level access to a video framebuffer, audio output, mouse, and
20 keyboard. It can support both windowed and DGA modes of XFree86, and
21 it is designed to be portable - applications linked with SDL can also
22 be built on Win32 and BeOS.
23
24 %description -l pl
25 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
26 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
27 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
28 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
29 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
30
31 %package devel
32 Summary:        SDL - Header files
33 Group:          X11/Libraries
34 Group(pl):      X11/Biblioteki
35 Requires:       %{name} = %{version}
36
37 %description devel
38 SDL - Header files.
39
40 %package static
41 Summary:        SDL - static libraries
42 Group:          X11/Libraries
43 Group(pl):      X11/Biblioteki
44 Requires:       %{name} = %{version}
45
46 %description static
47 SDL - static libraries.
48
49 %prep
50 %setup -q
51 %build
52 LDFLAGS="-s"; export LDFLAGS
53 %configure \
54         --enable-nasm \
55         --enable-pthreads \
56         --with-x \
57         --enable-video-x11-dga \
58         --enable-video-x11-mtrr \
59         --enable-esd \
60         --disable-video-svga
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT \
67         m4datadir=%{_aclocaldir}
68
69 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
70
71 gzip -9nf BUGS README WhatsNew
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_libdir}/lib*.so.*.*
82
83 %files devel
84 %defattr(644,root,root,755)
85 %doc *gz docs.html docs
86 %attr(755,root,root) %{_bindir}/sdl-config
87 %attr(755,root,root) %{_libdir}/lib*.so
88 %attr(755,root,root) %{_libdir}/lib*.la
89 %{_libdir}/libSDLmain.a
90 %{_includedir}/SDL
91 %{_aclocaldir}/*
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/lib*.a
This page took 0.118713 seconds and 4 git commands to generate.