]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- BR+R: tslib-devel
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 %bcond_with     aalib           # with aalib graphics support
4 %bcond_with     caca            # with caca graphics support
5 %bcond_with     directfb        # with DirectFB graphics support
6 %bcond_with     ggi             # with GGI graphics support
7 %bcond_with     nas             # with NAS audio support
8 %bcond_with     svga            # with svgalib graphics support
9 %bcond_without  alsa            # without ALSA audio support
10 %bcond_without  arts            # without aRts audio support
11 %bcond_without  esd             # without EsounD audio support
12 %bcond_without  static_libs     # don't build static libraries
13 #
14 # NOTE: the following libraries are dlopened by soname detected at build time:
15 # libasound.so.2
16 # libesd.so.0
17 # libpulse-simple.so.0
18 # libX11.so.6
19 # libXext.so.6
20 # libXrender.so.1
21 # libXrandr.so.2
22 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
23 Summary(pl.UTF-8):      SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
24 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) Generic APIs - 游戏/多媒体库
25 Name:           SDL
26 Version:        1.2.13
27 Release:        1
28 License:        LGPL v2.1+
29 Group:          Libraries
30 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
31 # Source0-md5:  c6660feea2a6834de10bc71b2f8e4d88
32 Patch0:         %{name}-mmx-constraints.patch
33 Patch1:         %{name}-acfix.patch
34 Patch2:         %{name}-caca.patch
35 URL:            http://www.libsdl.org/
36 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.15}
37 BuildRequires:  OpenGL-GLU-devel
38 %{?with_aalib:BuildRequires:    aalib-devel}
39 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
40 %{?with_arts:BuildRequires:     artsc-devel >= 1.1}
41 BuildRequires:  autoconf >= 2.59-9
42 BuildRequires:  automake
43 %{?with_esd:BuildRequires:      esound-devel >= 0.2.8}
44 BuildRequires:  gcc >= 5:4.0
45 %{?with_caca:BuildRequires:     libcaca-devel}
46 %{?with_ggi:BuildRequires:      libggi-devel}
47 BuildRequires:  libtool >= 2:1.4d
48 %{?with_nas:BuildRequires:      nas-devel}
49 %ifarch %{ix86}
50 BuildRequires:  nasm
51 %endif
52 BuildRequires:  perl-modules
53 %{?with_directfb:BuildRequires: pkgconfig >= 1:0.7}
54 BuildRequires:  pulseaudio-devel >= 0.9
55 %{?with_svga:BuildRequires:     svgalib-devel >= 1.4.0}
56 BuildRequires:  tslib-devel
57 BuildRequires:  xorg-lib-libX11-devel
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXrandr-devel
60 BuildRequires:  xorg-lib-libXrender-devel
61 BuildRequires:  xorg-proto-xextproto-devel
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 SDL (Simple DirectMedia Layer) is a library that allows you portable,
66 low level access to a video framebuffer, audio output, mouse, and
67 keyboard. It can support both windowed and DGA modes of XFree86, and
68 it is designed to be portable - applications linked with SDL can also
69 be built on Win32 and BeOS.
70
71 %description -l pl.UTF-8
72 SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
73 przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
74 myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
75 jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
76 konsolidowane z SDL można również budować w systemach Win32 i BeOS.
77
78 %description -l pt_BR.UTF-8
79 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
80 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
81
82 Essa biblioteca é usada por alguns jogos.
83
84 %description -l ru.UTF-8
85 SDL (Simple DirectMedia Layer) это набор функций, предоставляющий
86 низкоуровневый доступ к звуку, клавиатуре, манипулятору мышь и к
87 буферу экрана на множестве различных платформ.
88
89 %package devel
90 Summary:        SDL - Header files
91 Summary(pl.UTF-8):      SDL - Pliki nagłówkowe
92 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de cabeçalho para aplicações SDL
93 Summary(ru.UTF-8):      Файлы, необходимые для разработки программ, использующих SDL
94 Summary(uk.UTF-8):      Файли, необхідні для розробки програм, що використовують SDL
95 Summary(zh_CN.UTF-8):   SDL (Simple DirectMedia Layer) 开发库
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98 Suggests:       OpenGL-GLU-devel
99 %{?with_directfb:Requires:      DirectFB-devel >= 0.9.15}
100 %{?with_aa:Requires:    aalib-devel}
101 %{?with_caca:Requires:  libcaca-devel}
102 %{?with_ggi:Requires:   libggi-devel}
103 %{?with_nas:Requires:   nas-devel}
104 %{?with_svga:Requires:  svgalib-devel >= 1.4.0}
105 Requires:       tslib-devel
106
107 %description devel
108 SDL - Header files.
109
110 %description devel -l pl.UTF-8
111 SDL - Pliki nagłówkowe.
112
113 %description devel -l pt_BR.UTF-8
114 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
115 recursos para o desenvolvimento de aplicativos com SDL.
116
117 %description devel -l ru.UTF-8
118 Этот пакет содержит файлы, необходимые для разработки программ,
119 использующих SDL.
120
121 %description devel -l uk.UTF-8
122 Цей пакет містить файли, необхідні для розробки програм, що
123 використовують SDL.
124
125 %package static
126 Summary:        SDL - static libraries
127 Summary(pl.UTF-8):      SDL - biblioteki statyczne
128 Summary(pt_BR.UTF-8):   Biblioteca estática para desenvolvimento de aplicações com a SDL
129 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием SDL
130 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням SDL
131 Group:          Development/Libraries
132 Requires:       %{name}-devel = %{version}-%{release}
133
134 %description static
135 SDL - static libraries.
136
137 %description static -l pl.UTF-8
138 SDL - biblioteki statyczne.
139
140 %description static -l pt_BR.UTF-8
141 Biblioteca estática para desenvolvimento de aplicações com a SDL.
142
143 %description static -l ru.UTF-8
144 Этот пакет содержит статические библиотеки для разработки программ,
145 использующих SDL.
146
147 %description static -l uk.UTF-8
148 Цей пакет містить статичні бібліотеки для розробки програм, що
149 використовують SDL.
150
151 %package examples
152 Summary:        SDL - example programs
153 Summary(pl.UTF-8):      SDL - programy przykładowe
154 License:        Public Domain
155 Group:          Development/Libraries
156 Requires:       %{name}-devel = %{version}-%{release}
157
158 %description examples
159 SDL - example programs.
160
161 %description examples -l pl.UTF-8
162 SDL - przykładowe programy.
163
164 %prep
165 %setup -q
166 %patch0 -p1
167 %patch1 -p1
168 #%patch2 -p1    # needs rewrite
169
170 %{!?with_alsa:echo 'AC_DEFUN([AM_PATH_ALSA],[$3])' >> acinclude.m4}
171 %{!?with_esd:echo 'AC_DEFUN([AM_PATH_ESD],[$3])' >> acinclude.m4}
172
173 %build
174 %{__libtoolize}
175 %{__aclocal}
176 %{__autoconf}
177 %configure \
178 %ifarch %{ix86}
179         --enable-nasm \
180 %else
181         --disable-nasm \
182 %endif
183         --disable-rpath \
184         %{!?with_alsa:--disable-alsa} \
185         %{!?with_arts:--disable-arts} \
186         --enable-dga \
187         %{!?with_esd:--disable-esd} \
188         %{!?with_nas:--disable-nas} \
189         --enable-pthreads \
190         --enable-pthread-sem \
191         %{?with_aalib:--enable-video-aalib} \
192         %{?with_caca:--enable-video-caca} \
193         %{!?with_directfb:--disable-video-directfb} \
194         --enable-video-dga \
195         --enable-video-fbcon \
196         %{?with_ggi:--enable-video-ggi} \
197         --enable-video-opengl \
198         %{!?with_svga:--disable-video-svga} \
199         --enable-video-x11-dgamouse \
200         --enable-video-x11-vm \
201         --enable-video-x11-xinerama \
202         --enable-video-x11-xme \
203         --enable-video-x11-xrandr \
204         --enable-video-x11-xv \
205         --with-x \
206         %{!?with_static_libs:--disable-static}
207
208 %{__make}
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
213
214 %{__make} install \
215         DESTDIR=$RPM_BUILD_ROOT \
216         m4datadir=%{_aclocaldir}
217
218 rm -rf test/autom4te.cache
219 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
220
221 rm -rf docs/man3
222
223 %clean
224 rm -rf $RPM_BUILD_ROOT
225
226 %post   -p /sbin/ldconfig
227 %postun -p /sbin/ldconfig
228
229 %files
230 %defattr(644,root,root,755)
231 %doc BUGS CREDITS README README-SDL.txt TODO WhatsNew
232 %attr(755,root,root) %{_libdir}/libSDL-1.2.so.*.*.*
233 %attr(755,root,root) %ghost %{_libdir}/libSDL-1.2.so.0
234
235 %files devel
236 %defattr(644,root,root,755)
237 %doc docs.html docs
238 %attr(755,root,root) %{_bindir}/sdl-config
239 %attr(755,root,root) %{_libdir}/libSDL.so
240 %{_libdir}/libSDL.la
241 %{_libdir}/libSDLmain.a
242 %{_includedir}/SDL
243 %{_aclocaldir}/sdl.m4
244 %{_pkgconfigdir}/sdl.pc
245 %{_mandir}/man3/SDL*.3*
246
247 %if %{with static_libs}
248 %files static
249 %defattr(644,root,root,755)
250 %{_libdir}/libSDL.a
251 %endif
252
253 %files examples
254 %defattr(644,root,root,755)
255 %{_examplesdir}/%{name}-%{version}
This page took 0.049541 seconds and 4 git commands to generate.