]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- de
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - use bconds
3 Summary:        Rexx interpreter
4 Summary(de):    Ein Interpreter für REXX
5 Summary(pl):    Interpreter jêzyka REXX
6 Name:           Regina
7 Version:        3.3
8 Release:        0.1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
12 # Source0-md5:  bdb85f57cbe3e7f9b45aea329cd7752e
13 Source1:        %{name}.init
14 Patch0:         %{name}-makefileinfix.patch
15 URL:            http://regina-rexx.sourceforge.net
16 BuildRequires:  bison
17 BuildRequires:  flex
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(post,preun):   /sbin/chkconfig
20 Provides:       rexx
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Regina is a Rexx interpreter that has been ported to most Unix
25 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
26 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
27 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
28 programming language that was designed to be easy to use for
29 inexperienced programmers yet powerful enough for experienced users.
30 It is also a language ideally suited as a macro language for other
31 applications.
32
33 There are two major goals for Regina:
34 - become 100% compliant with the ANSI Standard.
35 - be available on as many platforms as possible
36
37 %description -l de
38 Regina ist ein Rexx Interpreter der für die meisten Unix Platformen
39 übersetzt worden ist (Linux, FreeBSD, Solaris, AIX, HP-UX, usw.) und
40 auser dem auch für OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, Aros,
41 QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS und
42 OpenEdition. Rexx ist eine Programiersprache die für unerfahrene
43 Programierer entwickelt wurde aber Stark genug für erfahrene
44 Programierer ist. Es ist ebenfalls eine Sprache die sich ideal als
45 Makrosprache für andere Applikationen eignet.
46
47 Regina hat zwei Hauptziele:
48 - es soll 100% kompatibel mit dem ANSI Standard sein
49 - es soll auf so vielen Platformen wie nur möglich laufen
50
51 %description -l pl
52 Regina jest interpreterem jêzyka REXX, który zosta³ ju¿ przeniesiony
53 na wiêkszo¶æ Unixowych platform (Linux, FreeBSD, Solaris, AIX, HP-UX,
54 itp.) a tak¿e OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x,
55 QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition.
56 Rexx jest jêzykiem programowania, który zosta³ zaprojektowany, by byæ
57 prostym w u¿yciu przez niedo¶wiadczonych programistów oraz
58 wystarczaj±co u¿ytecznym, by byæ u¿ywanym przez do¶wiadczonych.
59 Idealnie sprawdza siê jako jêzyk pisania makr dla innych aplikacji
60
61 Dwa g³ówne cele tego interpretera, to
62 - Stuprocentowa kompatybilno¶æ ze standardemi ANSI
63 - dostêpno¶æ na jak najwiêkszej liczbie platform
64
65 %package devel
66 Summary:        Header files for Regina
67 Summary(de):    Header Dateien für Regina
68 Summary(pl):    Pliki nag³ówkowe dla Regina
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71
72 %description devel
73 Development files for Regina.
74
75 %description devel -l de
76 Header Dateien für Regina.
77
78 %description devel -l pl
79 Pliki nag³ówkowe dla Regina.
80
81 %package libs
82 Summary:        Libraries for Regina
83 Summary(de):    Regina Libraries
84 Summary(pl):    Biblioteki dla Regina
85 Group:          Libraries
86 Provides:       libregina.so
87 Provides:       libregina.so(REXXSAA_API)
88 Provides:       libregina.so(regina_2.0)
89
90 %description libs
91 Regina libraries.
92
93 %description libs -l de
94 Regina Libraries.
95
96 %description libs -l pl
97 Biblioteki dla packietu Regina.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102
103 %build
104 ./configure
105 %{__make} \
106         CC="%{__cc}" \
107         CFLAGS="%{rpmcflags}"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_mandir}/man1}
112 %{__make} install \
113     DESTDIR=$RPM_BUILD_ROOT
114 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
115 install regina.1 $RPM_BUILD_ROOT%{_mandir}/man1
116 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
117 rm -f $RPM_BUILD_ROOT%{_prefix}/man1/regina.1
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 /sbin/chkconfig --add rxstack
124 %service rxstack restart
125
126 %preun
127 if [ "$1" = "0" ] ; then
128         %service rxstack stop
129         /sbin/chkconfig --del rxstack
130 fi
131
132 %post libs -p /sbin/ldconfig
133 %postun libs -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc COPYING-LIB README* demo
138 %attr(755,root,root) %{_bindir}/*
139 %attr(754,root,root) /etc/rc.d/init.d/rxstack
140 %dir %{_datadir}/regina
141 %attr(755,root,root) %{_datadir}/regina/*.rexx
142 %{_datadir}/regina/*.mtb
143 %{_mandir}/man1/regina.1*
144
145 %files libs
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/*.so
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/*.a
152 %{_includedir}/rexxsaa.h
This page took 1.670392 seconds and 3 git commands to generate.