]> git.pld-linux.org Git - packages/QtSingleApplication.git/blob - QtSingleApplication.spec
- add patch from clementine; rel 3
[packages/QtSingleApplication.git] / QtSingleApplication.spec
1 Summary:        Qt library to start applications only once per user
2 Name:           QtSingleApplication
3 Version:        2.6
4 Release:        3
5 License:        GPL v3 or LGPL v2 with exceptions
6 Group:          Libraries
7 URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsingleapplication
8 Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/qtsingleapplication-%{version}_1-opensource.tar.gz
9 # Source0-md5:  902795eb13ecedbdc112f00d7ec22949
10 Source1:        qtsingleapplication.prf
11 Patch0:         qtsingleapplication-build.diff
12 Patch1:         qtsingleapplication-dont-bundle-external-libs.patch
13 Patch2:         clementine.patch
14 BuildRequires:  QtCore-devel
15 BuildRequires:  QtGui-devel
16 BuildRequires:  QtLockedFile-devel
17 BuildRequires:  QtNetwork-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  qt4-build
20 BuildRequires:  qt4-qmake
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _qt4_datadir    %{_datadir}/qt4
24
25 %description
26 For some applications it is useful or even critical that they are
27 started only once by any user. Future attempts to start the
28 application should activate any already running instance, and possibly
29 perform requested actions, e.g. loading a file, in that instance.
30
31 The QtSingleApplication class provides an interface to detect a
32 running instance, and to send command strings to that instance.
33
34 For console (non-GUI) applications, the QtSingleCoreApplication
35 variant is provided, which avoids dependency on QtGui.
36
37 %package        devel
38 Summary:        Development files for QtSingleApplication
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       qt4-build
42 Requires:       qt4-qmake
43
44 %description    devel
45 This package contains libraries and header files for developing
46 applications that use QtSingleApplication.
47
48 %prep
49 %setup -q -n qtsingleapplication-%{version}_1-opensource
50 %patch0 -p1
51 %patch1 -p1
52 %patch2 -p1
53
54 # We already disabled bundling this extrenal library.
55 # But just to make sure:
56 rm src/{QtLocked,qtlocked}*
57
58 %build
59 touch .licenseAccepted
60 # Does not use GNU configure
61 ./configure \
62         -library
63
64 # XXX fix QtLockedFile package
65 qmake-qt4 INCLUDEPATH+=%{_includedir}/QtSolutions
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 # libraries
72 install -d $RPM_BUILD_ROOT%{_libdir}
73 cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
74 rm $RPM_BUILD_ROOT%{_libdir}/lib*.so.1.0
75
76 # headers
77 install -d $RPM_BUILD_ROOT%{_includedir}/QtSolutions
78 cp -a \
79     src/qtsingleapplication.h \
80     src/QtSingleApplication \
81     src/qtsinglecoreapplication.h \
82     src/QtSingleCoreApplication \
83     $RPM_BUILD_ROOT%{_includedir}/QtSolutions
84
85 install -d $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
86 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc LGPL_EXCEPTION.txt LICENSE.* README.TXT
97 %attr(755,root,root) %{_libdir}/libQtSolutions_SingleApplication-%{version}.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libQtSolutions_SingleApplication-%{version}.so.1
99
100 %files devel
101 %defattr(644,root,root,755)
102 %doc doc examples
103 %{_libdir}/libQtSolutions_SingleApplication-%{version}.so
104 # XXX dir shared dir with QtLockedFile.spec
105 %dir %{_includedir}/QtSolutions
106 %{_includedir}/QtSolutions/QtSingleApplication
107 %{_includedir}/QtSolutions/QtSingleCoreApplication
108 %{_includedir}/QtSolutions/qtsingleapplication.h
109 %{_includedir}/QtSolutions/qtsinglecoreapplication.h
110 %{_qt4_datadir}/mkspecs/features/qtsingleapplication.prf
This page took 0.033395 seconds and 4 git commands to generate.