]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
583058bdd24c40e94a9921713b69d8ef74f84a18
[packages/QtCurve.git] / QtCurve.spec
1 # TODO:
2 #  - kde4
3 #  - gtk1 no longer updated. drop?
4 #  - include /usr/share/themes/QtCurve/mozilla somewhere
5 #
6 # Conditional build:
7 %bcond_with     gtk     # build GTK styles
8 %bcond_without  gtk2    # don't build GTK+2 styles
9 #
10 %define         kde_ver         0.55.1
11 %define         gtk2_ver        0.55.1
12 %define         gtk1_ver        0.42.2
13 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
14 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
15 Name:           QtCurve
16 Version:        0.55.1
17 Release:        1
18 License:        GPL
19 Group:          Themes
20 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
21 # Source0-md5:  1ba394626a40e8926966739500dbf87d
22 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
23 # Source1-md5:  0d5eeb45990c3ecf060daa68a2ed2e6f
24 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
25 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
26 Patch0:         %{name}-amd64.patch
27 Patch1:         kde-am110.patch
28 Patch2:         kde-ac260-lt.patch
29 URL:            http://www.kde-look.org/content/show.php?content=40492
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %{?with_gtk:BuildRequires:      gtk+-devel}
33 %{?with_gtk2:BuildRequires:     gtk+2-devel}
34 BuildRequires:  kdelibs-devel >= 3.1
35 BuildRequires:  libtool
36 BuildRequires:  pkgconfig
37 BuildRequires:  sed > 4.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A free and corrected port of Red Hat's GTK+/Qt theme.
42
43 %description -l pl.UTF-8
44 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
45
46 %package -n kde-style-QtCurve
47 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
48 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
49 Group:          Themes
50 Requires:       kdelibs >= 3.1
51
52 %description -n kde-style-QtCurve
53 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
54
55 %description -n kde-style-QtCurve -l pl.UTF-8
56 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
57 Wersja pod KDE.
58
59 %package -n gtk-theme-QtCurve
60 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
61 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
62 Group:          Themes
63 Requires:       theme-QtCurve-common = %{version}-%{release}
64
65 %description -n gtk-theme-QtCurve
66 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
67
68 %description -n gtk-theme-QtCurve -l pl.UTF-8
69 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
70 Wersja pod GTK+.
71
72 %package -n gtk2-theme-QtCurve
73 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
74 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
75 Group:          Themes
76 Requires:       theme-QtCurve-common = %{version}-%{release}
77
78 %description -n gtk2-theme-QtCurve
79 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
80
81 %description -n gtk2-theme-QtCurve -l pl.UTF-8
82 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
83 Wersja pod GTK+2.
84
85 %package -n theme-QtCurve-common
86 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
87 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
88 Group:          Themes
89 Obsoletes:      theme-bluecurve-common
90 Obsoletes:      gtk2-theme-bluecurve
91 Obsoletes:      gtk-theme-bluecurve
92 Obsoletes:      kde-style-bluecurve
93 Obsoletes:      kde-theme-bluecurve
94
95 %description -n theme-QtCurve-common
96 A free and corrected port of Red Hat's GTK+/Qt theme.
97 Documentation and common files package.
98
99 %description -n theme-QtCurve-common -l pl.UTF-8
100 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
101 Pakiet z dokumentacja i plikami współdzielonymi.
102
103 %prep
104 %setup -q -c -a1 -a2
105 #%patch0 -p1
106 cd %{name}-KDE3-%{kde_ver}
107 %patch1 -p1
108 %patch2 -p1
109
110 %build
111 cd %{name}-KDE3-%{kde_ver}
112 cp /usr/share/automake/config.sub admin
113
114 %{__make} -f admin/Makefile.common cvs
115 %configure \
116         --with-qt-libraries=%{_libdir}
117
118 %{__make}
119 cd -
120
121 %if %{with gtk}
122 cd %{name}-Gtk1-%{gtk1_ver}
123 %{__libtoolize}
124 %{__aclocal}
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure
129 %{__make}
130 cd -
131 %endif
132
133 %if %{with gtk2}
134 cd %{name}-Gtk2-%{gtk2_ver}
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140 %configure
141 %{__make}
142 cd -
143 %endif
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} -C %{name}-KDE3-%{kde_ver} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 %if %{with gtk}
152 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
153         DESTDIR=$RPM_BUILD_ROOT
154 %endif
155
156 %if %{with gtk2}
157 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
158         DESTDIR=$RPM_BUILD_ROOT
159 %endif
160
161 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %files -n kde-style-QtCurve
167 %defattr(644,root,root,755)
168 %{_libdir}/kde3/kstyle_qtcurve_config.la
169 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
170 %{_libdir}/kde3/plugins/styles/*.la
171 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
172 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
173 %{_datadir}/apps/QtCurve
174
175 %if %{with gtk}
176 %files -n gtk-theme-QtCurve
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
179 %{_datadir}/themes/QtCurve/gtk
180 %endif
181
182 %if %{with gtk2}
183 %files -n gtk2-theme-QtCurve
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
186 %{_datadir}/themes/QtCurve/gtk-2.0
187 %endif
188
189 %files -n theme-QtCurve-common
190 %defattr(644,root,root,755)
191 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
192 %dir %{_datadir}/themes/QtCurve
This page took 0.046319 seconds and 3 git commands to generate.