]> git.pld-linux.org Git - packages/Qt6Keychain.git/blob - Qt6Keychain.spec
- updated dependencies, package missing dirs
[packages/Qt6Keychain.git] / Qt6Keychain.spec
1 Summary:        Qt API to store passwords and other secret data securely
2 Summary(pl.UTF-8):      API Qt do bezpiecznego przechowywania haseł i innych tajnych danych
3 Name:           Qt6Keychain
4 Version:        0.14.2
5 Release:        1
6 License:        Modified BSD License
7 Group:          Libraries
8 #Source0Download: https://github.com/frankosterfeld/qtkeychain/releases
9 # TODO use:
10 #Source0:       https://github.com/frankosterfeld/qtkeychain/archive/%{version}/qtkeychain-%{version}.tar.gz
11 Source0:        https://github.com/frankosterfeld/qtkeychain/archive/refs/tags/%{version}.tar.gz
12 # Source0-md5:  7f75753541784068400d903e0e7a0d55
13 URL:            https://github.com/frankosterfeld/qtkeychain
14 BuildRequires:  Qt6Core-devel >= 6
15 BuildRequires:  Qt6DBus-devel >= 6
16 BuildRequires:  cmake >= 3.16
17 BuildRequires:  libsecret-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  pkgconfig
20 BuildRequires:  qt6-build >= 6
21 BuildRequires:  qt6-linguist >= 6
22 BuildRequires:  qt6-qmake >= 6
23 BuildRequires:  rpmbuild(find_lang) >= 1.37
24 BuildRequires:  rpmbuild(macros) >= 1.605
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Qt6Keychain a Qt API to store passwords and other secret data
29 securely.
30
31 How the data is stored depends on the platform:
32 - Mac OS X: Passwords are stored in the OS X Keychain.
33 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
34   tries to use KWallet (via D-Bus), if available.
35 - Windows: Windows does not provide a service for secure storage.
36   Qt6Keychain uses the Windows API function
37
38 %description -l pl.UTF-8
39 API Qt do bezpiecznego przechowywania haseł i innych tajnych danych.
40
41 Sposób przechowywania danych zależy od platformy:
42 - Mac OS X: hasła są przechowywanie poprzez usługę OS X Keychain
43 - Linux/Unix: używany jest GNOME Keyring jeśli jest uruchomiony, w
44   przeciwnym wypadku używany jest KWallet (przez DBus), o ile jest
45   dostępny
46 - Windows: system nie udostępnia usługi do bezpiecznego przechowywania
47   danych; Qt6Keychain używa funkcji Windows API
48
49 %package devel
50 Summary:        Development files for Qt6Keychain
51 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Qt6Keychain
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       Qt6Core-devel >= 6
55
56 %description devel
57 This package contains the header files for developing applications
58 that use Qt6Keychain.
59
60 %description devel -l pl.UTF-8
61 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
62 wykorzystujących bibliotekę Qt6Keychain.
63
64 %prep
65 %setup -q -n qtkeychain-%{version}
66
67 %build
68 %cmake -B build-qt6 \
69         -DBUILD_WITH_QT6:BOOL=ON \
70         -DECM_MKSPECS_INSTALL_DIR=%{_libdir}/qt6/mkspecs/modules
71 %{__make} -C build-qt6
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -C build-qt6 install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %find_lang qtkeychain --with-qm
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files -f qtkeychain.lang
88 %defattr(644,root,root,755)
89 %doc COPYING ChangeLog
90 %attr(755,root,root) %{_libdir}/libqt6keychain.so.*.*
91 %ghost %{_libdir}/libqt6keychain.so.1
92 %dir %{_datadir}/qt6keychain
93 %dir %{_datadir}/qt6keychain/translations
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_includedir}/qt6keychain
98 %{_libdir}/cmake/Qt6Keychain
99 %{_libdir}/libqt6keychain.so
100 %{_libdir}/qt6/mkspecs/modules/qt_Qt6Keychain.pri
This page took 0.057256 seconds and 3 git commands to generate.